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Safety instructions

Safety symbols and messages
Read these instructions carefully and look at the equipment to become familiar with
the device before trying to install, operate, service or maintain it. The following
special messages may appear throughout this bulletin or on the equipment to warn
of potential hazards or to call attention to information that clarifies or simplifies a
procedure.

Risk of electric shock
The addition of either symbol to a Danger or Warning safety label indicates that an
electrical hazard exists, which will result in personal injury if the instructions are not
followed.
ANSI symbol.

IEC symbol.

Safety alert
This is the safety alert symbol. It is used to alert you to potential personal injury
hazards. Obey all safety messages that follow this symbol to avoid possible injury or
death.

Safety messages

DANGER
DANGER indicates an imminently hazardous situation which, if not avoided,
will result in death or serious injury.

WARNING
WARNING indicates a potentially hazardous situation which, if not avoided,
can result in death or serious injury.

CAUTION
CAUTION indicates a potentially hazardous situation which, if not avoided, can
result in minor or moderate injury.

NOTICE
NOTICE is used to address practices not related to physical injury.

Important notes
Restricted liability
Electrical equipment should be serviced and maintained only by qualified personnel.
No responsibility is assumed by Schneider Electric for any consequences arising out
of the use of this manual. This document is not intended as an instruction manual for
untrained persons.

Device operation
The user is responsible for checking that the rated characteristics of the device are
suitable for its application. The user is responsible for reading and following the
device’s operating and installation instructions before attempting to commission or
maintain it. Failure to follow these instructions can affect device operation and
constitute a hazard for people and property.

Protective grounding
The user is responsible for compliance with all the existing international and national
electrical codes concerning protective grounding of any device.
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Introduction
IEC 61850 implementation

CET850 is an advanced tool for configuring IEC 61850 communication.
This manual presents how the IEC 61850 protocol is implemented in Schneider
Electric devices, and explains how to use the CET850. For more information about
the IEC 61850 protocol, please refer to the Sepam IEC 61850 communication user’s
manual (reference SEPED306024EN).

General
IEC 61850 is a standard for communication networks and systems in automated
electric substations.
The following devices can be connected to an IEC 61850 station bus:
b G3200 Modbus-to-IEC 61850 servers
b PowerLogic ION Series 7000/8000 power meters
b Sepam series 20/40/60/80 protection relays
Sepam units can be connected to an IEC 61850 station bus with one of the following
communication interfaces:
b the ECI850 Sepam server, for Sepam series 20, Sepam series 40, Sepam series
60, and Sepam series 80
b the ACE850 communication interface, for Sepam series 40, Sepam series 60, and
Sepam series 80 only
Sepam units with ECI850 and ACE850 are compliant with:
b IEC 61850-6
b IEC 61850-7-1
b IEC 61850-7-2
b IEC 61850-7-3
b IEC 61850-7-4
b IEC 61850-8-1

Application and benefits
Based on the Ethernet protocol, the IEC 61850 communication standard ensures:
b high communication speeds and versatile communication architecture
b interoperability between manufacturers

ECI850 Sepam server
The ECI850 Sepam server provides a high-performance, cost-effective, and versatile
solution for connecting Sepam units to an IEC 61850-compliant system.
The ECI850 Sepam server provides:
b compatibility with the whole Sepam range (series 20, 40, 60, and 80) to fit your
needs perfectly
b ability to upgrade existing Sepam units to ensure the durability of your assets
b ability to connect up to 1 Sepam series 80 units to 1 ECI850, 2 Sepam series 60
units to 1 ECI850, or 3 Sepam series 40 units to 1 ECI850, or 5 Sepam series 20
units to 1 ECI850, ensuring a cost-effective solution
b IEC 61850 logical nodes and configurable data sets to fit the needs of your Scada
system
b high-performance because the ECI850 is not a generic gateway but a data server
dedicated to Sepam

ACE850 communication interface
The Sepam series 40, Sepam series 60, and Sepam series 80 fitted with the
ACE850 communication interface provide a built-in solution for demanding IEC 61850
applications including:
b IEC 61850 logical nodes and configurable data sets to fit the needs of your Scada
system
b peer-to-peer communication capabilities on Sepam series 60 and Sepam
series 80 with GOOSE messages to enhance your protection and control system
without additional wiring
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G3200 Modbus-to-IEC 61850 server
The G3200 Modbus-to-IEC 61850 server enables the majority of Modbus
communicating devices to be connected to an IEC 61850 station bus and benefit from
advanced features such as efficient time management, meaningful and optimized
data retrieval, and simultaneous support of devices over Modbus TCP.
The G3200 offers the following benefits:
b highly-accurate time-stamped data and associated time synchronization with the
source,
b facilitated retrieval of meaningful information,
b enhanced security control model,
b optimized network bandwidth usage,
b easy integration into IEC 61850 systems,
b simultaneous support of Modbus TCP and IEC 61850, with the ability to connect
legacy Modbus TCP-based tools in parallel with IEC 61850 communication.
Easy integration into IEC 61850 systems
The configuration files loaded in to the G3200 and corresponding Modbus devices
are IEC 61850 compliant and so are easily manageable by any IEC 61850 system
configuration tool.
Simultaneous support of Modbus TCP and IEC 61850
The G3200 not only provides the communication benefits offered by the IEC 61850
protocol, but also ensures inter-operability of these devices in a Modbus TCP system.

Implementation
Configuration tools
The Sepam IEC 61850 solution can be configured with either of the following software
tools:
b The SFT2841 setting and operating software ensures straightforward configuration
and builds standard IEC 61850 configuration files.
b The CET850 configuration tools adapt the communication profile of the devices to
the precise needs of the system. The CET850 software tool is explained in this
manual.
b The ION Meter setup tool configures the meter’s communications.

Configuration files
The IEC 61850 configuration process uses and generates the following types of
Substation Configuration Language (SCL) files:

SCL file

Explanation

ICD
An ICD file exists for each type of Sepam device.
IED (Intelligent Electronic Device) An ICD file describes the functions and communication data
Capability Description
available in a Sepam.
ICD files are provided in a library with SFT2841 and CET850
configuration tools, and are used as device models in the
configuration process.
IID
The IID file describes the project-specific configuration of a
Instantiated IED Description
single IED in a system.
It is used as an exchange file between the CET850
configuration tool and other IEC 61850 system configuration
tools to exchange the configuration data for a single IED
instantiated specifically for a project.
CID
For every configured Sepam or ECI850 device there is a CID
Configured IED Description
file. It describes the operating IEC 61850 configuration of the
device.
A CID file is created when a device is configured with the
configuration tools. The CID file is then loaded into the device
to configure it. A CID file for an ECI850 contains configuration
information for all the Sepam devices to which it is connected.
SCD
An IEC 61850 Substation Automation System has an SCD
Substation Configuration
file.
An SCD file contains configuration data for the IEC 61850
Description
system and the communication configuration settings for all
related IEC 61850 devices.

SEPED306025EN - 01/2013

3

Introduction
IEC 61850 implementation

CET850 configuration
software

SFT2841 for standard Sepam IEC 61850
configuration
DE80436

The Sepam setting and operating software, SFT2841, is used to produce a standard
IEC 61850 configuration. The standard configuration enables the use of all the
communication data of a Sepam without modification, as described in the ICD files.
The SFT2841 is used to:
1 Get the information from Sepam and ECI850 connected to the IEC 61850
network. This can be done manually by keying the Sepam description (name,
type, address) or automatically by the SFT2841 polling the network to find
connected devices.
2 Extract ICD files from the library to build a configuration based on the Sepam
description.
3 Build a CID file as a result of the configuration for each Sepam or ECI850
connected to the IEC 61850 network. For an ECI850, it contains the configuration
of all the Sepam connected to the ECI850.
4 Generate an SCD file for use by other IEC 61850 configuration tools. It contains
the configuration of all Sepam and ECI850 connected to the IEC 61850 network.

Sepam series 20/40/60/80
6

1

.cid
5

template library

SFT2841

.scd

4

2

.icd

3

.cid

5 Import a CID file into SFT2841 to modify it: for example to add or remove a Sepam
in the IEC 61850 network topology.

SCL files with SFT2841.

6 Download a CID file into Sepam or ECI850 with SFT2841.

DE81081

CET850 for advanced IEC 61850
configuration
IEC 61850 configuration software CET850 is used to create, display, modify, or
optimize an IEC 61850 configuration.

.cid
.iid

.icd
1

Schneider devices
template library

The CET850 can be used to:
1 Create an IEC 61850 configuration using an ICD, or an IID, or a CID file as an
input.

1

1

5

1

CET850
2

.icd
3

6
2

.icd
user
customized ICD

SCL files with CET850.

2

4

.scd

2

.cid
.iid

2 Edit an existing CID, SCD, IID, or user-customized ICD file to modify its contents
by:
b adding or removing a device
b displaying the configuration
b modifying communication parameter values
b optimizing configuration by creating or modifying Datasets and Report Control
Blocks
b configuring or optimizing the GOOSE communication by creating or modifying
the GOOSE messages production and subscription.
3 Generate a user-customized ICD file using a device IED template from the factory
ICD library.
4 Generate a CID file for storing the configuration of one device which can then be
downloaded to the device or ECI850 Sepam server using SFT2841 or by FTP
with standard Internet browser software or G3200 generic server.
5 Generate an SCD file for storing the configuration of an IEC 61850 system which
can then be used by other IEC 61850 configuration tools.
6 Generate an IID file for storing the specific configuration of an instantiated IED
which can then be used by other IEC 61850 system configuration tools.
Note: The CID or SCD file can come from the SFT2841. ICD Factory library templates for
Schneider Electric devices can not be modified.
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Introduction
On installation, the user is requested to register the software. A license number is
needed in order to register.
If it is not registered, the software is installed in demonstration mode, for a trial period
of 30 days.

Demonstration mode
In demonstration mode, all the software functions are available without restriction.
The user is requested to register each time the software is run. At the end of the trial
period of 30 days, it is no longer possible to run the software and it must be
registered.

Registration methods
To register a running version of the software:
1. Click Help > About CET850 in the menu bar.
2. Select the License Agreement tab.
3. Click the Register Product button.
4. Click OK on the message that warns about the expired evaluation period.
5. Click Yes to begin the Registration Wizard.
During registration, a wizard offers the user the following registration methods:
b requesting a license number
b transferring license rights
b entering a license number (code obtained by fax or E-mail)

Requesting a license number
The user can request a license number, as follows:
b using the Internet from the PC it is installed on
b using the Internet from another PC
b by telephone using the number given by the installation wizard
b by E-mail, using the address given by the installation wizard
b by fax, sent to the number given by the installation wizard

Transferring license rights
The rights for an existing license can be transferred using:
b a USB key
b another connected computer
It is possible for the license rights to be transferred to another user from a different
company.

Software version and licence agreement
To display the current version and the licence agreement of the running CET850
software, click Help > About in the menu bar.

SEPED306025EN - 01/2013
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PE80390

The main window of CET850 enables the user to browse an SCL file using a tree
view that displays the content of the file.
The main window contains the following parts:
1
2
3

4

5
6
7
1. Title bar
2. Menu bar
3. Toolbar
4. Tree view
5. Property view
6. Help area
7. Status bar

Title bar, menu bar, and toolbar
b The title bar displays the name of the open file and the IEC 61850 edition used to
edit the file.
A star appears next to the file name when the file has been modified and not yet
saved.
b The menu bar gives access to all functions of CET850.
b The toolbar gives access to main functions. Depending on use, some functions
may be disabled and will appear in gray.

Display and editing area
The display and editing area is divided into 2 parts: on the left, the tree view with a
yellow background, and on the right, the property view with white background.
Tree view
The tree view initially shows the highest level sections of the SCL file:
b Header and History
b Substation
b Communication
b IED sections
b Data Type template
These sections can then be expanded to obtain more details.
Only the sections present in the SCL file are shown. Furthermore, some sections
may be hidden, depending on the display options set in the User Preferences.
Property view
The property view displays detailed information about the element selected from the
tree view.
Editing
To edit an element, choose the Edit option from the menu bar. The user can also
select an element and then choose an Edit option from the contextual menu. There
are dialog boxes to guide the user when editing element information.

Help area
The help area is located at the bottom of the property view and above the status bar.
It gives additional information about the element selected from the tree view or in the
property view.

Status bar
The status bar is located at the bottom of the window. It gives information pertaining
to the context or operation in progress.

6
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Tree view of an SCL file

An IEC 61850 system is represented as a hierarchical tree, which is constructed from
the information defined in an SCL file. This tree is composed of different elements of
different levels.
Click the + symbol in front of an element to expand it and see its sublevel or click the
- symbol to hide its sublevel. Click any element of the tree to select it and to display
the corresponding attributes in the property view.
There are 3 possible colors to display an element in the tree view:
b Black means that the element properties can be modified.
b Gray means that the element properties cannot be modified.
b Red means that the element has an error status.

PE80569

Header
The Header section contains a History subsection. CET850 provides a specific
function that allows the user to add an entry in the History subsection in order to track
the modifications made to the file. Tracking is not done automatically by the software
and must be handled by the user. See "Editing History", page 19.

Substation

Main SCL file sections.

The Substation section describes the functional structure of the electrical substation,
identifies the primary devices and their electrical connections, and defines the
system functionality by attaching Logical Nodes to primary equipment. This section
deals with the system configuration only; it is optional in an SCD file and not relevant
to a CID file.
By default, this section is hidden in the tree view. To display this section, set the
relevant option in the CET850 User preferences. The section is displayed in gray
because it is not editable with CET850.

Communication
The Communication section contains the definition of all subnetworks defined in the
IEC 61850 system, with the list of the connected IEDs. Both client/server and peerto-peer communication access points are displayed.
CET850 provides specific functions to:
b add or delete a subnetwork
b add or remove an IED on a subnetwork
b set or modify the communication parameters

IED sections
The IED sections contain the definition of all IEDs defined in the IEC 61850 system.
Each IED is displayed with all its contents:
b Logical Devices (LD)
b Logical Nodes (LN)
b Datasets (DS)
b Report Control Blocks (RCB)
b Log Control Blocks (LCB)
b GOOSE Control Blocks (GCB)
b GOOSE Receive

Data Type templates
The Data Type template section provides a detailed description of the data types
used by the IEDs defined in the configuration: Logical Node types, Data Object types,
Data Attribute types, Enumeration types.
This section is intended for IEC 61850 experts and is hidden by default. To display
this section, set the relevant option in the CET850 User preferences. The section is
displayed in gray because it is not editable.
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7

CET850 configuration
software

CET850 description
Property views

The content of the property view varies depending on the element selected from the
tree view. There are 5 types of view:
b Standard property view
b History view
b Communication view
b Logical Node view
b GOOSE Receive view.

Standard property view
PE80583

The standard property view is the most common. It is displayed whenever the user
selects any element except Communication, Subnet or Logical Node.
The attributes of the selected element are displayed in a 2-column table. The first
column contains the attribute’s name and the second column contains the attribute’s
value.
To modify an attribute, right-click the attribute line and select Modify in the contextual
menu.

Standard property view.

PE80592

History view

History view.

The History view is displayed when the user selects the History element in the
Header section. This table lists the history of the modifications done in the SCL file.
Each History entry is displayed in a row. The associated attributes are displayed in
columns.
To modify an attribute, right-click the History entry line and select Modify in the
contextual menu.

PE80799

Communication view

Communication view.

The Communication view is displayed when a Communication or a Subnet element
is selected.
The communication property view is divided into 2 parts:
b The upper part gives an overview of the Client-Server communication. All
subnetworks are displayed with the connected IEDs and their communication
parameters.
b The lower part gives an overview of the GOOSE communication. All
subnetworks are displayed with the list of the IEDs that produce GOOSE messages.
The multicast network addresses used to transmit GOOSE messages are displayed.
To modify an attribute, right-click the attribute line and select Modify in the contextual
menu. It is also possible to modify main attributes directly in the view.

Logical Node view
PE80585

The Logical Node view is displayed when the user selects a Logical Node element
from the tree view.
The Logical Node view is divided into 2 parts.
b The upper part is the same as the standard property view and gives the
description of the Logical Node attributes.
b The lower part displays all the Data Objects (DOs) and Data Attributes (DAs) that
are instantiated in the Logical Node.
Each DO or DA is displayed in a row. The associated attributes are displayed in
columns. Some attributes are editable: they are displayed in a colored cell.
To modify the value of an editable attribute, click the colored cell and change the
value.

Logical Node view.
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GOOSE Receive view
PE80796

The GOOSE Receive view is displayed when the user selects the GOOSE Receive
section of an IED from the tree view.
The GOOSE Receive property view is divided into 2 parts:
b The upper part gives the list of all GOOSE messages that are consumed by the
IED (GOOSE input messages) with their description.
b The lower part gives a detailed view of the structure of the Dataset attached to the
GOOSE message selected in the upper part.
Each Data Attribute (DA) contained in the dataset is displayed with a specific mark
that indicates if it has been selected for subscription or not.
Mark

Meaning
The Data Attribute (DA) is free and can be selected for subscription.
The DA is selected for subscription.

GOOSE Receive view.

The structure contains at least 1 DA which is free and which can be
selected for subscription.
The structure contains at least 1 DA which is selected for subscription.
The DA is not valid for subscription.
The structure does not contain any DA valid for subscription.

PE80782

b The lower part can be divided into 2 when the structure of the Dataset attached to
the GOOSE message in the Producer Side is different from the Receiver Side.
b The lower part is split into 2 when the structure of the Dataset in the Producer Side
is different from the structure of the Dataset in the Private GOOSE Receive.
v The first column displays the content of the Private GOOSE Receive.
v The second column displays the content of the Dataset in the Producer Side.

GOOSE Receive Input Details view.
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Help

CET850 provides 2 types of help:
b on-demand help
b automatic help

On-demand help
On-demand help is contextual help that applies to the elements displayed in the tree
view and the property view, and to some dialog boxes for specific operations.
It is activated by the F1 key (or by the Help menu), and by the Help button in dialog
boxes.
This help text is based on the following PDF documents:
b CET850 User’s manual (this manual)
b IEC 61850 Communication User’s manual for Sepam
b IEC 61850 Modbus and ION Technology User guide
The help topics are displayed using the Acrobat Reader application, which is
automatically launched by CET850.
The relevant page of the relevant PDF document is displayed depending on the
element selected by the user from the tree view or the property view, and depending
on the operation implemented within the dialog box.
Note: Adobe Acrobat Reader must be installed on the user’s PC to display PDF documents.

Automatic help
When available, help topics are displayed automatically in the Help area at the
bottom of the property view. They provide details about the selected element,
regarding the IEC 61850 standard and its implementation by Schneider Electric
devices.

10
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Functions can be accessed through the:
b menu bar
b toolbar
b contextual menu accessed by right-clicking an element in the tree view or the
property view
The table below gives the different functions available for each menu in the Menu bar.
Menu

Function

Description

Toolbar
icon

See

New

Create a new SCL file.

-

Open

Open an existing SCL file.
The file may be an SCD, a CID, an ICD, or an IID file.

-

Close
Save

Close the open SCL file.
Save the open SCL file.

-

-

Save as
Validate
Build all CID files
Build CID file
Export all IID files
Export IID file
Import all CID files
Import CID file
Find duplicates
Export to SFT2841

-

page 13
page 13
page 13
page 14
page 14
page 15
page 15
page 16

Print
Print preview
Print options
Exit

Save the open SCL file under chosen name and location.
Check the XML syntax and the global consistency of the open file.
Generate all the CID files of the current SCL file.
Generate the CID file of the selected IED.
Export all the IID files of the current SCL file.
Export the IID file of the selected IED.
Import all CID files to the SCL file.
Import an individual CID file to the SCL file.
Find duplicate IEDs in the SCL file.
Export a package to the SFT2841 containing a NET file and all the CID
files defined in the NET file.
Print a report of the SCL file or a report of the selected element.
Display a preview of the report to be printed.
Set filter options for the print report.
Exit from CET850 tool

-

page 16
page 16
-

Undo

Undo last editing action.

-

Cut

Cut the selected item and put it in the clipboard.

-

Copy

Copy the selected item in the clipboard.

-

Paste

Paste an item from the clipboard.

-

Delete
Find

Delete the selected item.
Find a character string in the tree structure or in the XML code.

-

-

Toolbar
Status bar
Show Errors
Property view
XML source

Display or hide the toolbar.
Display or hide the status bar.
Display the syntax error line number(s) of the current SCL file.
Display the property view.
Display the XML view.

-

page 13
page 8
page 47

History
IED
Logical Devices
Connected Access Point
Dataset
Report Control Block
Log Control Block
GOOSE Control Block
GSE Element

Add a History entry to track file modifications.
Add an IED into the current SCL file.
Add a Logical Device inside an IED.
Add a Connected Access Point onto a subnetwork.
Add a Dataset into a Logical Node.
Add a Report Control Block into a Logical Node.
Add a log control block in a Logical Node.
Add a GOOSE Control Block into a Logical Node.
Configure an incoming GOOSE message

-

page 19
page 20
page 23
page 25
page 27
page 31
page 34
page 37
page 40

Download All CID To Devices
Download CID To Device
Upload CID from Device

Download several CID files to a device.
Download an individual CID file to a device.
Upload CID files from a device.

-

page 45
page 45
page 46

File

Edit

View

Add

FTP
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11

CET850 configuration
software

Menu

CET850 description
Menu description (cont.)

Function

Description

Toolbar
icon

See

Preferences
Languages

Set CET850 display and running options.
Select the language of the user interface.

-

page 47
-

Help Topics
About CET850

Display contextual help about selected element or open window.
Give various information about the CET850 software (version
identification and license agreement).

-

page 10
page 5

Tools

Help
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Only the main functions of the File menu are explained here. Other functions are
standard ones and do not require specific descriptions.

PE80587

Validate

Syntax error displayed in red color.

The Validate function includes 3 kinds of verification:
b verification of the structure and content of the SCL file
b verification of the structure against the IEC 61850 schema
b verification of the consistency of the GOOSE communication
Verification of the structure and content of the SCL file
The Substation Configuration Language is based on XML.
The structure and content of all SCL files are fully specified by the IEC 61850
standard using an XML Schema (XSD files).
CET850 is delivered with the set of XSD files defined by the IEC 61850 standard and
checks the validity of SCL files against the IEC 61850 XML Schema.
CET850 uses the Xerces parser to check the validity of the SCL files.
Verification of the consistency of the GOOSE communication
The dataset sent via GOOSE messages must meet a specific size constraint.
The data sent by a producer IED must be consistent with the data expected and
subscribed by the consumer IED.
CET850 checks the size and the consistency of the data exchanged via GOOSE
messages.

Validating an SCL file at saving time
The Validate function can be automatically activated when the user saves an SCL
file.
Automatic validation is enabled or disabled using a specific option in the CET850
User Preferences.

Validating an SCL file during editing
The Validate function can be explicitly triggered when an SCL file is open.
In the menu bar or in the contextual menu, click File > Validate.
b If the SCL file is valid, the message Validation is successful is displayed.
b If the SCL file is not valid, the Validation Errors window opens.
See "Error display" on the following section.
The Validate function can be activated both when the Property view is displayed and
when the XML source is displayed.

Error display
PE80586

As a result of an explicit Validate action, the Validation Errors window lists all the
errors detected in the SCL file. For each error, a message is displayed indicating the
reason for the error and its location in the XML source file.
Erroneous elements in the tree view are displayed in red. In the XML source,
erroneous lines are displayed in red.
To obtain details about an erroneous element displayed in the tree view, select this
element and click Show errors in the contextual menu
Syntax error pop-up window.

Build CID files
To configure an IED for IEC 61850 communication, the user needs to build a CID file
and load it into the IED.
When an SCD file is open, CET850 can build the CID file for a specific IED or all the
CID files for all the connected IEDs defined in the SCD file.

Building the CID file of a specific IED
This function is available when the user has selected from the tree view an IED that
is connected to a subnet.
Procedure
1. From the tree view, select an IED that is connected to a subnet.
2. In the menu bar, click File > Build CID File. A dialog box opens.
3. In the dialog box, enter the location and the name of the output CID file.
By default, the name of the CID file is based on the name of the IED.
4. Click OK to validate the operation.
The CID file is created in the directory specified in step 3.

SEPED306025EN - 01/2013
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Building CID files for all IEDs in the SCD file
This function is available when the SCD file includes at least one IED that is
connected to a subnet.
Procedure
1. In the menu bar, click File > Build All CID Files.
2. In the dialog box, enter the location of the output CID files.
3. Click OK to validate the operation.
The CID files of all IEDs are created in the directory specified in step 2.
The name of the CID files is based on the name of the IEDs.

Integrity check
To be sure that the CID file has not been modified or corrupted before being loaded
into the target device, an integrity key is generated by CET850. This key is stored in
a private section at the beginning of the SCL file.
When editing a CID file, the integrity key is automatically rebuilt by CET850 when
saving and closing the file.

Export IID files
IID files are used to exchange the configuration of IEDs between the CET850
configuration tool and other IEC 61850 configuration tools.
Exporting IID files allows the user to generate the configuration file of IEDs done with
CET850 in order to integrate them to a system configuration done using other
IEC 61850 configuration tools. When an SCD file is open, CET850 can export the IID
file for a specific IED or all the IID files for all the connected IEDs defined in the SCD
file.

Exporting the IID file of a specific IED
This function is available when the user has selected from the tree view an IED that
is connected to a subnet.
Procedure
1. From the tree view, select an IED that is connected to a subnet.
2. In the menu bar, click File > Export IID File. A dialog box opens.
3. In the dialog box, enter the location and the name of the output IID file.
The default name of the IID file is based on the name of the IED.
4. Click OK to validate the operation.
The IID file is created in the directory specified in step 3.

Exporting IID files for all IEDs in the SCD file
This function is available when the SCD file includes at least one IED that is
connected to a subnet.
Procedure
1. In the menu bar, click File > Export All IID Files.
2. In the dialog box, enter the location of the output IID files.
3. Click OK to validate the operation.
The IID files of all IEDs are created in the directory specified in step 2.
The default name of the IID files is based on the name of the IEDs.

Importing IID files
CET850 can import to a system configuration the IID files generated by other
IEC 61850 configuration tools. The import operation is done using the Add IED
function. See “Adding an IED” on page 20.
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Import all CID files
Importing all CID files to the SCL file
This function is available when at least one SCD file is open.
Procedure
1. In the menu bar, click File > Import all CID Files. A dialog box opens.
2. In the dialog box, enter the location of the input CID files.
3. Click OK to validate the operation.
All the CID files contained in the selected folder are imported.
This function imports the communication parameters defined in the CID file.

Import CID file
Importing a CID file to the SCL file
This function is available when at least one SCD file is open.
Procedure
1. In the menu bar, click File > Import CID File. A dialog box opens.
2. In the dialog box, enter the location of the input CID file.
3. Click OK to validate the operation. The CID file is imported.
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Export to SFT2841
SFT2841 is the setting tool for Sepam devices. It gives access to Sepam devices via
Ethernet TCP/IP and may be used to identify the Sepam connected to the network
and to load the associated CID files.
For that purpose, SFT2841 uses a configuration file named NET file which contains
the IP address of each Sepam, the reference to its CID file, and the identification of
the originating ICD file from the Sepam ICD library.
When an SCD file is open, CET850 can export the NET file and the CID files for all
the connected IEDs defined in the SCD file.

Exporting to SFT2841
This function is available when the SCD file contains at least one connected IED.
Procedure
1. In the menu bar, click File > Export To SFT2841. A dialog box opens.
2. In the dialog box, enter the location and the name of the output NET file.
The default name of the NET file is the same as the name of the SCD.
3. Click OK to validate the operation.
The NET file is created in the directory specified in step 2.
The CID sub-directory is created inside the output directory specified in step 2:
it contains all the CID files for the IED declared in the NET file.

Print
Print options
Print options allow the user to select the list of elements to be printed in the report.
The following elements can be selected:
b History
b Communication
b Subnet
b IED
b LD
b Dataset
b Report Control Block
b GOOSE Control Block
b GOOSE Receive

Print SCL file
Print SCL file sends a report of the SCL file to the printer. The content of the report
depends on the options set by the user using the menu File > Print options.
To print an SCL file:
The Print function is available when an SCL file is opened.
1. In the menu bar, click File > Print SCL file.
2. Click OK to validate the operation.
A general report is printed out.

Print Element
Print Element sends a report of a selected element in the tree to the printer. Reports
on the following sections or elements can be printed separately:
b History
b Communication
b Subnet
b IED
b LD
b Dataset
b Report Control Block
b GOOSE Control Block
b GOOSE Receive
Procedure
The Print Element function is available when an SCL file is open.
1. From the tree view, select an element from the list above
2. In the menu bar, click File > Print Element.
3. Click OK to validate the operation.
A report of the selected element is printed.
When printing a report on an IED, the content of the report depends on the options
set by the user using the menu File > Print options.

16
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Editing an SCL file consists in:
b adding or removing elements from the tree view
b modifying element attributes in the property view
In both cases, the SCL file is updated when it is saved.

Adding elements
The table below gives for an element of the tree, the next level elements that can be
added by the user.
Selected element

Icon

SCL (SCL file level)

Elements that can be
added

Icon

IED
Connected Access Point

History

History entry

Communication

Connected Access Point

Subnet

Connected Access Point

Connected Access Point

GSE Element

IED (Sepam Server)

Logical Device

Logical Node

DataSet
RCB (reports)
Log Control Block
GOOSE Control Block (GCB)
(LN0 only)

Procedure
1. From the tree view, select the element where you want to add the new element.
2. In the menu bar or in the contextual menu, click Add then click the element to be
added.
3. Refer to specific procedures in this manual for further instructions.

Removing elements
Any element that can be added can also be removed from the tree view.

Procedure
1. From the tree view, select the element you want to remove.
2. In the menu bar or in the contextual menu, click Edit > Delete or press the DEL key.
3. If the Delete Confirmation Required option is checked in Tools > Preference,
click Yes in the confirmation dialog box to delete the selected element.
The selected element is deleted from the tree view.
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Moving or copying elements
Copy/paste or cut/paste functions are enabled depending on the context and the type
of element selected from the tree view.

Procedure
1. Select the element to be cut or copied.
2. In the menu bar or in the contextual menu, click Edit > Cut or Copy.
3. From the tree view, select the location where the item should be pasted.
4. In the menu bar or in the contextual menu, click Edit > Paste.
The element is either moved or copied from its location.
Note: Copy/Paste and Cut/Paste operations may lead to SCL errors due to duplicate references
or missing references. These errors will be detected by CET850 and must be corrected by the
user to obtain a consistent SCL file.

The order of some elements displayed in the tree view can be changed in a section.
(For instance, the order of the Connected Access Points can be modified inside the
subnet section).
Use drag-and-drop or cut/paste methods to move an element in a section.

Modifying attributes
Some elements are editable and their attributes may be modified. There are 3
possible ways to edit an element, depending on its type:
b From the tree view, select the element and right-click Edit > Modify in the
contextual menu.
b From the tree view, select the element and double-click it.
b In the property view, click Edit > Modify in the contextual menu.
In addition, specific attributes of DataObjects (DOs) and DataAttributes (DAs)
displayed in the LN details view are editable. They are displayed in a colored cell. To
modify their values, click the colored cell. For instance, the user can set or modify the
description of a DO, or modify the value of the deadband of a measurement (DA
"db").

18
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The history allows tracking of the SCL file modifications during the configuration
process. Each time the file is modified, the user should add a History entry with
comments.

Adding a History entry
Procedure
1. Double-click the Header section to expand it.
2. Click the History element to select it.
Then the history content is displayed in the property view.
3. In the menu bar or in the contextual menu, click Add > History. A pop-up window
opens, displaying a table with all attributes to fill.
4. Click the Attribute Value column fields to fill them with comments. The 3 first
attributes (Version, Revision and When) are compulsory.
5. Click OK to validate the operation.
A new entry is added in the history table displayed in the property view.

Modifying a History entry
Procedure
1. Double-click the Header section to expand it.
2. Click the History element to select it.
3. In the property view, select the History entry you want to edit and click Modify in
the contextual menu. A pop-up window opens, displaying all attributes with their
current values.
4. Click the Attribute Value column fields to modify them.
5. Click OK to validate the modification.
The selected entry is updated accordingly in the history table.

Removing a History entry
Procedure
1. Double-click the Header section to expand it.
2. Click the History element to select it.
3. In the property view, select the History entry you want to delete and click Delete
in the contextual menu.
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PE80798

Adding an IED
CET850 enables the addition of an IED to an IEC 61850 system using its ICD
description file, or the addition of a device already defined by either a CID file or an
IID file.
For Schneider Electric devices, the ICD files are available in a library included in the
CET850 software package. The ICD library is automatically installed during the
installation of CET850.

Procedure
Adding an IED.

1. From the tree view, select the SCL root element.
2. In the menu bar or in the contextual menu, click Add > IED.
3. Set the IED Identification and optionally the Address parameters according to
following descriptions.
4. Click OK to validate the operation.
A new IED element is added to the tree view.

PE80589

IED Identification

PE80591

Identification settings.

ICD/CID file
The IEC 61850 description of the IED to add is given by an ICD, a CID, or an IID file.
To select the description file, click:
.
b ICD file selection
v Choose the Device From Library option to select an ICD file from the internal
library. CET850 software is delivered with a library of ICD files for all types of Sepam
devices and all Sepam applications. This library also includes the ICD file for the
ECI850. To browse inside the ICD library, use the access keys Family, Model, and
Version.
v Choose the Other Device option to select an ICD file outside the ICD library.
b CID file selection
Choose the Other Device option to select a CID file or an ICD file outside the
standard ICD library.
b IID file selection
Choose the Other Device option to select an IID file outside the standard ICD library.
IED name
Assign a name to the IED. The name of the IED must be unique in the IEC 61850
system. Its length is restricted to a maximum of 64 characters, and consists of
alphanumeric and underscore (_) characters, beginning with a letter.

Description or configuration file selection.

IED description
This is a free ASCII string where the user can write comments about the device.

Address
PE80590

Address parameters are set to connect the IED to the communication network.
Connecting the IED can be done at this stage or later using the
Add > Connected Access Point menu.
See "Adding a Connected Access Point", page 25.
b Subnet:
To select the subnet you want to connect the IED to, click:
.

Network settings.

To select an existing subnet or create a new one, enter the following parameters:
b IP Address: address of the IED
b IP Subnet: subnet mask
b IP Gateway: address of the subnet gateway
If the user chooses an existing subnet, IP Subnet and IP Gateway are automatically
supplied.
Note: If subnetwork parameters are not yet known, they can be entered later. See "Adding a
Connected Access Point", page 25. The IED icon will then be displayed in the tree view with a
blue right-upper corner, to show that the IED is not connected to any subnet.
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Modifying an IED
Procedure
1. From the tree view, select, the IED you want to modify.
2. From the property view, select an attribute and click Modify in the contextual
menu.
A dialog box opens, displaying a table with the attributes and their values.
3. Click the Attribute Value column fields to modify them.
4. Click OK to validate the modification.
The IED parameters are updated.

Removing an IED
Procedure
1. From the tree view, select the IED you want to remove.
2. In the menu bar or in the contextual menu, click Edit > Delete or press the DEL key.
The IED and the relevant Connected Access Point are removed from the SCL file.
The undo function can be used to go back to the previous state.
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Introduction
CET850 is able to manage ECI850 Sepam servers and G3200 generic servers.
ECI850 allows only Sepam devices to be connected. G3200 generic servers are
used for all other Schneider Electric and pre-defined Modbus devices.
The pre-defined Modbus devices allowed with CET850 are:
b PowerLogic Circuit Monitor Series 4000
b Micrologic A/P/H for Masterpact and Compact NS
b PowerLogic Power Meter 710
b PowerLogic Power Meter 850
b Easergy T200
b Sepam 2000

22
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ECI850 Sepam server
According to the IEC 61850 standard, Sepam devices that are connected to the
ECI850 Sepam server via Modbus subnet are seen as Logical Devices inside the
ECI850 IED. Sepam devices can be connected to the ECI850 Sepam server in one
of the following ways:
b 1 Sepam series 80 unit, or
b 2 Sepam series 60 unit, or
b 3 Sepam series 40 units, or
b 5 Sepam series 20 units.
The CET850 software is used to add or remove Sepam Logical Device inside an
ECI850 IED.

Adding a Logical Device
When an ECI850 Sepam server is selected from the tree view, CET850 allows the
addition of slave Sepam devices as Logical Devices of the ECI850 IED.

Procedure
1. From the tree view, select an IED element whose type is ECI850 Sepam server.
Such an IED is displayed with the icon

.

2. In the menu bar or in the contextual menu, click Add > Logical Device.
3. Set the fields of the Add Logical Device window according to the rules described
in the Logical Device identification section.
4. Click OK to validate the operation.
A new Logical Device element is added to the tree view inside the ECI850 Sepam
server.

PE80579

Logical Device identification

Logical Device settings.

b LD name
Assign a name to the Logical Device. The Logical Device name must be unique for
the ECI850 Sepam server. This is a string of up to 64 alphanumeric and underscore
(_) characters, starting with a letter.
b ICD file
Select the ICD file that provides the IEC 61850 description of the device either from
the ICD library or from a specific location.
CET850 software is delivered with a library of ICD files for all types of Sepam devices
and all Sepam applications. To browse inside the ICD library, use the access keys:
Family, Model, and Version.
b LD description
This is a free ASCII string where the user can write comments about the device.
b Modbus address
Assign a Modbus address from 1 to 247 to the device.
This address is used by the ECI850 to access the device as a slave device using the
Modbus subnetwork. It must be unique for the ECI850 Sepam server.

Modifying a Logical Device
Procedure
1. From the tree view, select the Logical Device to be modified.
2. In the property view, select an attribute and click Modify in the contextual menu.
A dialog box opens, displaying a table with the attributes and their values.
4. Click the Attribute Value column fields to modify them.
5. Click OK to validate the modification.
The LD parameters are updated.

Removing a Logical Device from an ECI850
Sepam server
Procedure
1. From the tree view, select the Logical Device you want to remove.
2. In the menu bar or in the contextual menu, click Edit > Delete or press the DEL
key.
The Logical device is removed from its ECI850 Sepam server.
Note: The ECI850 Sepam server has at least one LD (LD0) which describes the ECI850 device
itself. Removing the LD0 is not allowed.
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G3200 generic server
According to the IEC 61850 standard, devices that are connected to the G3200
Modbus-to-IEC 61850 server via Modbus subnet are seen as Logical Devices inside
the G3200 IED. These devices can be connected to the G3200 generic server in one
of the following ways:
b 1 PowerLogic Circuit Monitor Series 4000 unit, or
b 2 Micrologic A for Masterpact and Compact NS units, or
b 1 Micrologic P/H for Masterpact and Compact NS unit, or
b 2 PowerLogic Power Meter 710 units, or
b 1 PowerLogic Power Meter 850 unit, or
b 3 Easergy T200 units.
The CET850 software is used to add or remove a pre-defined Logical Device inside
a G3200 IED.
Note: G3200 does not support edition 2 and can not be selected in CET850 edition 2.

Adding a Logical Device
When a G3200 generic server is selected from the tree view, CET850 allows the
addition of slave devices as Logical Devices of the G3200 IED.

Procedure
1. From the tree view, select an IED element whose type is G3200 Generic server.
Such an IED is displayed with the icon:

.

2. In the menu bar or in the contextual menu, click Add > Logical Device.
3. Set the fields of the Add Logical Device window according to the rules described
in the Logical Device identification section.
4. Click OK to validate the operation.
A new Logical Device element is added to the tree view inside the G3200 generic
server.

PE80579

Logical Device identification

Logical Device settings.

b LD name
Assign a name to the Logical Device. The Logical Device name must be unique for
the G3200 generic server. This is a string of up to 64 alphanumeric and underscore
(_) characters, starting with a letter.
b ICD file
Select the ICD file that provides the IEC 61850 description of the device either from
the ICD library or from a specific location.
CET850 software is delivered with a library of ICD files for all types of pre-defined
applications. To browse inside the ICD library, use the access keys: Family, Model,
and Version.
b LD description
This is a free ASCII string where the user can write comments about the device.
b Modbus address
Assign a Modbus address from 1 to 247 to the device.
This address is used by the G3200 to access the device as a slave device using the
Modbus subnetwork. It must be unique for the G3200 generic server.

Modifying a Logical Device
Procedure
1. From the tree view, select the Logical Device to be modified.
2. In the property view, select an attribute and click Modify in the contextual menu.
A dialog box opens, displaying a table with the attributes and their values.
4. Click the Attribute Value column fields to modify them.
5. Click OK to validate the modification.
The LD parameters are updated.

Removing a Logical Device from a G3200
generic server
Procedure
1. From the tree view, select the Logical Device you want to remove.
2. In the menu bar or in the contextual menu, click Edit > Delete or press the DEL
key.
The Logical Device is removed from its G3200 generic server.
Note: The G3200 generic server has at least one LD (LD0) which describes the G3200 device
itself. Removing the LD0 is not allowed.
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The connection of an IED to the communication network is done using an Access
Point (AP).
An IED can have one or several APs. Sepam devices and the ECI850 Sepam server
have only one Access Point.
According to the IEC 61850 standard, connecting an IED consists in adding a
Connected Access Point (ConnectedAP) to a subnet. Using CET850, this operation
can be done when adding the IED (see "Adding an IED", page 20), or at a later stage,
using the Add > Connected Access Point action in the menu.

PE80580

Adding a Connected Access Point
Procedure

Adding a Connected Access Point.

1. From the tree view, select either the SCL root element, or the Communication
section, or a Subnet element.
2. In the menu bar or in the contextual menu, click Add > Connected Access Point.
3. Set the IED identification and Address parameters according to the following
descriptions.
4. Click OK to validate the operation.
A Connected Access Point (Connected AP) is added in the Communication section,
on an existing subnet or a newly created one.

IED identification
PE80581

b IED Name
Select the IED you want to connect. Only IEDs having a free Access Point (not yet
connected) are listed.
b AP Name
Select the Access Point of the IED you want to use for the connection.

Address
b Subnet: name of the subnetwork (must be unique in the SCL configuration)
To select the subnet you want to connect the IED to, click:

Connected Access Point settings.

The user can select an existing subnet or create a new one.
Enter the following parameters:
b IP Address: address of the IED
b IP Subnet: subnet mask
b IP Gateway: address of the subnet gateway
If the user chooses an existing subnet, the IP Subnet and IP Gateway are
automatically supplied.

Modifying a Connected Access Point
Procedure
1. From the tree view, select a Connected AP.
2. From the property view, select an attribute and click Modify in the contextual
menu. A dialog box opens, displaying a table with the attribute and their values.
3. Click the Attribute Value column fields to modify them.
4. Click OK to validate the operation.
The Connected AP parameters are updated consequently.

Removing a Connected Access Point
Procedure
1. From the tree view, select the Connected AP you want to remove.
2. In the menu bar or in the contextual menu, click Edit > Delete or press the DEL
key.
The Connected AP and the elements defined under the Connected AP are removed
from the SCL configuration.
If the subnet does not contain any more Connected AP, it is automatically removed
from the SCL configuration.
The undo function can be used to go back to the previous state.
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Adding a Subnet
A subnetwork can be created when adding a Connected AP or an IED, and setting
the address parameters. See "Address", page 25.

Removing a Subnet
Procedure
1. Select in the Communication section of the tree view, the subnetwork you want to
remove.
2. In the menu bar or in the contextual menu, click Edit > Delete or press the DEL
key.
The subnetwork is removed from the tree view. If there is no more subnet element in
the communication section, the communication section is automatically removed
from the SCL configuration file.
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A Dataset is a collection of Data Attributes (DAs) grouped together to increase
communication efficiency. In particular, Datasets are used for reports and GOOSE
messages.
Any LN instance can contain one or more Datasets depending on the capabilities of
the IED.
By default, each Sepam provides 3 Datasets pre-defined in the ICD file:
b StDs: this Dataset includes all status indications provided by all the Protection (or
related to protection) Logical Nodes present in Sepam, the Switchgear LN, the
Sensor and Monitoring LN, and the Physical Device itself.
b MxDs: this Dataset includes all measurements values provided by all the
Measurement Logical Nodes (MMXU) present in Sepam.
b BasicGseDs: this Dataset includes the main indications used for basic GOOSE
exchange.
By default, each ION Meter provides 6 Datasets pre-defined in the ICD file:
b STATUS: this Dataset includes all device operational status.
b MMXU: this Dataset includes all default measurements.
b MMTR: this Dataset includes all default metering.
b GGIO: this Dataset includes all default hardware input/output data.
b PQ: this Dataset includes all default power quality data.
b CUSTOMIO: this Dataset includes all default custom GGIO data.
Note: ION Meter does not support edition 2 and can not be selected in CET850 edition 2.

These default Datasets can be modified by the user and new Datasets can be added,
depending on the capabilities of the IED.
The capabilities of an IED regarding the configuration of Datasets are defined in the
Services element by the ConfDataSet element.

Displaying the IED capabilities
Procedure
1. From the tree view, select the IED.
2. In the property view, expand the Services element.
3. Expand the ConfDataSet element to display the capabilities attributes:
b modify: an existing Dataset can be modified if modify = true.
b max: this value defines the maximum number of Datasets that can be created
inside this IED.

PE80600

Adding a Dataset
Procedure
1. From the tree view, select a Logical Node of an IED.
2. In the menu bar or in the contextual menu, click Add > Dataset.
A dialog box opens enabling the user to set the Dataset attributes and its content.
3. Enter a Dataset name and enter a description text.
4. Create the Dataset content according to the following description.

Adding a Dataset.
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Dataset Content
PE80783

The Dataset Content frame in the dialog window allows the user to select the data
that will be put in the Dataset.
This frame displays 2 lists:
b a left-hand list
b a right-hand list
Left-hand list
The left-hand list displays all the data that can be placed in the Dataset. It contains
the Data Objects and Data Attributes of all the Logical Nodes present in the IED. The
list is displayed as a tree view and can be expanded or collapsed by clicking on the
+/- symbols. The highest level displayed is the Logical Device (LD) level. The user
can expand the tree view up to the Data Attribute (DA) level (last level or leaf level).
Each DA is displayed with its Functional Constraint (FC) preceding its name.
Right-hand list
The right-hand list gives the content of the Dataset. Each line specifies an element
of the Dataset.
An element may be an FCDA or an FCD:
b FCDA (Functional Constrained Data Attribute)
An FCDA identifies a single Data Attribute. This DA is identified by the name of the
LD, the name of the LN, the name of the DO and the name of the DA.
The Functional Constraint is displayed in the first column.
b FCD (Functional Constrained Data)
An FCD identifies a data structure that contains all the DAs of a DataObject, with a
given FC. The FCD is identified by the name of the LD, the name of the LN, and the
name of the DO. The attributes are implicitly identified and a star is displayed instead
at the attribute level. The Functional Constraint is displayed in the first column.
Selecting the data to be put into the Dataset
A filter, based on a specific FC is available to restrict the DAs displayed in the lefthand list.
b By default there is no filter (filter set to All FC).
In this case, all DAs are displayed in the list. The user can add only a fully constrained
DA, by selecting it at the leaf level of the tree. The entry created in the Dataset is a
single attribute and is called an FCDA (Functional Constrained Data Attribute)
b If the user sets a specific FC as filter, then the list is restricted according to this FC.
In this case the user can add an FCDA by selecting a DA at the leaf level of the tree
(as in the previous case), but the user can also select a DataObject at DO level.
When selecting a DataObject, the entry created in the Dataset is called an FCD
(Functional Constrained Data). The associated element that will be reported in the
Dataset is a data structure that includes all the attributes with the required FC.
Ordering the data in the Dataset
The order of the Dataset elements inside a Dataset is very important because it
determines its decoding by an IEC 61850 Client when it gets the Dataset.
When adding an element to a Dataset, it is added at the last position. The user can
modify the order of the Dataset elements by selecting an element and moving it up
or down using the Up and Down arrow buttons.
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Functional Constrained Data Attributes count
The count of Functional Constrained Data Attributes (FCDA) that can be contained
in the Dataset is checked against the memory capacity of the device. The maximum
limit is given in the ICD file by the max Attributes value defined in the Services
element by the ConfDataSet element.
During the definition of a Dataset, the amount of size used and available is given by
a bar-graph. The bar-graph is displayed in green up to the max Attributes defined
and in red above this value.
CET850 does not allow the creation of new Datasets with a Data Attribute count that
exceeds the maximum limit defined.
GOOSE capacity bar-graph
A Dataset can be attached to a Report Control Block or a GOOSE Control Block. It
can only be attached to a GOOSE message if its size is compatible with the size of
an Ethernet frame.
During the definition of a Dataset, the amount of size used and available is given by
a bar-graph and percentage. The bar-graph is displayed in green up to 100% of the
allowed capacity and in red above 100%.

PE80783

Creating the Dataset content
Procedure
1. Use the combo box filter to optionally assign a filter to the FC.
2. In the left-hand list, select the FCDAs or FCDs you want to add to the Dataset.
3. Click on the right arrow button to add the selected data to the right-hand list.
A new element is created at the end of the Dataset.
4. Repeat this operation to select all the data (FCDAs or FCDs) to be added to the
Dataset.
5. If necessary, re-arrange the order of the elements inside of the Dataset using the
Up and Down arrow buttons.
6. If necessary, to remove an element from the Dataset, select it in the right-hand list
and click the left arrow button.
7. Click OK to validate the Dataset.
After the Add Dataset operation is completed, the changes to the Dataset are
reflected in the current SCL file and the CET850 display is updated: a newly created
Dataset is displayed in the tree view. The content of the Dataset is updated in the
property view.
Dataset Content.

Modifying a Dataset
Procedure
1. From the tree view, select a Dataset and click Edit > Modify in the contextual
menu.
The Dataset edition window opens.
2. To modify the Dataset content, see "Dataset Content", page 28.

Copying or Moving a Dataset
Once a Dataset has been created it can be moved or copied to another Logical Node
of an other Logical Device, if needed, using the copy/cut and paste or drag-and-drop
methods.
Note: A dataset can be linked to Control blocks (Report Control Blocks, GOOSE Control Blocks).
Control blocks must reside in the same logical node as the Dataset they refer to. Be sure to move
or remove the control blocks together with their referenced datasets.
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Removing a Dataset
Procedure
1. From the tree view, select the Dataset you want to remove.
2. In the menu bar or in the contextual menu, click Edit > Delete or press the DEL key.
The Dataset is removed from its Logical Node.
The undo function can be used to go back to the previous state.
Note 1: A dataset can be linked to Control blocks (Report Control Blocks, GOOSE Control
Blocks). Control blocks must reside in the same logical node as the Dataset they reference. Be
sure to move or remove the control blocks together with their referenced datasets.
Note 2: CET850 does not allow the removal of a Dataset which is used by RCBs.
Note 3: The removal of Datasets used in GOOSE Control Blocks will result in inconsistencies.

Adjusting the dead band of measurements
Sepam produces many measurements that are accessible via the IEC 61850
communication interface as Measured Values (MV) and Complex measured values
(CMV).
To optimize the network bandwidth, it is possible to create a Dataset of
measurements and to send it on data changes only, rather than periodically.
Sepam and CET850 use the dead band parameter (db) defined by the IEC 61850
Standard for the MV and CMV to control the conditions for generating reports.
CET850 allows the user to set the dead band of each value for MV and CMV data
produced by Sepam. If the data is associated with a Dataset and an RCB with the
Data change trigger option (dchg), a report will be generated only when the value of
the data exceeds the dead band. If the data change is less than the dead band, no
report will be generated.

Procedure
1. From the tree view, select a Logical Node.
2. In the LN details part of the LN view, expand the LN.
3. Select the required measurement.
4. Click the colored cell of the dead band attribute and change the value.

30
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A Report Control Block (RCB) defines the way a Dataset is transmitted to a client.
An RCB can be created inside any Logical Node.
Sepam provides both buffered and unbuffered RCBs.
A buffered RCB (BRCB) is dedicated to at a maximum of one client at a time. If the
same report is to be used by more than one client, several reports of this type have
to be instantiated in the IED. The instances of a BRCB are identified using a
numerical index and are called commonly indexed BRCB.
An unbuffered RCB (URCB) may be used by several client.

Report Control Block in a Logical Node.

By default, each Sepam provides 2 pre-defined buffered RCBs in the LLN0, each
RCB defined with 2 instances. These RCBs are defined in each Sepam ICD file:
b brcbST01 and brcbST02 are the 2 BRCB associated with the StDs Dataset for
reporting status indications.
b brcbMX01 and brcbMX02 are the 2 BRCB associated with the MxDs Dataset for
reporting measurements.
By default, each ION Meter provides 6 pre-defined RCBs in the LLN0, each RCB
defined with 4 instances. These RCBs are defined in each ION Meter ICD file:
b uncbSTATUS associated with the STATUS Dataset for reporting status indications.
b uncbMMXU associated with the MMXU Dataset for reporting default
measurements.
b uncbMMTR associated with the MMTR Dataset for reporting default metering.
b uncbPQ associated with the PQ Dataset for reporting power quality data.
b uncbCUSTOMIO associated with the CUSTOMIO Dataset for reporting custom
GGIO data.
b brcbGGIO associated with the GGIO Dataset for reporting default hardware input/
output data.
These default RCBs can be modified by the user and new RCBs can be added,
depending on the capabilities of the IED.
The capabilities of an IED to configure RCBs are defined in the Services element by
the ConfReportControl element.

Displaying the IED capabilities
Procedure
1. From the tree view, select the IED.
2. In the property view, expand the Services element.
3. Expand the ConfReportControl element to display the capabilities attributes:
b max: this value defines the maximum number of instantiable Report Control
Blocks. If this is equal to the number of preconfigured instances, then no new
instances can be created.
b bufMode (unbuffered, buffered, both): this attribute specifies the buffer mode
supported by the device.
b bufConf (boolean): TRUE means the buffered attribute of preconfigured RCBs can
be changed via SCL configuration.

PE80582

Adding a Report Control Block (RCB)
Procedure

Adding a Report Control Block.

To add an RCB in a Logical Node, there must be at least one Dataset in this Logical
Node.
1. From the tree view, select a Logical Node of an IED.
2. In the menu bar or in the contextual menu, click Add > Report Control Block.
A dialog box opens that displays settings for the RCB attributes.
3. Set the RCB identification attributes and parameters according to the descriptions
below.
4. Click OK to validate the operation.
When the operation is complete, the changes to the RCB are reflected in the current
SCL file and the CET850 display is updated: a newly created RCB is displayed in the
tree view and the settings of the RCB are updated in the property view.
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Report Control Block identification

RCB identification settings.

b RCB name: name of the RCB (must be unique in the Logical Node). It contains
only alphanumeric characters.
b RCB Description
b Dataset: select in the list box the name of the Dataset to be associated with the
RCB.
b Report ID: Identification of the RCB. This parameter is optional. If it is empty, the
full name of the RCB will be used at reporting time instead of the
Report ID.
b Conf Rev: revision number of the Dataset. It indicates to the client any
modifications inside the RCB, or the Dataset attached to the RCB.

PE80784

Report Control Block parameters

RCB parameters settings.

The Report Control Block parameters attributes define how to build the report.
b Buffer time: delay between the first trigger event and the creation of the report.
b Integrity period: time to periodically create the report, even without triggering. The
value 0 disables the creation of the periodic report.
b Buffered: when this option is checked, the report content is memorized in buffers.
b Index: when this option is checked, the reports are automatically indexed.
This option is enabled only if the Buffered option has been checked.
b Number 01-99: number of indexed buffers to be created by the device. This field is
available only if the Index option has been checked.

Report trigger conditions
PE80785

These attributes define the conditions to trigger the report.
To set an attribute, click the corresponding Attribute Value and select true or false in
the combo box.
b dchg: report triggers on data change (see "Adjusting the dead band of
measurements", page 30).
b qchg: report triggers on quality change.
b dupd: report triggers on data update.
b period: report triggers periodically according to the Integrity period defined above.

RCB trigger settings.

PE80786

Report content
These attributes define the content of the report. Setting one of the attributes to true
means that the corresponding data will be included in the report. To set or reset an
attribute, click the corresponding Attribute Value and select true or false in the combo
box.
Attribute

A sequence number may be assigned to a report when it is sent by the
server. This number is incremented each time a report is sent.
If the seqNum option is set to TRUE, the sequence number will be
included in the report. Otherwise, it is omitted.

timeStamp

The report time stamp specifies the time when the report was created.
If this option is set to TRUE, the report time stamp shall be included in
the report. Otherwise, it is omitted.
If this option is set to TRUE, the reference of the Dataset shall be
included in the report. Otherwise, it is omitted.
If this option is set to TRUE, the data in the report shall be reported with
the reason for their inclusions (depending on the Trigger option, the
reason may be: data-change, quality-change, integrity, generalinterrogation). Otherwise, the data are reported without reason code.
If this option is set to TRUE, the data in the report are reported with their
FCDA reference. Otherwise, the references of the data are omitted.
If this option is set to TRUE, the configuration revision number of the
RCB shall be included in the report. Otherwise, it is omitted.

RCB content settings.

dataSet
reasonCode
(Reason for inclusion)

dataRef
configRef

32

Explanation

seqNum
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Modifying an RCB
Modifying the RCB content or the trigger conditions
1. From the tree view, select an RCB and click Edit > Modify in the contextual menu.
The RCB settings window opens.
2. To modify the RCB content or the trigger conditions, see "Report content", page 32
and "Report trigger conditions", page 32.
The undo function can be used to go back to the previous state.

Modifying the RCB type (Buffered/Unbuffered)
1. From the tree view, select an RCB and click Edit > Modify in the contextual menu.
The RCB settings window opens.
2. To modify the RCB type, see "Report Control Block parameters", page 32.
b If the RCB type is "Unbuffered", check the Buffered option.
b If the RCB type is "Buffered", uncheck the Buffered option.
b If the RCB type is indexed, check the Indexed option and select the number of
indexed reports.
b If the RCB type is not indexed, uncheck the Indexed option.

Copying or moving an RCB
Once an RCB has been created it can be moved or copied to another Logical Node
of a different Logical Device if needed, using the copy/cut and paste or drag-and-drop
methods.
The undo function can be used to go back to the previous state.
Note: Report Control blocks are linked to Datasets which must reside in the same Logical Node.
When copying or moving an RCB, be sure to keep valid the reference to the Dataset.

Removing an RCB
Procedure
1. From the tree view, select the RCB you want to remove.
2. In the menu bar or in the contextual menu, click Edit > Delete or press the DEL key.
The RCB is removed from its Logical Node.
The undo function can be used to go back to the previous state.
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A Log Control Block (LCB) defines which data values and when these data values
are to be stored in the log.

ACE850
For edition 1, ACE850 allows only 1 Log file (in Logical Device LD0) and only 1 LCBs.
For edition 2, ACE850 allows only 1 Log file (in Logical node LLN0 and Logical
Device LD0) and only 1 LCBs.
Logging is disabled by default in the ICD file. It must be enabled either dynamically
or at configuration time. Integrity period logging is not supported; write operations to
the corresponding field of the LCB are possible but the value is ignored.
Log data is stored in non-volatile memory. Two 128 kBytes memory blocks are used;
when both are full, the block containing the oldest data is erased. The minimum Log
depth is the 128 kBytes and the maximum one is 256 kBytes, which corresponds to
approximately between 1000 and 2000 single point status changes.
Add Log Control Block in a Logical Node.

To ensure that a valid TimeOfEntry is assigned to Log entries, logging is
automatically disabled if the SNTP synchronization is disabled or not successful,
whatever the value of LogEna.

ECI850
Logging is not supported by ECI850. If Log or LogControl elements are found in the
CID file, they are ignored. This may occur as ICD files are common for ACE850 and
ECI850 and contain defaults elements.
LCB can be added by the user depending on the capabilities of the IED and can be
modified by the user.

PE80806

Adding a Log Control Block (LCB)
Procedure
1. From the tree view, select a Logical Node of an IED.
2. In the menu bar or in the contextual menu, click Add > Log Control Block.
A dialog box opens and displays settings for the LCB attributes.
3. Set the LCB identification attributes and parameters according to the descriptions
below.
4. Click OK to validate the operation.
Adding a Log Control Block.

34

When the operation is complete, the changes to the LCB are reflected in the current
SCL file and the CET850 display is updated. The newly created LCB is displayed in
the tree view and the settings of the LCB are updated in the property view.
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Log Control Block identification
PE80807

b LCB Name: name of the LCB (must be unique in the Logical Node). It contains only
alphanumeric characters.
b LCB Description: free ASCII description.
b Dataset: select in the list the data set whose values are to be logged.
The LCB has several attributes and parameters that control the logging process.
LCB identification settings.

PE80808

Log attributes

Log attributes settings.

Log attributes indicate in which log, the entries are to be stored.
b LD inst: the name of the logical device where the log resides. If missing, the it's the
same LD in which the LCB is places.
b Log Name: the name of the log. The log element exist and cannot be added nor
modified.
In edition 1, LD inst and Log Name are set with default values and cannot be
modified.
In edition 2, LD inst and Log Name are chosen in list box.

LCB parameters
PE80809

b Integrity Period: time to periodically create the log in ms.

LCB parameters settings.

Trigger conditions
PE80810

Trigger conditions contain the reasons which cause the control block to store an entry
into the log.
The reasons for storing a log entry into the log may be:
b dchg: report triggers on data change.
b qchg: report triggers on quality change.
b dupd: report triggers on data update.
b period: report triggers periodically according to the integrity period defined above.
To set an attribute, click the corresponding attribute value and select true or false in
the combo box.
LCB trigger settings.

Optional attributes
PE80811

b logEna: select true to enable the logging process, false to disable it.
b reasonCode: select true to store the reason code for the event trigger into the log.

LCB optional attributes settings.
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Modifying a LCB
Procedure
1. From the tree view, select a LCB and click Edit > Modify in the contextual menu.
The LCB settings window is opened.
2. To modify the LCB content, see Log Control Block information and "LCB
parameters", page 35.
The undo function can be used to go back to the previous state.

Copying or moving a LCB
Once an LCB is created, it can be moved or copied to another Logical Device if
needed, using the copy/cut and paste or drag-and drop methods.
The undo function can be used to go back to the previous state.
Note: Log Control blocks are linked to Datasets which must reside in the same Logical device.
When copying or moving an LCB, make sure to keep valid reference to the Dataset.

Removing a LCB
Procedure
1. From the tree view, select the LCB you want to remove.
2. In the menu bar or in the contextual menu, click Edit > Delete or press the DEL key.
The LCB is removed from its Logical Node.
The undo function can be used to go back to the previous state.

36
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The GOOSE message service is an efficient real-time communication service for
peer-to-peer exchanges between IEDs.
A GOOSE Control Block defines the way a Dataset is transmitted in a GOOSE
message.
A GCB can be created inside the LN0 only. The capabilities of an IED regarding the
configuration of GCBs are defined in the Services element by the GOOSE element.
For Sepam devices, only Sepam series 60 and Sepam series 80 IEDs implement the
GOOSE communication service.
By default, each Sepam series 60 or Sepam series 80 IED provides 1 GCB defined
in the LLN0. This GCB is pre-defined in each Sepam series 60 or Sepam series 80
ICD file. This GCB is named gcbBasicGse and is associated with the BasicGseDs
Dataset.
This default GCB can be modified by the user and new GCBs can be added,
depending on the capabilities of the IED.

Displaying the IED capabilities
Procedure
1. From the tree view, select the IED.
2. In the property view, expand the Services element.
3. Expand the GOOSE element to display the capabilities attributes:
b max: this value defines the maximum number of GOOSE Control Blocks that can
be created. If the max value is equal to the number of preconfigured GCB, no new
GCB can be created.

Adding a GOOSE Control Block (GCB)
PE80607

To add a GCB in the LN0, there must be at least one Dataset GOOSE compatible in
this Logical Node.
A Dataset is compatible when:
b The number of FCDA defined is less or equal to the maximum allowed.
b The size of the dataset is compatible with the Ethernet frame size.

Procedure

Adding a GOOSE Control Block.

1. From the tree view, select the LN0 of an IED.
2. In the menu bar or in the contextual menu, click Add > GOOSE Control Block.
The GOOSE Control Block Details dialog box opens which is used to set the GCB
attributes.
3. Set the GCB attributes according to the information given in the GOOSE Control
Block Details section below.
4. Click OK to validate the operation.
When the operation is complete, the changes to the GCB are reflected in the current
SCL file and the CET850 display is updated: a newly created GCB is displayed in the
tree view and the settings of the GCB are updated in the property view.

GOOSE Control Block Details
PE80608

b GCB name: name of the GCB. The name must be unique in the Logical Node. Only
alphanumeric characters are allowed.
b GCB description: description of the GCB (optional, may be empty).
b Dataset: name of the Dataset attached to the GCB. It is selected from the list of
the compatible datasets given in a list box.
b GOOSE ID: Identification of the GCB. A system-wide unique identification of the
application to which the GOOSE message belongs (mandatory, cannot be empty).
b Configuration revision: Revision number of the Dataset. It indicates to the client
any modifications inside the GCB (mandatory, cannot be empty), or inside the
associated Dataset.
GOOSE Control Block Details.
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GOOSE Control Block Properties
PE80787

b Subscribers: list of consumer IED names of the GCB.

GOOSE Control Block Properties.

Communication settings
PE80609

These attributes are used to transmit the GOOSE.
Enable GOOSE Publishing
This option is available only if the IED is connected to the communication network.
To connect the IED, see See “Adding a Connected Access Point” on page 25.
Checking/unchecking this option allows to enable/disable the publishing of the
GOOSE message on the communication network.
When the publishing is enabled, a GSE element is automatically created at the same
time in the ConnectedAP section inside the communication section.
When the publishing is disabled, the GSE element is automatically deleted.
It is also possible to enable/disable the publishing of a GOOSE at the Connected
Access Point level, inside the Communication section. See “Editing GSE Elements”
on page 40.

GOOSE Control Block communication settings.
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GSE Element Details
b MAC-Address: multicast MAC address of the GOOSE, default '01 0C CD 01 00 00'
b APPID: application identifier. 4 hexadecimal digits from '0000' to '3FFF', default
'0000'.
b VLAN-PRIORITY: Virtual LAN priority. From '0' to '7', default '4'.
b VLAN-ID: Virtual LAN identifier. 3 hexadecimal digits, default '000'.
b MinTime: Minimum time for GOOSE message reiteration. Range from 4 ms to
30 000 ms, default 8 ms.
b MaxTime: Maximum time for GOOSE message reiteration. Range from 4 ms to
30000 ms (30 s), default 2050 ms.

SEPED306025EN - 01/2013

CET850 configuration
software

Functional description
Editing GOOSE Control Blocks

Modifying a GOOSE Control Block
Procedure
1. From the tree view, select a GCB and click Edit > Modify in the contextual menu.
The GCB settings window opens.
2. To modify the GCB content, See “GOOSE Control Block Details” on page 37.
The undo function can be used to go back to the previous state.

Copying or moving a GOOSE Control Block
When a GCB has been created, it can be moved or copied to the LN0 of an other
Logical Device if needed, using the copy/cut and paste or drag-and-drop
methods.
The undo function can be used to go back to the previous state.
Note: GOOSE Control blocks are linked to Datasets which must reside in the same Logical Node.
When copying or moving a GCB, be sure to keep valid the reference to the Dataset.

Removing a GCB
Procedure
1. From the tree view, select, the GCB you want to remove.
2. In the menu bar or in the contextual menu, click Edit > Delete or press the DEL
key.
The GCB is removed from its Logical Node.
The undo function can be used to go back to the previous state.
Note: If the GCB is linked to a GSE element at the Connected Access Point level in the
Communication section, the GSE element is automatically deleted when removing the GCB.
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The GSE element contains the settings used for publishing of a GOOSE message
on the communication network by an IED. It is defined at the IED Connected Access
Point level, inside the Communication section.

GSE element in a ConnectedAp.

PE80603

Adding a GSE element
To add a GSE element to the Connected AP element of an IED, there must be at least
one GOOSE Control Block in this IED to publish.

Procedure

Adding a GSE element.

To create a GSE element:
1. From the tree view in the Communication section, select a ConnectedAP of an IED.
2. In the menu bar or in the contextual menu, click Add > GSE Element.
A dialog box opens that allows setting the GSE element attributes.
3. Set the GSE element attributes according to the GCB Identification and GOOSE
Publishing Details sections below.
4. Click OK to validate the operation.
Once the operation is complete, the changes to the GSE element are reflected in the
current SCL file and the CET850 display is updated: a newly created GSE element
is displayed in the tree view and the settings of the GSE element are updated in the
property view.

GCB identification
PE80604

b IED name: name of the IED. This field is grayed and cannot be changed.
b AP name: name of the Connected AP. This field is grayed and cannot be changed.
b GCB name: list of available GCBs in the selected IED.

GCB identification settings.

PE80605

GOOSE publishing
Enable GOOSE Publishing option
Adding a GSE element is equivalent to enable the publishing of a GOOSE message.
By default this option is checked and cannot be changed.
GSE Element Details
b MAC-Address: multicast MAC address of the GOOSE, default '01 0C CD 01 00 00'
b APPID: application identifier. 4 hexadecimal digits from '0000' to '3FFF', default
'0000'.
b VLAN-PRIORITY: Virtual LAN priority. From '0' to '7', default '4'.
b VLAN-ID: Virtual LAN identifier. 3 hexadecimal digits, default '000'.
b MinTime: Minimum time for GOOSE message reiteration. Range from 4 ms to
50 ms, default 8 ms.
b MaxTime: Maximum time for GOOSE message reiteration. Range from 100 ms to
30000 ms (30 s), default 2000 ms (2 s).

GOOSE publishing settings.

40
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Modifying a GSE element
Procedure
1. From the tree view, select an GCB and click Edit > Modify in the contextual menu.
The GSE element settings window opens.
2. To edit the GSE element details, see "GSE Element Details", page 40
The undo function can be used to go back to the previous state.

Removing a GSE element
Removing a GSE element is equivalent to disable the publishing of a GOOSE
message.
There are 2 possible ways to remove a GSE element:
b directly by deleting the GSE element from the tree view (see procedure 1 below),
b indirectly by editing the associated GOOSE Control Block and disabling the
GOOSE publishing (see procedure 2 below).

Procedure 1
1. From the tree view, select the GSE Element you want to remove.
2. In the menu bar or in the contextual menu, click Edit > Delete or press the DEL key.
The GSE Element is removed from its ConnectedAP.
The undo function can be used to go back to the previous state.

Procedure 2
1. From the tree view, select the GOOSE Control Block associated with the GSE
Element you want to remove.
2. In the menu bar or in the contextual menu, click Edit > Modify.
3. Uncheck the Enable GOOSE Publishing option.
4. Click OK to validate the modification.
The GSE Element is removed from its ConnectedAP in the Communication section
The undo function can be used to go back to the previous state.
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The capability of a Schneider Electric IED to receive GOOSE messages is defined in
its ICD file. It appears in the tree view with the presence of the GOOSE Receive
element defined at the beginning of the IED section.
Editing the GOOSE receive element allows the user to select the GOOSE messages
and the data to which the IED must subscribe and to assign the subscribed data to
Sepam GOOSE inputs.

Displaying the GOOSE Receive details

GOOSE Receive Input Details view.
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The GOOSE Receive details are displayed in the GOOSE Receive view when the
user selects the GOOSE Receive element from the tree view.
The property view is divided into 2 parts:
b the upper part named GOOSE Receive:
The GOOSE Receive part displays the list of all GOOSE messages that are
consumed by the IED.
b the lower part named GOOSE Input Details.
The GOOSE Input Details part displays the structure of the dataset attached to the
GOOSE message selected in the GOOSE Receive part.
b The lower part is split into 2 when the structure of the Dataset in the Producer Side
is different from the structure of the Dataset in the Private GOOSE Receive.
v The first column displays the content of the Private GOOSE Receive.
v The second column displays the content of the Dataset in the Producer Side.
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Modifying the GOOSE Receive
PE80384

Procedure
1. From the tree view, double-click GOOSE Receive of the consumer IED or
click Edit > Modify in the contextual menu. A dialog box, organized in 2 tabs, opens.
The dialog box enables the user to select GOOSE Messages to subscribe to data
from these messages, and then to assign the subscribed data to Sepam GOOSE
inputs.
2. In the Subscription tab:
2.1 Select the GOOSE messages that will be received by the IED (these messages
are selected from all the GOOSE messages produced on the network).
2.2 Select the Data Attributes (DA) which might be useful for the consumer IED.
3. In the Assign GOOSE Inputs tab, using the list of all subscribed DA, assign each
FCDA to a Sepam GOOSE input. A user name and user description can also be
assigned to each Sepam GOOSE input.
GOOSE subscription dialog box.

Subscription tab
The subscription tab is divided into 2 parts:
b The left part gives the list of all GOOSE messages that are produced by the IEDs
present in the SCL file, including their associated datasets.
b The right part gives the list of the Data Attributes (DAs) selected for subscription
from the datasets published as GOOSE messages.
All the DAs defined in the dataset are displayed, but only DAs with a Functional
Constraint [ST] can be selected. Inside the [ST] group, only the DA of type
BOOLEAN, Dbpos, or Quality can be selected. A specific mark is added to indicate
if a DA can be selected or if it is already selected.
Mark

Meaning
The DA is free and can be selected for subscription.
The DA is selected for subscription. It cannot be selected again.
The structure contains at least 1 DA which is free and which can be selected
for subscription.
The structure contains at least 1 DA which is selected for subscription.
The DA is not valid for subscription.
The structure does not contain any valid DA for subscription.

It is possible to select for subscription a GOOSE message produced by the IED itself.
The same data attribute can be selected for subscription only once.
GOOSE messages with incompatible dataset cannot be selected and are displayed
in the list in grey color.
Procedure
Subscribe
1. Select the valid DA in the left part and click on the right button arrow
.
The DA is added to the right list for subscription.
Unsubscribe
2. Select the DA in the right part and click on the left button arrow
.
The DA is removed from the right list for subscription.
To validate the subscriptions and go to the Assign GOOSE Inputs tab, select the
button Apply.

PE80793

When the GOOSE message subscription is complete, the list of subscriber IED
names is updated in the GCB Properties view for each GCB subscriber.
To obtain the list of subscribers for a given GCB, select the GCB. The Properties view
is refreshed with the section Subscribers that contains the IED subscribers.

GOOSE Receive Subscribers section view.
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Editing GOOSE Receive

GOOSE Input Details
The GOOSE Input Details section is updated with all the GOOSE messages
subscribed in the GOOSE Receive dialog box.
b The lower part is split into 2 when the structure of the Dataset in the Producer Side
is different from the structure of the Dataset in the Private GOOSE Receive.
v The first column displays the content of the Private GOOSE Receive.
v The second column displays the content of the Dataset in the Producer Side.

Assign GOOSE Inputs tab
PE80385

The Assign GOOSE Inputs tab is used to assign the subscribed DAs to the Sepam
GOOSE inputs. This tab is available only if some GOOSE data has been previously
subscribed.
The Assign GOOSE Inputs tab displays a table.

Assign GOOSE Inputs tab.

Table rows
The table rows lists all the DAs previously selected for subscription, with their full
name and their associated description.
Two specific attributes by dataset are added for assignment:
b QR: quality reception
At run time, the QR attribute is set to 1 to inform that the GOOSE message was not
received in the expected time.
b QD: dataset consistency
At run time, the QD attribute is set to 1 to inform that the structure of the received
GOOSE message is different from the structure defined at subscription time.
Table columns
The table gives in column the list of the Sepam GOOSE inputs to which the DAs can
be assigned/de-assigned by selecting the appropriate cells in the table.
Sepam provides 31 GOOSE inputs named G401 to G416 and G501 to G515.
Several DAs can be assigned to the same Sepam GOOSE input. In this case, Sepam
applies a wired-OR logic operation to these DAs.
Procedure to assign/de-assign a DA
1. To assign/de-assign a DA to/from a Sepam GOOSE input, click on the cell
associated with the DA (in row) and with the GOOSE input (in column).
When the DA is assigned to the GOOSE input, a cross is displayed inside the cell.
When the DA is de-assigned from the GOOSE input, the cross disappears.
2. To validate the assignment matrix, click on the Apply button.

PE80606

Procedure to edit GOOSE Inputs Infos
The lower part of the main dialog box can be extended to edit details about the
Sepam GOOSE inputs. This part of the dialog allows the user to assign a name and
a description to each Sepam GOOSE input.
1. To display the GOOSE Inputs details, click the GOOSE Inputs Infos >> button.
2. A table is displayed that lists all of the GOOSE inputs with 2 text fields for the user
name and description. The user can edit these 2 fields for each GOOSE input.

GOOSE Inputs infos.

Logical Node Inputs
PE80794

The Logical Nodes Inputs section is updated with all the GOOSE messages
subscribed in the GOOSE Receive dialog box.
The list of all GOOSE messages subscribed in displayed in the Properties view.

Logical Node Inputs Properties view.
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FTP menu

PE80788

The FTP function is used to download or upload CID files to/from a device.
With the CET850, the user can download an individual CID file or several CID files
as a group.

FTP menu.

Downloading all CID files
Procedure
PE80789

To download all CID files:
1. From the tree view, select the Communication element.
2. From the tree view, select the subnet element.
3. In the menu bar, right-click and select the Download All CID To Devices.
A dialog box opens, displaying the CID files available for download.
4. In the dialog box, select the files to download by checking the associated box.
To download all files, check the Select All box.
5. Click Download to validate the operation.
The dialog box remains open until all the CID files are downloaded.

PE80790

Downloading all CID files.

If a download operation is unsuccessful, the line is red.
To close the dialog box, click the Exit button.

Selecting CID files to download.

Downloading a CID file
Procedure
PE80791

To download a CID file:
1. From the Communication tree view, select the connected Access Point
associated with the IED.
2. In the menu bar, right-click and select the Download CID To Device.
3. Click Download to validate the operation.

Downloading a CID file.
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Uploading a CID file
PE80792

Procedure

Uploading a CID file.

To upload a CID file:
1. In the menu bar, right-click and select the Upload CID from Device.
A dialog box opens, displaying the server identification and device credentials fields
to complete.
2. In the dialog box, complete the fields as follows:
b UserName: enter the default username specific to the device type:
v Sepam series 20, Sepam series 40, Sepam series 60, and Sepam series 80:
Admin
v G3200: Administrator
v ION Series 7000/8000: 0
v ECI850 Sepam server: Administrator
b Password: enter the default username specific to the device type:
v Sepam series 20, Sepam series 40, Sepam series 60, and Sepam series 80:
ACE850
v G3200: G3200
v ION Series 7000/8000: 0
v ECI850 Sepam server: ECI850
b Device Type: select the device type from the combo list.
b CID File Path: the default location is automatically selected by the CET850. This
location is the same as the default location used for building CID files.
b Upload Location: enter the path of the desired location on the hard drive.
Note: The default device credentials are kept in the Windows registry.During a download
operation, the CET850 checks for the registry settings and attempts to authenticate the settings
if present.If the registry settings are missing, the CET850 uses the hardcoded default values.

3. Click OK to validate the operation.
b If the device credentials entered are invalid, a box opens prompting the user for
valid credentials.
b If the CID file selected is at the correct location and the device credentials entered
are valid, the CET850 displays a message indicating that the CID file download is in
progress.
b If the CID file selected or the device credentials entered are invalid, the CET850
displays a message indicating that the CID file download is unsuccessful.
b If the selected IED already exists in the default location of the CID file, the CET850
displays a message prompting the user to use the existing IED or to rebuild the CID
file.
The download starts as soon as the CID file is built.
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PE80588

XML source editing
Expert users can directly edit the XML code of the SCL file. By default, this function
is disabled. It can be enabled by checking the Enable XML source editing option in
the menu Tools > Preferences.
To display XML code:
In the menu bar, click View > XML source.
The whole file is displayed even if some parts are hidden in the tree view.
To go back to normal display mode, click View > Property View.

NOTICE
RISK OF SCL FILE CORRUPTION
XML source editing must be used with extreme care. Inappropriate
modifications may corrupt the SCL file.
XML source view.

Failure to follow these instructions can result in equipment damage.

Backup and file recovery
When an SCL file is opened for editing, a backup of the file is done with the same
name as the SCL file but with BAK extension. In case of errors in the file, it is possible
to go back to the previous state before the last save command.
By default, the current SCL file is saved every 5 minutes.
This function is controlled in the menu Tools > Preferences.

User preferences
The Preferences window allows the user to customize CET850.

Procedure
1. In the Menu bar, click Tools > Preferences to display Preferences window.
2. Check options or set fields to enable desired features in CET850.
Default

Explanation

IEC 61850 standard

Option/Field

1

Display welcome message

No

IED full display mode

No

Specifies the IEC 61850 edition to be
used in the CET850. This list box
displays all the available IEC 61850
editions supported by CET850.
Display/hide the Welcome message to
select the IEC61850 Edition at the
application launch.
Display/hide intermediate SCL levels
with little or no added value/interest
Display/hide DataType Templates
section
Display/hide Substation section

Display DataType Templates No
section
Display Substation section
No
Display Process Bus elements No
Delete confirmation required

Yes

Display/hide SMV elements in the
Communication section
Deletion needs confirmation

Enable XML source editing

No

Enable XML source editing

Enable periodical backup

Yes

Make periodical backup of open file

Period for automatic backup

5 mn

Period for current SCL file backup

Automatic validation at file
opening
Automatic validation at file
saving
ICD library path

Yes

Check XML syntax at file opening

No

Check XML syntax at file saving

SCL schema
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C:\Program Files\
Path for the standard ICD library
Schneider\SFTCommon\
IEC61850\Edition1\ICD
C:\Program Files\
Path for IEC 61850 SCL XML schema
Schneider\SFTCommon\
IEC61850\Edition1\XSD
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Meaning

AP

Access Point

APPID or AppID

Application Identification

BRCB

Buffered Report Control Block

BDA

Basic DATA Attribute, i.e. not structured

CB

Control Block

CDC

Common Data Class

CID

Configured IED Description

DA

Data Attribute

DAI

Instantiated Data Attribute

DAType

Type of Data Attribute

DO

Data Object

DOI

Instantiated Data Object

DOType

Type of a Data Object

FC

Functional Constraint

FCD

Functional Constrained Data

FCDA

Functional Constrained Data Attribute

GCB

GOOSE Control Block

GOOSE

Generic Object-Oriented Substation Event

GSE

Generic Substation Event

GSSE

Generic Substation Status Event

Hitem

History Item

ID

Identifier

IED

Intelligent Electronic Device

ICD

IED Configuration Description

IP

Internet Protocol

LD

Logical Device

IdInst

Instance identification of a Logical Device

LAN

Local Area Network

LCB

Log Control Block

LN

Logical Node

LNType

Type of a LN

InInst

Instance number of a Logical Node

MAC

Medium Access Control

MSV

Multicast Sampled Value

MsvID

ID for MSV (Multicast Sampled Value)

RCB

Report Control Block

SCD

Substation Configuration Description

SCL

Substation Configuration Description Language

SDI

Instantiated Sub DATA

SDO

Sub DATA within a DOType, referencing another DOType

SG

Setting Group

SV

Sampled Values

TCP

Transmission Control Protocol

URCB

Unbuffered Report Control Block

V-LAN

Virtual Local Area Network

XML

Extensible Markup Language
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