# Table of Contents

1. Legal Information.........................................................................................................................6

2. Technical Support..........................................................................................................................7

3. Safety Information........................................................................................................................8

4. About this Guide...........................................................................................................................11

5. About SCADAPack Workbench.......................................................................................................14

6. Starting SCADAPack Workbench.....................................................................................................15

7. Using SCADAPack Workbench with Target 3..............................................................................16

7.1 Getting Started with Target 3 .........................................................................................................16

7.1.1 Licensing Target 3.....................................................................................................................16

7.1.2 Understanding Target 3 Application Structure........................................................................16

7.1.3 Creating a New Target 3 Project...............................................................................................16

7.1.4 Accessing SCADAPack Configurator.......................................................................................16

7.1.5 Configuring Communications with a SCADAPack Device......................................................16

7.1.5.1 Configuring Communications in SCADAPack Configurator.............................................16

7.1.5.2 Configuring Communications in SCADAPack Workbench.............................................16

7.1.6 Restoring the Default User Interface Settings........................................................................16

7.2 Programming for Target 3 ............................................................................................................16

7.2.1 Adding Programs......................................................................................................................16

7.2.2 Adding and Editing Program Elements...................................................................................16

7.2.3 Defining Variables...................................................................................................................16

7.2.4 Assigning Variables..................................................................................................................16

7.2.4.1 Adding an I/O Device...........................................................................................................16

7.2.4.2 Assigning Variables to an I/O Device................................................................................16

7.2.4.3 Defining Analog Input Operation.......................................................................................16

7.2.5 Building the Solution................................................................................................................16

7.2.6 Downloading the Solution to the SCADAPack Device...........................................................16

7.2.7 Debugging Applications...........................................................................................................16

7.2.8 Using One Solution as the Basis for Another........................................................................16
1 Legal Information

Copyright © 2014 - 2017 Schneider Electric Canada Inc.
All rights reserved.

The information provided in this documentation contains general descriptions and/or technical characteristics of the performance of the products contained herein. This documentation is not intended as a substitute for and is not to be used for determining suitability or reliability of these products for specific user applications. It is the duty of any such user or integrator to perform the appropriate and complete risk analysis, evaluation and testing of the products with respect to the relevant specific application or use thereof. Neither Schneider Electric nor any of its affiliates or subsidiaries shall be responsible or liable for misuse of the information contained herein. If you have any suggestions for improvements or amendments or have found errors in this publication, please notify us.

No part of this document may be reproduced in any form or by any means, electronic or mechanical, including photocopying, without express written permission of Schneider Electric.

All pertinent state, regional, and local safety regulations must be observed when installing and using this product. For reasons of safety and to help ensure compliance with documented system data, only the manufacturer should perform repairs to components.

Trademarks

Schneider Electric, ClearSCADA, SCADApack, Flowstation, SCADALog, Solarpack, Realflo, Telepace, Telebus, and Modbus are trademarks and the property of Schneider Electric SE, its subsidiaries and affiliated companies. All other trademarks are the property of their respective owners.

Microsoft and Windows are registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Address

Schneider Electric
415 Legget Drive, Suite 101, Kanata, Ontario K2K 3R1 Canada
Direct Worldwide: +1 (613) 591-1943
Fax: +1 (613) 591-1022
Toll Free within North America: 1 (888) 267-2232
www.schneider-electric.com
2 Technical Support

Questions and requests related to any part of this documentation can be directed to one of the following support centers.

Technical Support: Americas, Europe, Middle East, Asia

Available Monday to Friday 8:00am – 6:30pm Eastern Time
Toll free within North America 1-888-226-6876
Direct Worldwide +1-613-591-1943
Email supportTRSS@schneider-electric.com

Technical Support: Australia

Inside Australia 1300 369 233
Email au.help@schneider-electric.com
3 Safety Information

Important Information

Read these instructions carefully and look at the equipment to become familiar with the device before trying to install, operate, service, or maintain it. The following special messages may appear throughout this documentation or on the equipment to warn of potential hazards or to call attention to information that clarifies or simplifies a procedure.

The addition of this symbol to a Danger or Warning safety label indicates that an electrical hazard exists, which will result in personal injury if the instructions are not followed.

This is the safety alert symbol. It is used to alert you to potential personal injury hazards. Obey all safety messages that follow this symbol to avoid possible injury or death.

### DANGER

**DANGER** indicates a hazardous situation which, if not avoided, **will result in** death or serious injury.

### WARNING

**WARNING** indicates a hazardous situation which, if not avoided, **can result in** death or serious injury.

### CAUTION

**CAUTION** indicates a potentially hazardous situation which, if not avoided, **can result in** minor or moderate injury.

### NOTICE

**NOTICE** is used to address practices not related to physical injury.
Please Note

Electrical equipment should be installed, operated, serviced, and maintained only by qualified personnel. No responsibility is assumed by Schneider Electric for any consequences arising out of the use of this material.

A qualified person is one who has skills and knowledge related to the construction, installation, and operation of electrical equipment and has received safety training to recognize and avoid the hazards involved.

Before You Begin

Do not use this product on machinery lacking effective point-of-operation guarding. Lack of effective point-of-operation guarding on a machine can result in serious injury to the operator of that machine.

<table>
<thead>
<tr>
<th>WARNING</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>EQUIPMENT OPERATION HAZARD</strong></td>
</tr>
<tr>
<td>• Verify that all installation and set up procedures have been completed.</td>
</tr>
<tr>
<td>• Before operational tests are performed, remove all blocks or other temporary holding means used for shipment from all component devices.</td>
</tr>
<tr>
<td>• Remove tools, meters, and debris from equipment.</td>
</tr>
<tr>
<td><strong>Failure to follow these instructions can result in death or serious injury.</strong></td>
</tr>
</tbody>
</table>

Follow all start-up tests recommended in the equipment documentation. Store all equipment documentation for future reference.

Test all software in both simulated and real environments.

Verify that the completed system is free from all short circuits and grounds, except those grounds installed according to local regulations (according to the National Electrical Code in the U.S.A, for instance). If high-potential voltage testing is necessary, follow recommendations in equipment documentation to help prevent accidental equipment damage.

Operation and Adjustments

The following precautions are from the NEMA Standards Publication ICS 7.1-1995 (English version prevails):

• Regardless of the care exercised in the design and manufacture of equipment or in the selection and ratings of components, there are hazards that can be encountered if such equipment is improperly operated.

• It is sometimes possible to misadjust the equipment and thus produce unsatisfactory or unsafe operation. Always use the manufacturer’s instructions as a guide for functional adjustments. Personnel who have access to these adjustments should be familiar with the equipment manufacturer’s instructions and the machinery used with the electrical equipment.

• Only those operational adjustments actually required by the operator should be accessible to the operator. Access to other controls should be restricted to help prevent unauthorized changes in operating characteristics.
Acceptable Use

SCADAPack and SCADAPack E remote Programmable Automation Controllers (rPACs), Remote Terminal Units (RTUs) and input/output (I/O) modules are intended for use in monitoring and controlling non-critical equipment only. They are not intended for safety-critical applications.

<table>
<thead>
<tr>
<th>WARNING</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNACCEPTABLE USE</td>
</tr>
</tbody>
</table>
Do not use SCADAPack RTUs, SCADAPack E rPACs and RTUs, or I/O modules as an integral part of a safety system. These devices are not safety products.

*Failure to follow this instruction can result in death or serious injury.*

<table>
<thead>
<tr>
<th>CAUTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>EQUIPMENT OPERATION HAZARD</td>
</tr>
</tbody>
</table>
When devices are used for applications with technical safety requirements, the relevant instructions must be followed.

Use only Schneider Electric software or approved software with Schneider Electric hardware products.

*Failure to follow these instructions can result in minor or moderate injury.*
4 About this Guide

Audience
This guide is written for people who are new to the SCADAPack Workbench programming environment for SCADAPack or SCADAPack E remote Programmable Automation Controllers (rPACs) or Remote Terminal Units (RTUs). These people are typically:

- Systems Engineers
- Commissioning Engineers
- Maintenance Technicians

Scope
This guide provides an overview of the SCADAPack Workbench programming environment and guides the reader through the basic steps required to create and compile an application. It includes information about:

- Using SCADAPack Workbench with Target 3
- Using SCADAPack Workbench with Target 5

This guide assumes that users who are moving from ISaGRAF 3 Workbench have already imported their projects into SCADAPack Workbench, as described in Migrating ISaGRAF 3 Workbench Projects to SCADAPack Workbench.

The simple tasks described in this guide are not a substitute for the detailed information provided in the other manuals in the SCADAPack Workbench documentation set. For details, see Related Documents.

Document Validity
This manual applies to:

- SCADAPack Workbench version 6.5.0

Target 3 hardware and software

- SCADAPack controllers running the firmware versions listed below. These firmware versions were the most recent versions available when the SCADAPack Workbench software was released.
  
  - SCADAPack 32 and SCADAPack 32P controllers: 2.23
  - SCADAPack 100 controllers: 2.50
  - SCADAPack 314, SCADAPack 330, SCADAPack 334, SCADAPack 350, and SCADAPack 357 controllers: 1.75
  - SCADAPack 4203 controllers: 1.63
  - NOCT60: 1.75

- SCADAPack Configurator version 1.2.1

Target 5 hardware and software

- SCADAPack E rPACs and RTUs running firmware version 8.14.1. This firmware version was the most recent version available when the SCADAPack Workbench software was released.
About this Guide

- SCADAPack E Configurator version 8.14.1
Product Related Information

WARNING

UNINTENDED EQUIPMENT OPERATION
The application of this product requires expertise in the design and programming of control systems. Only persons with such expertise should be allowed to program, install, alter and apply this product.

Follow all local and national safety codes and standards.

Failure to follow these instructions can result in death or serious injury.

Related Documents
This guide is intended to be used with the complete set of reference manuals provided for each target type supported in SCADAPack Workbench.

SCADAPack E Target 5
- SCADAPack E Target 5 Function Block Reference Manual
- SCADAPack E Target 5 I/O Device Reference Manual

To access these manuals, select HELP > SCADAPack E Target 5 Help from the SCADAPack Workbench main menu.

SCADAPack Target 3
- Migrating ISaGRAF 3 Workbench Projects to SCADAPack Workbench
- SCADAPack Configurator User Manual
- SCADAPack Target 3 Function Block Reference Manual
- SCADAPack Target 3 I/O Device Reference Manual

To access these manuals, select HELP > SCADAPack Target 3 Help from the SCADAPack Workbench main menu.

Additional information
To view additional information about using this platform to develop IEC 61131-3 applications, select HELP > View Help from the SCADAPack Workbench main menu.
5 About SCADAPack Workbench

SCADAPack Workbench provides IEC61131-3 international standard Programmable Logic Controller (PLC) programming capabilities for SCADAPack E and SCADAPack remote Programmable Automation Controllers (rPACs) and remote terminal units (RTUs). It is used to create, manage and simulate IEC 61131-3 applications.

The SCADAPack Workbench software executes on a PC and provides application generation, transferring and debugging through connection to the target virtual machine (VM) through serial or network communications.

The IEC 61131-3 target VM executes on the rPAC or RTU and is built-in to the operating system.

Target Support

SCADAPack Workbench supports the following target types:

- Target 3, which runs on SCADAPack RTUs
- Target 5, which runs on SCADAPack E rPACs and RTUs

Language Support

SCADAPack Workbench supports the four standard IEC 61131-3 programming languages described below. These languages can be mixed within an application to provide an optimum control strategy.

Functional Block Diagram (FBD)

The Function Block Diagram is a graphic language used to build complex procedures from a library of functions. Standard library functions such as math and logic may be combined with custom library functions such as serial port control, PID controls and Modbus master and slave protocols to create Function Block Diagram application programs. A class of programs called functions allows the creation of user functions that are not included in the library.

Structured Text (ST)

Structured Text is a high-level structured language, similar to Pascal and C, that is used for complex procedures or calculation that cannot be easily implemented using graphic languages. Structured Text is the default language used to describe actions within the steps of the Sequential Function Chart language.

Ladder Diagram (LD)

Ladder Diagram is a graphic language combining contacts and coils to build logical discrete control procedures. This language is similar to the relay ladder logic used by many programmable logic RTUs. Ladder Diagram contacts and coils can be used in the Function Block Diagram language for discrete control of functions.

Sequential Function Chart (SFC)

The Sequential Function Chart is a graphic language used to describe sequential operations in a process. The process is graphically partitioned into a set of steps containing actions performed using other languages. Steps are linked together with conditional transitions. This language is useful for batch processes and process procedures such as automatic startup and shut down.
6 Starting SCADAPack Workbench

To start SCADAPack Workbench, select the Start or Windows icon, then navigate to the Schneider Electric folder and select SCADAPack Workbench > SCADAPack Workbench.

Alternatively, if you are using SCADAPack E Configurator, you can select IEC 61131-3 > Launch Workbench from the main menu.

After you start SCADAPack Workbench for the first time, you need to license the application:

- Licensing Target 3
- Licensing Target 5
7 Using SCADAPack Workbench with Target 3

This section includes topics that explain how to use SCADAPack Workbench to develop programs for SCADAPack RTUs:

- Getting Started with Target 3
- Programming for Target 3
- Target 3 Sample Application

7.1 Getting Started with Target 3

This topic describes the basics of getting started with Target 3:

- Licensing Target 3
- Understanding Target 3 Application Structure
- Creating a New Target 3 Project
- Accessing SCADAPack Configurator
- Configuring Communications with a SCADAPack Device
- Restoring the Default User Interface Settings

7.1.1 Licensing Target 3

This topic describes licensing requirements for SCADAPack Workbench. While other licensing information may be provided in the Help topics for the underlying Automation Collaborative Platform (ACP), this is the only licensing information that applies to SCADAPack Workbench.

Before you use SCADAPack Workbench to develop a new application, to modify an existing application, or to import an ISaGRAF 3 Workbench application, you need to enter registration keys in the appropriate SCADAPack Workbench License Info window and validate your license.

Requesting Registration Keys

To request registration keys, you need the following information:

- The serial number for the software. If you have a DVD, the serial number is on the DVD case. The serial number starts with "R".
- The three user codes in the Licensing window for your target type.

The procedure below explains how to locate user codes, request registration keys and validate your license. Once your license is validated, SCADAPack Workbench is licensed for the duration you purchased:

- 1 month
- 6 months
- 12 months
- Unlimited

Reactivating or Extending a License
To reactivate a license after you upgrade, or to extend the license duration, contact Schneider Electric Customer Support at ordersTRSS@schneider-electric.com. See the information above for the details needed when requesting registration keys.

To License Target 3

1. Start SCADAPack Workbench.
2. Select HELP > Licensing Target 3.

3. Review the license description and expiration date.
4. Record the numbers in the User Code 1, User Code 2 and User Code 3 fields.
5. E-mail the three user codes, along with the serial number from the DVD case (the number that begins with "R"), to Schneider Electric Customer Support at ordersTRSS@schneider-electric.com. You will receive Registration Key 1 and Registration Key 2.
6. Enter the Registration Keys in their respective fields in the Licensing window, then click Validate.

If you have difficulty with these tasks, contact Schneider Electric Technical Support.
7.1.2 Understanding Target 3 Application Structure

The figure below identifies the main elements in a Target 3 application structure.

- An IEC 61131-3 application is called a Solution.
- A **Solution** for an IEC 61131-3 application contains a Project. A solution contains everything needed to manage an IEC 61131-3 application on an RTU. It is opened and saved on the PC running SCADAPack Workbench.
- A **Project** contains a Device, which is a SCADAPack RTU. A project defines the available targets for this solution.
- A **Device** is the physical RTU. It contains Programs.
- A **Program** contains logic modules that are written in one of the supported SCADAPack Workbench languages.

This solution structure is used for SCADAPack Workbench programs. Although it's possible to structure the solution in other ways, they are not supported by the RTU.

**Renaming Solution Components**

Follow these rules when renaming solution components:

- Names must begin with a letter, followed by letters, digits and single underscore characters. The last character for a name must be a letter or digit. Names cannot end with an underscore character.

7.1.3 Creating a New Target 3 Project

Follow the steps below if you are using a SCADAPack RTU running Target 3.

To **Create a New SCADAPack Target 3 Solution**

1. Start SCADAPack Workbench.
2. From the Start Page, click **New Project**. If the Start Page isn't open, select **FILE > New > Project**.
3. From the list of installed templates, select **CAM Projects > Target 3 > SCADAPack**.

4. In the middle panel, select your RTU model.

5. In the **Name** field, type the name of the project. The same name will be given to the Solution.
   
   Names must begin with a letter, followed by letters, digits and single underscore characters. Dashes (-) are not supported in project names.

6. Change the default location, if required.

7. Click **OK** to create the solution file.

   SCADAPack Workbench opens the Deployment View for the solution.
The Deployment View displays the communications link between the RTU and the computer running SCADAPack Workbench.

The Solution Explorer shows the solution. Click on the symbols to expand and contract your view of the solution components. For details, see Understanding SCADAPack Target 3 Application Structure.

The next step is to configure the communications link. For details, see Configuring Communications with a SCADAPack Device.

### 7.1.4 Accessing SCADAPack Configurator

SCADAPack RTUs are configured using SCADAPack Configurator.

To access SCADAPack Configurator from SCADAPack Workbench, open the solution and do one of the
following:

- Right-click on the RTU and select **Launch SCADAPack Configurator**.
- In the SCADAPack Workbench main menu, select **TOOLS > Launch SCADAPack Configurator**.

For information about using SCADAPack Configurator, see the SCADAPack Configurator User Manual.

### Switching between SCADAPack Configurator and SCADAPack Workbench

If you are running SCADAPack Configurator and SCADAPack Workbench at the same time, follow the guidelines below when switching between applications.

<table>
<thead>
<tr>
<th>Connection Type</th>
<th>Switching from SCADAPack Configurator to SCADAPack Workbench</th>
<th>Switching from SCADAPack Workbench to SCADAPack Configurator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Serial</td>
<td>Click <strong>Disconnect</strong> in SCADAPack Configurator so SCADAPack Workbench can access the communication channel to the RTU.</td>
<td>Disconnect communications between SCADAPack Workbench and the RTU.</td>
</tr>
<tr>
<td>USB</td>
<td>No additional steps.</td>
<td>No additional steps.</td>
</tr>
<tr>
<td>TCP/IP</td>
<td>No additional steps.</td>
<td>No additional steps.</td>
</tr>
</tbody>
</table>

### 7.1.5 Configuring Communications with a SCADAPack Device

Once you create your project, you need to configure the communications link between SCADAPack Workbench and the RTU.

You can continue programming without configuring the link, but you need to configure the link before you can **download the solution**.
To configure communications between SCADAPack Workbench and a SCADAPack RTU

1. Configure communications in SCADAPack Configurator.
2. Configure communications in SCADAPack Workbench.

7.1.5.1 Configuring Communications in SCADAPack Configurator

The procedure below provides the high level steps to configure the SCADAPack RTU to communicate with SCADAPack Configurator. For detailed information about the port properties, see Configuring Controller Communication Settings in the SCADAPack Configurator manual.

To Configure Controller Communication Settings in SCADAPack Configurator

1. In the SCADAPack Workbench main menu, select TOOLS > Launch SCADAPack Configurator.
2. In the SCADAPack Configurator tree, expand the Project folder and select the required communication type.
3. Configure the communication settings for the connection between your SCADAPack RTU and SCADAPack Configurator.

7.1.5.2 Configuring Communications in SCADAPack Workbench

When you create a new project for a SCADAPack RTU, the protocol is automatically set to TeleBUS. The next step is to select the communication protocol that is running over TeleBUS. The procedure below describes how to select the communication protocol and access the protocol configuration parameters.

To Configure Communications with a SCADAPack RTU

1. With the solution open, select VIEW > Deployment View from the main menu.

   The Deployment View is displayed.

2. In the Deployment View, right-click on the communication link to the RTU and select Properties.

   The Connection Information Properties are displayed, as shown below. Use these properties only to select the communication protocol. To configure other communication parameters, such as time outs or retry attempts, use the protocol configuration parameters as described in step 5 below.
3. In the Properties window, click on Protocol, then click on the Select button to view the list of communication protocols.
The Communication protocols list is displayed, as shown below.
4. Select the communication protocol that is running over TeleBUS.

5. Do one of the following:

   a. To configure parameters, such as time outs and retry attempts for the selected protocol, click "Configure..."

   b. To close the protocols list and configure the protocol parameters through SCADAPack Configurator, click "OK".

   For details about protocol parameters, see the SCADAPack Configurator User Manual.

   The next step is to determine how you want to manage libraries in your solution.

7.1.6 Restoring the Default User Interface Settings

SCADAPack Workbench allows you to customize a number of user interface preferences such as window positioning, fonts, and menu items.

If needed, you can restore SCADAPack Workbench to its default user interface settings. You will have the option to save your current user interface settings so they can be restored at a later time, or to overwrite your current settings with the default settings.

To Restore the Default User Interface Settings in SCADAPack Workbench

1. In the SCADAPack Workbench main menu, select TOOLS > Import and Export Settings...
The Import and Export Settings Wizard is displayed.

2. Select **Reset all settings** then click **Next**.

3. Select one of the following options:

   a. If you want to be able to restore your customized user interface settings at a later time, select **Yes, save my current settings**.

   b. If you want to revert to the default user interface settings without saving your customized settings, select **No, just reset settings, overwriting my current settings**.
4. Click Finish.

7.2 Programming for Target 3

This section describes the basic steps required to develop an IEC 61131-3 application for a SCADAPack RTU running Target 3 firmware.

- Adding Programs
- Adding and Editing Program Elements
- Defining Variables
- Assigning Variables
- Building the Solution
- Downloading the Solution to the SCADAPack Device
- Debugging Applications
- Using One Solution as the Basis for Another
- Managing SCADAPack Target 3 Libraries
7.2.1 Adding Programs

Once you create a solution, you need to add one or more programs to each program group. Each program is also called a Program Organization Unit or POU. You can program in the following languages in a program group:

- Function block diagram
- Ladder diagram
- Structured text
- Sequential function chart

For more information, see Language Support.

The steps below describe how to add a function block diagram to the program group. The steps to add the other program types are the same.

To Add a Program

1. Right-click on Programs and select Add > New FBD: Function Block Diagram.

A new program called Prog1 is created in the Programs group.

2. Double-click on Prog1 to open the Function Block Diagram (FBD) editor.

7.2.2 Adding and Editing Program Elements

To Add a Function Block, Variable or other Program Element

1. Double-click on a program to open the Function Block Diagram (FBD) editor.
2. Select **VIEW > Toolbox**.

The toolbox lists the elements that you can use in the function block editor.
3. In the Toolbox, double-click on the required tool.

   For tools that require a secondary action, a new dialog opens where you can select the appropriate item for addition to the program.

**To Connect Program Elements**

1. Move the mouse to the connector on one element.
2. Click and drag to the connector on the second element.
To Invert the State of a BOOL Link

1. Select the link
2. In the Properties dialog set Is Negation to True.
7.2.3 Defining Variables

If you want to add variables to your program, you need to define them for the project compile successfully.

The variable's Data Type determines the kind of information that can be stored in the variable.

The variable’s Direction defines its relationship to physical I/O. For example, a variable with a Var direction is internal and is not attached to I/O.

To Define Variables

1. Click on the symbol beside Prog1 to expand the tree.

2. Double-click on Local Variables to open the variables grid.

3. Click in the empty box under Name to enter a name for the variable.
   Press Tab to move from one field to the next.
   For more information about the fields in the variables grid, select HELP > View Help in SCADAPack Workbench.

4. Save the application by selecting FILE > Save All.
   The local variables list also contains instances of the function blocks used in the program.

7.2.4 Assigning Variables

Input and output variables need to be assigned to an input or output I/O device. This provides a connection between the IEC 61131-3 resource and the point database or other PLC devices.

On a SCADAPack RTU, variables are assigned to the channels in the complex equipment and I/O board devices that you add.

There are three steps to assigning variables to physical I/O:

1. Add the I/O device.
2. Assign the variables to the device.
3. Define analog input operation, if applicable.

7.2.4.1 Adding an I/O Device

To Add an I/O Device for a SCADAPack RTU

1. In the Solution Explorer, right-click on the RTU type then select I/O Wiring to open the I/O Wiring...
2. In the I/O Wiring editor, click the **Add a device** icon to open the Device Selector.

3. In the Device Selector, select the device type.
4. Set the Number of Channels. Channels can be left unwired if they are not needed.

5. Click **OK**.

### Assigning Variables to an I/O Device

**To Assign Variables to a SCADAPack I/O Device**

1. In the I/O Wiring editor, use the up and down arrows to select the I/O channel to which you want to assign a variable.

2. In the list of variables, select the variable that you want to assign to the I/O channel.
3. Assign the remaining variables.

4. Save the application by selecting **FILE > Save All**.

### 7.2.4.3 Defining Analog Input Operation

#### To Define Analog Input Operation for a SCADAPack RTU

1. In the Device Selector, select the AIN sub-module.

2. Click the double arrows to expand the OEM Parameters list.
3. Define the analog input values for the OEM Parameters in the list.
   The valid values are described in the SCADAPack Target 3 I/O Device Reference Manual.

7.2.5 **Building the Solution**

Building the solution compiles the programs, checks for conditions preventing a successful build, and prepares the solution to be downloaded to the SCADAPack device.
To Build the Solution

- Select BUILD > Build Solution from the menu

The build results are shown in the Output window at the bottom of the screen, as shown in the example below. A window will open if there are any conditions preventing a successful build of the application. Correct the reported items and build again. The solution is now ready to be downloaded to the SCADAPack device.

7.2.6 Downloading the Solution to the SCADAPack Device

⚠️ WARNING

UNINTENDED EQUIPMENT OPERATION

Before downloading the solution, verify that you are connected to the correct device.

Failure to follow these instructions can result in death or serious injury.

Before you can download the solution, you need to configure communications between SCADAPack Workbench and the device.
To Download the Solution to the Device

1. Connect the communication cable from the SCADAPack Workbench computer to the device.

   **WARNING**
   **UNINTENDED EQUIPMENT OPERATION**

   Hazardous situations can occur if system state is not confirmed prior to downloading.

   Before downloading a solution, evaluate the operational state of the equipment monitored and controlled by the device.

   **Failure to follow these instructions can result in death or serious injury.**

2. In the Solution Explorer, right-click on the project and select Download from the menu.

The project is downloaded to the device. The Output window displays a progress message, as shown in the example below.

If communication is unsuccessful check the communications settings.
7.2.7 Debugging Applications

Once you have downloaded the solution to the device, you can debug the application. The SCADAPack Workbench debugger allows you to view the operation of your programs and to change the values of variables.

⚠️ WARNING

UNINTENDED EQUIPMENT OPERATION

Hazardous situations can occur if system state is not confirmed prior to debugging.

Before debugging, evaluate the operational state of the equipment monitored and controlled by the device.

Failure to follow these instructions can result in death or serious injury.

To Start Debugging

1. Select DEBUG > Start Debugging.
2. In the Solution Explorer, double click on Prog1.

The execution state of the application is shown. The figure below shows a debugging example for Target 3.
The sample application shown above has two inputs that come from input points. If you have built the sample application, but don't have real signals connected to the inputs, the program logic can be tested by locking the input and writing its value.

**To Test Sample Application Logic**

1. Double-click on the Time_cyc variable.
2. Set **Time value** to 10 ms.
3. Click **Write**.
5. Double-click on the Switch variable.
6. Set Value to True.
7. Click Write.

The program starts cycling the LED outputs.

**To See the Current State of Variables**
- Double-click on Local Variables under Prog1 in the Solution Explorer.

You can modify the logical value and the lock status from this view as well.

**To End Debugging**
- Select DEBUG > Stop Debugging.

For more information about debugging, select HELP > View Help from the main menu.

### 7.2.8 Using One Solution as the Basis for Another

Once you have developed and debugged an application, you can save the solution with a new name so you can reuse the project elements in another solution.

### To Use One Solution as the Basis for Another
1. In Windows Explorer, make a copy of the solution folder and give it a new name.
2. In SCADAPack Workbench, select **FILE > Open > Project/Solution**.
3. Navigate to the location where the renamed solution is located and select the `.isasln` file.
4. Click **Open** to open the project.
5. In the Solution Explorer, right-click on each project elements then select **Rename** to rename the elements for the new solution.
6. Adapt the solution as required for the new application.

### 7.2.9 Managing SCADAPack Target 3 Libraries

Before you add programs and program elements to your Target 3 project, you need to determine how you want to manage libraries.

#### Using the Default Library

When you create a new SCADAPack Target 3 project, a standard SCADAPack library is automatically created and referenced by the project. This library is stored with the project in the `\ProjectName\LIB` folder.

#### Adding User-Defined Functions and Function Blocks

You can create your own Target 3 functions and function blocks to supplement those in the default library. There are two ways to manage user-defined functions and function blocks in SCADAPack Workbench:

- **Single-project library**: If you want to use your own functions and function blocks to one project only, you need to add them to the default library for the project. For details, see [Adding User-Defined Functions and Function Blocks to a Project Library](#).

- **Multi-project library**: If you want to use your own functions and function blocks in multiple projects, you need to add them to a global library that can be accessed by any project. For details, see [Creating a User-Defined Library](#) and [Referencing a User-Defined Library](#).

#### Accessing your ISaGRAF 3 Workbench User-Defined Library

If you created your own Target 3 functions or function blocks in ISaGRAF 3 Workbench, and you want to use them in SCADAPack Workbench projects, you need to import them into SCADAPack Workbench. Once you import user-defined library functions and function blocks, they are added to a global library that you can access from any SCADAPack Workbench project.

For details about importing ISaGRAF 3 Workbench library functions and function blocks, see the Migrating ISaGRAF 3 Workbench Projects to SCADAPack Workbench Manual.

For details about accessing your imported library in multiple projects, see [Referencing a User-Defined Library](#).

#### 7.2.9.1 Adding User-Defined Functions and Function Blocks to a Project Library

To access custom Target 3 functions and function blocks in a program, you need to add the default library for the project to the solution, then add your custom function blocks to the default library. This procedure is described below.

If you need to access user-defined functions and function blocks in multiple projects, see [Creating a User-Defined Library](#).
To Add User-Defined Functions and Function Blocks to a Project Library

1. In the Solution Explorer, right-click on Solution and select Add > Existing Project.

2. In the Add Existing Project window, navigate to the project folder, select the LIB.acfproj file, then click Open.

The figure below shows the typical path to the LIB.acfproj file within the project folder.

The default library project is added to the solution, as shown below.
3. Add your new functions and function blocks to the project library:
   a. To add a new function, right-click on Functions under LIB and select Add > New FBD: Function Block Diagram.
   b. To add a new function block, right-click on Function Blocks under LIB and select Add > New FBD: Function Block Diagram.
4. When you have added the required functions and function blocks, select LIB in the Solution Explorer then select **FILE > Save LIB** from the main menu.

Your user-defined functions and function blocks are now available for use in the project.
Creating a User-Defined Library

The procedure below explains how to create a library of your own Target 3 functions and function blocks that can be accessed by multiple projects. If you only need to access user-defined functions and function blocks in a single project, see Adding User-Defined Functions and Function Blocks to a Project Library.

Once you create your new library, you can reference it from any project. For details, see Referencing a User-Defined Library.

To Create a User-Defined SCADAPack Target 3 Library

1. Navigate to the SCADAPack Workbench installation directory and locate the LibraryImports folder.

   The default path is:
   - 64-bit system: C:\Program Files (x86)\Schneider Electric\SCADAPack Workbench\SCADAPack Workbench\LibraryImports
   - 32-bit system: C:\Program Files\Schneider Electric\SCADAPack Workbench\SCADAPack Workbench\LibraryImports

2. Copy the contents of the LibraryImports folder to another location on your computer.
When choosing a location, keep in mind that this location will store the custom SCADAPack Target 3 library and will need to be referenced by any project that uses the library.

3. **Start SCADAPack Workbench** then select **FILE > Open > Project/Solution.**

![SCADAPack Workbench](image1)

4. In the Open Project window, navigate to the folder where you copied the library files, select the **LIB.acfproj** file, then click **Open.**

![File Explorer](image2)

The library project opens. If required, you can right-click on LIB in the Solution Explorer and select **Rename** to rename the library.
5. Add your new functions and function blocks to the library:
   
   a. To add a new function, right-click on Functions under LIB and select **Add > Program Type**.
   
   b. To add a new function block, right-click on Function Blocks under LIB and select **Add > Program Type**.
6. When you have added the required functions and function blocks, select LIB in the Solution Explorer then select **FILE > Save All** from the main menu.

7. Select **FILE > Close Solution** from the main menu to close the solution.

You can now reference your user-defined library from any project. For details, see **Referencing a User-Defined Library**.

### 7.2.9.3 Referencing a User-Defined Library

Once you create or import a user-defined library of Target 3 functions and function blocks, you can reference the library from any project. When you reference a library, the functions and function blocks it contains become available to the project.

Keep the following in mind when referencing the same user-defined library in multiple projects:

- The project files and the library files have to be shared and copied among users. For example, if User A wants to share a project with User B, User A needs to copy the contents of `C:\GoodLocation\SCADAPackTarget3Lib` to provide access to the library files and the contents of `C:\Users\User A\Documents\SCADAPack Workbench\Solutions\SCADAPackProjectName` to provide access to the project files.

If User B sees the icon shown below when the project is opened in SCADAPack Workbench, then User B needs to update the library reference, as described below.
If you change the location of the user-defined library, or any project file that references the library, you need to update the library reference, as described below.

**To Reference a User-Defined Library or Update a Library Reference**

1. Start SCADAPack Workbench.
2. In SCADAPack Workbench, create a new project, open an existing project, or import a SCADAPack Target 3 project.
   
   The Migrating ISaGRAF 3 Projects to SCADAPack Workbench Manual describes how to import SCADAPack Target 3 projects.

3. When the solution opens, right-click on the default library (LIB) under Dependencies and select **Delete**.
4. To add your custom library, right-click on Dependencies and select **Add Dependency**.

5. In the Dependencies window, select the Libraries tab, then click **Browse**.
6. In the Browse window, navigate to the location where you copied your custom library. Open the folders until you get to the *.acfproj file, then select it and click Open.

The library is listed in the Dependencies window.

7. In the Dependencies window, select the library, then click OK.
Your library is added as a dependency of the project and you can use your functions or function blocks in this SCADAPack Workbench project.

7.2.10 Output Messages

The output messages listed below are specific to SCADAPack devices running Target 3 firmware. For information about other output messages, select HELP > View Help in the SCADAPack Workbench main menu and search on the message text.

Target 3 Messages

<table>
<thead>
<tr>
<th>Message</th>
<th>Suggested Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>SCADAPack Target 3 solution validation: The solution format requires that exactly one resource exists. Please remove extra resources from the device.</td>
<td>Remove the extra resources from the device.</td>
</tr>
<tr>
<td>Issue Description</td>
<td>Action</td>
</tr>
<tr>
<td>----------------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>SCADAPack Target 3 solution validation: The solution format requires that exactly one Target 3 project exists (not including Target 3 libraries). Please remove extra projects from the solution.</td>
<td>Remove the extra projects from the solution.</td>
</tr>
<tr>
<td>SCADAPack Target 3 solution validation: The solution format requires that exactly one device exists. Please remove extra devices from the project.</td>
<td>Remove the extra devices from the project.</td>
</tr>
<tr>
<td>No resource exists.</td>
<td>Add a resource to the project.</td>
</tr>
<tr>
<td>Invalid device name. The device name exceeds the maximum limit of 8 characters.</td>
<td>Rename the device with a name that is 8 characters or less.</td>
</tr>
<tr>
<td>Invalid project type.</td>
<td>Check the project and verify that the structure and device are valid for Target 3. For guidance, see Understanding Target 3 Application Structure.</td>
</tr>
<tr>
<td>Invalid solution.</td>
<td>Check the solution structure and verify that it is valid for Target 3. For guidance, see Understanding Target 3 Application Structure.</td>
</tr>
<tr>
<td>Modbus address conflicts were found on the following variables.</td>
<td>Check the variables listed to identify and correct the Modbus address conflicts. No two variables can have the same Modbus address.</td>
</tr>
<tr>
<td>Modbus address verification was unsuccessful.</td>
<td>Check the Modbus addresses to confirm that they are within the valid range.</td>
</tr>
<tr>
<td>No device exists.</td>
<td>Add a device to the project.</td>
</tr>
<tr>
<td>No project loaded.</td>
<td>Select FILE &gt; Open Project/Solution from the main menu to open a project.</td>
</tr>
<tr>
<td>Project is of unexpected type. Expected: Target 3.</td>
<td>Close the project and open a Target 3 project.</td>
</tr>
<tr>
<td>The Modbus Address of variable <em>name</em>, <em>hex address</em>, <em>decimal address</em> is not valid.</td>
<td>Check that the Modbus address for the variable is within the valid range.</td>
</tr>
<tr>
<td>The range of registers used by variable <em>name</em> located at Modbus Address <em>hex address</em>, <em>decimal address</em> exceeds the upper limit of <em>hex limit</em>, <em>decimal limit</em>.</td>
<td>Check that the range of registers used by the variable is within the valid range.</td>
</tr>
<tr>
<td>This version of SCADAPack Workbench is not authorized to build, rebuild or clean projects.</td>
<td>You have tried to compile the project in the Technician version of the application. Functionality in the Technician version is limited.</td>
</tr>
</tbody>
</table>
Unable to validate the SCADAPack project. | An unknown error has occurred in the build validation task. Try the validation task again.

Validation was unsuccessful. | The project could not be validated. Check the project configuration. For guidance, see Understanding Target 3 Application Structure.

### SCADAPack Configurator Messages

<table>
<thead>
<tr>
<th>Message</th>
<th>Suggested Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unable to locate SCADAPack Configurator. Would you like to locate the file yourself?</td>
<td>The SCADAPack Configurator path is invalid. Select TOOLS &gt; Options &gt; SCADAPack and verify the path to SCADAPack Configurator.</td>
</tr>
<tr>
<td>Unable to open SCADAPack Configurator. Please verify the configuration under TOOLS &gt; Options &gt; SCADAPack.</td>
<td>Process creation for SCADAPack Configurator was not successful. Select TOOLS &gt; Options &gt; SCADAPack to verify the configuration.</td>
</tr>
</tbody>
</table>

### 7.3 Target 3 Sample Application

If you are using a SCADAPack RTU, you can build the sample application shown below to practice using SCADAPack Workbench.

#### To Develop the Sample Application on a SCADAPack RTU

1. Using the FBD editor, enter the sample FBD application shown below.
2. Save the application by selecting **FILE > Save All**.

For information about debugging applications, see [Debugging Applications](#).
Workbench Quick Start Guide

Using SCADAPack Workbench with Target 5

8 Using SCADAPack Workbench with Target 5

This section includes topics that explain how to use SCADAPack Workbench to develop programs for SCADAPack E rPACs and RTUs:

- Getting Started with Target 5
- Programming for Target 5
- Target 5 Sample Application

8.1 Getting Started with Target 5

This topic describes the basics of getting started with Target 5:

- Licensing Target 5
- Understanding Target 5 Application Structure
- Creating a New Target 5 Project
- Accessing SCADAPack E Configurator
- Configuring Communications with a SCADAPack E Device
- Restoring the Default User Interface Settings

8.1.1 Licensing Target 5

This topic describes licensing requirements for SCADAPack Workbench. While other licensing information may be provided in the Help topics for the underlying Automation Collaborative Platform (ACP), this is the only licensing information that applies to SCADAPack Workbench.

Before you use SCADAPack Workbench to develop a new application, or to modify an existing application, you need to enter registration keys in the appropriate SCADAPack Workbench License Info window and validate your license.

Requesting Registration Keys

To request registration keys, you need the following information:

- The serial number for the software. If you have a DVD, the serial number is on the DVD case. The serial number starts with "R".
- The three user codes in the Licensing window for your target type.

The procedure below explains how to locate user codes, request registration keys and validate your license. Once your license is validated, SCADAPack Workbench is licensed for the duration you purchased:

- 1 month
- 6 months
- 12 months
- Unlimited

Reactivating or Extending a License
To reactivate a license after you upgrade, or to extend the license duration, contact Schneider Electric Customer Support at ordersTRSS@schneider-electric.com. See the information above for the details needed when requesting registration keys.

**To License Target 5**

1. Start SCADAPack Workbench.
2. Select HELP > Licensing Target 5.
3. Review the license description and expiration date.
4. Record the numbers in the User Code 1, User Code 2 and User Code 3 fields.
5. E-mail the three user codes, along with the serial number from the DVD case (the number that begins with "R"), to Schneider Electric Customer Support at ordersTRSS@schneider-electric.com.
   
   You will receive Registration Key 1 and Registration Key 2.
6. Enter the Registration Keys in their respective fields in the Licensing window, then click Validate.

If you have difficulty with these tasks, contact Schneider Electric Technical Support. 
8.1.2 Understanding Target 5 Application Structure

The figure below identifies the main elements in a Target 5 application structure:

- An IEC 61131-3 application is called a **Solution**.
- A **Solution** for an IEC 61131-3 application contains a **Project**. A solution contains everything needed to manage an IEC 61131-3 application on an rPAC or RTU. It is opened and saved on the PC running SCADAPack Workbench.
- A **Project** contains a **Device**, which is a SCADAPack rPAC or RTU. A project defines the available targets for this solution. A project can be exported to other solutions.
- A **Device** is the physical rPAC or RTU. It can contain one or two **Resources**. Resources are independent parts of the application. Resources can be stopped, downloaded, uploaded and started independently.
- A **Resource** defines what executes on the target. A Resource contains IEC 61131-3 programs (also called Program Organization Units or POUs), I/O devices, functions, function blocks, and variables. The two Resources are independent, but can exchange data through variable binding.
- A **Program** contains logic modules that are written in one of the supported SCADAPack Workbench languages.

This solution structure is used for SCADAPack Workbench programs. Although it's possible to structure the solution in other ways, they are not supported by the rPAC or RTU.

**Renaming Solution Components**

Follow these rules when renaming solution components:

- Names must begin with a letter, followed by letters, digits and single underscore characters. The last character for a name must be a letter or digit. Names cannot end with an underscore character.
- Resource names can be a maximum of 16 characters.
8.1.3 Creating a New Target 5 Project

Follow the steps below if you are using a SCADAPack E rPAC or RTU running Target 5.

To Create a New SCADAPack E Target 5 Solution

1. Start SCADAPack Workbench.
2. On the Start Page, click New Project. If the Start Page isn't open, select FILE > New > Project.
3. From the list of installed templates, select CAM Projects > Target 5 > SCADAPack E.

4. Expand the list of SCADAPack E firmware releases and select the firmware version running on your rPAC or RTU.
   
   For example, if your device is running 8.12.5 firmware, select Firmware 8.12.4+.

5. In the middle panel, select your rPAC or RTU model and the type of link the rPAC or RTU will use to communicate with SCADAPack Workbench.

6. In the Name field, type the name of the project. The same name is given to the Solution.
   
   Names must begin with a letter, followed by letters, digits and single underscore characters. Dashes (-) are not supported in project names.

7. Change the default location, if required.

8. Click OK to create the solution file.
   
   SCADAPack Workbench opens the Deployment View for the solution.
The Deployment View displays the communications link between the rPAC or RTU and the computer running SCADAPack Workbench.

The Solution Explorer shows the solution. Click on the symbols to expand and contract your view of the solution components. For details, see Understanding SCADAPack E Target 5 Application Structure.

The next step is to configure the communications link.

8.1.4 Accessing SCADAPack E Configurator

SCADAPack E rPACs and RTUs are configured using SCADAPack E Configurator.

To access SCADAPack E Configurator, select the Start or Windows icon, then navigate to the Schneider Electric folder and select SCADAPack E > SCADAPack E Configurator.

For information about using SCADAPack E Configurator, see the SCADAPack E Configurator User Manual.
8.1.5 Configuring Communications with a SCADAPack E Device

This section explains how to configure:

- Ethernet communications with a SCADAPack E device
- Serial communications with a SCADAPack E device

8.1.5.1 Configuring Ethernet Communications with a SCADAPack E Device

Once you create your project, you need to configure the communications link between SCADAPack Workbench and the rPAC or RTU.

You can continue programming without configuring the link, but you need to configure the link before you can download the solution.

To configure Ethernet communications between SCADAPack Workbench and a SCADAPack E rPAC or RTU

1. Configure Ethernet communications in SCADAPack E Configurator.
2. Configure Ethernet communications in SCADAPack Workbench.

8.1.5.1.1 Configuring Ethernet Communications in SCADAPack E Configurator

Follow the procedure below to configure an rPAC or RTU port for Ethernet communications with SCADAPack Workbench. These procedures assume:

- The rPAC or RTU is communicating with SCADAPack E Configurator.
- You have already started SCADAPack E Configurator and created a configuration file for your rPAC or RTU.

For details about these steps, see the SCADAPack E Configurator User Manual.

To Configure Ethernet Communications in SCADAPack E Configurator

1. Select the Start or Windows icon, then navigate to the Schneider Electric folder and select SCADAPack E > SCADAPack E Configurator.
2. In the tree control, open the TCP/IP folder.
3. Select the TCP/IP property page.
4. Verify that the ISaGRAF/TCP service is enabled.
5. Configure the Ethernet port that you will use to communicate with SCADAPack Workbench. In the example below, Ethernet 2 is being used to communicate with SCADAPack Workbench.
6. Select **Communication > Communication Type**.
   - In the **Type** field, select **TCP**.
   - In the **Target DNP3 Address** field, type the address of the rPAC or RTU. Use 0 if the address has not previously been set.
   - Click **OK**.

7. Select **Communication > Communication Settings**.
   - In the **IP Address / Name** field, enter the IP address of the rPAC or RTU Ethernet port being used to communicate with SCADAPack Workbench.
   - Enter the **TCP Port Number**.
   - Click **OK**.

8. Select **File > Save** to save the configuration file.

9. Select **File > Write RTU Configuration** to write the configuration to the device.

8.1.5.1.2 Configuring Ethernet Communications in SCADAPack Workbench

You need to configure the communication settings between SCADAPack Workbench and the SCADAPack E rPAC or RTU before you can download the solution to the device.
To Configure Ethernet Communications in SCADAPack Workbench

1. With the solution open, select **VIEW > Deployment View** from the main menu.
   The Deployment View is displayed.

2. Right-click on the LAN link that is connected to the rPAC or RTU in the deployment view and select **Properties**.

   ![Deployment View](image)

   Creating project 'SCADAPackProject1'... project creation successful.

   The Properties for the LAN link are displayed, as shown below.
3. Enter the **IPAddress** of the rPAC or RTU you are using to communicate with SCADAPack Workbench.

### 8.1.5.2 Configuring Serial Communications with a SCADAPack E Device

Once you create your project, you need to configure the communications link between SCADAPack Workbench and the rPAC or RTU.

You can continue programming without configuring the link, but you need to configure the link before you can download the solution.

**To configure serial communications between SCADAPack Workbench and a SCADAPack E rPAC or RTU**

2. Configure serial communications in SCADAPack Workbench.
8.1.5.2.1 Configuring Serial Communications in SCADAPack E Configurator

Follow the procedure below to configure an rPAC or RTU port for serial communications with SCADAPack Workbench. These procedures assume:

- The rPAC or RTU is communicating with SCADAPack E Configurator.
- You have already started SCADAPack E Configurator and created a configuration file for your rPAC or RTU.

For details about these steps, see the SCADAPack E Configurator User Manual.

To Configure Serial Communications in SCADAPack E Configurator

1. Select the Start or Windows icon, then navigate to the Schneider Electric folder and select SCADAPack E > SCADAPack E Configurator.
2. In the tree control, open the Ports folder.
3. Select the Ports 0-3 or Ports 0-4 property page.
4. Configure one of the serial ports for DNP3 and another for ISaGRAF. An example is shown below.

5. Select Communication > Communication Type.
   - In the Type field, select Serial.
   - In the Target DNP3 Address field, type the address of the rPAC or RTU. Use 0 if the address has not previously been set.
   - Click OK.
   - In the Port field, select the serial port on the PC that is connected to the rPAC or RTU.
   - Click OK.
7. Select **File > Save** to save the configuration.
8. Select **File > Write RTU Configuration** to write the configuration to the device.

### 8.1.5.2.2 Configuring Serial Communications in SCADAPack Workbench

You need to configure the communication settings between SCADAPack Workbench and the SCADAPack E RTU before you can download the solution to the device.

**To Configure Serial Communications in SCADAPack Workbench**

1. With the solution open, select **VIEW > Deployment View** from the main menu.
   The Deployment View is displayed.
2. Right-click on the serial communication link in the deployment view and select **Properties**.

The Properties for the serial link are displayed, as shown below.
3. Edit the serial communication settings.
   - Set **BaudRate** to the required communication speed.
   - Set **HardwareFlowControl** to FALSE.
   - Set **Parity** to N.
   - Set **Port** to the serial port on your PC that is connected to the RTU.
   - Set **StopBit** to 1.
8.1.5.3 Changing the SCADAPack E Communications Type

Follow the procedure below if:

- You are using serial communications to communicate with the rPAC or RTU and want to switch to Ethernet communications.
- You are using Ethernet communications to communicate with the rPAC or RTU and want to switch to serial communications.

To Change the Communications Type

This procedure describes how to switch from serial communications to Ethernet communications. Follow the same steps if you are switching from Ethernet communications to serial communications.

1. With the solution open, select VIEW > Deployment View from the main menu.

   The Deployment View is displayed.

2. Click on the communications link to select it, then select EDIT > Delete from the main menu.
3. Right-click on the empty space where the communications link was located, then select **Add New Network > TCP/IP**.

If you are switching from an Ethernet link to a serial link, select **Add New Network > Serial**.
4. Click on the new link to select it, then hover the mouse over the lower middle anchor point until the hand symbol is displayed. Drag the hand symbol toward the target icon, then let go.
Links to the Work Station and the target are added.
5. Configure the communications settings for the new link type in SCADAPack E Configurator.
   - Configuring Ethernet Communications in SCADAPack E Configurator
   - Configuring Serial Communications in SCADAPack E Configurator

6. Configure the communications settings for the new link type in SCADAPack Workbench.
   - Configuring Ethernet Communications in SCADAPack Workbench
   - Configuring Serial Communications in SCADAPack Workbench

7. In SCADAPack Workbench, select **BUILD > Build Solution** from the main menu to rebuild the solution. For details, see Building the Solution.
8. In the Solution Explorer, right-click on the project and select **Download** from the menu. For details, see [Downloading the Solution to the rPAC or RTU](#).

9. In SCADAPack E Configurator, select the **Logic > IEC 61131-3** property page, then click the **Refresh** icon to verify the application is running on the rPAC or RTU.

### 8.1.6 Restoring the Default User Interface Settings

SCADAPack Workbench allows you to customize a number of user interface preferences such as window positioning, fonts, and menu items.
If needed, you can restore SCADAPack Workbench to its default user interface settings. You will have the option to save your current user interface settings so they can be restored at a later time, or to overwrite your current settings with the default settings.

**To Restore the Default User Interface Settings in SCADAPack Workbench**

1. In the SCADAPack Workbench main menu, select **TOOLS > Import and Export Settings**…

   ![Import and Export Settings Wizard](image)

   The Import and Export Settings Wizard is displayed.

2. Select **Reset all settings** then click **Next**.

3. Select one of the following options:

   a. If you want to be able to restore your customized user interface settings at a later time, select **Yes, save my current settings**.
b. If you want to revert to the default user interface settings without saving your customized settings, select **No, just reset settings, overwriting my current settings**.

4. Click **Finish**.

### 8.2 Programming for Target 5

This section describes the basic steps required to develop an IEC 61131-3 application for a SCADAPack E rPAC or RTU running Target 5 firmware.

- **Adding Programs**[
- **Adding and Editing Program Elements**[
- **Defining Variables**[
- **Assigning Variables**[
- **Building the Solution**[
- **Downloading the Solution to the RTU**[
- **Debugging Applications**[
- **Using One Solution as the Basis for Another**[


8.2.1 Adding Programs

Once you create a solution, you need to add one or more programs to each program group. Each program is also called a Program Organization Unit or POU. You can program in the following languages in a program group:

- Function block diagram
- Ladder diagram
- Structured text
- Sequential function chart

For more information, see Language Support.

The steps below describe how to add a function block diagram to the program group. The steps to add the other program types are the same.

To Add a Program

1. Right-click on Programs and select Add > New FBD: Function Block Diagram.

   A new program called Prog1 is created in the Programs group.

2. Double-click on Prog1 to open the Function Block Diagram (FBD) editor.

8.2.2 Adding and Editing Program Elements

To Add a Function Block, Variable or other Program Element
1. Double-click on a program to open the Function Block Diagram (FBD) editor.

2. Select **VIEW > Toolbox**.

The toolbox lists the elements that you can use in the function block editor.
3. In the Toolbox, double-click on the required tool.

   For tools that require a secondary action, a new dialog opens where you can select the appropriate item for addition to the program.

**To Connect Program Elements**

1. Move the mouse to the connector on one element.

2. Click and drag to the connector on the second element.
To Invert the State of a BOOL Link

1. Select the link

2. In the Properties dialog set Is Negation to True.
8.2.3 Defining Variables

If you want to add variables to your program, you need to define them for the project compile successfully.

The variable’s Data Type determines the kind of information that can be stored in the variable.

The variable’s Direction defines its relationship to physical I/O. For example, a variable with a Var direction is internal and is not attached to I/O.

To Define Variables

1. Click on the symbol beside Prog1 to expand the tree.
2. Double-click on Local Variables to open the variables grid.

   - A variable with a VarInput direction is attached to a physical input.
   - A variable with a VarOutput direction is attached to a physical output.
   - DNP3 points (input, output or derived) defined within the points database are considered as physical I/O that is external to SCADAPack Workbench. As a result, variables that need to be attached to the points database are assigned a VarInput or VarOutput direction.

3. Click in the empty box under Name to enter a name for the variable.

   Press Tab to move from one field to the next.

   For more information about the fields in the variables grid, select HELP > View Help in SCADAPack Workbench.

4. Save the application by selecting FILE > Save All.

   The local variables list also contains instances of the function blocks used in the program.

8.2.4 Assigning Variables

If you are using a SCADAPack E rPAC or RTU, you need to use I/O Devices in SCADAPack Workbench to assign a variable to each point within the device database that you want to access in your application.

Input and output variables need to be assigned to an input or output I/O device. This provides a connection between the IEC 61131-3 resource and the point in the rPAC or RTU points database.

There are two steps to assigning variables to the points in the SCADAPack E rPAC or RTU database:

1. Add the I/O device
2. Assign variables to the device
8.2.4.1 Adding an I/O Device

To Add an I/O Device for a SCADAPack E rPAC or RTU

1. In the Solution Explorer, right-click on **Resource1** then select **I/O Device** to open the Resource I/O Device editor.

2. In the Resource I/O Device editor, click on the **Add Device** icon to open the Device Selector.

3. In the Device Selector, select the device type.
The table below matches rPAC or RTU point types to SCADAPack Workbench I/O Devices.

<table>
<thead>
<tr>
<th>Point Type</th>
<th>I/O Device in SCADAPack Workbench</th>
</tr>
</thead>
<tbody>
<tr>
<td>Binary</td>
<td>RTU_BIN_xxxx_xxxx</td>
</tr>
<tr>
<td>Analog</td>
<td>RTU_RAW_xxxx_xxxx</td>
</tr>
<tr>
<td>Analog point engineering values</td>
<td>RTU_ENG_xxxx_xxxx</td>
</tr>
<tr>
<td>String</td>
<td>RTU_STRING_xxxx_xxxx</td>
</tr>
<tr>
<td>Counter</td>
<td>RTU_COUNTER_xxxx_xxxx</td>
</tr>
<tr>
<td>Modbus using Modbus RTU protocol</td>
<td>MBUS_xxxx_xxxx</td>
</tr>
<tr>
<td>Modbus using Modbus RTU in TCP</td>
<td>MRTUTCP_xxxx_xxxx</td>
</tr>
<tr>
<td>Modbus using Modbus/TCP</td>
<td>MRCP_xxxx_xxxx</td>
</tr>
<tr>
<td>DF1</td>
<td>DF1_xxxx_xxxx</td>
</tr>
</tbody>
</table>

4. Set the Number of Channels. Channels can be left unwired if they are not needed.
5. Click OK.

8.2.4.2 Assigning Variables to an I/O Device

To Assign Variables to a SCADAPack E I/O Device
1. Select the input to which you want to wire the variable.
2. Click on the drop-down arrow to display the variables list.
3. Select the variable.
   
   In the figure below, the Switch1@Prog1 variable has been selected for the RTU_BIN_READ I/O device.

4. Assign the remaining variables.
5. Select FILE > Save All to save the file.

### 8.2.5 Building the Solution

Building the solution compiles the programs, checks for conditions preventing a successful build, and prepares the solution to be downloaded to the SCADAPack device.

**To Build the Solution**

- Select BUILD > Build Solution from the menu
The build results are shown in the Output window at the bottom of the screen, as shown in the example below. A window will open if there are any conditions preventing a successful build of the application. Correct the reported items and build again. The solution is now ready to be downloaded to the SCADAPack device.

**8.2.6 Downloading the Solution to the SCADAPack E Device**

**WARNING**

**UNINTENDED EQUIPMENT OPERATION**

Before downloading the solution, verify that you are connected to the correct device.

Failure to follow these instructions can result in death or serious injury.

Before you can download the solution, you need to configure communications between SCADAPack Workbench and the device.

**To Download the Solution to the Device**

1. Connect the communication cable from the SCADAPack Workbench computer to the device.
2. In the Solution Explorer, right-click on the project and select **Download** from the menu.

   The project is downloaded to the device. The Output window displays a progress message, as shown in the example below.

   ![Output window showing download progress]

   If communication is unsuccessful check the communications settings.

### 8.2.7 Debugging Applications

Once you have downloaded the solution to the device, you can debug the application. The SCADAPack Workbench debugger allows you to view the operation of your programs, and to change the values of...
variables.

⚠️ WARNING

UNINTENDED EQUIPMENT OPERATION

Hazardous situations can occur if system state is not confirmed prior to debugging.

Before debugging, evaluate the operational state of the equipment monitored and controlled by the device.

Failure to follow these instructions can result in death or serious injury.

To Start Debugging

1. Select DEBUG > Start Debugging.
2. In the Solution Explorer, double click on Prog1.

The execution state of the application is shown. The figure below shows a debugging example for a sample SCADAPack E application.
The sample application shown above has two inputs that come from input points. If you have built the sample application, but don't have real signals connected to the inputs, the program logic can be tested by locking the input and writing its value.

**To Test Sample Application Logic**

1. Double-click on the Speed Control variable.
2. Set Value to 1000.0 (this corresponds to 1000 ms).
3. Click Write.
5. Double-click on the Switch1 variable.
6. Set Value to True.
7. Click Write.

The program starts cycling the LED outputs.

**To See the Current State of Variables**

- Double-click on Local Variables under Prog1 in the Solution Explorer.

You can modify the logical value and the lock status from this view as well.

**To End Debugging**

- Select DEBUG > Stop Debugging.

For more information about debugging, select HELP > View Help from the main menu.

**8.2.8 Using One Solution as the Basis for Another**

Once you have developed and debugged an application, you can save the solution with a new name so you can reuse the project elements in another solution.
To Use One Solution as the Basis for Another

1. In Windows Explorer, make a copy of the solution folder and give it a new name.
2. In SCADAPack Workbench, select **FILE > Open > Project/Solution**.
3. Navigate to the location where the renamed solution is located and select the `.isasln` file.
4. Click **Open** to open the project.
5. In the Solution Explorer, right-click on each project elements then select **Rename** to rename the elements for the new solution.
6. Adapt the solution as required for the new application.

8.2.9 Output Messages

The output messages listed below are specific to SCADAPack E devices running Target 5 firmware. For information about other output messages, select **HELP > View Help** in the SCADAPack Workbench main menu and search on the message text.

**Target 5 Messages**

<table>
<thead>
<tr>
<th>Message</th>
<th>Suggested Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>RTU point pre-processor did not complete successfully.</td>
<td>Contact Schneider Electric Technical Support</td>
</tr>
<tr>
<td>RTU point pre-processor did not complete successfully. Unable to save changes to the Defined Words list.</td>
<td>Contact Schneider Electric Technical Support</td>
</tr>
<tr>
<td>The I5P package file is not generated for builds at the resource or program level.</td>
<td>Build the project from the solution level.</td>
</tr>
<tr>
<td>Unable to generate a SCADAPack file package.</td>
<td>Build the project from the solution level. If that does not resolve the issue, contact Schneider Electric Technical Support</td>
</tr>
<tr>
<td>Unable to run the RTU point pre-processor.</td>
<td>Contact Schneider Electric Technical Support</td>
</tr>
<tr>
<td>Unable to validate SCADAPack project.</td>
<td>Check the project and verify that the structure and device are valid for Target 5. For guidance, see Understanding Target 5 Application Structure</td>
</tr>
<tr>
<td>Validation was unsuccessful.</td>
<td>Check the project and verify that the structure and device are valid for Target 5. For guidance, see Understanding Target 5 Application Structure</td>
</tr>
<tr>
<td>The solution format requires that at least one resource exists. Please add a resource.</td>
<td>Add a resource to the device.</td>
</tr>
<tr>
<td>Error Message</td>
<td>Solution</td>
</tr>
<tr>
<td>------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
<tr>
<td>The solution format requires that exactly one Target 5 project exists. Please remove extra projects from the solution.</td>
<td>Remove extra projects from the solution.</td>
</tr>
<tr>
<td>The solution format requires that exactly one device exists. Please add a device.</td>
<td>Add a device to the solution.</td>
</tr>
<tr>
<td>The solution format requires that exactly one device exists. Please remove extra devices from the project.</td>
<td>Remove extra devices from the project.</td>
</tr>
<tr>
<td>The solution format requires that no more than two resources exist. Please remove extra resources from the device.</td>
<td>Remove extra resources from the device.</td>
</tr>
<tr>
<td>Device data is invalid.</td>
<td>Contact Schneider Electric Technical Support.</td>
</tr>
<tr>
<td>Device name is invalid.</td>
<td>Verify that the device has a valid device name.</td>
</tr>
<tr>
<td>Device names must begin with a letter, followed by letters, digits and single underscore characters. The last character for a name must be a letter or digit. Names cannot end with an underscore character.</td>
<td></td>
</tr>
<tr>
<td>Invalid number of resources. <em>Min-max resources expected.</em></td>
<td>Check the project and verify that the structure and resources are valid for Target 5. For guidance, see Understanding Target 5 Application Structure.</td>
</tr>
<tr>
<td>Invalid POU name.</td>
<td>Rename the Program Organization Unit (POU).</td>
</tr>
<tr>
<td>POU names must begin with a letter, followed by letters, digits and single underscore characters. The last character for a name must be a letter or digit. Names cannot end with an underscore character.</td>
<td></td>
</tr>
<tr>
<td>Invalid project name.</td>
<td>Check for a valid Target 5 project name.</td>
</tr>
<tr>
<td>The project name must begin with a letter, followed by letters, digits and single underscore characters. The last character for a name must be a letter or digit. Names cannot end with an underscore character.</td>
<td></td>
</tr>
<tr>
<td>Invalid resource number <em>number</em> found in resource <em>name</em>. Resource numbers <em>min-max</em> expected.</td>
<td>In the resource properties, verify that the resource Number property is set to 1 or 2.</td>
</tr>
<tr>
<td>No files to add to package.</td>
<td>Build the project from the solution level.</td>
</tr>
<tr>
<td>Issue</td>
<td>Solution</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
<tr>
<td>No projects loaded.</td>
<td>Select FILE &gt; Open Project/Solution to open a Target 5 project.</td>
</tr>
<tr>
<td>Package data is invalid.</td>
<td>Build the project from the solution level. If that does not work, contact Schneider Electric Technical Support.</td>
</tr>
<tr>
<td>Package validation was unsuccessful.</td>
<td>Build the project from the solution level. If that does not work, contact Schneider Electric Technical Support.</td>
</tr>
<tr>
<td>Project information is invalid.</td>
<td>Ensure the project has a valid Target 5 name.</td>
</tr>
<tr>
<td></td>
<td>The project name must begin with a letter, followed by letters, digits and single underscore characters. The last character for a name must be a letter or digit. Names cannot end with an underscore character.</td>
</tr>
<tr>
<td>Project is of unexpected type. Expected: Target 5.</td>
<td>Close the project and open a Target 5 project.</td>
</tr>
<tr>
<td>Resource data is invalid.</td>
<td>Build the project from the solution level.</td>
</tr>
<tr>
<td>Resource is of unexpected type. Expected: Target 5.</td>
<td>Close the project and open a Target 5 project.</td>
</tr>
<tr>
<td>Resource name is invalid.</td>
<td>Verify that the resource has a valid Target 5 name.</td>
</tr>
<tr>
<td></td>
<td>The resource name can be a maximum of 16 characters. The name must begin with a letter, followed by letters, digits and single underscore characters. The last character for a name must be a letter or digit. Names cannot end with an underscore character.</td>
</tr>
<tr>
<td>Target is of unexpected type. Expected: Target 5.</td>
<td>The SCADAPack E device is not running Target 5 firmware.</td>
</tr>
<tr>
<td></td>
<td>Disconnect from the device and connect to a device that is running Target 5 firmware.</td>
</tr>
<tr>
<td>Target type name is not recognized.</td>
<td>The device is not running Target 5 firmware.</td>
</tr>
<tr>
<td></td>
<td>Disconnect from the device and connect to a device that is running Target 5 firmware.</td>
</tr>
<tr>
<td>The embedded zipped source file does not exist. This file has not been included in the I5P</td>
<td>In the properties for the resource, set the Embedded Zip Source property to a value other than None.</td>
</tr>
<tr>
<td>Package file.</td>
<td></td>
</tr>
<tr>
<td>---------------------------------</td>
<td></td>
</tr>
<tr>
<td>The network configuration files do not exist. These files have not been included in the I5P package file.</td>
<td>Build the project from the project level or the solution level to generate the network configuration files.</td>
</tr>
<tr>
<td>Unable to add <code>filename</code> to the manifest.</td>
<td>Build the project from the solution level.</td>
</tr>
<tr>
<td>Unable to generate the file package header.</td>
<td>Build the project from the solution level.</td>
</tr>
<tr>
<td>Unable to generate the metadata file.</td>
<td>Build the project from the solution level.</td>
</tr>
<tr>
<td>Unable to generate the package file.</td>
<td>Build the project from the solution level.</td>
</tr>
<tr>
<td>Unable to generate the package file. Cannot find expected POU file: <code>POU name</code></td>
<td>Build the project from the solution level.</td>
</tr>
<tr>
<td>Unable to generate the package file. Resource <code>number</code> configuration file does not exist.</td>
<td>Build the project from the solution level.</td>
</tr>
<tr>
<td>Unable to generate the package file. The network configuration file does not exist.</td>
<td>Build the project from the solution level.</td>
</tr>
<tr>
<td>Unable to overwrite existing manifest file <code>filename</code>.</td>
<td>Close then reopen SCADAPack Workbench.</td>
</tr>
<tr>
<td>Unable to package files.</td>
<td>Build the project from the solution level. If that does not work, contact Schneider Electric Technical Support.</td>
</tr>
<tr>
<td>Unable to retrieve the device information.</td>
<td>Check the communications link with the SCADAPack device.</td>
</tr>
<tr>
<td>Unable to retrieve the project type.</td>
<td>Make a copy of the project, then contact Schneider Electric Technical Support.</td>
</tr>
<tr>
<td>Unable to retrieve the resource information.</td>
<td>Make a copy of the project, then contact Schneider Electric Technical Support.</td>
</tr>
<tr>
<td>Unable to retrieve the solution information.</td>
<td>Make a copy of the project, then contact Schneider Electric for Technical Support.</td>
</tr>
<tr>
<td>Defined Word name: <code>Name, message</code></td>
<td>The Defined Word cannot be added to the collection. Verify that the defined word name is valid.</td>
</tr>
<tr>
<td>RTU point pre-processor was unable to run.</td>
<td>Contact Schneider Electric Technical Support.</td>
</tr>
</tbody>
</table>
Unable to add the RTU point variables to the list of Defined Words.  
Contact Schneider Electric Technical Support.

Unable to obtain the list of wired variables.  
Contact Schneider Electric Technical Support.

Unable to validate the number of unwired channels.  
Contact Schneider Electric Technical Support.

### 8.3 Target 5 Sample Application

If you are using a SCADAPack E rPAC or RTU, you can build the sample application shown below to practice using SCADAPack Workbench.

**To Develop the Sample Application on a SCADAPack E rPAC or RTU**

1. Using the FBD editor, enter the sample FBD application shown below.
2. Save the application by selecting **FILE > Save All**.

For information about debugging applications, see [Debugging Applications](#).