The Schneider Electric brand and any registered trademarks of Schneider Electric Industries SAS referred to in this guide are the sole property of Schneider Electric SA and its subsidiaries. They may not be used for any purpose without the owner's permission, given in writing. This guide and its content are protected, within the meaning of the French intellectual property code (Code de la propriété intellectuelle français, referred to hereafter as "the Code"), under the laws of copyright covering texts, drawings and models, as well as by trademark law. You agree not to reproduce, other than for your own personal, noncommercial use as defined in the Code, all or part of this guide on any medium whatsoever without Schneider Electric's permission, given in writing. You also agree not to establish any hypertext links to this guide or its content. Schneider Electric does not grant any right or license for the personal and noncommercial use of the guide or its content, except for a non-exclusive license to consult it on an "as is" basis, at your own risk. All other rights are reserved.

Electrical equipment should be installed, operated, serviced and maintained only by qualified personnel. No responsibility is assumed by Schneider Electric for any consequences arising out of the use of this material.

As standards, specifications and designs change from time to time, please ask for confirmation of the information given in this publication.
Important information

Read these instructions carefully and look at the equipment to become familiar with the device before trying to install, operate, service or maintain it. The following special messages may appear throughout this bulletin or on the equipment to warn of potential hazards or to call attention to information that clarifies or simplifies a procedure.

The addition of either symbol to a "Danger" or "Warning" safety label indicates that an electrical hazard exists which will result in personal injury if the instructions are not followed.

This is the safety alert symbol. It is used to alert you to potential personal injury hazards. Obey all safety messages that follow this symbol to avoid possible injury or death.

DANGER

DANGER indicates a hazardous situation which, if not avoided, will result in death or serious injury.

WARNING

WARNING indicates a hazardous situation which, if not avoided, could result in death or serious injury.

CAUTION

CAUTION indicates a hazardous situation which, if not avoided, could result in minor or moderate injury.

NOTICE

NOTICE is used to address practices not related to physical injury.

Please note

Electrical equipment should be installed, operated, serviced and maintained only by qualified personnel. No responsibility is assumed by Schneider Electric for any consequences arising out of the use of this material.

A qualified person is one who has skills and knowledge related to the construction, installation, and operation of electrical equipment and has received safety training to recognize and avoid the hazards involved.
Safety Precautions

During installation or use of this software, pay attention to all safety messages that occur in the software and that are included in the documentation. The following safety messages apply to this software in its entirety.

⚠️ WARNING

UNINTENDED EQUIPMENT OPERATION

• Do not use the software for critical control or protection applications where human or equipment safety relies on the operation of the control action.
• Do not use the software to control time-critical functions because communication delays can occur between the time a control is initiated and when that action is applied.
• Do not use the software to control remote equipment without securing it with an authorized access level, and without including a status object to provide feedback about the status of the control operation.

Failure to follow these instructions can result in death or serious injury.

⚠️ WARNING

INACCURATE DATA RESULTS

• Do not incorrectly configure the software, as this can lead to inaccurate reports and/or data results.
• Do not base your maintenance or service actions solely on messages and information displayed by the software.
• Do not rely solely on software messages and reports to determine if the system is functioning correctly or meeting all applicable standards and requirements.
• Consider the implications of unanticipated transmission delays or failures of communications links.

Failure to follow these instructions can result in death, serious injury, equipment damage, or permanent loss of data.
Contents

Chapter 1: Introduction ........................................................................................................... 13
  Supported operating systems and SQL Server versions ............................................... 14
  Power Monitoring Expert software components ......................................................... 15
    Monitoring applications .............................................................................................. 15
    Management applications .......................................................................................... 16
    Programming applications ......................................................................................... 17
  ION Windows Services ................................................................................................. 17
  Power Monitoring Expert databases ............................................................................ 19
Getting started .................................................................................................................. 20
  Starting a component of Power Monitoring Expert .................................................... 21
  Logging into a component ............................................................................................ 21
  Ending a session ............................................................................................................ 21
Additional information ...................................................................................................... 22
  Customizing and navigating interface displays .......................................................... 22
    Adjusting the display of a window or dialog ............................................................... 23
    Grid table controls ..................................................................................................... 23

Chapter 2: Management Console ....................................................................................... 27
  The Management Console interface ............................................................................ 28
  Management Console network components .............................................................. 30
Setting up your network in Management Console ......................................................... 32
  Adding a server ............................................................................................................. 33
  Setting Up devices for direct serial communications .................................................. 33
  Setting up devices for ethernet gateway communications ......................................... 34
  Adding an ethernet device ............................................................................................ 34
  Setting up devices for OPC communications ............................................................. 34
  Adding a modem .......................................................................................................... 35
  Editing a network component ...................................................................................... 36
  Deleting a network component .................................................................................... 36
Renaming devices and groups ......................................................................................... 36
  Renaming a device ........................................................................................................ 37
  Changing a group name ............................................................................................... 37
  Considerations when renaming devices or groups ...................................................... 37
Creating managed circuits ............................................................................................... 38
  Managed circuits considerations ................................................................................ 38
Accessing meters with advanced security ..................................................................... 39
Configuring connection schedules ............................................................................... 40
System Log events .......................................................................................................... 41
Setting up large systems ............................................................................................... 42
  The Duplicate and Configure interface ..................................................................... 42
  Creating multiple copies of a device .......................................................................... 44
Vista user diagrams ................................................................. 104
Monitoring your system in Vista .................................................. 107
Viewing real-time data ................................................................. 110
  Viewing data with numeric objects ........................................... 110
  Viewing data with status objects ............................................. 111
Viewing logged data ................................................................. 111
  Using a Data Log Viewer ......................................................... 112
  Using the Event and Global Event Log Viewers ......................... 113
  Displaying the Global Event Log Viewer .................................. 114
  Acknowledging alarms ......................................................... 115
Controlling system functions ...................................................... 116
Plotting logged data ................................................................. 117
  The Log View Plotter interface ................................................. 117
  Viewing the Plot Display tab ................................................... 119
  Viewing the Harmonics Analysis tab ....................................... 122
  Viewing the Phasor Diagram tab ............................................. 123
  Plotting waveforms from devices with high sampling rates ............ 124
  Adding parameters to a Log View Plotter ................................ 125
  Customizing the Log View Plotter display ................................ 126
  Overlaying curves in the Log View Plotter ................................ 130
Creating and customizing a user diagram .................................... 132
Editing a user diagram .............................................................. 133
  The Enable Undo option ....................................................... 133
  Adding a diagram object to a user diagram ............................... 133
  Cutting, copying, and pasting a diagram object ......................... 135
  Copying a group of diagram objects to a framework .................... 135
  Adjusting diagram object layout and size ................................ 136
Customizing a diagram object .................................................... 137
  Caption options ................................................................. 139
  Text options ........................................................................ 139
  Edit Text options .................................................................. 140
  Link options ........................................................................ 140
  Query Server options ........................................................... 141
  Display options .................................................................... 141
  Action options ...................................................................... 146
  Box options .......................................................................... 148
  Annunciation options ........................................................... 148
  Alarming options ................................................................... 149
Linking a diagram object to a data source .................................... 150
Querying the database ............................................................... 152
  Using the Query options ....................................................... 152
  Using the Query Wizard ........................................................ 154
Creating a diagram window ......................................................... 158
<table>
<thead>
<tr>
<th>Chapter 5: Designer</th>
<th>165</th>
</tr>
</thead>
<tbody>
<tr>
<td>Getting started with Designer</td>
<td>166</td>
</tr>
<tr>
<td>Node diagrams and the Designer interface</td>
<td>166</td>
</tr>
<tr>
<td>The Designer interface</td>
<td>167</td>
</tr>
<tr>
<td>The node diagram</td>
<td>168</td>
</tr>
<tr>
<td>Display mode versus Edit mode</td>
<td>170</td>
</tr>
<tr>
<td>Designer shortcuts</td>
<td>170</td>
</tr>
<tr>
<td>Designer icons</td>
<td>171</td>
</tr>
<tr>
<td>Designer windows</td>
<td>175</td>
</tr>
<tr>
<td>ION module overview</td>
<td>176</td>
</tr>
<tr>
<td>Using ION modules</td>
<td>178</td>
</tr>
<tr>
<td>Adding a new ION module</td>
<td>180</td>
</tr>
<tr>
<td>Deleting or cutting an ION module</td>
<td>180</td>
</tr>
<tr>
<td>Viewing a node or module as text</td>
<td>183</td>
</tr>
<tr>
<td>Creating a shortcut to an ION module</td>
<td>184</td>
</tr>
<tr>
<td>Adding a text box to a node diagram</td>
<td>184</td>
</tr>
<tr>
<td>Linking ION modules</td>
<td>186</td>
</tr>
<tr>
<td>Linking ION modules graphically</td>
<td>187</td>
</tr>
<tr>
<td>Linking ION modules on the same node</td>
<td>187</td>
</tr>
<tr>
<td>Linking ION modules across different nodes</td>
<td>188</td>
</tr>
<tr>
<td>Linking ION modules using the ION tree</td>
<td>190</td>
</tr>
<tr>
<td>Deleting links</td>
<td>190</td>
</tr>
<tr>
<td>Configuring ION modules</td>
<td>192</td>
</tr>
<tr>
<td>Copying and pasting ION modules</td>
<td>197</td>
</tr>
<tr>
<td>Viewing output registers, setup registers, and inputs</td>
<td>205</td>
</tr>
<tr>
<td>Viewing output register information</td>
<td>206</td>
</tr>
<tr>
<td>Viewing setup register information</td>
<td>206</td>
</tr>
<tr>
<td>Viewing input information</td>
<td>207</td>
</tr>
<tr>
<td>Virtual Processor service</td>
<td>207</td>
</tr>
<tr>
<td>Using the Virtual Processor</td>
<td>208</td>
</tr>
<tr>
<td>Distributed control</td>
<td>209</td>
</tr>
<tr>
<td>Common Virtual Processor applications</td>
<td>212</td>
</tr>
<tr>
<td>Setting global parameters</td>
<td>213</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 6: Database Manager and Windows Task Scheduler</th>
<th>215</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prerequisites</td>
<td>216</td>
</tr>
<tr>
<td>Database Manager</td>
<td>216</td>
</tr>
<tr>
<td>Manual actions</td>
<td>218</td>
</tr>
<tr>
<td>Archive</td>
<td>218</td>
</tr>
<tr>
<td>Export Registry Setting</td>
<td>219</td>
</tr>
</tbody>
</table>
PQDIF Exporter jobs ................................................................. 292
PQDIF data templates ............................................................. 292
Scheduled export jobs ............................................................ 292
Manual export jobs ............................................................... 294
Editing the PQDIF Exporter jobs .............................................. 296
Duplicating PQDIF Exporter jobs ............................................ 297
Enabling/disabling the PQDIF Exporter jobs ......................... 297
Adjusting the column widths ................................................... 297
Sorting the PQDIF Exporter job list ......................................... 297
Deleting PQDIF Exporter jobs ................................................ 297
Closing the PQDIF Exporter window ....................................... 297

Appendix B: OPC Server Assistant ........................................... 299
Optional OPC server license ................................................... 300
OPC server type ............................................................... 300
OPC server support ............................................................ 300
Creating/updating default OPC mapping ............................... 300
OPC Server Assistant .......................................................... 300
Exporting OPC measurements through Designer .................... 301
Exporting OPC measurements through Modbus Device Importer 301
Description of commands .................................................... 302
Viewing OPC data ............................................................. 302

Appendix C: Time synchronization for ION meters .................. 303
Enabling and configuring time synchronization ....................... 303
Time synchronization blackout ............................................. 304
Changing default blackout settings ...................................... 305

Index ..................................................................................... 307
Chapter 1: Introduction

Power Monitoring Expert software is a power management solution for energy suppliers and consumers. It allows you to manage energy information from metering and control devices installed in your facility or other remote locations. The product offers control capabilities and comprehensive power quality and reliability analyses to help you reduce energy-related costs.

The product supports multiple communications standards and protocols available on various intelligent metering devices. You can also connect to existing power monitoring systems through industry standard protocols such as Modbus, OPC, DNP and XML.

In this section

Supported operating systems and SQL Server versions ............................................. 14
Power Monitoring Expert software components ..................................................... 15
ION Windows Services ......................................................................................... 17
Power Monitoring Expert databases ...................................................................... 19
Getting started ...................................................................................................... 20
Additional information .......................................................................................... 22
Customizing and navigating interface displays .................................................. 22
Supported operating systems and SQL Server versions

Windows operating systems

You can install Power Monitoring Expert software on servers using any of the following Windows operating systems.

**NOTE:** Power Monitoring Expert software can be installed on servers in a domain environment, however it cannot be installed on domain controllers. If Power Monitoring Expert software is installed on a server that is subsequently changed to a domain controller, the software ceases to function correctly.

- Windows 7 Professional/Enterprise, SP1
- Windows 8.1 Professional/Enterprise
- Windows 10 Professional/Enterprise
- Windows Server 2008 R2 Standard/Enterprise, SP1
- Windows Server 2012 Standard, SP1
- Windows Server 2012 R2 Standard

SQL Server editions

If no supported SQL Server version is detected during the installation of Power Monitoring Expert on a Standalone Server, then SQL Server 2014 Express is installed.

If a supported edition of SQL Server Express is already installed but not configured with a database instance for use with Power Monitoring Expert, the installer adds the required database instance. Otherwise, one of the following SQL Server editions needs to be installed prior to installing Power Monitoring Expert software. (See the "Installing SQL Server" topic in the StruxureWare Power Monitoring Expert Installation Guide for more information.)

Note that supported 32-bit and 64-bit SQL Server editions can only be installed on supported 32-bit and 64-bit Windows operating systems, respectively. For example, a 32-bit SQL Server edition is not supported on a 64-bit Windows operating system.

<table>
<thead>
<tr>
<th>SQL Server Editions</th>
<th>Standalone Server</th>
<th>Distributed Database Server</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQL Server 2008 R2 Express, SP3</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>SQL Server 2012 Express, SP2</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>SQL Server 2014 Express, SP1</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>SQL Server 2008 R2 Standard/Enterprise, SP3</td>
<td>Yes</td>
<td>Yes ¹</td>
</tr>
<tr>
<td>SQL Server 2012 Standard/Enterprise/Business Intelligence, SP2</td>
<td>Yes</td>
<td>Yes ²</td>
</tr>
<tr>
<td>SQL Server Editions</td>
<td>Standalone Server</td>
<td>Distributed Database Server</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>SQL Server 2014 Standard/Enterprise/Business Intelligence, SP1</td>
<td>Yes</td>
<td>Yes ²</td>
</tr>
</tbody>
</table>

¹ Supported for a distributed database server configuration on Windows Server 2008 R2 Standard/Enterprise SP1.
² Supported for a distributed database server configuration on Windows Server 2012 Standard SP1, and on Windows Server 2012 R2 Standard.

You can use an existing SQL Server instance of these editions to host the product's databases.

**Power Monitoring Expert software components**

This section outlines the Power Monitoring Expert software components, and how they are used to build, monitor, maintain and customize your system.

**Monitoring applications**

The following applications are most commonly used in day-to-day power monitoring tasks:

**Vista**

The "Vista" component displays graphical representations of your power monitoring system. Vista displays real-time and historical information, visual objects that indicate the current status of your system, and interactive objects that you can use to perform certain actions such as resetting a counter.

**NOTE:** In this document, "Vista" refers to the Vista component of Power Monitoring Expert. The Microsoft Windows Vista operating system is referred to as "Windows Vista".

**Web applications**

The Web Applications component of the product includes the following applications for your power monitoring requirements:

- Dashboards
- Diagrams
- Tables
- Trends
- Alarms (includes alarms and events)
- Reports

For further information see the online help in the Web Applications component.
Alarm Configuration

The Alarm Configuration application allows you to configure software alarms for multiple sources and measurements. Each alarm configuration is represented as an Alarm Rule. The rule includes a threshold value, pickup and dropout delays, an update rate, and the alarm priority.

For further information, see Alarm Configuration Help available from the Alarm Configuration application.

Management applications

The following applications help you set up and maintain your power management system.

Management Console

Use the "Management Console" component to add and configure network components such as servers, sites (communication links) and devices. Management Console also provides access to system and database applications, and utilities. These are described in the following topics:

- "Database Manager and Windows Task Scheduler" on page 215
- "User Manager" on page 53
- "Reporting Configuration Manager" on page 56
- "Deactivate alarms" on page 57
- "Event Watcher Manager " on page 58
- "Designer" on page 165
- "Diagnostics Viewer" on page 61
- "Device Upgrader" on page 72
- "Logical Device editors" on page 76
- "Hierarchy Manager" on page 88
- "Remote Modem Setup" on page 89
- "Virtual Processor setup" on page 90
- "Modbus Device Importer" on page 231
- "Time of Use Editor " on page 91

Also available from the Tools menu is the PQDIF Exporter. This component lets you export data to Power Quality Data Interchange Format (PQDIF) and set scheduled exports with notification. See "PQDIF Exporter" on page 287 for more information.
Optional OPC Server Assistant

The OPC Server Assistant is a utility that you use to expose measurements as OPC tags. You open the utility from Designer or the Modbus Device Importer. See "OPC Server Assistant" on page 299 for further information.

The OPC Server Assistant is available during the 90-day trial period. After the trial period, you need to purchase an OPC DA Server license and activate it through the Floating License Manager to enable OPC server functionality.

Programming applications

The following applications help you customize elements in your system and configure third-party devices so the system can recognize and utilize them:

Designer

Use the "Designer" component to perform a wide range of functions, from configuring setup registers of ION devices on your network to creating complex frameworks using a combination of ION modules from hardware or software nodes.

Modbus Device Importer

Use the "Modbus Device Importer" component to integrate third-party Modbus devices into your network.

Large system setup using Management Console

Use the Duplicate and Configure function to set up large systems efficiently. See "Setting up large systems" on page 42 for more information.

ION Windows Services

Many of the product’s core components run as Windows Services. This allows your servers to continue monitoring your power management system when no users are logged on. In the event of a power outage, your system automatically resumes power monitoring when the power is restored. The table below summarizes the services and indicates whether the service is configured to start automatically or manually, by default.

![Service Table]

<table>
<thead>
<tr>
<th>Service Name</th>
<th>Description</th>
<th>Manual/Automatic</th>
</tr>
</thead>
<tbody>
<tr>
<td>ApplicationModules AlarmServiceHost</td>
<td>Hosts alarm services used by the Web Applications component.</td>
<td>Manual</td>
</tr>
<tr>
<td>ApplicationModules CoreServicesHost</td>
<td>Hosts common web services used by the Web Applications component.</td>
<td>Automatic</td>
</tr>
</tbody>
</table>

NOTE: ION Network Router Service has many dependent services. For example, the Virtual Processor, ION Log Inserter Service and ION Site Service cannot start and operate without it running.
<table>
<thead>
<tr>
<th>Service Name</th>
<th>Description</th>
<th>Manual/Automatic</th>
</tr>
</thead>
<tbody>
<tr>
<td>ApplicationModules DataServicesHost</td>
<td>Hosts web services that provide low-level access to system data for the Web Applications component.</td>
<td>Automatic</td>
</tr>
<tr>
<td>ApplicationModules ProviderEngineHost</td>
<td>Hosts web services that provide data processing for the Web Applications component.</td>
<td>Automatic</td>
</tr>
<tr>
<td>ION Alert Monitor</td>
<td>Checks the computer’s communications ports continuously for high priority events occurring at remote modem sites. When this happens, Alert Monitor initiates a communications connection to the remote modem site.</td>
<td>Manual</td>
</tr>
<tr>
<td>ION Component Identifier Service</td>
<td>Locates local and remote product components. Although this service is configured as Manual, the service starts when a client attempts to connect to it.</td>
<td>Manual</td>
</tr>
<tr>
<td>ION Connection Management Service</td>
<td>Determines the connection status of sites and devices in the system, and handles allocation of resources such as modems. This service manages the state of site and device connectivity for the system. In order to establish the most appropriate state for the system, each connection and disconnection request is evaluated against the overall state of the system and availability of communications channels.</td>
<td>Manual</td>
</tr>
<tr>
<td>ION Event Watcher Service</td>
<td>Monitors system events for conditions specified in Event Watcher Manager (see &quot;Event Watcher Manager&quot; on page 58).</td>
<td>Automatic</td>
</tr>
<tr>
<td>ION Log Inserter Service</td>
<td>Provides historical data collection and storage for your power monitoring system. See &quot;Log Inserter&quot; on page 229.</td>
<td>Automatic</td>
</tr>
<tr>
<td>ION Managed Circuit Service</td>
<td>This service is used to create individual real-time and historical data sources for multi-circuit meters.</td>
<td>Automatic</td>
</tr>
<tr>
<td>ION Network Router Service</td>
<td>Routes all information between the software components, such as client workstations and the Log Inserter. The service dynamically detects changes to the network configuration, including the addition of new servers; it can also recognize new software nodes, such as Vista, that are added to an existing server.</td>
<td>Automatic</td>
</tr>
<tr>
<td>ION OPC Data Access Server</td>
<td>Manages and is responsible for supplying OPC data to client applications. Although this service is configured as Manual, the service starts when an OPC client attempts to connect to it.</td>
<td>Manual</td>
</tr>
<tr>
<td>ION PQDIF Exporter Service</td>
<td>Translates data from the product’s databases to PQDIF file format and manages scheduled PQDIF exports.</td>
<td>Manual</td>
</tr>
<tr>
<td>ION Query Service</td>
<td>Provides historical data retrieval for your power monitoring system. See &quot;Linking a Data Log Viewer or Event Log Viewer&quot; on page 151 for more information regarding this service.</td>
<td>Automatic</td>
</tr>
<tr>
<td>ION Real Time Data Service</td>
<td>Manages and provides access to real time data from the power management system.</td>
<td>Automatic</td>
</tr>
<tr>
<td>Service Name</td>
<td>Description</td>
<td>Manual/Automatic</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>----------------------------------</td>
</tr>
<tr>
<td>ION Report Subscription Service</td>
<td>This service manages report subscriptions in the Reports application. (This service is only available if you are using a supported edition of SQL Server Standard or Enterprise with the software product.)</td>
<td>Automatic (Delayed Start)</td>
</tr>
<tr>
<td>ION Site Service</td>
<td>Manages communication links to and from the product. ION Site Service is responsible for handling packet communications to system devices and controlling direct device communications. The service reacts to changes in network configuration: for example, often changes to certain channels, configuration parameters, ports, or device parameters can interrupt a connection.</td>
<td>Automatic</td>
</tr>
<tr>
<td>ION Software Alarm Service</td>
<td>Performs alarm evaluation based on real-time data from the power monitoring system.</td>
<td>Automatic</td>
</tr>
<tr>
<td>ION Software Modbus Gateway Service</td>
<td>Enables software data services via ModbusTCP/IP.</td>
<td>Manual</td>
</tr>
<tr>
<td>ION Virtual Processor Service</td>
<td>Provides coordinated data collection, data processing, and control functions for groups of meters. For more information on the Virtual Processor and its functionality, see &quot;Virtual Processor setup&quot; on page 90.</td>
<td>Automatic</td>
</tr>
<tr>
<td>ION XML Subscription Service</td>
<td>Manages subscriptions to XML data for Vista user diagrams. This service is used only by the Diagrams application. When you open a Vista user diagram in a web browser, the ION XML Subscription Service creates a subscription and delivers the real-time data in XML format.</td>
<td>Automatic</td>
</tr>
<tr>
<td>ION XML Subscription Store Service</td>
<td>Stores XML data subscriptions for the power monitoring devices on the network. This service is used only by the Diagrams application.</td>
<td>Automatic</td>
</tr>
</tbody>
</table>

**Power Monitoring Expert databases**

The product’s databases are installed on a Database Server or a Primary Server and run in the background of your system. To connect to these databases, Power Monitoring Expert uses the SQL Server instance you created when you installed the product or configured SQL Server.

For information on managing these databases in the product, see "Database Manager and Windows Task Scheduler" on page 215.

**Microsoft SQL Server database**

Microsoft SQL Server is the database engine that manages the product’s databases: the ION database (ION_Data), the Network Configuration database (ION_Network), the System Events database (ION_SystemLog), and the Application Modules database.
(ApplicationModules). The product uses a SQL Server instance to connect to the databases. The instance is created either when you install a supported SQL Server Standard or Enterprise edition, or when you install a supported edition of SQL Server 2012 Express, SP1 with the product. You can also specify a pre-existing instance during the installation process.

**The Network Configuration database**
The Network Configuration database ("ION_Network") stores information about your network topology — the network connections, computers and every connected device, including dial-out modems. This information is used by the communications services (for example, ION Network Router Service, ION Site Service) and other software components to manage data and control requests to and from the devices and the other product components (that is, Vista, Designer).

**The System Events database**
The System Events database ("ION_SystemLog") stores data about events that occur during the operation of the components. For example, the event details about the communication service’s interactions with devices, details about controls initiated through Vista, and general or alarm level events that occur in the Virtual Processor are all inserted into the System Events database. These can then be viewed when you click the System Log Events icon in Management Console or through access to the ION_Data database using Vista (Event Log Viewer).

ION_SystemLog is not backed up. Some contents of the System Log — System Events with a priority of 192 or greater — are automatically inserted into the ION_Data database on a regular basis and can be viewed in Vista.

**The ION database**
The ION database ("ION_Data") contains all the data collected from devices that have the ability to record data and from the product’s components. This database uses the ION Log Inserter Service to gather data from all of the available sources, and then makes the data available to components like Vista (through the ION Query Service) or Reports (through direct database queries).

**The Application Modules database**
The Application Modules database (ApplicationModules) contains all of the configuration data for the Dashboards and Tables applications in the Web Applications component. This includes such items as saved dashboards, gadgets, and tables.

**Getting started**
This section describes how to start, log on to, and exit most of the components of the Power Monitoring Expert product.
Starting a component of Power Monitoring Expert

Use one of the following methods to start the main components Management Console, Vista, or Web Applications of your product installation:

- Open the StruxureWare Power Monitoring Expert folder on your desktop and double-click the icon of the program you want to start.
- Click Start > All Programs > Schneider Electric > StruxureWare Power Monitoring Expert and select the program you want to start.

Logging into a component

Most Power Monitoring Expert programs require you to log in before you can access them. At the logon prompt, type your user name and password in the appropriate box, then click OK. Some actions are restricted to certain users or groups, depending on how their login permissions were set up. See "User Manager" on page 53 for details. If you do not have a user name and password, log on in View Only mode for limited access.

For information about setting up user accounts and changing passwords, see "User Manager" on page 53.

After you log on, the program interface appears.

Ending a session

There are two ways to end a session in a component:

- Log off if you want to end the current user session but keep the program running, or
- Exit if you want to close the program completely.

Some components offer both options; some only offer the Exit option.

Logging off

1. Select File > Logoff.
   A message appears, prompting you to confirm your intention to log off.
2. Click Yes to log off or No to return to the program.
   If you attempt to log off without saving your work, you are prompted to save your changes. Click Yes to save your changes, No to discard them, or Cancel to return to the program.

After you log off, the component's Logon screen appears.

Exiting

1. Select File > Exit.
   A message appears, prompting you to confirm your intention to exit the application.
2. Click Yes to exit or No to return to the program.
If you attempt to exit without saving your work, the program prompts you to save your changes. Click **Yes** to save your changes, **No** to discard them, or **Cancel** to return to the program.

**Additional information**

For more information about Power Monitoring Expert components, using devices with the product, and ION architecture, visit www.schneider-electric.com to obtain the following documents:

- Power Monitoring Expert Installation Guide
- Troubleshooting Serial Communications in PowerLogic ION Meters
- Troubleshooting Meter Wiring
- Upgrading ION Device Firmware
- ION Reference

Release notes and mapping spreadsheets for device drivers recently added to the product are included in the product’s installation location in …\Schneider Electric\Power Monitoring Expert\system\doc\Device Support\. The release notes provide information about the firmware versions supported by the device drivers, implementation details, images of Vista diagrams for the devices, and pertinent safety messages. The device driver mapping spreadsheets contain details such as modbus register addresses and corresponding ION register addresses (handles). Register mapping information is also provided for any devices using PC logging.

Note that the PQDIF Exporter and OPC Server Assistant documentation have been incorporated into this document. See “PQDIF Exporter” on page 287 and “OPC Server Assistant” on page 299 for further information.

**Customizing and navigating interface displays**

The following sections describe ways to customize and navigate display windows, dialogs, and tables in components of Power Monitoring Expert.

**Navigating tree structures**

Information is often displayed in a tree structure. Click “+” to expand items in the tree or “-” to collapse them.

**Selecting multiple items in tables, tree structures, diagrams and folder structures**

To select adjacent items, select the first item, hold down the SHIFT key then click the last item.

To select non-adjacent items, hold down the CTRL key then click to select the items.

To select adjacent items in Vista or Designer diagrams, drag a selection box around the items. All items in the box are selected.
Adjusting the display of a window or dialog

The following sections describe how to resize and hide or reveal panes.

Resizing panes

To resize panes in a window, point the mouse at the border where the two sections meet. When the resize handle appears, drag to move the border.

Dock (Pin) or hide (Unpin) pane

Some component interfaces have panes that can be hidden (visible temporarily) or docked (visible all the time).

To hide or dock a pane, click the Pin/Unpin button on the pane. When a pane is hidden, it is minimized to a button at the edge of the workspace.

To temporarily show a hidden pane, hover the mouse over the button for that pane. Move the mouse away to hide the pane again.

Grid table controls

Certain windows and utilities display information in “grid” tables. These tables have unique table and information display commands.

Select columns/column selector

Some tables allow you to select which columns to include in the table.

1. In Management Console, hover over the column selector tab on the right side of the display window. In other interfaces, click the “Select Columns” link.

2. Select the boxes for the columns you want to include in the table. Clear the boxes for the columns you do not want to include in the table.

Adjust column width

To change the width of a column, point the mouse to the right edge of the column header. When the resize handle (double-arrow pointer) appears, click and drag to adjust the width. To adjust the width for best fit, point to the right edge of the column header, then double-click when the resize handle appears.

Best Fit

To adjust a column width to the best fit with the least amount of white space:

- For one column, right-click a column header and select Best Fit.
- For all columns, right-click the column title area and select Best Fit (all columns).

Arrange columns

To change the order of the columns, drag a column header to the left or right of its original position.
**Group by column**

To group data according to the contents of a particular column, drag the column header to the area above it (marked “Drag a column header here to group by that column”). To expand or collapse the groups, click the “+” or “-” button. To expand or collapse all groups, right-click the column header in the Group By Box area and select **Full Expand** or **Full Collapse**, respectively.

You can also group by multiple columns in a specific order, with sorting and filtering applied. To do this drag each column to the **Group By Box** area in the order that you want to group them.

To ungroup, drag the column header back to its original position (or right-click the column header and select **Ungroup**).

To show or hide the **Group By Box** area, right-click the column header and select or clear **Group By Box**.

**Sorting data in a column**

Click a column header to sort table rows according to data in that column. You can sort in ascending or descending order (indicated by an up or down arrow, respectively). To cancel sorting and return the column to its default state, right-click the column and select **Clear Sorting**.

**Filtering data in a column**

The following sections describe the available filtering options.

**Using the Simple Column Filter**

When the mouse is positioned over a column header, the Filter icon appears in the top right corner of the header. Click it to select one of the listed filter conditions and apply it to the data in that column. Select **(Custom)** to apply one or two logic conditions to filter the data. To cancel filtering and return the column to its default state, right-click the column and select **Clear Filter**.

**Using the Dynamic Column Filter**

Some tables have a row between the column header and the table data. This is the dynamic filter area.

To use the dynamic filter area, start typing the entry you want to filter on in the space above the applicable column. You can use an asterisk (*) at the beginning of the filter as a wildcard. Once you achieve the filter results you want, you can stop typing. For example, to filter out “DST” from “disturbance” in System Log Events, you only need to type “di”.
Using the Filter Builder

The Filter Builder is an advanced data filtering tool. Use it to create filters with multiple conditions across multiple columns. To use the Filter Builder:

1. Right-click a column header and select Filter Editor to open the Filter Builder dialog.
2. Specify the filter conditions.
   The elements of the filter builder are: <Column Header> <Condition> <Value>
   Click an element to display the options available, then select the option you want to use.

3. Select the <Column Header> and the <Condition> you want to apply. Type the <Value> to test for.
4. To add another filter, click the “+” button on the top.
5. Select a logic to apply to this new filter (in relationship to the current filter).
6. Repeat step 3.
7. To remove a filter, click the delete (“x”) button beside it.

In the following example, the filter finds all devices in group name containing "Mfg" and whose types begin with "ION".

The rows returned are as follows:
A Select the checkbox to turn the filter on; clear it to turn the filter off. Click the "X" to cancel and exit the filter mode.

B Click Edit Filter to configure the filter conditions.
Chapter 2: Management Console

Use Management Console to add, remove or configure system components, such as metering devices, in your Power Monitoring Expert power management system. You can set up different types of sites (communication links such as Ethernet or serial), and set up connection schedules for these sites.

In addition, the Management Console Tools menu provides access to device and system configuration, maintenance and programming tools. See "Management Console tools" on page 51 for details.

**NOTICE**

**NETWORK INOPERABILITY**

- Do not make unauthorized changes in the network configuration using Management Console.
- Only users with Operator-level or Supervisor-level authority can make network changes using Management Console.

Failure to follow these instructions can result in an unstable or unusable network.

In this section

- The Management Console interface .................................................. 28
- Management Console network components ........................................... 30
- Setting up your network in Management Console ................................... 32
- Renaming devices and groups ................................................................. 36
- Creating managed circuits ..................................................................... 38
- Accessing meters with advanced security ............................................... 39
- Configuring connection schedules ......................................................... 40
- System Log events ................................................................. 41
- Setting up large systems ...................................................................... 42
The Management Console interface

Window title
The window title displays the name of the software program and the current user.

System Setup pane
The icons in the System Setup pane represent categories of items you can add, remove, set up, and view. Click an icon to go to the associated display window.

Display window
The Display window shows the contents of the item currently selected in the System Setup pane.

Refresh
To manually refresh Management Console and reload its contents, select View > Refresh (or press F5).
Options
Select **Tools > Options** to open the Options dialog. Use this dialog to change display settings for the System Log Events display window.

Highlighting
Highlighting controls how Error events are displayed in the System Log Events display window. Select or clear the Enable Highlighting check box to turn highlighting on or off. Click **Set Highlight Color** to change the highlight color for Critical or Error events in the System Log Events display window.

Events
The Events section of the dialog lets you control how many records appear in the System Log Events display window and how date and time are displayed.

Customizing the Management Console interface
You can customize what is displayed in the Management Console interface and the tables within the display windows:

- Select which columns appear in tables.
- Filter, sort and group data in tables.

For instructions on using these features, see "Customizing and navigating interface displays" on page 22.

Display window shortcut menus
To access shortcut menus in the Display window, first click the icon of the System Setup item you are interested in. Then right-click the display window area or on a network component to display the shortcut menu. The menu items available vary depending on the network component selected.

- **New** displays the options available for adding new network items.
- **Duplicate** creates one or more copies of a selected item.

**NOTE:** For the **Duplicate** command, each one of the duplicates needs to be opened individually in order to configure them. **Duplicate and Configure** allows you to create and configure multiple devices at the same time.

- **Duplicate and Configure** lets you perform batch cloning of devices. When multiple devices are selected, this right-click shortcut becomes **Configure Selected Devices** which lets you perform setup functions such as batch renaming of devices.
- **Delete** removes the selected items.
- **Connect** and **Disconnect** lets you manually connect to or disconnect from the selected site.
NOTE: You cannot connect or disconnect an individual serial device in a site; you can only connect or disconnect the site for that serial device.

- **Connect Ethernet** and **Disconnect Ethernet** let you manually connect to or disconnect from the selected Ethernet device.
- **Security** accesses the Meter Security Settings dialog. This is used by the software to gain access to security-enabled devices (for example, ION8600 or ION7650); it is only available from the shortcut menu for the Devices display pane.
- **Configure <Network Component>** opens the <Network Component> Configuration dialog (where <network component> is the component selected). Use this dialog to make changes to the properties for the selected network component.

**Management Console network components**

This section describes the different components in Management Console: Servers, Sites, Devices, Dial Out Modems, Connection Schedules, and System Log Events.

See "Setting up your network in Management Console" on page 32 for information on adding these components to your network.

**Servers**

A server is a computer in the Power Monitoring Expert system that runs administrative software to control access to the network and its resources, such as metering devices.

**Sites**

A site is a group of devices in the system that share a common communications link. A site can be a direct site, a modem site, an Ethernet gateway site, or an OPC site.

**Direct site**

In a direct site, serial communications occur between a computer and one or more meters. The standards most commonly used on computers are RS-232 (for connecting one device) and RS-485 (for connecting a loop of up to 32 devices). When connecting to more than one serial device, use an RS-232 to RS-485 converter. Note that you should keep the number of devices on a daisy chain to a minimum to reduce the delay in real-time updates.

**Modem site**

In a modem site, communications occur between a remote modem (at the Modem Site) and a local modem (on the server).

**NOTE:** Remote sites that use radio modems or leased-line modems are configured as Direct (Serial) Sites, not as Modem Sites.
Modem sites can include traditional hardware modems (those that are configured and controlled by Power Monitoring Expert or WinModems (Windows modems). If multiple modems are set up in the modem site, Power Monitoring Expert selects the first available modem to establish communications (this is referred to as "modem pooling").

**Ethernet gateway site**

An Ethernet gateway site (for example, EtherGate or Modbus gateway) consists of an RS-485 chain of devices that communicates with an Ethernet network via an Ethernet device. The Ethernet device acts as a gateway that transfers data between an Ethernet network and the devices connected to it via RS-485. The gateway device converts RS-232/RS-485 communications to and from Ethernet.

**OPC site**

An OPC site consists of an OPC client that communicates with OPC-compliant devices on the network.

**Devices**

A device is a meter or other component that communicates and gathers data, and is installed on a network.

Release notes and mapping spreadsheets for device drivers recently added to the product are included in the product's installation location in ...\Schneider Electric\Power Monitoring Expert\system\doc\Device Support\. The release notes provide information about the firmware versions supported by the device drivers, implementation details, images of Vista diagrams for the devices, and pertinent safety messages. The device driver mapping spreadsheets contain details such as modbus register addresses and corresponding ION register addresses (handles). Register mapping information is also provided for any devices using PC logging.

**Serial devices**

Serial devices belong to direct sites, modem sites, or Ethernet gateway sites — they communicate through a modem, RS-232, RS-485, or Ethernet-to-Serial gateway connection. You must have the appropriate sites configured first before you can add serial devices.

**Ethernet devices**

Ethernet devices are those that are directly connected to the network via Ethernet. You can manually connect or disconnect your Ethernet device through the Management Console.

**Logical devices**

Logical devices are a collection of measurements from physical and VIP devices grouped into single sources for use in the system.

**OPC devices**

OPC devices represent physical devices to which the system is communicating through an OPC interface.
Dial Out Modems
A dial-out modem is one that a server computer uses to communicate with a remote modem at a modem site. The modem implemented can be a traditional hardware-based modem or it can be a software-based modem that uses the computer's processor to emulate a traditional hardware-based modem.

When a modem site needs to establish communications, it selects a modem from the list of modems configured in the modem site. You can add hardware modems or WinModems to the modem list.

NOTE: A WinModem is a modem that is directly controlled by the computer's operating system.

Connection schedules
Connection schedules are programmed routines for a server to regularly connect to and disconnect from sites (and their associated devices) and Ethernet devices. See "Configuring connection schedules" on page 40 for more information.

System Log Events
System Log Events lists events for the network. You can select what timeframe and components you want to view events for. See "System Log events" on page 41 for more information.

Setting up your network in Management Console
The Primary Server contains all the Power Monitoring Expert programs and it controls the overall operation of your energy management system. The primary server is displayed on the Server screen when you first start Management Console.

To start building your system, add and configure your sites and devices.

NOTE: Do not use names such as CON, AUX, COM1, and LPT1 when naming sites and devices. Consult Microsoft documentation regarding restrictions for naming files, paths, and namespaces.

Adding network components
For details on adding various components, see the following sections.

Follow the procedure below to add a new network component:

1. In the System Setup pane, select the icon for the type of item that you want to add (Site, Device, or Dial Out Modem).
2. Right-click the display window, select New, and then select the specific type of network component from the shortcut menu to open the Configuration dialog.

The options differ depending on which system setup icon you selected.
3. Use the fields and drop-down menus to configure properties. Mandatory items are highlighted in red. To configure advanced properties, right-click the dialog and select **Advanced Properties**. For more shortcut menu options, see "Configuration Dialog shortcut menus", below.

4. Click **OK** to add the component.

**Configuration Dialog shortcut menus**

Right-click the **Configuration** dialog to access the following shortcut menu options:

- **Property Details**: This opens a window that contains information on the selected property, including minimum and maximum allowable values, if applicable.

- **Advanced Properties**: This exposes all the property fields that are hidden in the default (basic) view. For further information about the Time synchronization option. see "Time synchronization for ION meters" on page 303 for further information.

- **Reset All To Default**: Resets all properties to their original values.

**Adding a server**

Click the Servers icon, right-click the display window and select **New > Computer**. Fill in the mandatory **Name** field.

**Setting Up devices for direct serial communications**

To set up devices for RS-232 or RS-485 communications on a direct serial loop, first add a direct site in Management Console and specify a serial communications port on the computer.

**Step 1: Adding a direct site**

Click the Sites icon. Right-click the display window and select **New > Direct Site**. Fill in the **Name** and **Serial Port** fields. Configure the other fields as you require.

**Step 2: Adding a device to the direct site**

Click the Devices icon. Right-click the display window and select **New > Serial Device** on **Direct Site**. Fill in these fields:

- **Group**: Type a name for the group or select an existing group from the list.

- **Name**: Type the name you want to give the device.

- **Device Type**: Select the type of the device.

- **Unit ID**: Type the Unit ID of the device; the range is 1-9999 for ION devices or 1-247 for Modbus RTU devices.

- **Site**: Select the direct site you previously set up.

Configure the other fields as you require.
Setting up devices for ethernet gateway communications

To set up devices for Ethernet gateway communications, first add and configure an Ethernet gateway site. Ethernet gateways that can be used include those that are simple Ethernet-to-Serial converters, or any gateway or data concentrator that provides ModbusTCP communications.

**Step 1: Adding an ethernet gateway site**

Click the Sites icon. Right-click the display window and select **New > Ethernet Gateway Site**.

Complete the **Name**, **TCP/IP Address** and **TCP/IP Port** fields. (The TCP/IP address can be IPv4 or IPv6.) The TCP/IP Port identifies which communications port is used to connect to the serial devices. The port you use depends on the type of Ethernet gateway you want to set up (i.e., use 7801 for an EtherGate gateway via COM1 or use port 502 for a Modbus gateway).

Configure the other fields as you require.

**Step 2: Adding a Device to the Ethernet Gateway Site**

Click the Devices icon. Right-click the display window and select **New > Serial Device on Ethernet Gateway Site**. Fill in these fields:

- **Group**: Type a name for the group or select an existing group from the list.
- **Name**: Type the name you want to give the device.
- **Device Type**: Select the type of device.
- **Unit ID**: Type the Unit ID of the device; the range is 1-9999 for ION devices or 1-247 for Modbus devices.
- **Site**: Select the Ethernet gateway site you previously set up.

Configure the other fields as you require.

Adding an ethernet device

Click the Devices icon. Right-click the display window and select **New > Ethernet Device**. Fill in the **Group**, **Name**, **Device Type** and **TCP/IP Address** fields. (The TCP/IP address can be IPv4 or IPv6.) Configure the other fields as you require.

**NOTE**: When you configure Ethernet or Ethernet gateway devices, you can specify either a hostname or an IP address in the TCP/IP Address field.

Setting up devices for OPC communications

To set up devices for OPC communications, first add an OPC site.

**Step 1: Adding an OPC site**

Click the Sites icon. Right-click the display window and select **New > OPC Site**. Fill in the **Name** and **Address** fields. Configure the other fields as you require.
Make sure you follow the correct syntax when typing in the address for the OPC site. Select the Address field to see an example address in the Property Description section (near the bottom of the OPC Site Configuration dialog).

Step 2: Adding a device to the OPC site

**NOTE:** At least one OPC Device Type needs to be preconfigured before an OPC Device can be created in Management Console. Contact Technical Support for assistance.

Click the Devices icon. Right-click the display window and select New > OPC Device. Fill in the Group, Name, Device Type and Site (select the OPC site you previously set up). Configure the other fields as you require.

**Adding a modem**

1. Click the Dial Out Modems icon, right-click the display window and select New, then select either Serial Modem (hardware modem) or WinModem (Windows modem).
2. Fill in the values for the mandatory fields:
   - For Serial modem, select the Modem Type from the list. If your modem is not in this list, select “Generic ION Modem - Other”. Select the Serial Port where your modem is connected.
   - For WinModems, select the Modem Name from the list.
   Configure the other fields as you require.
3. Click OK.

**WinModem installation notes**

Before you can use a WinModem, you must first install it on your computer (follow the instructions that came with the WinModem product). After you restart the computer, set up the WinModem:

1. In Microsoft Windows, click Start > Settings > Control Panel, then double-click Phone and Modem Options.
2. Click the Modems tab, select your WinModem, then click Properties.
3. Click the Advanced tab, then click Change Default Preference.
4. Set Port speed to match the baud rate that is used between the meter and the modem on the remote end of the connection (i.e., both modems must be set to the same baud rate).
5. Set Flow Control to “None”.
6. Click OK to save your changes.

**NOTE:** You may need to restart your computer for the settings to take effect.
Editing a network component

1. Click the icon in the System Setup pane for the type of component you want to edit.

2. In the display window, right-click the network component you want to edit and select **Configure <Network Component>** (with <Network Component> being the type of component you want to edit).

You can rename devices or groups displayed in the Devices pane without selecting the **Configure** option. See "Renaming devices and groups" on page 36 for further information.

**NOTE:** If you rename a group or device, the data that is already stored in the database is associated with the new group or device name. New data will be added to the database using the new name.

3. Make the required changes. To display all configurable fields, right-click the **Configuration** dialog and select **Advanced Properties**.

4. Click **OK** when you are finished to save your changes.

Deleting a network component

1. Click the System Setup icon for the type of component you want to delete.

2. In the display window, right-click the network component you want to delete and select **Delete** (or select the item and press the DELETE key).

3. Click **Yes** to confirm the deletion or **No** to cancel.

**NOTE:** When you delete a Site or a Server, all devices associated with it are also deleted.

Renaming devices and groups

You can change the display names of devices and groups without losing any of the real-time or historical data associated with them.

In the Devices pane in Management Console:

- **Group** and **Name** are separate columns.
  - The **Name** column is always displayed.
  - The **Group** column is displayed by default, but you can use the **Column Selector** to remove it from the display area. You can now drag and drop the **Group** column to the **Group By Box** area to show the devices organized within each group.

- **System Name** and **Data Availability** are columns that you can select for inclusion in the display area.
  - **System Name** shows the internal name in group.name format.
  - **Data Availability** indicates **All** for devices that are active and have real-time and historical data, and **Historical only** for devices that have been deleted and only provide
historical data. Historical devices are included in the devices displayed when you select the Show historical devices checkbox.

- The Show historical devices option displays devices that have been deleted. Since the data for these devices still exists in the system, they can be displayed when you select this option.

**Renaming a device**

Complete the following steps to change the display name of a device. The system (internal) name is not affected by this name change.

1. Right-click the device name in the Devices pane of Management Console and select Rename in the menu to open the Rename Device dialog.
2. Enter the new name for the device.
   
   The appearance of the exclamation icon (!) to the right of the field indicates that there are instructions or errors associated with the device name. Hover over the icon to display the text and take appropriate action.
3. Click OK to rename the device.

**Changing a group name**

Change a group name as follows:

1. Right-click a single group name or select multiple group names (Ctrl + left mouse click) in the Devices pane of Management Console and select Change Group in the menu to open the Change Group dialog. (You can also select the devices and click the Change Group option in the Edit menu.)
2. Enter a new group name or select a group name from the list of group names currently used in the system.
   
   The appearance of the exclamation icon (!) to the right of the field indicates that there are instructions or errors associated with the group name. Hover over the icon to display the text and take appropriate action.
3. Click OK to change the group name.

**Considerations when renaming devices or groups**

Note the following when you rename a device or a group:

- Complete any configuration tasks in progress, such as working in Designer, before changing names.
- Restart any open components such as Vista, Designer, or Web Applications after the name or group change has been completed to refresh the names that appear in them.
- Regenerate network diagrams in Vista to update the top-level grouping objects with the changed Group name.
• Update OPC data mapping after device renaming by selecting the **Update OPC Server** option in Management Console’s **Tools > System** menu. You can then update the OPC clients with the new data.

• System (internal) names, not display names, continue to appear in System Log Events in Management Console. You can view the system name of a device by selecting **System Name** in the **Column Selector** in the Devices pane.

### Creating managed circuits

The Managed Circuits function in Management Console allows you to automatically create devices representing the circuits of multi-circuit devices, such as BCPM and PM5350 devices, so that you can then treat each circuit as a source for both real time and historical data in the system.

These sources represent the physical structure in the system. For information about organizing these circuits and other metering points into a recognizable system-specific hierarchy view, see "Hierarchy Manager" on page 88 and also the online help in Hierarchy Manager.

The first step in creating managed circuits is to add the multi-circuit device to Management Console and check that it is communicating.

Once this is done, you can create managed circuits as source entries automatically as follows:

1. Right-click the multi-circuit device you added in Management Console to open the menu and click **Configure Managed Circuits**.
2. Click **OK** on the confirmation window to proceed.
   
   The **Configuring Managed Circuits** dialog opens showing a progress bar as the circuits are being created. The number of circuits created are indicated under the progress bar field.

3. Click **OK** at the completion of the process.
   
   The multi-circuit device now has an expand control (a plus symbol) on that row.

4. Click the + to expand the entry and view the circuits now associated with the multi-circuit device.

### Managed circuits considerations

Because managed circuits are related to a multi-circuit device and are configured as part of that device, you cannot change the name of individual managed circuits, delete individual managed circuits, or change the measurements associated with the individual managed circuits.
However, you can keep the configuration up-to-date through the multi-circuit device configuration changes and then re-running the configure managed circuits process to update the managed circuits. Any circuits that have not changed remain unchanged. Any circuits that have been removed in the multi-circuit device are deleted as managed circuits. Any new circuits are created as new managed circuits.

By mapping managed circuits into a hierarchy, you can specify more recognizable names and organize them into a view that matches the facility or building.

If you rename the group name or device name for the multi-circuit device, the name changes are also applied to the managed circuits associated with the device. See "Renaming devices and groups" on page 36.

If you delete the multi-circuit device, a dialog message indicates that the managed circuits associated with the multi-circuit device will also be deleted.

If you have a number of multi-circuit devices configured in different ways, and you want to see which measurements apply to a specific managed circuit, double-click the specific managed circuit in Management Console to open the Managed Circuit Properties window. It provides: information about the managed circuit, its parent device, its group name, and the measurements associated with the circuit.

You can use the Duplicate and Configure option in Management Console to create multiple devices and add unit IDs for each device. (See "Setting up large systems" on page 42 for additional information.) After multiple multi-circuit devices have been created, you can select them in Management Console, right-click to open the menu and click Configure Managed Circuits. In systems with many multi-circuit devices, the managed circuit creation process takes some time, but the progress bar provides feedback on the progress of the creation process.

**Accessing meters with advanced security**

If you have a meter in your network with Advanced Security enabled, use Management Console to allow ION Windows Services to access the meter:

1. Right-click the device that has Advanced Security enabled and select Security to open the Meter Security Settings dialog.
2. From the Software Access dropdown list, select the user (configured on the meter using Designer or ION Setup) that has the access settings that you want the services and components to use when accessing the device.
3. Click Match Password and type the password for that user in the Password field then re-type it in the Confirm Password field.
4. Select the check box if you want to allow the software to send secure time synchronization signals to the meter. Clear the check box if you do not want to send secure time synchronization signals to the device.
5. Click OK.
Configuring connection schedules

You can schedule the times when the server connects to a site or Ethernet device.

Adding a connection schedule

Click the Connection Schedules icon, right-click the display window, then select New > Connection Schedule to open the Scheduled Site Connection dialog.

The following sections describe the available tabs and how to configure them.

General Settings tab

On the General Settings tab:

- Type the name of your connection schedule (for example “Daily Reading”) in the Name field.
- Type a description of the connection schedule, if required.
- Select Enabled if you want to enable the schedule.
- Select the date from which the schedule is valid.

Sites tab

On the Sites tab:

- Click the box beside the sites and devices to select those that you want to include in the connection schedule. A check mark appears beside an item to indicate that it is included in the connection schedule.
- Set your Site Connection Settings. To enter the minimum and maximum time to stay connected, type the time in the fields or use the arrows to change the time.
- Set the Connection Priority. The higher the number, the greater the priority given to that schedule if there are concurrent connection requests.

Schedule tab

On the Schedule tab:

- Set up the date schedule for the connection (the default is Daily). Schedule options vary depending on the type of schedule selected.
  - Daily: Occurs every day.
  - Weekly: Occurs on the selected day at the specified frequency (in number of weeks) and stays active for the specified duration. For example, if you set Frequency to 2, Day of week to Sunday and Active Duration to 2, the connection occurs every second Sunday and stays active for two days.
  - Monthly - Day of Week: Occurs at the specified frequency (in months), in the week and on the day specified and for the specified duration. For example, if you set Frequency to 3, Day of Month to 2nd and Sunday, and Duration to 1, the connection occurs every third month on the second Sunday and stays active for 1 day.
- **Monthly - Day of Month**: Occurs at the specified frequency (in months), on the specified date of the month, and for the duration specified. For example, if you set Frequency to 2, Day of Month to 15th and Duration to 2, the connection occurs on the fifteenth day of every second month and stays active for 2 days.

- Set up the time period for the connection to occur by setting a start and an end time. In the Start Time and End Time fields, type the time or use the arrows to change the time.

If you configure a full-day (i.e., 24-hour) daily schedule, you need to allow enough time between the end time and the start of the next connection to avoid connection problems. For example, to add a 2-minute gap to a 24-hour schedule, set the Start Time to 0:00:00 and the End Time to 23:58:00.

**System Log events**

System Log Events lists events for components in the system. This information comes from the ION_SystemLog database.

**TIP**: For instructions on filtering and sorting columns and customizing the display, see "Customizing and navigating interface displays" on page 22.

**Viewing System Log events**

To view System Log Events:

1. Select System Log Events from the System Setup pane.
2. In the **Show** area select the checkboxes for the system components for which you want to view events (i.e., servers, sites, devices).
   - If there are no events for a particular system component, that check box is unavailable.
3. Select the minimum priority level of events to be displayed from the **Minimum Priority Level** dropdown list (see below for more information on priority levels).
4. Click **Modify** to change the date/time filter applied to the System Events Log display. See "System Log filter setup" on page 42.
5. To view details of an event, double-click on the entry in the event log.

**Priority**

Priority classifies what type of event has occurred. The value corresponds to the severity of the event: the higher the number, the more severe the event.

The priority is contained in the ION_SystemLog database as a number. In the System Events Log display, the priority levels are displayed as text strings. The priority numbers are mapped to the text strings as follows:

- **Diagnostic**: 0 - 5
- **Information**: 6 - 20
Warning 21 - 63
Error 64 - 191
Critical 192 - 255

By default, the Cutoff setup register of Log Inserter’s System Log Controller module is set to 192. This means that system events with a priority less than 192 are not transferred to the ION_Data database and therefore cannot be viewed in Vista using the Global Event Log Viewer. If you want to view lower priority events in Vista, use the above priority mapping as a guide to set the Cutoff setup register to a lower value (using Designer).

**System Log filter setup**
The System Log Filter Setup dialog lets you change the date and time filter applied to the System Events Log display.

1. Click **Modify** to display the **System Log Filter Setup** dialog.
2. Select the time range by which you want to filter from the dropdown list. To set up a custom filter, select **Custom Date Range** then use the dropdown lists and arrows in the **Select a Date Range** dialog to specify the start and end of the range.
3. Click **OK**.

**Setting up large systems**
To perform batch network setup of devices, create the first device in Management Console (see "Adding network components" on page 32) using a logical naming scheme. After you create this first device, you can then use it to create multiple duplicate devices and configure their properties.

**The Duplicate and Configure interface**

**NOTE:** The Duplicate and Configure function always operates on all devices visible in the table. When table rows are filtered in the Duplicate and Configure tool, changes done using the configuration editors on the top pane of the window affect only the devices that are visible in the Table Editing area. If you want to apply the changes to all devices, clear the filter first before making the changes.

**NOTE:** The Duplicate and Configure function cannot be used with logical devices. See "Creating multiple logical devices" on page 85 for information about creating more than one logical device.

**The Duplicate and Configure area**
The Duplicate and Configure area has different sections depending on the type of device you are duplicating.
Ethernet devices have the following sections:

- **Configure Names**: Use this section to create the duplicates.
- **Configure TCP/IP Addresses**: Use this section to create a sequence of IP addresses to assign to the duplicates after they have been created.
- **Configure TCP/IP Ports**: The port number used in the original device is automatically assigned to all the duplicates. If required, use this section to select a different port number for all the displayed devices in the Table Editing area (changes made in this area are applied to all devices, including the original).
- **Configure Unit IDs**: This section is disabled by default, since unit IDs do not apply to typical Ethernet devices. (To enable this section, you must first set up the Table Editing area so that the “Unit ID” column is visible).

Serial devices have the following sections:

- **Configure Names**: Use this section to create the duplicates.
- **Configure Unit IDs**: Use this section to create a sequence of unit IDs to assign to the duplicates after they have been created.
- **Configure Serial Sites**: The serial site used in the original device is automatically assigned to all the duplicates. If required, use this section to select a different serial site for all the displayed devices in the Table Editing area (changes made in this area are applied to all devices, including the original).

OPC devices have the following sections:

- **Configure Names**: Use this section to create the duplicates.
- **Configure OPC Address**: Use this section to create a sequence of addresses to assign to the duplicates after they have been created.
- **Configure OPC Sites**: The OPC site used in the original device is automatically assigned to all the duplicates. If required, use this section to select a different OPC site for all the displayed devices in the Table Editing area (changes made in this area are applied to all devices, including the original).

**The Table Editing area**

When making configuration changes in the Duplicate and Configure interface, these changes are applied only to the rows that are visible in the Table Editing area.

See "Customizing and navigating interface displays" on page 22 for instructions on filtering and sorting data in the table.

**NOTE**: To discard your changes since the last saved state, click Revert. You can also press CTRL+Z to undo the last action. To redo the last action, press SHIFT+CTRL+Z. You can only undo your last action (one undo).
Creating multiple copies of a device

This section describes how to duplicate and configure devices.

**Step 1: Configuring the first device**

1. Add the first device using your logical naming scheme.

   For example, you can use a scheme like “FL1_PNL1A.CCT01” to name a device that is installed on the “1st Floor” of the building, “electrical panel 1A”, and “Circuit breaker #1”. Type “FL1_PNL1A” as the group name and “CCT01” as the device name when you configure the first device.

2. Right-click the device you want to duplicate and select **Duplicate and Configure**. The Duplicate and Configure interface appears.

**Step 2: Configuring names**

In the Configure Names area, the device name is displayed. Each letter and number is selectable. A group of numbers is treated as a single entity. For example, in the name "MY8600" the entities you can select are "M", “Y” and “8600”. Leading zeroes are also supported, so you can set sequences such as “01, 02, 03” or “001, 002, 003”.

1. Select a letter or number in the device name. The **Start** box displays the selected number/letter, which is the start value. Use the up or down arrow in the spin box to change the start value, or simply type it in the box.

2. Click the up or down arrow on the **End** box edit the range, or type the end value in the box. To clear the range and start over, click **Remove Parameters**.

3. For letters, select Upper Case or Lower Case, depending on whether you require upper case or lower case letters.

4. Set exceptions for individual values or a range of values, if required. Exceptions reduce the number of names created (i.e., total generated names minus the exceptions). See “Setting exceptions to generated sequences” on page 45.

Once you have finished configuring names, you can duplicate the device. See “Step 3: Duplicating the device”, below, for more information.
Example

For example, if you select the first “1” from the example naming scheme and set the End spin box to “2”, two names are generated (the original, plus one duplicate). If you select a letter and set its Start value to “A” and the End value to “C”, three names are generated (the original, plus two duplicates).

The total number of generated names is the product of the first range multiplied by the next, and so on until the last range, as indicated in the following graphic.

The total generated names is the product:

\[2 \times 3 \times 10 = 60\]

Setting exceptions to generated sequences

The Exceptions option applies to the Configure Names and Configure TCP/IP Addresses sections only.

1. To set exceptions to the range of generated values, click Edit (this button is unavailable until you change the name or IP value).
2. Use the **Add number** or **Add character** (as applicable) spin box to set a value to exclude from the range you have specified, then click **Add**. Repeat to set additional values to exclude. To set a range of values to exclude, select **Add number range** or **Add character range**, then use the **Start** and **End** spin boxes to set the range to exclude.

Click **Add**. Repeat to set additional ranges of values to exclude.

**NOTE:** You cannot add the same number or letter to the list of exceptions more than once. If the **Add** button is disabled, check that the numbers or letters are not already included in the exceptions list near the top of the window.

3. Use the **Remove number** or **Remove character** spin box to remove the exception that was set for a given value (i.e., put it back in as an acceptable value). Use the **Remove number range** or **Remove character range** spin boxes to remove the exception that was set for a range of values. Click **Remove**.

**Step 3: Duplicating the device**

Once you have finished configuring names, you are ready to duplicate the device. Click **Duplicate**. The duplicated devices appear in the Table Editing area of the window.

The first device in the list is the original device. The remaining devices are the duplicates. Asterisks next to the device names indicate pending changes that have not yet been saved.

Click **Apply** to save your changes and continue editing devices, click **OK** to save your changes and return to Management Console, or click **Revert** to undo unsaved changes.

In Management Console, duplicated devices are always disabled when they are added.
Step 4: Configuring duplicated devices

See the following section, "Configuring multiple devices", for instructions on configuring other properties for multiple devices.

Configuring multiple devices

After you have duplicated the devices, you can select and configure any or all of them.

1. If you have closed the Duplicate and Configure interface, select the devices you want to configure from the Devices display window in Management Console. Right-click and select **Configure Selected Devices** (this option is only available if multiple devices are selected).

The Configure Selected Devices interface appears. This interface has the same layout and controls as the Duplicate and Configure interface; see "The Duplicate and Configure interface" on page 42 for information.

**NOTE:** Devices affected by a configuration change (that has not been saved) are identified by an asterisk in the first column of the Table Editing area.

2. Scroll to the right in the Duplicate and Configure area to view the Configure TCP/IP Addresses, Unit IDs, Ports and Sites sections of the interface (depending on the type of device being configured). If the number of items in this area does not match the number of items in the Table Editing area, a message in red text appears in the area. If the numbers match, the message text is black. Configure these parameters as described in "Configuring addresses, ports, unit IDs and sites" on page 48 then click **Configure** at the bottom of the applicable interface section.

**NOTE:** Configuration changes only affect the devices that are currently displayed in the Table Editing area. Use the column sorting and filtering features, described in "Customizing and navigating interface displays" on page 22, to control which devices are displayed in the table. If you want to apply the changes to all devices, clear any filtering before making the changes.

3. Click **Apply** to save your changes and continue working or click **OK** to save your changes and return to Management Console.

**NOTE:** If you changed the name of one or more devices, a message displays with a list of devices that will be renamed. If data for those devices already exist in the ION_Data database and you still proceed with the renaming, then the existing data associated with the old device name is lost ("orphaned").

Click **Continue** to proceed or **Cancel** to go back and edit the device configuration.

4. When you have finished, click **OK** to save your changes and return to Management Console or click **Cancel** to discard your changes.
If you click Cancel, a message prompts you if there are pending (unsaved) changes when you click Cancel. Click Yes to discard the changes and return to Management Console, or No to return to the configuration window and continue editing.

If inappropriate values (such as a device that is renamed with the same name as another existing device) are encountered, a message displays with error details. You cannot save the configuration changes until you have corrected the errors.

Configuring addresses, ports, unit IDs and sites
The following sections describe how to configure addresses, ports, and unit IDs.

Configuring TCP/IP addresses
1. Select the section of the IP address that you want to configure. The Start box displays the selected number/letter, which is the start value. Use the up or down arrow in the spin box to change the start value, or simply type it in the box.
2. Click the up or down arrow on the End box edit the range, or type the end value in the box. To clear the range and start over, click Remove Parameters.
3. Set exceptions for individual values or a range of values, if required. Exceptions reduce the number of addresses created (i.e., total generated addresses minus the exceptions). See "Setting exceptions to generated sequences" on page 45.
4. Click Configure at the bottom of the Configure TCP/IP Addresses section.

Configuring unit IDs
The following instructions apply to serial devices (and Ethernet devices that require a unit ID).
1. Use the up or down arrow in the Start spin box to change the start value, or simply type it in the box.
2. Click the up or down arrow on the End box edit the range, or type the end value in the box.
3. Click Configure at the bottom of the Configure Unit IDs section.

NOTE: To edit the unit ID of an Ethernet device, you must first add the Unit ID column to the table in the Table Editing area.

Configuring sites
1. From the dropdown list, select the site you want to use for the selected serial or OPC devices.
2. Click Configure at the bottom of the Configure Sites section.

Configuring ports
1. From the dropdown list, select the port you want to use for the selected Ethernet devices.
2. Click Configure at the bottom of the Configure Ports section.
Editing duplicated device information

The following sections describe how to quickly edit the properties of duplicated devices in the table editing area.

Copying device information from a spreadsheet

Sometimes device names do not follow any particular naming pattern. In this case, you can use the copy/paste function to apply configuration changes directly to the Table Editing area.

First, you need to add a new device in Management Console, then create as many duplicates of the device as the quantity of items you are pasting.

If you have a Microsoft Excel spreadsheet that contains a list of these devices to add to Management Console, you can use the Configure Names area to create duplicates of that device type, then use the Table Editing area to copy and paste the device properties from the Excel spreadsheet.

Example: Copy and paste 20 ethernet devices from excel

1. Confirm that the names in the Excel spreadsheet conform to the naming convention “[Group].[DeviceName]”.
2. Add the first device and set up its properties in Management Console. You can assign it a simple device name such as “A.B1” since it will be overwritten when the values are copied and pasted from Excel. Set the Enabled property to No so that Management Console does not attempt to connect to the device.
3. Click **OK** to add the device.
4. Right-click the device and select **Duplicate and Configure**.
5. Select the “1” in the Configure Names box, then use the End spin box to set the value to 20.
6. In the Hide/Show Columns area, clear the check box of all non-editable columns to hide those that contain grayed out values. Also hide the columns you do not want to paste over or those that are not included in the Excel spreadsheet.
7. On the Excel spreadsheet, arrange the columns so they match the order of the columns on the Table Editing area. Hide all columns on the Excel spreadsheet except those corresponding to columns on the Table Editing area.
8. Select the cells in Excel and copy them (CTRL+C).
9. On the Table Editing area, click on the first cell under the Name column to select it, then paste the contents of the clipboard (CTRL+V).
10. Click **Apply** to save your changes or click **OK** save your changes and return to Management Console.
Using Find and Replace to edit device information

Use the Find and Replace feature to modify matching characters in the device names or in any other editable columns on the device table. The Find and Replace feature does not work on read-only columns.

1. Right-click the device table and select Find and Replace (or press CTRL+H).
2. Type the characters you want to search for in the Find box. Do not use wildcard characters ("*"). Note that the search is case-sensitive.
3. Find in column lists all available columns. Select the column you want to search in.
4. In the Replace box, type the characters you want to use to replace the characters in the Find box. If you want to delete characters from a column value, leave the Replace box blank.
5. Click Preview to list the search results in the table. The Replace with column displays the new name or value resulting from the Find and Replace operation.
6. Use the check box in the Select column to select the rows for which you want to change values. Click Select All to select all the items or Clear Selected to clear all.
7. Click Apply to save your changes or Cancel to discard your changes.
8. Click OK to save your changes and close the dialog.
Chapter 3: Management Console tools

Management Console tools are additional programs that help you manage and monitor your Power Monitoring Expert network.

In this section

Introduction ................................................................. 52
User Manager ............................................................... 53
Reporting Configuration Manager ................................... 56
Deactivate alarms .......................................................... 57
Event Watcher Manager .................................................. 58
Diagnostics Viewer ......................................................... 61
Device Upgrader ............................................................ 72
Logical Device editors ..................................................... 76
Hierarchy Manager ......................................................... 88
Alarm Configuration ....................................................... 89
Remote Modem Setup ...................................................... 89
Virtual Processor setup ................................................... 90
Time of Use Editor ......................................................... 91
Introduction

The following applications are available in the product, and can be started through the Management Console Tools menu.

In Management Console > Tools (listed in the same sequence as in the menu):

- **Database Manager** allows you to perform maintenance tasks on the product's databases. See "Database Manager and Windows Task Scheduler" on page 215.

- **User Manager** allows you to configure user login names, access levels and passwords. See "User Manager" on page 53.

- **Reporting Configuration > Event Watcher Manager** allows you to set event conditions to report on and link those conditions to devices. (This application is only available if you are using a supported edition of SQL Server Standard or Enterprise with the software product.) See "Event Watcher Manager" on page 58.

- **Reporting Configuration > Reporting Configuration Manager** allows you to set up options for Diagrams and the optional web-based Reports application. See "Reporting Configuration Manager" on page 56.

- **Logical Device > Logical Device Type Editor** allows you to add, edit, or remove logical device types and logical devices to set up the monitoring of WAGES devices. See "Logical Device editors" on page 76.

- **Logical Device > Import Logical Device** allows you to import a CSV file containing configuration data for multiple logical devices. See "Creating multiple logical devices" on page 85.

- **Hierarchy Manager** allows you to organize devices by defining their relationships and displaying those relationships in a recognizable organization. See "Hierarchy Manager" on page 88.

- **Rate Editor** allows you to change the rates used for the billing reports without the need to manually edit the XML source files defining the rates. This item remains in the menu when the trial license expires but the utility is disabled pending licensing.

- **Alarm Configuration** allows you to configure software alarms for multiple sources and measurements. See "Alarm Configuration" on page 89

- **Deactivate Alarms** allows you to deactivate permanently active alarms. See "Deactivate alarms" on page 57.

- **Configure Managed Circuits** allow you to allows you to automatically create devices representing the circuits of multi-circuit devices so that you can treat each circuit as a source for both real-time and historical data in the system. See "Creating managed circuits" on page 38.
In Management Console > Tools > System (listed in the same sequence as in the menu):

- **Designer** allows you to configure devices and add custom functionality to them. See "Designer" on page 165.
- **Diagnostics Viewer** provides detailed records of all system and network events as well as communication states and problems. See "Diagnostics Viewer" on page 61.
- **Device Upgrader** allows you to upload new firmware to network meters or devices. See "Device Upgrader" on page 72.
- **Modbus Device Importer** allows you to add Modbus devices to the Power Monitoring Expert network; see "Modbus Device Importer" on page 231.
- **Remote Modem Setup** allows you to configure dialup modems that will be used at remote power management networks. See "Remote Modem Setup" on page 89.
- **ION Virtual Processor Setup** allows you to configure the ION Virtual Processor Service for user-programmed functionality. See "Virtual Processor setup" on page 90.
- The **Update OPC Server** command is included in the Tools > System menu during the trial period. After the trial period, it is included in the menu if the OPC DA Server license has been activated through the Floating License Manager. See "OPC Server Assistant" on page 299 for more information about this feature.
- **PQDIF Exporter** lets you export data to Power Quality Data Interchange Format (PQDIF) and set scheduled exports with notification. See "PQDIF Exporter" on page 287 for more information on this component.
- **Time of Use Editor** allows you to define a time of use schedule that is used by selected reports such as Energy and Demand. (This application is only available if you are using a supported edition of SQL Server Standard or Enterprise with the software product.) See "Time of Use Editor" on page 91.

**User Manager**

User Manager allows you to add users and edit user information, such as passwords, access level, and organizational information. You can also use User Manager to define groups of users for use in Reports subscriptions.

In Power Monitoring Expert, a user with supervisor-level access can assign the same access level to other users as required. However, assigning supervisor-level access should be tightly controlled to prevent unauthorized access to other components of the product.

You must have supervisor-level access to use User Manager, otherwise the menu option is unavailable.
## Access levels

<table>
<thead>
<tr>
<th>Type of Operation Allowed by Default</th>
<th>Access Level</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Observer/View Only (1)</td>
</tr>
<tr>
<td>View Vista or Designer diagrams</td>
<td>YES</td>
</tr>
<tr>
<td>Acknowledge alarms(^1) (using Alarms in the Web Applications component)</td>
<td>YES</td>
</tr>
<tr>
<td>Trigger events(^1)</td>
<td>YES</td>
</tr>
<tr>
<td>Connect/disconnect sites or devices</td>
<td>YES</td>
</tr>
<tr>
<td>Modify network configuration using Management Console)</td>
<td>YES</td>
</tr>
<tr>
<td>Edit Vista or Designer diagrams</td>
<td>YES</td>
</tr>
<tr>
<td>Administer software security (that is, add users)</td>
<td>YES</td>
</tr>
</tbody>
</table>

\(^1\) Supervisors can configure Vista objects (i.e., control objects or the global event log viewer) to allow different access levels to perform different actions (i.e., trigger events or acknowledge alarms). See "Customizing a diagram object" on page 137 for more information on configuring access levels for Vista objects.

## Starting User Manager

1. Start Management Console. Log in using an account with supervisor-level access.
2. Select **Tools > User Manager**.

**TIP:** You can customize the User Manager display by filtering and sorting. For instructions on using these features, see "Customizing and navigating interface displays" on page 22.

## Symbols used in the Updated column

The following symbols are used in the **Updated** column to display the status of information in a row:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>Information in the row has been modified since it was last saved.</td>
</tr>
<tr>
<td>!</td>
<td>Information in the row is inaccurate or incomplete.</td>
</tr>
<tr>
<td>+</td>
<td>The row is new since the user or group information was last saved.</td>
</tr>
</tbody>
</table>

## Users

Use the **Users** tab to view, add and edit users and user information. Information that is required but is missing or incorrect is marked by an exclamation mark ⚠.

### Adding users

1. Click **New**. A new row appears in the list of users and the fields in the Edit User Account section are empty.
2. Enter the user information (username and password are required; other information is optional):
   - **Username**: Type a username for the new user (maximum length: 50 characters; no spaces allowed).
   - **Password**: Type a password for the new user (maximum length: 50 characters; no spaces allowed).
   - **Re-enter Password**: Re-enter the password you typed in the password field. An exclamation mark appears beside this field unless the content of the two password fields matches.
   - **Access Level**: Select an access level for the user. See "Access levels" on page 54 for an outline of the different access levels and their permissions.
   - **First Name**: Type the user's given name.
   - **Last Name**: Type the user's family name.
   - **Organization**: Type the user's organization.
   - **Business Email**: Type a business email address for the user.
   - **Mobile Email**: Type a mobile email address for the user.

3. Click **OK** to save the changes and exit User Manager.

### Changing user information

1. Select the username associated with the information you want to change.

2. Type the new information in the Edit User Account section of the Users tab. After you edit a user's information, an asterisk appears beside that user in the list of users until you click **OK** to save the information.

3. Click **OK** to save the changes and exit User Manager.

### Deleting a user

1. Select the username of the user you want to delete then click **Delete**. The row disappears from the list of users. You cannot delete the user account you are currently logged in with—the Delete button becomes unavailable.

   **NOTE**: You cannot use the **Revert** button to undo a deletion. To undo a deletion, click **Cancel** to exit out of User Manager without saving your changes.

2. Click **OK** to save your changes and exit User Manager.

### Groups

Use the Groups tab of User Manager to define groups of users. Groups can be used to determine access to reports in the Reports application. Information that is required but is missing is marked by an exclamation mark 📜.
Defining groups

1. On the Groups tab, click New. A new row appears in the lists of groups.

2. In the Edit User Group section of the tab, enter the name (required) and description of the group.

3. To add a user to the selected group, select the username from the Users list and click the right arrow button ➡️.

4. To remove a user from the selected group, select the username from the Members Of list and click the left arrow button ◀️.

5. Click OK to save your changes and exit User Manager.

Changing group information

1. Select the group associated with the information you want to change.

2. Type the new information in the Edit User Group section of the Groups tab. Use the right and left arrow buttons to add or remove users from the selected group, as needed. After you edit a group’s name or description, an asterisk appears beside that group in the list of groups until you click OK to save the information.

3. Click OK to save the changes and exit User Manager.

Deleting groups

To delete a group, select the group from the list and click Delete.

NOTE: You cannot use the Revert button to undo a deletion. To undo a deletion, click Cancel to exit out of User Manager without saving your changes.

Reporting Configuration Manager

Use the Reporting Configuration Manager option in the Tools menu to configure options for the Reports application, such as the database to report on, subscription delivery options, and regional formatting settings.

1. Open Management Console and select Tools > Reporting Configuration > Reporting Configuration Manager to open the dialog.

2. Select the Reports tab to configure general reporting options:
   - From the dropdown list in the Reports Database section, select the database on which you want to run reports. Only those databases compatible with Reports are listed.
   - Use the slider in the Report Timeout section to set the time (in seconds) after which the Reports application stops trying to complete a report generation task.
3. Select the **Subscriptions** tab to configure settings related to report subscriptions:
   - **SMTP Server**: Type the network server name from which the report subscriptions are emailed.
   - **“From” Display Name**: Type the name that you want to appear in the “From” field of an emailed report.
   - **“From” Email Address**: Type the email address that you want to appear in the “From” field of the emailed report.
   - **Default “Overwrite Existing File” Setting**: Select the check box to set the default setting for the “Overwrite Existing File” check box that appears in the Subscriptions dialog when you select “File share” for the subscription Delivery Mode. If you select this check box, the existing report is overwritten by default. If you clear this check box, the new report is given a unique filename and the existing report is not overwritten.

4. Select the **Regional Formatting** tab to select settings for date, time, and currency format that appear on generated reports.
   - **Regional settings for formatting dates, times, and numbers**: Select the language and country from the list to apply the regional format to dates, times, and numbers.
   - **Currency Symbol**: Select the currency symbol from the list.

5. Click **OK** to save your changes.

### Deactivate alarms

Active alarms can continue to appear in the Alarms viewer if, for example, an alarm dropout has not been configured, or a device has been removed from the network after an alarm was issued. In such cases you can use the Deactivate Alarms utility to remove these permanently active alarms from the Alarms viewer.

<table>
<thead>
<tr>
<th><strong>WARNING</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>INACCURATE DATA RESULTS</strong></td>
</tr>
<tr>
<td>• Do not incorrectly configure the software; this can lead to inaccurate reports and/or data results.</td>
</tr>
<tr>
<td>• Do not rely solely on reports or data results to determine if the system is functioning correctly or meeting all applicable standards and compliances.</td>
</tr>
<tr>
<td>• Do not use reports or data results as substitutes for proper workplace practices or equipment maintenance; they are supplemental only.</td>
</tr>
</tbody>
</table>

**Failure to follow these instructions can result in death, serious injury, or equipment damage.**
To use the **Deactivate Alarms** utility:

1. Open **Management Console** and select **Tools > Deactivate Alarms** to open the dialog.

2. Select a date for the **Show Active Alarms older than** field if you want to change the default date.

3. Click **Load Active Alarms** to display a list of the active alarms that are older than the date specified.

4. Use the **Select** column to select the alarms that you want to set to an inactive state. You can also click **Select All** to select all of the alarms displayed in the grid. Use **Select None** to clear the selection of any alarms listed.

5. Click **Set Selected Alarms to Inactive**.

6. Click **Done** to close the **Deactivate Alarms** dialog and then close **Management Console**.

When you log in to **Management Console** again and open the **Deactivate Alarms** dialog, the number of alarms shown in the **Alarms Displayed** field matches the number in the **Alarms Displayed** field in the **All Active Alarms** view in the **Alarms** application. (The Alarms application is available in the Web Applications component.)

**Event Watcher Manager**

The Event Watcher Manager defines events for the “On Event” selection in report subscriptions. (For more information about report subscriptions, see *Creating report subscriptions* in the online help for Reports in the Web Applications component.)

The Event Watcher Manager interface consists of two tabs:

- **Event Watchers**: An event watcher links a device or group of devices to the conditions defined in a template.

- **Templates**: A template defines the conditions that make up an event.

**TIP**: For instructions on using filtering, sorting, and column selection to customize the Event Watcher Manager interface, see "Customizing and navigating interface displays" on page 22.

**Opening Event Watcher Manager**

To access Event Watcher Manager, select **Tools > Reporting Configuration > Event Watcher Manager** in Management Console.

**Symbols used in the Updated column**

The following symbols are used in the **Updated** column to display the status of information in a row:
| * | Information in the row has been modified since it was last saved. |
| ! | Information in the row is inaccurate or incomplete. |
| + | The row is new since the user or group information was last saved. |

Creating a template

Before adding an event watcher, you must have a template that defines the conditions to be watched. You can use one of the default templates or create your own. Use the **Templates** tab to define and edit templates.

Event Watcher Manager comes with default templates that can be modified for specific devices. Test any changes to the default template to ensure that events are available for selection for report subscriptions. In cases where a device is not supported by the default templates, you can create custom templates to define what you need.

To define a custom template:

1. Click **New** in the top right corner of the tab. A new row appears in the main table for the new template.
2. Type a name for the template. Type a description for the template if desired.
3. Use the Template Conditions section to set the conditions to be watched. See "Using the Template Conditions section", below.
4. Click **Apply** to save your changes, click **OK** to save your changes and exit Event Watcher Manager, or click the **Event Watchers** tab to set up an event watcher.

Using the Template Conditions section

Use this section of the interface to configure the condition the template watches for.

1. Add a condition:
   - To add a condition from the event log, click **Select from Event Log** to open the **Select Event Log Lines** dialog. To select an event, click on the boxes at the left of the table to select a check box. Click on the check box again to clear the check mark. Click **OK** to return to the Templates tab.
   - To add a condition without selecting from the event log, click **New**. A new row appears in the table for the new condition.

   **NOTE**: It is recommended that you use **Select From Event Log** to add conditions. This helps ensure that the syntax is correct. If the syntax is not correct, the event watcher will not work. Conditions only appear in the Select Event Log Lines dialog after they have occurred in the system.

2. Select the parameters you want to include in the condition by selecting or clearing the check boxes below the Template Conditions table. The available parameters are: Priority, Cause, Cause Value, Effect, Effect Value. You must include at least one para-
meter. If you select multiple parameters, the event watcher only activates when all parameters are met.

**The Logic of the Template Conditions**

The conditions within a row of the Template Conditions table must all be true for the condition to be met. For example, if you have a row with a Priority of greater than 220 and an Effect Value of Disturbance, both of these must be met for the condition to be true. If you have multiple rows in the table, the condition is met if any of the rows are true. For example, if you have a row with Priority greater than 220 and a row with an Effect Value of Disturbance, the condition is met if either of these are true.

**Deleting and reverting**

To delete a template condition, select the condition from the Template Condition table and click the **Delete** button in the Edit <Template> section. To delete a template, select the template from the main table and click the **Delete** button in the top right corner of the tab.

To undo changes, click **Revert**.

**Adding an event watcher**

To add an event watcher, you need a template. You can use one of the default templates or define your own (see "Creating a template" on page 59). Use the **Event Watchers** tab to define and edit event watchers.

1. Click **New** to add a new event watcher. A new row appears in the main table for the new event. Use the Event Watcher Editing Area to define the event watcher.

2. Type a name for the event watcher.

3. Select the template you want to use from the Template dropdown list.

4. Type a description of the event watcher if desired.

5. From the Devices table, select the devices you want to include in the event watcher. Click the check boxes to the left side of the devices to select or clear a device.

   **NOTE:** Checking **Select All** will include any Query Server, Log Inserter or Virtual Processor instances in the system. It also includes any devices or software nodes added in the future.

6. Click **Apply** to save your changes, click **OK** to save your changes and exit Event Watcher Manager, or click the **Templates** tab to edit the templates.

**Deleting and reverting**

To delete an event watcher, select the event watcher from the table and click **Delete**.

To undo changes, click **Revert**.
**Diagnostics Viewer**

Diagnostics Viewer is a tool you can use to troubleshoot network communications problems and related network errors.

**Starting Diagnostics Viewer**

1. Start Management Console and log in.
2. Click **Tools > System > Diagnostics Viewer**.

**TIP:** For instructions on using filtering, sorting, column selection, and pin/unpin to customize the Diagnostics Viewer display, see "Customizing and navigating interface displays" on page 22.

**Navigation pane**

Diagnostics information is grouped as follows:

- **Service Diagnostics**: Contains diagnostics information for certain services (ION Network Router Service, ION Site Service and ION Log Inserter Service).
- **Communication Diagnostics**: Contains diagnostics information for the sites, hardware devices, and software nodes.

Select an item in the navigation pane to display its diagnostics information.

If you add a new device in Management Console while Diagnostics Viewer is open, you can refresh the tree view to display the new device by collapsing then expanding the root node of the tree.

**Diagnostics Information pane**

The diagnostics information pane displays detailed data about the state of your power monitoring system and devices.

**Service Diagnostics**

Service Diagnostics records communication problems and similar events occurring with the product’s software components.

**Communication Server diagnostics**

Information about the communications server is arranged in these tabs:

- **Console Messages** lists all ION Network Router Service and ION Site Service console messages for the current session.

**TIP:** The blank area below the **Description** column header is a dynamic filter field. Type the wildcard character (*) in front of the text you want to search (for example, to display only messages prefixed with **WARNING**, type *warning*). The diagnostics information pane automatically displays only those records that match the text you typed in the box.
Chapter 3: Management Console tools

- **Connection Status** displays the current status of the software components connected to Network Router.

- **Tree States** displays the ION tree status of all nodes (hardware devices and software nodes).

**Log Inserter diagnostics**

The Log Inserter diagnostics information pane is split into two sections. The top section (Select Nodes pane) contains the available nodes, while the bottom section contains the node details.

**Select nodes to display**

In the **Select Nodes** pane, select the check box beside a node to display its diagnostics information. Clear the check box to hide that node’s diagnostics information.

**TIP:** If there are many nodes and you want to display only a few of them, right-click the **Select Nodes** area then click **Clear All**. Select only the nodes you want to display. To display all the nodes again, right-click the **Select Nodes** area and click **Select All**.

**Node details**

The node details are organized in these tabs:

- **Node Information** provides diagnostics associated with the communication status of each selected node. If the Log Inserter is not configured to gather data from a given node, it does not appear in the list in the **Node** column. If the Log Inserter is configured to automatically gather information for a node, but that node has not yet been processed, it does not initially appear in the list. Once information becomes available, the node appears (if it has been selected).

- **Node Performance** provides per-node performance summary information.

- **Log Performance** provides performance information on a per log basis.

The following table summarizes the columns on the **Node Information** tab:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Node</td>
<td>The name of the device, VIP, or Log Inserter.</td>
</tr>
<tr>
<td>DeviceType</td>
<td>The device type of the associated node that is returned by the device itself. The Log Inserter uses this to detect device swapouts.</td>
</tr>
<tr>
<td>SerialNumber</td>
<td>The serial number of the device that is returned by the device. The Log Inserter uses this to detect device swapouts.</td>
</tr>
<tr>
<td>Configured Polling Interval (s)</td>
<td>The requested polling interval in effect. It can be configured either from the log upload control or from the custom Windows Registry value. All of the nodes for which polling is disabled are identified with <strong>Polling Disabled</strong> in this column.</td>
</tr>
<tr>
<td>Column</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Average Update Interval (s)</td>
<td>A weighted average time between polled results for the device. The most recent interval accounts for 20% of the value, and the previous average accounts for the remainder. If the value deviates from the average by more than 30s, then the old average is discarded and the current interval is used. By default, the expected value for devices that support logs is the Configured Polling Interval (s) value. The expected value for devices that do not support logs is 60 seconds. If the Log Inserter is selected but it is not configured to collect data from its System Log Controller, it appears in the diagnostics and shows 300s for Average Update Interval. Initially this value is n/a.</td>
</tr>
<tr>
<td>Time Since Update (s)</td>
<td>The time in seconds since the last communication with the node. This time includes polling updates, record uploads, and configuration loads.</td>
</tr>
<tr>
<td>Column</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>CommStatus</td>
<td>Can be one of the following values:</td>
</tr>
<tr>
<td></td>
<td>• alive – The node is communicating.</td>
</tr>
<tr>
<td></td>
<td>• late – If a response to a polling program is not received within 3 minutes, the Log Inserter sends a ping. If the ping does not respond in 10 minutes, the communication status is set to late and another ping is sent. The system continues pinging every 10 minutes until a response is received.</td>
</tr>
<tr>
<td></td>
<td>• expired – If a ping returns before the response for any preceding request, the original request was lost. The request is abandoned and the communication status is set to expired. A request can be lost if a destination Site Server or VIP is shut down. The state changes from expired when the device responds to a request.</td>
</tr>
<tr>
<td></td>
<td>• timeout – A request to the device timed out. The device is not communicating.</td>
</tr>
<tr>
<td></td>
<td>• site not connected – The site is currently not connected.</td>
</tr>
<tr>
<td></td>
<td>• cannot send – An unrecoverable error. The Log Inserter cannot send a program to the communications subsystem. The Log Inserter shuts down if Network Router is not running. Restart the system.</td>
</tr>
<tr>
<td></td>
<td>• invalid password – The password entered for this device in Management Console is invalid.</td>
</tr>
<tr>
<td></td>
<td>• password changed – The password for this device has been changed. Update the password for the device in Management Console.</td>
</tr>
<tr>
<td></td>
<td>• site not responding – The connection is unexpectedly broken during communication with the device.</td>
</tr>
<tr>
<td></td>
<td>• device disabled – The device or its site is not enabled in Management Console. Note that Log Inserter automatically removes this node from this list if the node had been detected by automatic means.</td>
</tr>
<tr>
<td></td>
<td>• does not exist – The device is not registered in the system. In auto-mode, the device eventually disappears from the list unless it is referenced remotely by a VIP.</td>
</tr>
<tr>
<td></td>
<td>• pending – No responses have been processed.</td>
</tr>
<tr>
<td>Column</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>nack'd</td>
<td>The request was not acknowledged. This could mean that the Site Server hosting the device is not running.</td>
</tr>
<tr>
<td>validating</td>
<td>Treemon reported that the device is not responding. A signal is sent to Treemon to validate the state. This state clears once Treemon (via Validator) establishes communications with the device.</td>
</tr>
<tr>
<td>Comments</td>
<td>Under steady-state conditions, this is blank. While the Log Inserter attempts to upload configuration information, this can contain a string value indicating that the Tree is in use by another client. This indicates that the Log Inserter cannot process the device until the aforementioned client releases it. If the client is ION Designer, it is not released until the node is closed in Designer or Designer is closed. If the client's name ends with -not-clean, the node is currently being evaluated by Treemon/Validator.</td>
</tr>
<tr>
<td>AggregateSetupCount</td>
<td>The aggregate setup count of the device. The Log Inserter uses this to detect configuration changes.</td>
</tr>
<tr>
<td>RequestedIONs</td>
<td>The number of ION registers, modules, and/or managers that have been requested from the tree. The Log Inserter needs to upload configuration information to determine which logs need to be processed, which labels should be used for measurement mapping and source resolution, and which labels to use for event cause and effects. The Log Inserter retrieves the currently cached tree from Treemon, populating as needed by communicating directly with the device. The tree is locked for the duration of this process, and this prevents Designer from opening the tree. If the value is:</td>
</tr>
<tr>
<td></td>
<td>- none – No configuration information is currently required. This is typical in a steady-state condition.</td>
</tr>
<tr>
<td></td>
<td>- cache – Only the currently cached configuration is required. This is typically seen at startup.</td>
</tr>
<tr>
<td></td>
<td>- A number – The Log Inserter needs specific information and that number of ION objects has been explicitly requested.</td>
</tr>
</tbody>
</table>
### RequestStatus

The status of the tree requests can include one of the following values:

- **ready** – The Log Inserter does not require any configuration information.
- **requesting** – The Log Inserter requires configuration information and is in the process of gathering it. The value in Request Update Time indicates how long it has been processing this request.
- **retrying** – A previous tree request was not successful. (See the Comments column for the reason.) The request is retried, as shown by the value in Request Update Time. The amount of wait time before retrying a request depends on the nature of the unsuccessful tree request:
  - Tree in use by another node – 10 seconds.
  - Tree dirty – 10 seconds.
  - Not responding – 60 seconds.
  - Tree request timed out after 10 minutes – 5 minutes.
  - Comm error – 10 seconds.
  - Other errors – 5 minutes.
- **blocked** – The Log Inserter requires configuration information but all available resources are in use. By default, the Log Inserter can simultaneously request only up to 2 trees per site and 6 trees in total. The Request Update Time value indicates how long the request has been pending.
- **processing** – The Log Inserter has received the requested ION objects and is processing them. The Request Update Time value indicates how long this request has been processed, including the time during the "requesting" state.
- **abandoned** – This is the same as the retrying status but the request of some of the configuration information was not successful following the successful receipt of some information. The Log Inserter recovers when it retries the request.

### Request Update Time (s)

The time varies depending on the status of the tree requests described for RequestStatus.

The following table summarizes the columns on the Node Performance tab:
<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Node</td>
<td>The name of the device, VIP, or Log Inserter.</td>
</tr>
<tr>
<td>Responding</td>
<td>Indicates whether or not the node is responding. For a VIP, this includes all external nodes connected, directly or indirectly, to the input of a Recorder. The responding state is used to determine whether or not the download of the log is caught up.</td>
</tr>
<tr>
<td>All Logs Polling Disabled</td>
<td>Indicates if log upload is disabled for all recorders on the device. A Yes in the column indicates that log upload is disabled.</td>
</tr>
<tr>
<td>TotalLogs</td>
<td>The total number of Data Recorders, Waveform Recorders, Event Log Controllers, and System Log Controllers that the Log Inserter is configured to collect data from a given node. Note that when automatically detecting these modules, this number may change as the Log Inserter gathers configuration information.</td>
</tr>
<tr>
<td>PendingRecords</td>
<td>The total number of records that the Log Inserter has requested from the node but has not yet received.</td>
</tr>
<tr>
<td>OutstandingRecords</td>
<td>The total number of records not yet uploaded based on the last read position counter on the device and the position of the last uploaded record, taking into account the maximum depth of each log.</td>
</tr>
<tr>
<td>ProcessedRecords</td>
<td>The number of records that have been inserted into the database. Note that a record typically corresponds to a number of DataLog entries. The term “record” refers to records at the device level.</td>
</tr>
<tr>
<td>Generated Rec. per sec</td>
<td>An estimate of the number of new records being generated per second.</td>
</tr>
<tr>
<td>Retrieved Rec. per sec</td>
<td>An estimate of the number of records being uploaded per second.</td>
</tr>
<tr>
<td>Avg Retrieval Time (s)</td>
<td>The average round-trip time in seconds taken to retrieve a record from a device.</td>
</tr>
<tr>
<td>Avg Processing Time (s)</td>
<td>The average time in seconds necessary to insert a record into the database.</td>
</tr>
<tr>
<td>RestoredLogs</td>
<td>The total number of logs that the Log Inserter is configured to gather information for.</td>
</tr>
<tr>
<td>ManagedLogs</td>
<td>The total number from the value in RestoredLogs that is being monitored by an enabled Log Acquisition Module (LAM).</td>
</tr>
<tr>
<td>ConfiguredLogs</td>
<td>The total number from the value in RestoredLogs that are Recorders and have source inputs or are Event Log Controllers or System Log Controllers.</td>
</tr>
<tr>
<td>ConfirmedLogs</td>
<td>The total number from the value in RestoredLogs for which the current configuration is known.</td>
</tr>
<tr>
<td>NumCaughtUp</td>
<td>The total number from the value in RestoredLogs for which the node is responding and there are no records outstanding or pending.</td>
</tr>
</tbody>
</table>
The following table summarizes the columns on the **Log Performance** tab:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Node</td>
<td>The name of the device, VIP, or Log Inserter in question.</td>
</tr>
<tr>
<td>LogHandle</td>
<td>The handle of the Log Register or Event Log Register for this Node.</td>
</tr>
<tr>
<td>Responding</td>
<td>Indicates whether or not the node is responding. For a VIP, this includes all external nodes connected, directly or indirectly, to the input of a Recorder. This state is used to determine whether or not it is caught up.</td>
</tr>
<tr>
<td>Polling Disabled</td>
<td>Indicates which individual recorders are excluded from polling requests. <strong>Yes</strong> in the column indicates which recorders are excluded.</td>
</tr>
<tr>
<td>PendingRecords</td>
<td>The total number of records that the Log Inserter has requested from the node but has not yet received. This number includes event records that have been uploaded but are cached internally pending configuration information necessary to complete the processing of the cause and/or effect ION objects.</td>
</tr>
<tr>
<td>OutstandingRecords</td>
<td>The total number of records not yet uploaded based on the last read position counter on the device and the position of the last uploaded record, taking into account the maximum depth of each log.</td>
</tr>
<tr>
<td>ProcessedRecords</td>
<td>The number of records that have been inserted into the database. Note that a record typically corresponds to a number of DataLog entries. In this context, &quot;record&quot; refers to records at the device level.</td>
</tr>
<tr>
<td>Generated Rec. per sec</td>
<td>An estimate of the number of new records being generated per second.</td>
</tr>
<tr>
<td>Retrieved Rec. per sec</td>
<td>An estimate of the number of records being uploaded per second.</td>
</tr>
<tr>
<td>Avg Retrieval Time (s)</td>
<td>The average round-trip time in seconds taken to retrieve a record from a device.</td>
</tr>
<tr>
<td>Avg Processing Time (s)</td>
<td>The average time in seconds necessary to insert a record into the database.</td>
</tr>
<tr>
<td>Restored</td>
<td>This is always yes. If the log is not &quot;restored&quot;, it does not appear in the list.</td>
</tr>
<tr>
<td>Managed</td>
<td>A Log Acquisition Module (LAM) is enabled that is monitoring this log.</td>
</tr>
<tr>
<td>Configured</td>
<td>The log is a Recorder that has source inputs or it is an Event Log Controller or a System Log Controller.</td>
</tr>
<tr>
<td>Column</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Confirmed</td>
<td>The latest configuration for the log has been uploaded. For a VIP Recorder that references external devices, directly or indirectly, the configuration information includes information from the external device.</td>
</tr>
<tr>
<td>CaughtUp</td>
<td>The node is communicating, the current configuration is known, and there are no outstanding or pending records. For a VIP, any device on which the log depends for information must also be responding.</td>
</tr>
</tbody>
</table>

**Alarm Service**

Alarm Service provides the status of alarms that you configure and enable in the Alarm Configuration application.

The information is organized in a grid. The column labels indicate the type of information provided, such as *Rule Name*, *Alarm Name*, *Alarm Status*, and so on. See the *Alarm Configuration Help* (accessible from the Alarm Configuration application) for further information about configuring alarms for multiple sources and measurements.

**Communications Diagnostics**

Communications Diagnostics provides diagnostics information for sites and devices connected to the workstation.

**Site overview**

Diagnostics information for the sites are contained in these tabs:

- **Device Summary** displays communications statistics for each site.
- **NetUser Status** displays the number of ION programs currently in the ION Network Router Service queue (awaiting processing) and the total number of ION programs already processed.

**NOTE**: Requests and responses transmitted between the software components are referred to as “ION programs”.

**Site/Device Diagnostics**

Diagnostics information for sites and devices are summarized in these tabs:

- **Communication Status** displays error rates and connection statistics for the selected site or device. The following information is available from the *Communications Status* tab:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Node</td>
<td>The device (or software node) name.</td>
</tr>
<tr>
<td>Requests</td>
<td>The number of communications requests transmitted to the meter.</td>
</tr>
<tr>
<td>Column</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Responses</td>
<td>The number of successful responses received.</td>
</tr>
<tr>
<td>Request Ratio</td>
<td>The number of requests sent to the device to fulfil the last client request. The value is always 1 for ION devices but it varies for Modbus devices.</td>
</tr>
<tr>
<td>Total Errors</td>
<td>The total number of communication errors.</td>
</tr>
<tr>
<td>Total Err Rate (%)</td>
<td>The ratio of Total Errors to Requests.</td>
</tr>
<tr>
<td>Sliding Err Rate (%)</td>
<td>The error rate in the last 100 requests. This can indicate a trend in communications performance.</td>
</tr>
<tr>
<td>Time Util (%)</td>
<td>The percentage of the communication channel utilized (serial line or Ethernet) on the site.</td>
</tr>
<tr>
<td>Avg Resp Time (s)</td>
<td>Average time in seconds for the meter to respond.</td>
</tr>
<tr>
<td>Last Resp Time (s)</td>
<td>The last response time, in seconds.</td>
</tr>
<tr>
<td>Timeouts</td>
<td>The number of timeouts. A timeout occurs when no data is received in response to a request.</td>
</tr>
<tr>
<td>Bad CRC</td>
<td>The number of bad packets received, that is, those that do not pass the error-detection checksum.</td>
</tr>
<tr>
<td>Incompl. Fm</td>
<td>The number of incomplete packets received, that is, those that did not have all the expected bytes.</td>
</tr>
<tr>
<td>Broken Conn.</td>
<td>Number of times the connection was lost to the meters on a site.</td>
</tr>
<tr>
<td>Bad Frames</td>
<td>The number of received packets that had an internal error.</td>
</tr>
<tr>
<td>HW Errors</td>
<td>Number of errors reported by the computer’s communication hardware.</td>
</tr>
<tr>
<td>Misc Errors</td>
<td>Number of other errors that do not fit any of the above descriptions.</td>
</tr>
</tbody>
</table>

- **Site Status** displays site statistics such as connection status and totals.
- **Polling Status** displays the number of programs currently in the ION Site Service queue (awaiting processing) and the total number of programs already processed.

**Communication Status vs. Site Status**

This section explains the difference between the statistics provided on the Communication Status tab and those on the Site Status tab.

“Total Errors” in the Communication Status tab is an ION Site Service derived statistic, while “Bad Responses” in the Site Status tab is a client derived statistic.

To explain this difference, consider a situation where a direct site is experiencing timeouts. Communications with the device is attempted according to two parameters: Connect Attempts (an advanced site property in Management Console) and Maximum Attempts.
**Multiple** (an advanced device property in Management Console). Multiplying the values of these two properties determines the number of attempts made to re-establish communications with the device.

For instance, if **Connect Attempts** is set to 1 and **Maximum Attempts Multiple** is set to 3, the device will go offline after 3 attempts (that is, 1 x 3).

The “Total Errors” statistic increases by one every time ION Site Service detects a timeout. However, the “Bad Responses” statistic only increments every time a response is sent back to a client.

Using the previous example, consider the case where four timeouts occurred and the device went offline. In this case, “Total Errors” increases by four, while “Bad Responses” only increases by one. If only two timeouts occurred, “Total Errors” would increase by two, while “Bad Responses” would not change.

The following information is available from the **Site Status** tab.

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Node</td>
<td>The device (or software node) name.</td>
</tr>
<tr>
<td>Status</td>
<td>The device communication status.</td>
</tr>
<tr>
<td>Current Attempt</td>
<td>The current number of repeated attempts to communicate with the device.</td>
</tr>
<tr>
<td>Max Attempts</td>
<td>The maximum number of attempts before flagging the device as offline (Timed-out).</td>
</tr>
<tr>
<td>Offline Count</td>
<td>The total number of times the device went offline.</td>
</tr>
<tr>
<td>Bad Responses</td>
<td>The total number of errors sent back to the clients, such as to Vista.</td>
</tr>
<tr>
<td>Last Response</td>
<td>The time when the last response was received.</td>
</tr>
<tr>
<td>Last Attempt</td>
<td>The last time that a request was sent to the device.</td>
</tr>
<tr>
<td>RT Data Reqs</td>
<td>The total number of requests to the device sent by the Real Time Data Service.</td>
</tr>
<tr>
<td>TreeMon Reqs</td>
<td>The total number of requests to the device sent by the TreeMon service.</td>
</tr>
<tr>
<td>VISTA Reqs</td>
<td>The total number of one shot requests to the device sent by a Vista client (control, label requests...).</td>
</tr>
<tr>
<td>LogInserter Reqs</td>
<td>The total number of requests to the device sent by the LogInserter service.</td>
</tr>
<tr>
<td>IONSERVICE Reqs</td>
<td>The total number of requests to the device sent by ION real-time services.</td>
</tr>
</tbody>
</table>

Note that the last five columns on the **Site Status** tab are dynamic. That is, the columns are only shown when requests were sent to the device from a Power Monitoring Expert service or client.
Additional commands

The following sections describe additional display options and shortcut menus available in Diagnostics Viewer.

Diagnostic Details

In the tabs on the diagnostics information pane, double-click a row to display its Diagnostic Details screen. This displays the diagnostic information for the selected item only.

Use the Previous and Next buttons to view the details of other rows in that tab of the diagnostics information pane.

To copy information to the clipboard, select the rows you want to copy, then press CTRL+C.

Diagnostics Information pane shortcut menu options

Right-click the diagnostics information pane to display a shortcut menu. The following table lists all the commands available (though not all panes in Diagnostics Viewer provide all the commands listed):

<table>
<thead>
<tr>
<th>Right-click Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Update</td>
<td>Refreshes the information in the diagnostic table.</td>
</tr>
<tr>
<td>Reset</td>
<td>Resets the information in the diagnostic table (not available in the Communications Server Diagnostics display).</td>
</tr>
<tr>
<td>Copy All</td>
<td>Copies all selected information to the clipboard.</td>
</tr>
<tr>
<td>Auto Scroll</td>
<td>Enabled by default, this option is only available in the Console Messages tab of the Communications Server Diagnostics display. This option automatically scrolls and selects the latest console message. Clear this option to disable scrolling (that is., select and view an older console message without jumping to the latest one when Diagnostics Viewer refreshes).</td>
</tr>
<tr>
<td>Options</td>
<td>Displays the Options dialog where you can change the diagnostics refresh rate. Note that changing the refresh rate frequency can affect the product's performance.</td>
</tr>
</tbody>
</table>

Device Upgrader

Use Device Upgrader to upgrade the firmware on one or more ION meters of the same type in a single session. Supervisor-level access is required to upgrade devices. Ensure that you record your device’s usernames and passwords prior to upgrading the device firmware.
WARNING

UNINTENDED EQUIPMENT OPERATION
Do not use a meter’s digital outputs for any safety critical application due to possible unexpected changes of state during power cycles, power outages, or firmware upgrades.

Failure to follow these instructions can result in death, serious injury, or equipment damage.

To reduce the risk of upgrade errors, the computer power option needs to be set to stay on and the screensaver needs to be disabled. If you are using a laptop, plug it into a wall outlet and set the power option to “do nothing” if the lid is closed.

NOTICE

LOSS OF DATA
Backup a meter’s data before you upgrade a meter’s firmware.

Failure to follow these instructions can result in a loss of data.

NOTE: A firmware upgrade erases data that is stored in a meter’s memory. The data includes waveforms, data recorders, min and max values, and integrator values (for example, kWh). Be sure to upload or save any of the data that you want to keep before performing the firmware upgrade.

Using Device Upgrader

Before you begin
If you intend to upgrade the firmware for Ethernet devices, you can improve upgrade time by completing the following:

1. Right-click the device in Management Console and click Configure Device to open the Ethernet Device Configuration dialog.
2. Right-click the dialog and click Advanced Properties.
3. Set the Transmit Delay to 0 and Use Acknaks to No.
   Remember to reset these properties after the firmware upgrade completes.

Upgrading a meter’s firmware
Complete the following steps to upgrade the firmware of an ION meter:

1. Obtain the applicable upgrade (.upg) files for your device from the Web site or from Technical Support.
2. Save the files in a folder accessible on the computer.
3. Close Vista if it is open, and stop the ION Log Inserter Service and ION Virtual Processor Service before proceeding.

4. Start Management Console.

5. Click **Tools > System > Device Upgrader**. Type your username and password in the log in prompt. A dialog opens with recommendations regarding the upgrade operation. After reading the recommendations, click **OK** to open Device Upgrader.

   If you need to implement any changes because of the recommendations and warnings, close Device Upgrader, make the changes then re-open Device Upgrader and continue.

6. Select the device type of the device(s) you want to upgrade from the **List Devices of Type** dropdown list.

7. Select the names of the devices that you want to upgrade in the **Select Devices to Upgrade** box.

8. In the **Select Revision** section, click **Select File**. Locate and select the upgrade (.upg) file that you saved in step 2, then click **Open**.

9. Select or clear the **Save/Restore framework** check box (selected by default). If selected, this keeps a copy of your current framework template during the upgrade. After the firmware upgrade finishes, Device Upgrader restores your framework template.

   **NOTE:** The Device Upgrader loads new meter firmware that does not contain any framework templates. If you want to preserve customizations you have made to your device framework, select **Save/Restore framework**. However, if you intend to replace the existing meter framework with a new one (for example, with a new default meter template that you have downloaded), clear **Save/Restore framework**.

10. If you are upgrading multiple devices, specify in the **Attempts** area how the Device Upgrader responds to an unsuccessful upgrade:

    - Select **Halt After**, then enter a number in the box to specify how many attempts Device Upgrader should make before stopping during an unsuccessful upgrade. By default, the utility is set to stop after the first unsuccessful upgrade.

    - Select **Ignore Unsuccessful** to attempt to upgrade all of the selected devices regardless of the number of devices with unsuccessful upgrades.

11. Click **Upgrade** to upgrade the selected devices.

    The Upgrade Status box shows the stages of the upgrade process. The **Completed** progress bar indicates what percentage of the upgrade is complete. Each completed upgrade is listed in the **Upgrade Status** box.

12. Restart the ION Log Inserter Service and ION Virtual Processor Service.
Firmware upgrade error codes

The following table describes the various error codes that may occur when you upgrade your device’s firmware.

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0,1,2,3,4, 5, 6, 7, 8, or 9</td>
<td>Indicates a negative acknowledgment to a request. Contact Technical Support for assistance.</td>
</tr>
<tr>
<td>100</td>
<td>Device timed out while downloading firmware. Probable causes: a) poor communication or b) the device stopped functioning.</td>
</tr>
<tr>
<td>101,102, 103, 104, 105</td>
<td>Indicates a bad response to a request. Contact Technical Support for assistance.</td>
</tr>
<tr>
<td>106</td>
<td>Device Upgrader was unable to prepare the device to accept new firmware. Try to upgrade the device again. Contact Technical Support for assistance if the problem persists.</td>
</tr>
<tr>
<td>107</td>
<td>Device Upgrader was unable to verify the device’s new firmware. Try to upgrade the device again. Contact Technical Support for assistance if the error persists.</td>
</tr>
<tr>
<td>108</td>
<td>Device Upgrader was unable to download a firmware packet. Try to upgrade the device again. Contact Technical Support for assistance if the error persists.</td>
</tr>
<tr>
<td>109</td>
<td>Device Upgrader was unable to retrieve the device framework. Probable causes: a) time out or b) device not functioning.</td>
</tr>
<tr>
<td>110</td>
<td>Device Upgrader was unable to retrieve the device’s firmware revision. Probable causes: (a) time out, (b) device not functioning, or (c) cannot access the device’s firmware revision register.</td>
</tr>
<tr>
<td>150</td>
<td>Device Upgrader cannot save the device framework to the file &lt;device_name&gt;.conf. Make sure the ...\Power Monitoring Expert\config\upgrade directory exists and that you have write permissions.</td>
</tr>
<tr>
<td>151, 155</td>
<td>The Device Upgrader did not successfully upgrade a device and left a &lt;device_name&gt;.conf file. Probable cause: you are attempting to upgrade a different device than the one that the Device Upgrader previously unsuccessfully upgraded.</td>
</tr>
<tr>
<td>152</td>
<td>The information in the file &lt;device_name&gt;.conf is corrupted or unrecognizable by the Device Upgrader. Contact Technical Support for assistance.</td>
</tr>
<tr>
<td>154</td>
<td>Device Upgrader was unable to restore the device setup. Probable causes: a) time out or b) device not functioning.</td>
</tr>
<tr>
<td>156</td>
<td>Device Upgrader was unable to restore the device framework completely to the file &lt;device_name&gt;.conf. This error is most likely caused by a full hard drive.</td>
</tr>
</tbody>
</table>
Logical Device editors

The logical device functionality allows you to assign logical names to output registers on physical devices, and associate the generic inputs with standard measurements, including WAGES measurements.

Before you can create a logical device, the physical device that it references must be created in Management Console. You can create one or more logical devices from a single physical device, or you can also create a single logical device from several physical devices.

After you create a logical device, you can view its real-time data in the following components:

- Vista.
- The Diagrams application (formerly WebReach) in the Web Applications component.
- The Tables application in the Web Applications component.

⚠️ CAUTION

INACCURATE DATA RESULTS

- Do not incorrectly configure logical devices; this can lead to inaccurate reports and/or data results.
- Do not rely solely on reports to determine if the system is functioning correctly or meeting all applicable standards and compliances.
- Do not use reports or data results as substitutes for proper workplace practices or equipment maintenance; they are supplemental only.

Failure to follow these instructions can result in injury or equipment damage.

Each logical device has a logical device type associated with it. Each logical device type is defined with a collection of output measurements. The measurements defined by the device type become the output measurements for instances of that device type, that is, for the logical devices. You use the Logical Device Type Editor to create logical device types. See "Using the Logical Device Type Editor" on page 77 for information about viewing, creating, editing, and deleting logical device types.

The Logical Device Editor in Management Console allows you to configure specific logical devices by mapping input registers to output measurements that are defined in the associated device type. See "Using the Logical Device Editor" on page 82 for information about creating, configuring, editing, and deleting logical devices.

Access level for the editors

You need supervisor-level access to be able to define logical device types and to create logical devices in the editors.

See "User Manager" on page 53 for further information about creating users and groups, and for setting system access levels.
Using the Logical Device Type Editor

Use the Logical Device Type Editor to define a collection of output measurements for each logical device type. Logical device types created with this editor are available for selection in the Logical Device Editor, where you map input registers to output measurements.

**Open the Logical Device Type Editor**

1. Start Management Console and log in using an account with supervisor-level access.
2. Select **Tools > Logical Device > Logical Device Type Editor**.

The top portion of the editor contains a logical device type display grid listing the logical device types that have been defined. The bottom portion is an edit area where you can modify existing device types and their measurements, or create new ones.
The display grid area

The Modified column displays one of the following characters indicating a change of status of an entry:

+ (plus) - a new entry.

* (asterisk) - an existing entry has been modified.

! (exclamation mark) - the entry is in error.

The Type Name column contains the names for the defined device types. Type names must be unique.

The System Measurements and Custom Measurements columns show the number of measurements that have been defined for each device type.

The edit area

When a device type is selected in the display grid, the current information for that device type is displayed in the edit area. The edit area has a Summary tab and a Measurement tab.

The Summary tab contains the following:

- A Type Name field showing the name of the device type that is selected in the display grid at the top.

- In the Measurements area, expand System and Custom to view the measurements defined for these respective categories. You can expand each list to show all of the measurements that have been defined for the selected device type.

- A Notes input field that you can use to describe the device type.
The **Measurement** tab contains the following:

- Options that indicate whether to display the measurements with descriptive names or engineering names.

- An **Available Measurements** dropdown list that contains category names for the measurements, such as **Air, Current, and Voltage**. When you select one of these categories, only those measurements associated with the selected category appear in the grid.

The default **All** in the list displays all of the categories and their respective measurements in the grid.

- An available measurements grid listing the measurements available for selection when you define a device type. Measurements that are grayed out indicate that they have been added to the selected device type. Clicking **New** opens a dialog for defining a new, custom measurement. An X in the **Custom** column identifies the entry as a custom measurement. The **Edit** and **Delete** links give you the option to modify or delete custom measurements only.

**NOTE:** It is recommended that you add a new custom measurement *only if an existing measurement does not suffice*. Factory-defined System Measurements contain considerable information about their type and usage, which is then used throughout the system to provide intelligent assistance in Dashboard controls and Report selections. Since custom measurements do not have this information, their usage may not provide the expected results.

- A **Measurements For** grid that lists the measurements that comprise the device type that is selected in the display grid area. Use the >> button to add a measurement that you selected in the list of available measurements to the **Measurements For** list for the device type. Measurements that you select for a device type are grayed out to indicate that they have been assigned to the device type. Use the << button to remove a selected measurement from the **Measurements For** grid. Measurements that are removed are no longer grayed out in the list of available measurements and they are available for selection.

  Note that if you attempt to delete a custom measurement that has been mapped to any logical device, a message indicates that the measurement cannot be deleted. You need to unmap the custom measurement from the logical devices before you can delete it.

In all grids:

- Each of the columns can be sorted in ascending or descending order when you click on the column heading.

- When you place your cursor on a column heading, a filter icon appears on the right side of the heading area. Click this icon to open a list of items that are available for filtering. Click the item that you want to use as the filter. When you do this, the filter condition displays
on the left side of the status area at the bottom of the grid. Click the X icon in the status area to turn off the filter.

- The blank area immediately below a column heading is an entry field for filtering on an entry you type in that area. For example, to filter on a specific name, enter a name under the Name column to automatically filter the entries in the grid.
- You can drag and drop the grid column headers to rearrange the order of the columns in the grid.

Creating a new logical device type

Complete the following steps to create a new logical device type:

1. Click New on the top right of the editor.
   
   This clears the Type Name field and resets System measurements and Custom measurements to 0 (zero) on the Summary tab.
   
   All is selected by default in the Available Measurements list on the Measurements tab.

2. Enter a device type name in the Type Name field.
   
   The name appears in the logical device type display grid and an ! (exclamation) appears in the Modified column to indicate that the device type entry is incomplete.

3. Click the Measurements tab to go to the list of measurements that are available for selection.

4. Locate and click an available measurement that you want to associate with the device type, then click >> to add it to the Measurements For list. Repeat this step for each measurement that you want to associate with the device type.

5. To delete a device type, click the device type in the display grid and click Delete on the top right of the editor.
   
   Note that Delete is disabled if any logical devices are associated with the logical device type.

Custom measurements

The following sections describe how to create, modify, or delete custom measurements. Because factory-defined System Measurements contain considerable information about their type and usage, custom measurements should only be created in exceptional circumstances, and only with an understanding of the expected results from their usage.
INACCURATE DATA RESULTS

• Do not incorrectly configure logical devices; this can lead to inaccurate reports and/or data results.
• Do not rely solely on reports to determine if the system is functioning correctly or meeting all applicable standards and compliances.
• Do not use reports or data results as substitutes for proper workplace practices or equipment maintenance; they are supplemental only.

Failure to follow these instructions can result in injury or equipment damage.

Creating a new custom measurement

Complete the following steps to create a new, custom measurement:

1. Click New beside the Available Measurements dropdown list to open the New Measurement dialog. (You can also edit a new custom measurement by clicking Edit and modifying the entries.)

2. Enter a descriptive name and an engineering name for the new measurement in the respective fields. For example, Voltage A-B Low is the descriptive name, and Vll ab low if the engineering name.

3. Select the unit of measure from the Units list or add a custom unit of measure by typing it in the Units field.

   Note that the combination of the descriptive name, the engineering name, and the unit of measure must be unique for each custom measurement.

4. Select a type of information to be measured from the Quantity list.

5. Click OK to add the measurement.

   The new measurement is added as an available measurement in the grid and an X in the Custom column indicates that it is a custom measurement.

   You need to select All or Custom in the Available Measurements list to see the custom measurement in the grid.

Modifying or deleting a custom measurement

Complete the following steps to modify a custom measurement. Note that you cannot modify or delete system measurements.

1. Go to the Measurements tab of the Logical Device Type Editor.

2. Select the custom measurement that you want to modify or delete.
3. To modify the custom measurement, click **Edit** to open the **Edit Measurement** dialog, update the entries or selections in the dialog, and click **OK** to apply to changes.

4. To delete a custom measurement, click **Delete**.

   A message confirms the deletion.

   Note that if you attempt to delete a custom measurement that is associated with any logical devices, a message indicates that the measurement cannot be deleted.

### Using the Logical Device Editor

Use the Logical Device Editor to map measurements from physical devices to measurements provided by the logical device type that is associated with a logical device.

#### Open the Logical Device Editor

Start Management Console and log in using an account with supervisor-level access.

Click the **Devices** icon, then right-click the Display window and select **New > Logical Device**.

The devices defined in Management Console are listed in the **Input Devices** area of the Logical Device Editor.

The top portion of the editor consists of a header area that contains instructions, selection lists, and input fields. The bottom portion is the mapping area that allows you to map the input registers of a physical device to a list of measurements provided by the associated device type.
The instructions indicate the steps required to create a logical device.

The **Group** field is a combination input field and dropdown list. You can either enter a name for the group or select a group from the list.

The **Name** field identifies the name of the logical device that you are defining. Enter the name of the logical device in the field.

The **Logical Device Type** dropdown list contains the names of logical device types that are available for selection.

The **Input Devices** grid lists the devices that are in your system. When you select a device, its output registers are listed in the **Input Device Registers** area.

The **Register Mapping** grid is populated with a list of the output measurements that are defined for the logical device type that you select in the **Logical Device Type** dropdown list. They are listed under a generic **Device Name** label pending their mapping to the logical device name that you specified. Drag an entry from the **Input Device Registers** list to an output measurement in the **Register Mapping** grid to map the two values.
Defining a logical device

1. Select a logical device type from the Logical Device Type dropdown list.
   
   The output measurements defined for the selected logical device type are listed in the Output Measurement column in the Register Mapping area.

2. Either select an existing group name from the Group dropdown list, or enter a group name in the field.

3. Enter a name for the new logical device in the Name field.

4. Select one of the input devices from the Input Devices area of the editor.
   
   The registers for the selected input device appear in the Input Device Registers area.
   
   Note that if you choose to display the registers for the input device in an ION tree format, delays in displaying the registers can occur for devices with a large volume of registers.

5. Map an input device register to an output measurement by dragging it to the output measurement listed in the Register Mapping area of the editor.
   
   The input device registers appear in bold font when they are mapped to an output measurement.

6. Click OK to save the logical device configuration in Management Console.
   
   Any unmapped measurements are displayed in red.

7. To edit a logical device that is in the Device panel of Management Console, double-click the device name, or right-click the device name and select Configure Device to open the Logical Device Editor, or click the device then select Edit > Configure Device.

   Note that:

   - If you choose to edit the configuration of the logical device, delays can occur in displaying the registers for devices with a large volume of configured registers.

   - Duplicate and Duplicate and Configure in Management Console’s Edit menu cannot be used with logical devices. See “Creating multiple logical devices” on page 85 for information about creating more than one logical device.

Considerations regarding logical devices and historical data

When a logical device is configured, historical data for an output register (that is, an output measurement) on the physical device is automatically routed to the corresponding output measurement on the logical device.

When a logical device is configured, historical data is logged to the logical device and not the related physical device.
If multiple logical devices include the same input measurement from the same physical device, historical data from that input measurement is routed to the logical device that was configured last.

**Deleting a physical device that is mapped to a logical device**

If a physical device that is mapped to a logical device is deleted, the mapping of input measurements for the logical device can no longer be resolved. A message dialog opens to indicate the result of the delete action and asks whether you want to continue with the deletion.

If you right-click the logical device in Management Console and select **Configure Device** to open the Logical Device Editor after you have deleted the physical device, a message indicates that the physical device has been deleted. The **Register Mapping** grid for the logical device shows the deleted physical device/ION handle in the **Input Register** column.

If you re-create the physical device, the input measurement mapping for the logical device is automatically restored.

**Renaming a physical device that is mapped to a logical device**

If a physical device that is mapped to a logical device is renamed, a message dialog opens to indicate the result of the rename action and asks whether you want to continue with renaming.

If you right-click the logical device in Management Console and select **Configure Device** to open the Logical Device Editor after you have renamed the physical device, the **Register Mapping** grid for the logical device shows the renamed physical device in the **Device Name** column.

**Deleting a site which has a physical device mapped to a logical device**

If a site with a physical device mapped to a logical device is deleted, the physical device is also deleted and the mapping of input measurements for the logical device can no longer be resolved.

If you right-click the logical device in Management Console and select **Configure Device** to open the Logical Device Editor after you have deleted the site, a message indicates that the physical device has been deleted. The **Register Mapping** grid for the logical device shows the deleted physical device/ION handle in the **Input Register** column.

**Creating multiple logical devices**

You can create multiple logical devices by:

- Exporting a logical device configuration to a comma-separated values (CSV) file.
- Modifying the CSV file to add multiple logical device configurations based on the original logical device configuration.
- Importing the CSV file in Management Console to add the logical devices to the system.
Export a logical device configuration

Complete the following steps to export one or more logical device configurations to a CSV file.

1. Use the Logical Device Editor to create at least one logical device in the Devices area of Management Console.

2. Select one or more logical devices, right-click and select Export to open the Export Status dialog.
   
   Note that if you choose to export the registers for the logical device, delays in the export process can occur for logical devices with a large volume of configured registers.

3. Click the browse button on the right of the Selected File field to open the Save As dialog.

4. Navigate to the location where you want to save the file and enter a name for the file in the File name field.
   
   Text files (*.csv) is pre-selected in the Save as type field.

5. Click Save to return to the Export Status dialog.
   
   The Selected File field is populated with the location and file name that you specified.

6. Click Export.
   
   The Status column in the grid area of the dialog indicates Exported for a completed export operation. If the export operation is not successful, for example if the input registers cannot be retrieved for the logical device being exported, it is indicated in the Status column. Click the link to open the log file to view additional information.

   Configuration information for all of the selected logical devices is exported to the CSV file.

Create multiple entries in the CSV file

Use Microsoft Excel or a similar spreadsheet editor to open the CSV file. The column headings in the spreadsheet are labeled as follows:

- Logical device name
- Logical device type
- Physical device name
- Physical device type
- Input register
- Output measurement
- Handle - this column heading is required but the entries are not required unless there are duplicate labels, that is, input registers with the same name but with a different
ION handle. In this case the ION handle is required. You can view the ION handles by exporting the input measurements from the Logical Device Type Editor.

NOTE: The column headings remain in English for localized versions of the product. This is required for CSV file-processing purposes.

To create multiple entries for the logical device configuration, use the copy and paste function in Excel. It is recommended that only users with supervisor-level access create multiple entries.

1. Select the rows that you want to duplicate and press Ctrl+C to copy them.
2. Place the cursor in the left-most cell of the first blank row and press Ctrl+V to paste copies of the selected rows.
3. Continue the paste operation for as many logical device configurations that you want to create.
4. After completing the paste operation, be sure that you use unique device names to avoid duplicates.

You can also export all of the register names of a physical device as well as all of the measurement names of a logical device type. This gives you the ability to use these additional CSV files to copy and paste additional register names and measurement names into the CSV file you are using to create the multiple logical devices.

To export all of the register names of a physical device:

1. Open the Logical Device Editor and select a physical device.
2. Right-click anywhere in the register list in the Input Device Registers area to open a menu and select Export Device Input Registers.
3. Enter a name for the file and click OK.

To export all of the measurement names of a logical device type:

1. Open Management Console and select Tools > System > Logical Device Type Editor.
2. Select a logical device type in the logical device types area of the editor.
3. Click the Measurements tab.
4. Right-click anywhere in the grid under Measurements For and select Export Measurements.
5. Enter a name for the file and click OK.
Import multiple logical device configurations

Complete the following steps to import the CSV file with the multiple logical device configurations. It is recommended that only users with supervisor-level access import logical device configurations.

1. Open Management Console and select Tools > Import Logical Device in the Devices panel of Management Console to open the Logical Device Import Form window.

   Logical Device Import Form is available only when you are in the Devices panel of Management Console,

2. Use the Browse button to navigate to and select the CSV file to import.

3. Select Overwrite Existing Devices if you want overwrite logical devices with the same name that were previously created.

   Logical devices with the same name can occur as a result of a previous import operation.

4. Click Import to add the multiple logical devices to the Devices area of Management Console.

   The system performs a validation of the configuration data during the import operation.

   If an error occurs during the import operation:
   - The Status column in the grid area indicates Failed for any logical device that is not imported. Click Failed to view details about the cause of the unsuccessful import.
   - Logical devices are created for all correct entries in the CSV file. Logical device entries that are incorrect are not created in Management Console.

Hierarchy Manager

Depending on the number of devices you are currently monitoring, organizing the data coming from those devices can be a difficult task. The Hierarchy Manager feature allows you to organize the devices in Power Monitoring Expert by defining their relationships and displaying them in an easy to understand way. Once these relationships have been created, energy data can be grouped and summarized, and used by other components of Power Monitoring Expert.

Starting Hierarchy Manager

To use Hierarchy Manager:

1. Open Management Console.

2. Enter an operator-level or supervisor-level access username and password and click OK.

3. Click Tools > Hierarchy Manager to open the Hierarchy Manager Login dialog.

4. Enter an operator-level or supervisor-level access username and password and click
OK.

Hierarchy Manager opens using the default hierarchy template.

The hierarchy creation process is dependent on the current template. See the Hierarchy Manager online help for information regarding this feature. Click the Help link in the top right corner of Hierarchy Manager to access the information.

**Alarm Configuration**

The Alarm Configuration application allows you to configure software alarms for multiple sources and measurements. Each alarm configuration is represented as an Alarm Rule. The rule includes a threshold value, pickup and dropout delays, an update rate, and the alarm priority.

**Starting Alarm Configuration**

To use the Alarm Configuration application, either click **Alarm Configuration** in **Tools** menu in Management Console, or open the Web Applications component, click the **Alarms** icon, then click the **Alarm Configuration** link.

See **Alarm Configuration Help**, available from the Alarm Configuration application, for information about creating, configuring, and enabling alarm rules.

**Remote Modem Setup**

Use Remote Modem Setup to preconfigure dialup modems that will be connected to meters at remote locations. Hardware-based and software-based (WinModems) modems are supported.

Remote Modem Setup provides access to a database that contains configuration data for a variety of modems you can pick from. Remote Modem Setup also provides direct access to your modem so you can customize settings and troubleshoot its operation.

**Preliminary Setup**

Follow the instructions in your modem’s documentation to set up and connect the modem to one of your computer’s serial ports. Select a port that the Power Monitoring Expert Communications Server is not using.

**Using Remote Modem Setup**

1. Start Management Console.
2. Click **Tools > System > Remote Modem Setup** to open the **Remote Modem Setup** dialog.
3. Set the Port to the serial communications port that the computer uses to communicate with (and set up) the modem. Set the Baud Rate to match the modem’s baud rate.

**NOTE:** To reduce possible communication issues, set the computer, modems and meters to the same baud rate.
4. Set the following properties for the remote modem:
   - Select the type of modem from the **Type** box.
   - Set the Site Baud Rate.
   - To set the modem to answer after a specified number of rings, select **Auto Answer**, then type the appropriate number in the Number of Rings box.
   - To save the modem configuration data in the modem’s onboard memory, select **Store Profile**. This feature allows the modem to revert to the saved settings after a power outage. Clear **Store Profile** to disable this feature.
   - To turn on the modem’s internal speaker, select **Speaker On**, then select a setting from the Volume list. Clear **Speaker On** to disable this feature.

5. Click **Send** to save the settings to the modem.

The modem is now ready to be used at the remote power monitoring site.

**Virtual Processor setup**

The Virtual Processor (VIP) is the Power Monitoring Expert service (“ION Virtual Processor Service”) that provides coordinated data collection and aggregation, control, and mathematical analysis of power monitoring system data from groups of metering or similar intelligent devices. Use Virtual Processor Setup to configure a Virtual Processor Modbus Service for defining sites and devices in a Modbus network, and to set up the communications port for it. Virtual Processor Setup can also be used to improve the performance of the ION Virtual Processor Service by modifying its global operating parameters.

See "Virtual Processor service" on page 207 for application examples using the Virtual Processor.

**Modifying the Global Parameters**

Typically, you do not need to change the default Virtual Processor’s **Global Parameters**. However, the settings in the following table can be modified to try to optimize system performance. To view and select the settings, expand **Global Parameters**.
<table>
<thead>
<tr>
<th>Global Parameter</th>
<th>Value Range</th>
<th>Description</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Module Update Period</td>
<td>50 to 1000 ms</td>
<td>The interval at which ION modules inside the Virtual Processor are updated.</td>
<td>Frequent module updates contribute to the workstation’s processor load. By increasing the Module Update Period, you reduce the number of times a module executes in a given time period.</td>
</tr>
<tr>
<td>Configuration Saver Period</td>
<td>10 to 600 seconds</td>
<td>The interval at which the Virtual Processor writes its configuration data to the workstation’s hard disk.</td>
<td>Increasing the Configuration Saver Period significantly reduces the processor load if you have a large Virtual Processor configuration file.</td>
</tr>
<tr>
<td>Client Polling Period</td>
<td>500 to 300000 ms</td>
<td>The interval at which the Virtual Processor gets information from other nodes in the network (for example, another Virtual Processor or a device).</td>
<td>You can increase the period for less critical Virtual Processor applications and reduce the period for more critical applications.</td>
</tr>
<tr>
<td>Server Polling Period</td>
<td>200 to 1440000 ms</td>
<td>The interval at which the Virtual Processor responds to requests for information from client nodes such as Vista or the Log Inserter.</td>
<td>Reducing this value increases the rate at which these responses are sent; however, this can also increase network traffic.</td>
</tr>
</tbody>
</table>

**Time of Use Editor**

Time of Use (TOU) schedules created with the Time of Use Editor are designed to be used with the Reports application. When you use a TOU schedule in a report, the report data is presented according to the time periods you defined in the schedule. See Report definitions in the online help for Reports in the Web Applications component for information on the Energy Cost Report.

A typical TOU has On Peak, Off Peak and Shoulder periods. Since rate schedules vary not only by day and week, but also by season, the TOU schedules can be set up to match your precise needs.

**Opening the Time of Use Editor**

To access the Time of Use Editor, select **Tools > System > Time of Use Editor** in Management Console.

Use the navigation pane on the left to navigate through the schedules. Right-click a schedule or sub-schedule to access menu items. Select an item to display associated tabs in the tab display pane on the right.
Overview: Creating a TOU schedule
To create a TOU schedule, you need to:

1. Add a schedule. See "Adding or editing a schedule" on page 92.
2. Add a sub-schedule, if you need more than one sub-schedule. See "Adding or editing a sub-schedule" on page 93.
3. Add a season, if you need more than one. See "Configuring seasons" on page 94.
4. Configure special days (such as holidays) to include in your TOU schedule. See "Adding special days" on page 96.
5. Add day groups, if you need groups other than the default day groups. See "Configuring Day groups" on page 97.
6. Add TOU names, if you need names other than the default names. See "Defining TOU names" on page 98.
7. Assign TOU periods to TOU names. See "Defining TOU periods" on page 99.

To view a sample schedule, right-click the navigation pane and select **Import Schedule**. Select SampleSchedule.tou from the ...\Power Monitoring Expert\system\etc folder and click **Open**.

Adding or editing a schedule
This section describes how to add a blank schedule, and import or copy an existing schedule.

Adding a blank schedule

1. Select **File > New Schedule** to open the **Add a Schedule** dialog.
2. Type a name and description for the schedule. Click the arrow beside the effective date to bring up a calendar where you can select the effective date of the schedule.
3. Click **OK**. That schedule name appears in the list in the navigation pane.

Copying an existing schedule

1. In the navigation pane, right-click the schedule that you want to copy.
2. Select **Save as New Schedule** to open the **Save as New Schedule** dialog.
3. Enter a name and description for the new schedule.
4. Click **OK**. The new schedule appears in the navigation pane with the attributes of the copied schedule.

Importing a schedule

1. Place the schedule that you want to import into a folder that can be accessed from the computer.
2. In the navigation pane, right-click an empty area of the navigation pane then select **Import Schedule** to open the **Open** dialog.

3. Navigate to the folder where you placed the schedule. Select the schedule and click **Open**.

   The schedule is imported with the extension "_imported". For example, a schedule named "ScheduleA" becomes "ScheduleA_imported".

**Exporting a schedule**

To export a schedule to use in another TOU installation:

1. Right-click the schedule you want to export in the navigation pane. Click **Export** to open the **Save As** dialog.

2. Select the folder where you want to save the schedule.

3. Enter a schedule name in the **File name** box.

4. Click **Save**.

   The schedule is saved with the extension ".tou". For example, “ScheduleB” becomes “ScheduleB.tou”.

**Editing an existing schedule**

To edit a schedule name or description:

1. From the navigation pane, right-click a schedule name then click **Edit Schedule** to open the **Edit a Schedule** dialog.

2. Change the schedule name or description.

   To change the effective date, you must make the change to the sub-schedule(s). See "Editoring a sub-schedule effective date" on page 94.

3. Click **OK**.

**Deleting a schedule**

To delete a schedule, right-click the schedule name in the navigation pane then select **Delete Schedule**. This deletes the entire schedule, including any sub-schedules.

**Adding or editing a sub-schedule**

When you add the basic schedule, it contains one sub-schedule, with the effective date (start date) you entered for the schedule. To add additional sub-schedules with alternate effective dates, follow the instructions in the following sections.

Expand a schedule to display its sub-schedule(s). Sub-schedules are listed in order of their effective dates.
Adding a blank sub-schedule

1. Right-click the schedule name and select **New SubSchedule** to open the **New SubSchedule** dialog.
2. Click the arrow beside the effective date to open a calendar where you can choose an effective date for the new sub-schedule.
3. Click **OK**.

   The sub-schedule displays in the navigation pane. Continue configuring the sub-schedule by adding seasons and day groups.

To add a new sub-schedule that has the same settings as an existing sub-schedule, see "Copying an existing sub-schedule", below.

Copying an existing sub-schedule

1. Right-click the sub-schedule that you want to copy and select **Save as New SubSchedule** to open the **New SubSchedule** dialog.
2. Click the arrow beside the effective date to open a calendar where you can choose an effective date for the new sub-schedule.
3. Click **OK**. The new sub-schedule displays in the navigation pane with the same attributes (other than effective date) of the sub-schedule you copied.

Editing a sub-schedule effective date

1. Right-click the sub-schedule for which you want to change the effective date, then select **Edit Effective Date** to open the **Edit SubSchedule Effective Date** dialog.
2. Click the arrow beside the effective date to open a calendar where you can choose an effective date for the new sub-schedule.
3. Click **OK**.

Deleting a sub-schedule

To delete a sub-schedule, right-click the sub-schedule name in the navigation pane and select **Delete**. This also deletes all seasons in that sub-schedule (and any day groups, special days, etc., that they contain).

### Configuring seasons

Use seasons to create timeframes for presenting data in reports. A newly created schedule has a single season, called All Year. Expand a sub-schedule to view its seasons.
If you only need one season (All Year), you can skip the steps below and go to configuring special days.

**Configuring seasons**

Use the **Define a Season** tab to set up or edit the time spans for each season.

**NOTE:** A date can only belong to one season; you cannot overlap dates in one season with dates in another.

1. From the navigation pane, select the sub-schedule to which the season belongs.

2. In the tab display pane, select the **Define a Season** tab.

   After you add a sub-schedule, the tab displays only one season (All Year) that covers the entire year. The season is listed at the top of the tab, and the calendar that shows the days and months that belong to that season is full. To make room to add other seasons, you must edit the All Year season.

3. Select **All Year** from the **Define a Season** tab and click **Edit** to open the **Edit a Season** dialog.

4. In the **Season Name** field, type the name of one of the seasons you want to define (for example, Summer).

5. Set the Start Date and End Date for the season. You can specify fixed start and end dates (For example, 12/31) or relative start and end dates (for example, the last Saturday of October).

   **Fixed Date:** Click on the month or day portion of the date then either type the new date or use the up and down arrows beside the date to edit it.

   **Relative Date:** Select the day and month from the dropdown lists.

   For the end date, select the Time of Day the season ends (Start of Day or End of Day). If you select Start of Day, the season ends at 12:00:00 AM on the selected day; if you select End of Day, the season ends at 12:00:00 AM on the next day so there are no gaps in the schedule.

   **NOTE:** If you use relative dates, you can configure a schedule that may become invalid in future years. Be careful when you configure the schedule that there will be no missing or overlapping days in the schedule in future years. For example, rather than scheduling one season to end on the 1st Sunday in June and the next to start on the 1st Monday in June, it is better to schedule the first season to end at Start of Day on the 1st Sunday in June and the next season to start on the 1st Sunday in June.

6. If this is a split season (where there is a gap between two parts of the season), select the **Split Season** check box and add a second sets of dates. For example, winter is typically a split season because it occurs in the first and last months of the year.

7. Click **OK**.
The calendar on the **Define a Season** tab now shows one season with the rest of the year unassigned.

8. Click **Add** to create additional seasons. Repeat steps 4 to 6 to name the season and define the start and end dates.

**NOTE:** Do not leave any dates unassigned: unassigned dates are not calculated in the reports.

**Editing a season**

1. On the **Define a Season** tab, select the season you want to edit then click **Edit** to open the **Edit a Season** dialog.

2. Make the changes you require then click **OK**.

**Deleting a season**

To delete a season, select the season in the **Define a Season** tab then click **Delete**. This also deletes the day groups and TOU periods configured for that season.

**Adding special days**

After you define a sub-schedule, you need to set up holidays and other special days. You can define holidays that occur on the same date every year or at some other regular interval (such as the third Thursday in November). You can also define special days, such as inventory days, that might occur regularly and require special treatment in reports.

Use the **Define Special Days** tab to set up holidays and other special days.

1. In the navigation pane, select the sub-schedule for which you want to define special days.

2. In the tab display pane, select the **Define Special Days** tab.

3. Click **Add** to open the **Add a Special Day** dialog.

4. Type a name for the special day in the Name field.

5. Select the frequency of the day:
   - **One time only:** Enter the date for a single day that does not repeat in future years; for example, a special day for your organization that does not repeat every year.
   - **Repeat yearly:** Enter the date; for example, a holiday that occurs on the same date every year.
   - **Repeat on:** Complete the fields in the Repeat On section to define how the day repeats and in which months it occurs. Select whether it occurs on a particular date of the selected month(s) (Day) or a relative day (i.e., Last Saturday) in the selected month(s).

6. Repeat steps 3 to 5 to add additional special days.

7. Click **OK** to save your changes and return to the **Define Special Days** tab.
See “Configuring Day groups” on page 97 for instructions on how to apply special days to a sub-schedule.

Deleting a special day
To delete a special day, select the special day in the Define a Special Day tab then click Delete.

Configuring Day groups
Day groups define how days of the week are divided into groups.
Day groups can include:
- days of the week
- special days, such as holidays or other specially designated days (such as inventory days)

Default settings are weekdays (Monday to Friday) and weekends (Saturday and Sunday) but you can add additional groups. There can be a maximum of 47 day groups in any season.
Make sure that all days have been accounted for since unaccounted time is not included in any reports.

Adding a Day group
Before you add a day group, make sure that you have defined seasons and special days for the sub-schedule.

1. In the navigation pane, select the season for which you want to define day groups. The Define DayGroups tab appears in the tab display pane.
2. Click Add to open the Add a DayGroup dialog.
   If the Add button is unavailable, there are no free days to add to a day group. A day can only belong to one day group. To add another day group, you must first remove days from an existing day group.
3. Type a name for the day group.
4. Select one of the following options:
   - **Day of week**: Select the check box(es) for the day(s) you want to include. A day can belong to only one day group; if a day is unavailable, it already belongs to an existing group. If all days are unavailable, you can only include special days in this group unless you remove days from another day group.
   - **Special Day(s) Only**: Select the special day in the Include Special Days list then click to select or clear the day. Days with a check mark beside them are included in the day group. You can only include a special day in one day group.
5. Click OK. The name is added to the day group list.
Chapter 3: Management Console tools

Editing a Day group

1. On the Define DayGroups tab, select the day group you want to change, then click Edit to open the Edit a DayGroup dialog.
2. Make the changes you require then click OK.

Deleting a Day group

To delete a day group, select the day group in the Define DayGroups tab then click Delete. When you delete a day group, you also delete the TOU periods configured for that day group. If you add a day group again, you will need to reconfigure the TOU periods.

Configuring TOU names and TOU periods

When you run reports, the reports calculate and display data according to the information you enter in the Define TOU Periods and Define TOU Names tabs.

NOTE: You need to define TOU names and periods for each schedule that you create. Be sure to apply a TOU name to every square on the calendar. Unaccounted time causes your reports to display inaccurate information.

Defining TOU names

A TOU name is a designation that is used to differentiate billing rates. Three TOU Names are already defined: On Peak, Off Peak and Partial Peak. You can edit or delete these names, or add new names.

To define TOU names:

1. In the navigation pane, select the day group for which you want to define TOU names then select the Define TOU Names tab.
2. Click Add to open the Add a TOU Name dialog.
3. Type the TOU name you want to add then click OK. The TOU name is added to the list of TOU names.

Editing an existing TOU name

1. Select the TOU Name in the list on the Define TOU Names tab and click Edit to open the Edit a TOU Name dialog.
2. Type the new name in the TOU name field.
3. Click OK.

Deleting a TOU name

Select the TOU name in the list on the Define TOU Names tab and click Delete.

NOTE: If you delete a TOU name, the TOU periods assigned to the name are replaced with "Unaccounted". Deleting a TOU name in a particular schedule affects all sub-schedules in that schedule.
Defining TOU periods

A TOU period is the time span within the 24-hour period to which you apply a TOU name (such as 8:00 a.m. to 5:00 p.m. for On Peak). You must have TOU names defined before you can associate TOU periods with those names.

Two TOU names are already defined: On Peak and Off Peak. You can edit or delete these names, or add new names.

Adding TOU periods

Select a day groups to set up the TOU time periods (on-peak, off-peak, etc.) for that group.

1. In the navigation pane, select the day group for which you want to define a TOU period then select the Define TOU Periods tab.

2. Click Add to open the Add a Time Period dialog.

3. In the Start Time field, type the time that the period begins, or select the hours and minutes and use the up and down arrows to set the start time.

4. In the Stop Time field, type the time that the period begins, or select the hours and minutes and use the up and down arrows to set the stop time.

5. From the Time of Use Name dropdown list, select the TOU name to associate with the time period.

6. Click OK.

To add a split time period (i.e., a time period that spans from 19:00 to 6:00), you must add two separate time periods and associate them with the same time of use name.

If you want to expand a time period into time that already belongs to another period, you must first edit the other time period to clear the time.

Continue adding time periods until the 24 hour period is filled. Unaccounted time blocks cause your reports to display inaccurate information.

Editing TOU periods

1. Highlight the period you want to edit and click Edit to open the Edit a Time Period dialog.

2. Make the required changes then click OK.

Deleting TOU periods

To delete a period, highlight the period and click Delete.
Chapter 4: Vista

Vista is the Power Monitoring Expert component that displays and controls your power monitoring/management system.

**WARNING**

UNINTENDED EQUIPMENT OPERATION

- Do not use control objects for time-critical functions because delays can occur between the time a control action is initiated and when that action is applied.
- Do not create a custom control object in a Vista diagram for remote equipment operation without configuring it with the appropriate access level, and without configuring a status object to indicate the status of the control operation.

Failure to follow these instructions can result in death, serious injury, or equipment damage.

For information on starting and logging on to Vista or ending your Vista session, see "Getting started" on page 20.

In this section

- The Vista interface .......................................................... 102
- Vista user diagrams ....................................................... 104
- Monitoring your system in Vista ........................................ 107
- Viewing real-time data ...................................................... 110
- Viewing logged data ....................................................... 111
- Controlling system functions ............................................ 116
- Plotting logged data ....................................................... 117
- The Log View Plotter interface .......................................... 117
- Creating and customizing a user diagram ............................. 132
- Editing a user diagram ................................................... 133
- Customizing a diagram object .......................................... 137
- Linking a diagram object to a data source ............................ 150
- Querying the database .................................................... 152
- Customizing a diagram window ....................................... 158
**The Vista interface**

The Vista interface consists of a main screen with a title bar, a menu bar, a toolbar, a workspace, a status bar and (in Edit mode) a toolbox.

For information on opening or generating a Vista diagram, see "Generating, opening and closing a user diagram" on page 106.

The following image illustrates the Vista interface with a user diagram showing real-time values.

![Vista Interface Diagram]

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Menu Bar</td>
</tr>
<tr>
<td>B</td>
<td>Toolbar</td>
</tr>
<tr>
<td>C</td>
<td>Workspace</td>
</tr>
<tr>
<td>D</td>
<td>Click a tab to display its data</td>
</tr>
<tr>
<td>E</td>
<td>Click to return to the Network Diagram view</td>
</tr>
<tr>
<td>F</td>
<td>Status Bar</td>
</tr>
<tr>
<td>G</td>
<td>Click this grouping object to open another window containing more data</td>
</tr>
<tr>
<td>H</td>
<td>Toolbox</td>
</tr>
<tr>
<td>I</td>
<td>Receive/Transmit Status indicators</td>
</tr>
</tbody>
</table>

**Toolbar**

The toolbar offers quick access to the commands that are used most frequently. Each command on the toolbar is also available from the menus.
Zoom
Select View > Zoom In or click the Zoom button to change the mouse pointer to a crosshair. Use this pointer to drag an outline around the area you want to enlarge.

Restore to 100%
Select View > Restore to 100% or click the Restore to 100% button to return to the normal view.

Fit to Window
Select View > Fit to Window or click the Fit to Window button to force the user diagram to fit in the current window.

Up One Level
Select File > Up One Level or click the Up One Level button to return to the previously displayed window. Note that this also closes the current window. If you want to be prompted when you reach the top level of a diagram, make sure Options > Browse closes active window is selected.

Workspace
The main area in the center of the Vista screen is the workspace. The workspace is used to display information such as user diagrams and data and event viewers.

Status Bar
The status bar displays:
- The status line, which describes any active processes and provides a brief description of the currently selected command or toolbar button.
- The current time on the workstation.
- A progress indicator bar.
- Two communication status lights.

Toolbox
In Edit mode, the toolbox also appears on the screen. You can add objects to the user diagram using the toolbox. See "Creating and customizing a user diagram" on page 132 for more information on the toolbox and Edit mode.
Other display features

Vista offers several display features to assist you when viewing a user diagram. Some of these are accessible through the toolbar and menu options (see “Toolbar” on page 102). Those only accessible through menu options are:

Browse closes active window

Select Options > Browse closes active window to have each window that you open replace the previous one. This option is selected by default. Without this option selected, any previously opened windows remain open.

Arrange All

Select Window > Arrange All to tile all open windows in the workspace.

Display mode and Edit mode

There are two display modes in Vista, which affect how you navigate a user diagram. Whether or not the toolbox is shown indicates the mode you are in: if the toolbox is open, you are in edit mode; if it is closed, you are in display mode.

- Display mode allows you to monitor your system, view system data, and control some aspects of your system. In Display mode, single-click objects to view the information they contain or perform their associated action.

- Edit mode allows you to configure the appearance and function of user diagrams and diagram objects. In Edit mode, double-click objects to view the information they contain or perform their associated action. Right-click the objects to view configuration options. See "Creating and customizing a user diagram" on page 132 and "Customizing a diagram object" on page 137 for more information.

When instructed to click a diagram object, either single-click or double-click, depending on the mode you are in.

Vista user diagrams

This section explains how to use Vista user diagrams to view real-time and logged data from your power monitoring system. The information that you obtain from your Power Monitoring Expert network is represented graphically in a user diagram.
WARNING

INACCURATE DATA RESULTS

- Do not incorrectly configure the software; this can lead to inaccurate reports and/or data results.
- Do not rely solely on reports or data results to determine if the system is functioning correctly or meeting all applicable standards and compliances.
- Do not use reports or data results as substitutes for proper workplace practices or equipment maintenance; they are supplemental only.

Failure to follow these instructions can result in death, serious injury, or equipment damage.

What is a user diagram?

A user diagram is a configurable display that consists of two main elements:

- **Diagram objects** are configurable graphic icons that display your system information. Each diagram object displays a single piece of information from somewhere in your power monitoring network. In some cases, diagram objects are stored within grouping windows.

- **Grouping object**: In some cases, a user diagram stores related information within a grouping object. Click on a grouping object to open a grouping window and display its contents.

  **NOTE:** To configure a grouping object to open a grouping window, see "Specifying an action for numeric, status, or grouping objects" on page 146.

- **Grouping windows** are a type of folder or "sub-window" that contain diagram objects. Vista uses grouping windows to logically organize diagram objects within a user diagram. When closed, a grouping window is usually represented by a grouping object icon.

  **TIP:** It is better to use grouping objects to open other user diagrams rather than to open grouping windows. Large numbers of grouping windows in a user diagram can slow the performance of Vista.

You can create as many user diagrams as you want and edit each one to suit your needs. You can share user diagrams with multiple users over your network, and users can view them simultaneously and share the same information. For more information on creating user diagrams, see "Creating and customizing a user diagram" on page 132.

Default user diagrams

Vista provides a set of pre-configured user diagrams that you can use to display data. These default diagrams provide a standard set of options that you can use to access your device's most commonly required functions.
The default diagram displays real-time data. It includes a simple power system illustration that displays the various real-time parameters measured by the device.

**Generating, opening and closing a user diagram**

A user diagram is identified by its “.dgm” extension. You can generate, open, and close user diagrams as needed.

**Generating a network diagram**

The network diagram displays your entire power monitoring system by linking to individual default user diagrams that display data from each device in your system. When you generate a network diagram, Vista automatically locates all devices in your system and displays them. This diagram is saved with the default name "network.dgm".

1. Select **File > Generate Network Diagram**.
   
   The network diagram appears in the workspace containing icons that represent groups of devices on your system.

2. Click on one of the grouping objects to open a window and display the node icons contained within.

3. Click a node icon to display the user diagram for the associated device.

4. Save the network diagram.

**NOTE:** Regenerating a network diagram and saving it overwrites the previously saved (network.dgm) file.

**Opening a user diagram**

To open a user diagram:

1. Select **File > Open**.

2. Navigate to the user diagram you want to open and select it from the **Open Diagram** dialog.

3. Click **Open** to open the selected user diagram.

**Specifying the user diagram that opens for a given user**

To set a specific Vista workspace and set of diagrams to open every time a given user logs on:

1. Log on to Vista using the particular user’s logon credentials.

2. Organize Vista to appear as you want it to appear on startup.

3. Click **Save**, then close Vista.

4. Use Windows Explorer to navigate to the ...\Power Monitoring Expert\config\cfg\ud folder.
5. Locate the .wsu file for the user you are setting up (i.e., `<username>.wsu`). Right-click and select **Properties**.

6. Select the **Read-only** attribute, then click **OK**.

**NOTE:** Applying the Read-only attribute prevents the workspace information from being modified, so Vista opens the same way for a given user every time. The user can still modify and save user diagrams (if allowed by their access level).

### Closing a User Diagram

To close a user diagram:

- Select **File > Close** to close the current diagram.
- Select **File > Close All** to close all diagrams.

### Navigating a user diagram

After you open a user diagram, you can use it to interact with your power monitoring system. Each user diagram displays system information through diagram objects, which you can use to monitor and control various aspects of your system.

### Monitoring your system in Vista

Use Vista user diagrams to display real-time and logged data, monitor events and alarms, and control a variety of system functions.

#### WARNING

**UNINTENDED EQUIPMENT OPERATION**

- Do not use control objects for time-critical functions because delays can occur between the time a control action is initiated and when that action is applied.
- Do not create a custom control object in a Vista diagram for remote equipment operation without configuring it with the appropriate access level, and without configuring a status object to indicate the status of the control operation.

Failure to follow these instructions can result in death, serious injury, or equipment damage.

### How data is displayed

Information in your user diagram is displayed using diagram objects. Each diagram object communicates a single piece of information from somewhere in your power monitoring network; for example, a single numeric object displays numeric data from a single source.

There are seven types of diagram objects: grouping, text, numeric, status, data log viewer, event log viewer, and control. Each type of object performs a specific type of function.
In most cases, you can identify an object’s function by a caption, a label, or both (the text object does not use a caption or a label).

- By default, the caption is usually located below the diagram object and identifies the node to which the diagram object is connected. The caption can be modified to display a custom description. See "Caption options" on page 139 for more information.

- When a label is used, it is usually displayed to one side of the diagram object. By default, the label identifies the register (on the node) to which the diagram object is connected. The label can be modified to display a custom label name. See "Text options" on page 139 for more information.

**TIP**: To toggle between default labels and custom labels, select or clear Options > Show Default Labels. You can identify the type of diagram object by pointing to it with the mouse. The object type appears on the status line.

### Identifying stale data

Real-time data that has not been refreshed is referred to as stale data. Vista detects stale data as it occurs and identifies it with a colored border. By default, Vista identifies data as stale after 60 seconds. Position the mouse pointer over an object to display a ToolTip that explains why the data has become stale.

The stale data settings are user-configurable on a per-diagram basis, and can be customized by anyone with the necessary access level.

#### Changing the Stale Data settings

To change the amount of time (in seconds) that Vista uses to identify stale data:

1. Ensure that the Toolbox is open (Options > Show Toolbox), right-click the background of the diagram and click Properties.

2. Click the Updates tab and change the settings in the Stale Data section.

3. Click OK.

#### Changing the flag settings for Stale Data

To change the flag color:

1. Click Options > Flag Colors.

2. Click the Edit button for the flag color you want to change, select the new color and click OK.

### Identifying errors in communication

Vista detects errors (such as disabled devices, security access restrictions, or configuration errors) and identifies these with a colored border around an object (orange, by default). The border color can be customized (see the previous section, "Changing the flag settings for Stale Data"). Position the mouse pointer over an object that Vista is indicating has an error to display a ToolTip that explains the error.
Increasing the timeout period of a Vista query

When Vista queries the ION_Data database, the query can timeout if the database is large. To increase the timeout period of a Vista query, a new entry to the registry of ION_SERVER needs to be created, and the Query Server connect timeout period needs to be increased.

**NOTICE**

IRREVERSIBLE OPERATING SYSTEM DAMAGE OR DATA CORRUPTION

- Do not modify system registry keys without sufficient knowledge or experience in these procedures.
- Before making any changes, back up your system registry in a network folder or other remote location.
- Obtain assistance from knowledgeable and qualified personnel.

Failure to follow these instructions can result in irreparable damage to your computer’s operating system and all existing data.

Increase the Vista query timeout

1. Select **Start > Run** and type regedit in the **Run** window to open the registry.

2. Navigate to **HKEY_LOCAL_MACHINE\SOFTWARE\Schneider Electric\Power Monitoring Expert\x.x**, where x.x is the version number.

   If the component is run on a 64-bit operating system, navigate to:

   **HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\Power Monitoring Expert\x.x**

3. Right-click an empty area in the pane on the right and select **New > DWORD Value**.

4. Name the new DWORD VistaQueryTimeout_s.

5. Right-click VistaQueryTimeout_s and select **Modify**.

6. Enter a value for the timeout period.

   The timeout period is 60 (for 60 seconds) by default. You can increase the value to 120 initially. If timeouts still occur, modify the value to 180.

7. Select **File > Exit** to exit the registry editor.

**NOTE:** If your system installation includes Client machines running Vista, you need to update the registry for each one.

Increase the Query Server timeout

1. Open the Power Monitoring Expert folder and double-click the Designer icon to start Designer.
2. Select File > Open > QUERYSERVER.host_name (where host_name is your workstation name) to open the Query Server node.

3. Double-click the Query Modules grouping object, then right-click the query module to open its setup dialog.

4. Select the Connection String setup register and click Modify.

5. Change Connect_Timeout from the default 60 to 120 (or 180 if necessary).

6. Save your change and restart the Query Server Service.

**Viewing real-time data**

Vista uses numeric objects and status objects to display real-time data. Numeric objects display real-time numeric values and status objects display real-time Boolean (ON/OFF) information.

**Viewing data with numeric objects**

Vista uses numeric objects to display real-time numeric data from your power monitoring system. Numeric objects can display many types of data, such as line voltage or current, power or energy levels, harmonics, or demand parameters.

Depending on their configuration, numeric objects can display data in different formats: alphanumeric, dial, horizontal or vertical bar, or scrolling graph.

See "Customizing the display of a numeric object" on page 141 for more information on configuring numeric objects.

**Using flags on a numeric object**

In some cases, a numeric object may use flags to indicate the low and high limits of the displayed parameter.

When used on a dial display, flags appear as colored areas on the dial. When used on other types of numeric objects, flags change the object's background color to indicate that a Low, Low Low, High, or High High limit is currently exceeded. To view or change the default colors, select Options > Flag Colors.

The following image depicts a Low Limit of 140, a Low Low Limit of 60, a High Limit of 260, and a High High Limit of 340. The portion of the dial between 140 and 260 is transparent in Vista (the background color fills that portion of the dial), and is white in the Web-based Diagrams application.
**TIP:** If you need only Low Low and High High limits, set the Low limit equal to the Low Low limit and the High limit equal to the High High limit.

Flag colors are stored in the workspace file on a per-user basis. They are configurable and can be customized by anyone who has the necessary access level. See "Display options" on page 141 for more information on configuring flags.

**Viewing data with status objects**

Vista uses status objects to display Boolean (ON/OFF) conditions in your system. A status object may display the status of a digital output (such as a relay), a digital input (status input), or a setpoint in your system.

The default status object appears as an indicator light that changes color to indicate various conditions. Gray indicates the status object is not linked or not receiving data.

Like most diagram objects, status objects can be modified by any user with an appropriate access level. Depending on how a status object has been configured, its appearance and function can differ significantly from the default settings.

You can specify that it appear as an alphabetic display or you can select custom images representing different conditions, for example for ON, OFF, and Unconnected. See "Customizing the display of a status object" on page 143 for more information.

**NOTE:** In some cases, the active state of a status object may have been changed (inverted) so that an active state appears as inactive and vice versa. See "Customizing a diagram object" on page 137 for more information.

**Viewing logged data**

Data and events recorded by the devices in your system are regularly transferred by the Log Inserter from each device to the database. Vista uses the ION Query Service to transfer this information from the database to your workstation. Vista provides two ways to view logged data and events: the Data Log Viewer and the Event (and Global Event) Log Viewer.

- The Data Log Viewer displays data logs from all devices represented in the active user diagram. You can use the Data Log Viewer to display waveform and trend data in tabular format. You can also select a range of logs from the viewer and display the data.
graphically in the log view plotter.

- The Event Log Viewer typically displays events and alarms from each device represented in the active user diagram. The Event Log Viewer is used primarily to monitor low-priority events and alarms associated with the active user diagram. Each Event Log Viewer is associated with a single user diagram.

- The Global Event Log Viewer is a special version of the Event Log Viewer used primarily to display high-priority events and alarms for your entire system. The Global Event Log Viewer is not associated with any single user diagram; the event information it displays is common, or global, to the entire system.

**Using a Data Log Viewer**

Use a Data Log Viewer to view system data stored in the database. Data Log Viewers display historical trend data (from data recorders) and waveform data (from waveform recorders).

You can select any data displayed in a Data Log Viewer and plot it as a graph or copy it to another application (for example, Microsoft Excel) where you can perform advanced calculations or include it in a report.

See "Using the Query options" on page 152 for information on log viewer configuration.

**Displaying a Data Log Viewer**

Click on a Data Log Viewer object in your user diagram. The Data Log Viewer appears.

Each Data Log Viewer displays data as a table of columns and rows. Each labeled column contains a single type of data and each numbered row represents a single data record.

**Plotting a range of data from the Data Log Viewer**

You can plot data from a Data Log Viewer in the Log View Plotter.

1. Highlight the cells containing the data that you want to plot. The range of data can be selected in one of three ways:
   - To graph trends for all parameters over a particular time span, select a group of rows.
   - To graph the trend for a specific parameter using all available records, select the entire column.
   - To graph multiple parameters over a specific time span, click on the first cell in the desired range then drag to highlight the last cell of the range.

2. Select **Edit > Plot Selected Data** or click 📊.

The Log View Plotter window appears, displaying a graphical representation of the selected data. See "Plotting logged data" on page 117 for more information.
**TIP:** To quickly plot a single waveform, double-click on its waveform symbol in the Data Log Viewer.

**Copying a selection to another application**

1. Highlight the cells containing the data that you want to copy.
2. Select **Edit > Copy** or click ![Copy](image). This copies the selection to the Windows Clipboard.
3. Switch to another application and paste the selection.

**Using the Event and Global Event Log Viewers**

Events and alarms that occur in your system are recorded by the meter and transferred via Log Inserter to the database.

Vista provides two ways to view event records stored in the database:

- **The Event Log Viewer** displays events and alarms from the device(s) represented in the active user diagram. Use it to monitor low-priority events and alarms associated with the active user diagram. The Event Log Viewer is associated with a single user diagram, so alarms only update when the user diagram is open.

- **The Global Event Log Viewer** displays events and alarms for your entire system. Use it to monitor high-priority events and alarms for the entire system. The Global Event Log Viewer operates independently of any user diagram. The Global Event Log Viewer does not require a user diagram and updates as soon as you start Vista.

See "Using the Query options" on page 152 for information on log viewer configuration.

**TIP:** To quickly display the user diagram for any device represented in a Global Event Log Viewer, double-click on the node name (in the node column) of a device to display its user diagram.

**Displaying an Event Log Viewer**

Click an Event Log Viewer object in your user diagram to open the Event Log Viewer.

The Event Log Viewer displays logged events in a table of columns and rows. Each labeled column contains a single category or event description and each numbered row represents a single event record.

Typically, Event Log Viewers display the following information:

- **Timestamp:** This indicates the event’s date and time.

- **Priority:** This determines the relative significance of the event. Each type of event has a numeric value assigned to it that represents its relative priority level.
• **Cause:** This is the label and value describing the cause of the event. For example, if the label is “Setpoint #1” and the value is “Active,” then the event was caused by setpoint #1 changing to an active state.

• **Effect:** This is the label and value describing the effect of the event. For example, if label is “Relay #1” and the value is “Forced On,” then the effect of the event was to force relay #1 on.

• **Ack Time:** This is the date and time that an alarm was acknowledged.

**NOTE:** Because Event Log Viewers are associated with a single user diagram, they only update when the user diagram is open. All Event Log Viewers need to be re-opened if a diagram is closed or the software is shut down.

### Displaying the Global Event Log Viewer

The Global Event Log Viewer displays event data stored in the database. It includes records retrieved from meter and Virtual Processor event logs, as well as records transferred from the system log database. Users share a single Global Event Log Viewer and, generally, the information displayed is common, or global, to the entire system.

**NOTE:** It is recommended that you do not delete the Global Event Log Viewer. If the pre-configured Global Event Log Viewer is deleted, a new one must be created and configured. If one user deletes it, the Global Event Log Viewer is automatically deleted from all workstations. Only a user with supervisor-level access can delete a Global Event Log Viewer.

You can add multiple Global Event Log Viewers (if you have sufficient authority). You can change each viewer’s filter criteria to query the database for events from a specific node or group of nodes or for events with a certain priority level.

### Adding a Global Event Log Viewer

Select **Edit > Add Global Event Log Viewer** to open a Global Event Log Viewer window.

The new Global Event Log Viewer is pre-configured with default link and query information. However, you can link the viewer to another log server using the procedure described in "Linking a Data Log Viewer or Event Log Viewer" on page 151.

If you want to reconfigure a Global Event Log Viewer, ensure that the Toolbox is open (Options > Show Toolbox) then right-click the viewer window to display the Event Log Viewer Configuration dialog. You can edit the Caption, Query Server, Query or Alarming options in the same way you edit these options on an individual Event Log Viewer. See "Customizing a diagram object" on page 137 for information on configuring these options.

**NOTE:** When you add a Global Event Log Viewer to your workstation, it is automatically added to all Vista workstations in your network.
Viewing the Global Event Log Viewer

Select **Window > Global Event Viewer** to open the Global Event Log Viewer.

**TIP:** To temporarily “hide” the Global Event Log Viewer, clear **View > Show Global Event Viewer.**

Acknowledging alarms

Every type of event has a prioritized value that identifies its relative significance on a scale of 0 (zero) to 255. By default, Vista identifies any event with a priority of 128 (default) or greater as an alarm.

The event record is highlighted in red, and identified under the **Ack Time** column as "ALARM". The **Cause** column lists the source of the alarm and the **Effect** column describes the event.

By default, Vista plays a "beep" to annunciate an event with a priority range of 128-191, and a beep combined with a flashing display to annunciate an event with a priority range of 192-255. To customize these options, see "Alarming options" on page 149.

When you acknowledge an alarm, Vista records the time the alarm was acknowledged (in the **Ack Time** column) and your user ID (in the **User Name** column).

The alarm acknowledgement function is also available in the Alarms application in the Web Applications component. See the online help for the Alarms application for information about acknowledging alarms.

**NOTE:** In some cases, your access level may not be sufficient to acknowledge an alarm; for example, a critical alarm may require Supervisor access. This is a user-configurable option. See "Alarming options" on page 149 for more information.

Acknowledging an alarm

1. Open an Event Log Viewer or Global Event Log Viewer, then do one of the following:
   - To acknowledge a single alarm, click the word ALARM in the **Ack Time** column or highlight the row containing the alarm.
   - To acknowledge all alarms to date, click the **Ack Time** column heading.
     A confirmation box appears, asking if you want to acknowledge the selected alarms.

2. Select **Yes** to acknowledge the alarms or **No** to cancel.

If you acknowledge the alarm but do not have a sufficient access level, the alarm remains unacknowledged and the message "Insufficient Authorization" appears in the status line.
NOTE: When an alarm has been acknowledged in the Web-based Alarms application, and you view the entry in the Event Log Viewer or Global Event Log Viewer, the Ack Time and User Name columns are populated with the appropriate acknowledgement entries for the ON value. However, these columns remain blank for the related OFF value even though the alarm has been acknowledged.

Silencing alarms

If you are not ready or able to acknowledge an alarm, you can silence it until it can be acknowledged by selecting Options > Silence Outstanding Alarms.

NOTE: Acknowledging an alarm does not change the operating condition that caused the alarm. You must ensure that the cause is corrected to remove the alarm condition.

Controlling system functions

You can use control objects to send commands from Vista to a node.

WARNING

UNINTENDED EQUIPMENT OPERATION

- Do not use control objects for time-critical functions because delays can occur between the time a control action is initiated and when that action is applied.
- Do not create a custom control object in a Vista diagram for remote equipment operation without configuring it with the appropriate access level, and without configuring a status object to indicate the status of the control operation.

Failure to follow these instructions can result in death, serious injury, or equipment damage.

Each control object in your user diagram is configured to perform a single function. When you click a control object, it performs the specified function. For example, you could click a control object to clear an energy accumulator, toggle a relay, reset a counter, or adjust the value of an analog output device.

The default appearance of a control object depends on the function it has been configured to perform:

- Boolean
- Pulse
- Numeric

Regardless of their appearance, all control objects are used the same way—to use a control object, click it.

NOTE: For information on configuring the message, appearance and access level of control objects, see "Customizing the action for a control object" on page 147 and "Customizing the display of a control object" on page 145.
When you click on a control object, one of the following happens, depending on how the control object is configured:

- Vista performs the specified action immediately.
- Vista displays a confirmation message. Click Yes to proceed or No to cancel the operation.
- Vista requests a password. Type your logon password then click OK to proceed.

Depending on the function, a dialog prompting for the meter password may also open. If so, type the meter password then click OK to proceed.

Plotting logged data

This section describes how to use and customize the Log View Plotter to view logged data in a graphical representation. Use the Log View Plotter to graphically show trends in numeric data, display logged waveforms, display phasor diagrams, and perform harmonics analysis on waveform data. You can also plot Sag/Swell voltage disturbances and compare them to industry standard voltage tolerance curves (such as the CBEMA/ITIC curve).

TIP: You can copy information displayed by Vista Log Viewers to the Windows Clipboard and paste it into other Windows applications.

Plotting logged data

1. Select data from a data log viewer:
   - To graph trends for all parameters over a particular time span, select a group of rows.
   - To graph a trend for a specific parameter using all available records, select an entire column.
   - To graph multiple parameters over a specific time span, select the first cell in the desired range and drag to highlight to the last cell of the range.

2. Select Edit > Plot Selected Data or click .

Vista plots the data and displays it in the Log View Plotter window.

The Log View Plotter interface

The Log View Plotter is a Vista window that graphically displays selected data.

The default display is the Plot Display tab. Depending on the type of data selected, the Log View Plotter may also offer a Harmonics Analysis tab and a Phasor Diagram tab.

In all cases, the Log View Plotter offers additional information in two floating boxes: the Legend and the Calculations window.

The Legend

Each line or bar in the graph is represented by a pattern of the same color in the legend.
TIP: Click on the curve sample in the legend to select its equivalent in the graph.

Displaying the Legend
1. Right-click the background of the Log View Plotter window.
2. Select Graph Options in the menu to open the Graph Options dialog.
3. Select the Show legend check box then click OK.

The Calculations window
The Log View Plotter calculates several values for every line or bar in the graph. You can view the results of these calculations in the Calculations window.

The Calculations window updates automatically, displaying a range of calculated values based on the currently selected parameter. By default, all values displayed in the Calculations window are calculated from the first parameter. To view the calculations for a different parameter, select the line or bar you want.

For example, to view the calculations for a curve on the Plot Display tab, click on the curve line in the graph or on its line pattern in the legend. When you click a different tab, the Calculations window displays the values relevant to that tab.

Displaying the Calculations Window
1. Right-click the background of the Log View Plotter window.
2. Select Graph Options from the menu to open the Graph Options dialog.
3. Select the Show calculations check box then click OK.

Changing graph options
When using the Log View Plotter, you can adjust the graph options to change the title of a graph or the way data is displayed.

1. Right-click the graph background then select Graph Options. The Graph Options box appears.
   - Type a name for the graph in the Title box. This name appears in the title bar of the Log View Plotter window. The default is Log View Plotter.
   - Select or clear the Show legend and Show calculations check boxes to show or hide the legend and Calculations window.
   - Select the Align triggers check box to align the trigger times of all waveforms in the graph. (When multiple waveforms are plotted, their trigger times may not always be correlated.)
   - Select Separate curves vertically to display each curve separately.
2. Click **OK** to save your changes.

Displaying curve data in a table

After you plot data in the Log View Plotter, you can select a curve and display its data points in a table. This option is only available on the **Plot Display** and **Harmonic Analysis** tabs.

1. Right-click the curve line in the **Plot Display** or **Harmonic Analysis** tab and select **Data** from the menu.
   - **Plot Display** tab: The data points are displayed. The X column lists the x-axis coordinates and the Y column lists the y-axis coordinates. The first column (#) assigns a number to each set of points.
   - **Harmonic Analysis** tab: A window appears listing each harmonic number and the magnitude of each harmonic for each parameter. The first column numbers the rows. The X column lists the harmonics number and the Y1, Y2, Y3, etc., columns list the harmonic values for each bar in the harmonics histogram. Rows where the X value is not an integer (i.e., .5, 1.5, 2.25) contain sub-harmonic values.

2. Click **Format** to change the number of significant digits displayed in the X and Y columns or to change the width of these columns.
   - **Width** defines the number of characters the column can display.
   - **Precision** defines the number of significant digits displayed.

3. Click **Copy** to copy columns to the clipboard. This allows you to paste a copy of the data into another application, such as a spreadsheet program or a text file.

**NOTE:** The Log View Plotter can only display one data table at a time. If you want to display tabular data for another curve (from the same graph or a different one), you must first close any open data window.

Viewing the Plot Display tab

The **Plot Display** tab depicts the specified parameters as curves against a graph. Each parameter is plotted in a different color. The legend identifies the color of each curve in the selection and what it represents. Click on a curve to select it or right-click it to display additional options. The timestamp at the top of the tab identifies the first point in the selected curve.

The vertical axis (y-axis) represents the specified range; the horizontal axis (x-axis) represents time. Vista automatically adjusts the scale of the y-axis and x-axis to accommodate the largest parameter(s) in the selection. Right-click either axis to change the scale of its properties; right-click the axis numbers to change their format.
The time unit indicator in the lower right corner identifies the time scale of the x-axis (for example, “h” indicates an hourly scale). Possible time scale units include months, days, hours, minutes, and seconds.

**Zooming in on the Plot Display tab**

To zoom in on the Plot Display tab, click on the Zoom button and then drag a selection box around the area you want to view. To view the entire plot, click the Restore to 100% button.

**Calculations window parameters for the Plot Display tab**

The Calculations window updates automatically, displaying the following values for the currently selected curve:

<table>
<thead>
<tr>
<th>Value Label</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cursor 1</td>
<td>The timestamp and the y-value of the selected curve at Cursor 1.</td>
</tr>
<tr>
<td>Cursor 2</td>
<td>The timestamp and the y-value of the selected curve at Cursor 2.</td>
</tr>
<tr>
<td>Delta C</td>
<td>The time difference between Cursor 1 and Cursor 2, and the difference between the y-values at Cursor 1 and at Cursor 2.</td>
</tr>
<tr>
<td>Min</td>
<td>The minimum value of the selected curve between the two cursors.</td>
</tr>
<tr>
<td>Max</td>
<td>The maximum value of the selected curve between the two cursors.</td>
</tr>
<tr>
<td>dpeak</td>
<td>The maximum peak-to-peak value of the selected curve between the two cursors (Max-Min).</td>
</tr>
<tr>
<td>Avg¹</td>
<td>The average value of the selected curve between the two cursors.</td>
</tr>
<tr>
<td>RMS¹</td>
<td>The root-mean-square value of the selected curve between the two cursors.</td>
</tr>
<tr>
<td>Int(H)¹</td>
<td>The integration of the selected curve between the two cursors with respect to time in hours (for example, if the curve is in kW, the information is displayed in kWh.).</td>
</tr>
</tbody>
</table>

¹ The last three values (Avg, RMS, Int(H)) on the Calculations window are only available on plots where the x-axis represents time. They are not offered on other types of plots (for example, CBEMA plots).

Both numeric data and waveform data can be plotted in the same graph. On waveform plots, the trigger time is represented by a red vertical line.

**Using the cursor lines**

There are vertical cursor lines at either end of the curves in the Log View Plotter. These cursor lines define the start and end points used by the Calculations window. By default, Cursor 1 is located on the leftmost point of the selected curve and Cursor 2 on the rightmost point.
To define a new start point, drag Cursor 1 along the curve to the new start point. Repeat this procedure with Cursor 2 to define a new end point. You can also use the arrow keys to move the active cursor left or right. The active cursor is identified by a small box that appears where the cursor line meets the curve. Use the TAB key to switch the active cursor between Cursor 1 and Cursor 2.

As the cursor line moves from point to point along the curve, the information in the Calculations window is updated. You cannot drag Cursor 1 past Cursor 2 or vice versa.

**De-indexing parameters and specifying Y-offsets**

If you are plotting multiple parameters with different magnitudes, the lower magnitude values may be difficult to see in the default graph. Vista allows you to index any parameter to a different axis that can be scaled and offset independently from the other axes.

The new axis automatically assumes a scale appropriate for the selected parameter. In this way, you can plot parameters of different magnitudes on the same graph (such as voltage and current).

**De-indexing a parameter or offsetting a parameter on the Y-axis**

1. Right-click the graph background to display the menu. In the last section of the menu, highlight the curve you want to change.

   The curve's sub-menu appears. (You can also access the sub-menu directly by right-clicking on the parameter curve or on its curve sample in the legend.)

2. Select **Options** from the sub-menu to open the **Curve Option** dialog.

3. Choose one of the four axis options for the selected parameter. The axis is indicated by the location of the tick marks.

   Specify a Y-offset if required. This shifts the selected parameter up the y-axis (or down for a negative number) by the amount you specify.

4. Click **OK**. A new axis appears with a default title and a scale appropriate for the selected parameter.

   The scale of the default axis can also be adjusted to accommodate the remaining curves. A parameter has an asterisk after it in the legend if it has been offset.

Repeat these steps for each parameter that you want to de-index from the default axis. You can assign more than one parameter to an axis and the scale adjusts accordingly to incorporate each new parameter. For example, if you have plotted three voltage parameters and three current parameters, you can select the current curves and assign each of them to another common axis, leaving the three voltage curves to share the default axis.
Displaying Power Factor data

If you have plotted power factor data (from historical logs) in the Log View Plotter, you can improve the display to avoid discontinuity by setting the vertical axis to Power Factor Display (-100,+100).

Setting any vertical axis for Power Factor display

1. Right-click the vertical axis or right-click the graph background and select the axis after you have plotted the power factor data.
2. Select Power Factor Display from the menu. A check mark appears beside the option to indicate that it is selected.

You can plot other non-power factor data on the same graph; however, you should not plot the new data on the same axis as the power factor data. De-index the new data on a separate axis as described in "De-indexing a parameter or offsetting a parameter on the Y-axis" on page 121.

Viewing the Harmonics Analysis tab

If any of the parameters you have plotted is a waveform, you can display a histogram of the signal's harmonic content by selecting the Harmonics tab on the Log View Plotter window. The resulting histogram shows the harmonics for all waveforms in the plot.

**NOTE:** The cycle used is the first full cycle to the right of Cursor 1 on the Plot Display tab.

The total harmonic distortion (THD), K-factor and Crest factor values for this waveform are displayed in the Calculations window.

To view the calculations for another parameter, click on it in the graph or on its curve sample in the legend. The Calculations window updates automatically. The currently selected parameter is indicated above the calculations.

Calculating Harmonics using more than one cycle

By default, the harmonics are calculated using one cycle. You can increase the number of cycles by any power of two cycles (i.e., 2, 4, 8, 16, 32 or 64) up to the maximum number of cycles available for the waveform.

1. Right-click the background of the graph area then select **Graph Options** to open the **Graph Options** dialog.
2. Select the number of cycles over which harmonics calculations are to be performed from the "# of cycles for harmonics" list.
3. Select the appropriate frequency in the “System Frequency" box, if the waveform you are analyzing came from a system with a frequency other than 50Hz or 60Hz. (For example, if the waveform was captured from a 400 Hz system using a 3710 ACM, specify “400Hz" in this box.)
NOTE: The Harmonics Analysis tab is only available for waveform records. Vista does not perform a harmonics analysis for trend data or for waveforms with less than eight samples per cycle. You cannot display the harmonics of more than 16 parameters at a time.

Viewing the Phasor Diagram tab

If you have plotted waveforms for all three voltages and/or currents of your system, you can view this information as a phasor diagram. The phasor diagram graphically displays the three phases (voltages and/or currents), showing their relative magnitudes and angles.

You can use a phasor diagram to evaluate important aspects of your power system such as voltage balance, per-phase loading, and type of load (or generator operating mode). A phasor diagram also provides a way to identify PT or CT wiring problems.

NOTE: The timestamp at the top of the Phasor Diagram tab is based on the time of Cursor 1 on the Plot Display tab.

To display a phasor diagram, select the Phasor Diagram tab from the Log View Plotter window.

The Phasor Diagram and calculations are derived from a one-cycle window starting at Cursor 1 on the Plot Display tab. The magnitude and angle of the selected phase is displayed in the Calculations window.

NOTE: The Log View Plotter conforms to the convention where all phasors are plotted with respect to V1 (always at 0°) and rotate in a positive counter-clockwise direction. On a balanced power system, all three phases should appear 120 degrees apart.

To edit a phasor displayed on a phasor diagram, right-click a parameter in the legend to display a menu where you can change the phasor’s color or delete the phasor from the diagram.

Symmetrical components

The Log View Plotter calculates the symmetrical components of your power system — the positive, negative, and zero sequences relative to the first phase — for the cycle selected. If you have plotted waveforms for three voltages and/or currents, you can access their symmetrical component calculations. To produce correct symmetrical components, the waveforms must have been plotted in the correct order (for example, V1, V2, V3 — not V1, V3, V2).

The analysis of an unbalanced system, such as determining the effects of a system fault, is made simpler by using symmetrical components. Symmetrical components are a mathematical tool that allows any system of three unbalanced phasors to be represented by three balanced phasor systems. The total current or voltage in any phase wire is expressed as the sum of three balanced, three-phase components.
Positive Sequence Components (1) - these consist of three phasors that are equal in magnitude and displaced from each other by 120° and have the same phase sequence as the original phasors.

Negative Sequence Components (2) - these consist of three phasors that are equal in magnitude and displaced from each other by 120° and have the phase sequence opposite to that of the original phasors.

Zero Sequence Components (0) - these consist of three phasors that are equal in magnitude and with zero phase displacement from each other.

If the original phasors of voltages are Va, Vb, and Vc, then the symmetrical components would be as follows:

\[
\begin{align*}
Va &= Va1 + Va2 + Va0 \\
Vb &= Vb1 + Vb2 + Vb0 \\
Vc &= Vc1 + Vc2 + Vc0
\end{align*}
\]

The symmetrical components function, as implemented inside some ION meters, is useful for steady state analysis (unbalance), since the parameters are updated every second. However, when determining the symmetrical components during a fault, per-cycle analysis is required. For this application, you do not need real-time updates from the meter, because you are only interested in the relatively short time before, during, and after a system fault. This information is contained in the waveforms recorded when triggered by a disturbance.

**Viewing symmetrical components**

1. From a waveform Data Log Viewer (such as Waveforms/Sequence of Events), select all three phases of a fault (voltage or current).
2. Select Edit > Plot Selected Data.
3. Drag the Cursor and move it to the location of the fault.
4. Click on the Phasor Diagram tab to view the Symmetrical Components in the Calculations window.

**Plotting waveforms from devices with high sampling rates**

Waveforms from devices with high sampling rates can be quite large. These large waveforms are split into a series of smaller waveforms when displayed in the data log. To plot all the sections of the waveform in Vista, you must select all the rows that relate to the waveform before you click the Plot button. All the rows related to the one waveform have the same timestamp.

When the waveform is displayed, you may need to zoom in to view the area of the waveform you are interested in. To zoom in, drag a selection box around the area you are interested in.
Adding parameters to a Log View Plotter

After you have created a graph and the Log View Plotter window is visible, you can add additional parameters to the graph by copying and pasting them into the graph. These parameters can be copied from the same data log viewer, a different data log viewer, or from a different Windows application such as Microsoft Excel. The x and y-axes are automatically re-scaled to accommodate the new parameters.

When adding waveforms to the log view plotter, you can correlate all of their trigger times. See "Overlaying curves in the Log View Plotter" on page 130 for more information.

Adding data from a Data Log Viewer

You can add additional parameters from any data log viewer configured to provide compatible time-based data. Any added parameter is plotted using the same x-axis used by the existing curves. To avoid confusion ensure that the column you selected for your x-axis in the data log viewer (from which you are adding data) contains the same parameter (typically a timestamp) as the original data log viewer.

Adding additional parameters from a Data Log Viewer

1. Select the range of cells you want to plot. Ensure that it contains the same type of information (timestamps) as the data already being plotted.

2. Select Edit > Copy.

3. Click on the title bar of the existing Log View Plotter window then select Edit > Paste. The parameters you selected are added to the graph.

If you want to plot waveforms on the same graph as historical data, the historical data should originate from high-speed data recorders and span a short time range, typically a few waveform cycles (<1 second).

Adding events from an Event Log Viewer

You can add events to a waveform or trend plot. This is useful for comparing abnormalities of the waveform or trend shape with any corresponding events that happened in the same time period.

1. Select the row(s) you want to add in the Event Log Viewer.

2. Select Edit > Copy.

3. Click on the title bar of the existing Log View Plotter window then select Edit > Paste. The copied event records are added to the graph.

Each event is represented in the Log View Plotter as a diamond symbol. A diamond symbol is added to the legend and diamond symbols appear at the appropriate areas along the top of the diagram.

Point to a diamond symbol to display a description of the event in the status bar at the bottom of the screen.
Adding data from a spreadsheet or text file

You can select data from a spreadsheet or text file and paste it into an existing graph. This is useful if you want to compare trends from different times, waveforms showing different system events, and other analysis applications.

Ensure that the first column of data in the spreadsheet or text file is the same type as the first column in the data log viewer from which the log plot originated. In particular, for timestamps, make sure the entire timestamp is contained in a single column and that it uses the same date and time format as defined in the Windows Control Panel. If the date portion of the timestamp is in one column and the time is in another, or if the format is different in any way, the data cannot be pasted into the Log View Plotter.

When you paste data into a graph, from both spreadsheets and text files, the Log View Plotter interprets the first row of data in the selection as a heading. The first row in your selection is used to label the parameter in the legend. So, if the first row is not already used for column headings, insert a row and type in the label you want to appear in the Log View Plotter.

To copy data from a text file, the text file must be formatted correctly. Each column in the text file must be separated by a tab and there must be a hard return at the end of each row.

Adding data to a graph from a spreadsheet or text file

1. Open the spreadsheet or text file.
2. Copy the range of values you want to plot, including the first column and the first row. Include other columns in your selection, if required.
3. Click on the title bar of the Log View Plotter window then select Edit > Paste.
   The parameters you copied and pasted are added to the graph. The axis scales are adjusted automatically to include the new data.

You can define a trigger for waveform records containing timestamps when you copy records from other applications. Simply add an exclamation mark to the end of the timestamp to indicate that it is the trigger time. For example, the exclamation mark at the end of 22/05/2015@02:00:41.035 PM! indicates that the trigger occurred at this time.

Customizing the Log View Plotter display

Many display attributes for each curve can be adjusted. In most cases, if you right-click an area of the graph, either a menu or a dialog opens with configuration options. Unless otherwise noted, the options you specify for the Log View Plotter window are saved and restored every time you plot data from the original data log viewer. If you plot data from a different data log viewer, its graph has its own optional settings.

Customizing an axis

After you have plotted data in the Log View Plotter, use the following instructions customize the axis or gridlines, change an axis label’s format or add an axis title, or change the font or color used on all axes. You can also change the scale of an axis.
Configuring an axis

1. Right-click the graph background to display the menu. Highlight the axis from the menu to reveal the sub-menu. You can also right-click the axis to access the sub-menu directly.

2. Select Axis Properties from the sub-menu to open a dialog with the following options.
   - Range: Make changes in the From and To boxes to adjust the axis range.
   - Ticks: Make changes in the Major every and Sub-divided by boxes to adjust the frequency of major and minor ticks respectively.
   - Grid: Select or clear the Major and Minor check boxes to turn graph gridlines on or off. Click the Style buttons to change to the line style or width of major and minor gridlines.
   - Logarithmic scale: Select this check box to enable the logarithmic scale option.
   - Line: Click this button to display the Line Parameters dialog and change the line style or the width of the axis.

3. Click OK to save your changes.

**NOTE:** The axis range and the frequency of the major ticks are not stored in the diagram but are recalculated for every new plot.

Changing the color of an axis or the gridlines

1. Right-click the graph background to display the menu. Highlight the axis from the menu to reveal the sub-menu. You can also right-click the axis to access the sub-menu directly.

2. Select Axis Color, Major Grid Color, or Minor Grid Color from the sub-menu to open the Color dialog.

3. Select the color you want or click Define Custom Colors for more options.

4. Click OK to save your changes.

   The axis or the major or minor gridlines change to the color you selected.

Changing the format of the axis labels or adding an axis title

1. Right-click the graph background to display the menu. Highlight the axis from the menu to reveal the sub-menu. You can also right-click the axis labels to access the sub-menu directly.

2. Select Axis Labels from the sub-menu to open the Axis Labels dialog.

3. Select the format in which you want the axis labels to appear.
Decimal is used by default (for example, .01, .02, .03) but if the labels are too large or too small, select Scientific (1.0 x 10-2, 2.0 x 10-2, 3.0 x 10-2...) or Engineering (1m, 2m, 3m...).

4. Determine the axis title: select None to have no axis title or Text to enter your own title.

   For time-based plots, the default x-axis title is “s” if the timestamps of the data spans a number of seconds, “mn” for minutes, “h” for hours, “d” for days, “m” for months. (This applies to the Plot Display tab only.)

   For non time-based plots (CBEMA or harmonics), you can change the title. Select Text and type the title in the edit box. The title must be nine characters or less.

5. Click OK to save your changes.

   **NOTE:** If the first column of the source data includes a space or @ sign, the Log View Plotter assumes time on the horizontal axis and automatically determines the units based on timestamp information. The axis title is updated whenever the window is updated.

**Changing the font used on all axes**

1. Right-click anywhere in the graph background and select Graph Font to open the Font dialog.

2. Specify the font, style, size, effects and color options that you want to use for the axes labels.

3. Click OK to save your changes.

**Customizing curve style**

When displaying multiple parameters, Vista distinguishes between parameters using color. Each parameter is listed in the graph legend accompanied by a sample of its associated curve. The color of a curve can be changed after you have plotted data in the Log View Plotter.

If color is not enough to distinguish one curve from another—for example, if you plan to print the graph on a black and white printer—you can change the curve style after you have plotted data in the Log View Plotter.

By default:

- Each curve is shown by a thin line that connects each point of data. You can customize the style of each curve independently and show or hide the coordinates of each data point.

- Harmonics are displayed in a bar graph. You can distinguish between parameters by customizing the display style of each parameter. Display options include bar type, hatching, width and color.

Use the following instructions to customize curve styles, bar styles, and curve colors.
Changing the style of a curve on the Plot Display tab

1. Right-click the graph background to display the menu. Highlight the curve from the menu to reveal the sub-menu. You can also right-click the parameter curve in the diagram or its entry in the legend to access the sub-menu directly.

2. Select **Curve Properties** from the sub-menu to open the **Curve Style** dialog.
   - Select the type of curve you want from the Type list. Vista offers seven curve types: a simple line, a line with symbols, a scatter plot of markers, horizontal or vertical bars, or 3-D horizontal or vertical bars.
   - Select **Spline** (available for Line or Line + Symbol types) if you want the line that connects each point to be a smooth curve. If you leave it cleared, each pair of points is connected by a straight line.
   - Select **Fill Area** (available for Line type) to fill the area under the curve with the line color. Clear the check box to leave the area under the curve transparent.
   - The **Marker** section is available for Line + Symbol and Scattered types of lines. Specify the shape, size, and style of the marker used for the points. The Style options apply only to geometric shapes (for example, circles, boxes, diamonds, etc.).
   - For any line type, click **Line** to change the width and the style (for example, solid, dotted, dashed, etc.) of the line. For bar graph types, a dialog opens where you can specify the hatching pattern and the width of the bars.

3. Click **OK** to save your changes.

Changing the bar style for the Harmonics Analysis tab

1. Right-click the bar (or on its curve sample in the legend) and select **Curve Properties** to open the **Bar Graph Configuration** dialog.

2. Select the type of bar to use from the Type list. This selection is applied to all bars in the graph. Three bar styles are available:
   - **Group Bars**: Shows bars side-by-side
   - **Deep Bars**: Shows bars one behind the other
   - **Stacked Bars**: Shows bars stacked one on top of the other vertically

3. Select a hatching style for the selected bar from the Hatching list. This selection is applied to the currently selected bar only.

4. Set how wide you want each bar to be in the Width text box. The specified width is applied to all bars in the graph. The default depends upon the number of parameters.

5. Click **OK** to save your changes.
Changing the color of a curve

1. Right-click the graph background to display the menu. Highlight the curve from the menu to reveal the sub-menu. You can also right-click the curve in the diagram or its entry in the legend to access the sub-menu directly.
2. Select Curve Color from the sub-menu to open the Color dialog.
3. Select the color you want or click Define Custom Colors for more options.
4. Click OK. The curve changes to the color you selected.

Customizing graph and legend options

After you have plotted data in the Log View Plotter, you can change the color of the graphing area (and the legend) and define a font for the legend.

Changing the color of the graphing area

1. Right-click anywhere in the graph background and select Background Color to open the Color dialog.
2. Select the color you want or click Define Custom Colors for more options.
3. Click OK. The graphing area changes to the specified color.

Changing the font used in the legend

1. Right-click the background of the legend to open the Font dialog.
2. Specify the font, style, size, effects, and color options that you want to use for the legend text.
3. Click OK to save your changes.

Removing graph parameters

After you have plotted data in the Log View Plotter, you can remove a parameter from the graph.

1. Right-click the graph background to display the menu. Highlight the curve you want to remove from the menu to reveal the sub-menu. You can also right-click the curve in the diagram or its entry in the legend to access the sub-menu directly by right-clicking on the curve.
2. Select Delete Curve from the sub-menu. The curve is deleted without further prompting.

Overlaying curves in the Log View Plotter

After you plot data in the Log View Plotter, you can overlay a curve onto your graph to help analyze sag/swell data. This applies to devices that measure disturbances in voltage and store the magnitude and duration of these disturbances. When these values are inserted into
the ION_Data database, they provide a series of coordinates that can be plotted on a voltage tolerance curve. A voltage tolerance curve is often used to categorize the severity of a voltage disturbance.

**NOTE:** Most Vista queries are plotted against timestamps (with the timestamp as the x-axis); however, any query that uses the ION Sag/Swell module must be plotted against duration. When plotting sag/swell data, select Duration as the X-parameter of the Log View Plotter.

Vista provides common curves or voltage tolerance envelopes that can be used as overlays in the Log View Plotter:

- **CBEMA/ITIC:** These curves (for CBEMA, described by the IEEE standard 446-1987, and for ITIC, described by the IEEE 1100-1999 standard) define an upper and a lower bound on the types of disturbances that electrical equipment is likely to tolerate. It plots disturbance magnitude against disturbance duration and indicates at what points a voltage disturbance is likely to disrupt or damage equipment. Points near or outside the voltage tolerance envelope indicate events that could interrupt or damage electrical equipment.

- **SEMI F47-0200:** This specification defines the voltage sag tolerance capability required for semiconductor processing equipment, though it is now used by other industries. According to the specification, equipment must tolerate sags to 50% of nominal voltage for up to 200 milliseconds, sags to 70% of nominal voltage for up to 0.5 seconds, and sags to 80% of nominal voltage for up to 1 second. Points above the voltage tolerance curve indicate disturbances that exceed these specifications.

**Overlaying curves on plotted data**

To overlay one of the provided curves, you need a data log viewer that contains the magnitude and duration values for the sag/swell disturbances. The Duration column must be set as the X-parameter for the Log View Plotter—it appears in blue in the data log viewer table (See “X-Parameter for Log View Plotter” on page 154 for more information on setting the X-parameter for Data Log Viewers). The Magnitude values can be in any one of the other columns.

1. In the Data Log Viewer, select a range of cells to be plotted.
2. Select **Edit > Plot Selected Data**. The Log View Plotter window appears with Duration as the x-axis and Magnitude as the y-axis.
3. Right-click the graph and select **Overlay Curve** from the menu to open the **Overlay Curve** dialog.
4. Select the text file containing the curve data that you want to overlay (from the ...\Power Monitoring Expert\config\lvp directory).
5. Click **Open**. The selected curve appears in the graph.

You can review each point in your data and see where it falls in relation to the curve.

**NOTE:** This process automatically changes your x-axis scale to logarithmic.

Creating and customizing a user diagram

The following sections describe:

- How to customize an existing user diagram by customizing the appearance and function of a diagram object or diagram window.
- How to create a new user diagram.
- The various types of diagram objects and how to use each type to add function to your user diagram.

**NOTE:** You must have the appropriate security clearance to edit or create a user diagram. To determine if you can edit a diagram, select **Options > Show Toolbox**. If you can select this option, then you can edit a diagram. Consult your network administrator if you need to change your access privileges.

**NOTE:** Any changes you make to a default diagram affect all other devices using the same diagram.

Creating a new user diagram

To create a new user diagram, login to Vista and select **File > New**. A new (blank) user diagram appears. You can only create a new user diagram if you have supervisor-level access.

To automatically generate a network diagram based on devices added using Management Console, see "Generating a network diagram" on page 106.

Saving a user diagram

To save changes you made to a user diagram:

1. Select **File > Save** to save a new or existing user diagram, or **File > Save As** to open the **Save New Diagram** dialog.

2. Type a name for the diagram in the **File name** field and click **Save**.

By default, Vista points to the root of the \ud directory when you attempt to save a new diagram. If required, you can create a new folder within that directory to store your customized diagrams, rather than storing them in the \ud folder.

**NOTE:** This \ud directory should be located on a networked drive where it can provide multiple users with access to saved user diagrams.
NOTE: You should notify users of the Diagrams application in the Web Applications component of the location of the new custom network diagram if they want to use it instead of the automatically generated diagram. Users of the Diagrams application need to update the registry settings on their computer to specify the location of the new custom network diagram. See "Custom network diagram setup" in the Diagrams section of the Web Applications online help.

Editing a user diagram

To edit a user diagram, the Diagram Objects toolbox must be displayed. To open the toolbox, select Options > Show Toolbox. If the Show Toolbox option is grayed out, your user account does not have sufficient access; contact your system administrator.

The Enable Undo option

The Enable Undo option enables or disables the undo feature in Vista. With this option active, you are allowed to undo or "step backward" up to three times. This feature is enabled by default. If you disable the undo feature, you lose the ability to undo any previous changes. You cannot enable the feature and undo changes made prior to enabling the feature. A check mark appears beside Enable Undo in the Options menu when this option is selected.

NOTE: The Show Toolbox option must be selected for the Enable Undo option to become active — it remains unselectable otherwise.

Adding a diagram object to a user diagram

You can add a new diagram object to a user diagram by dragging it from the Diagram Objects toolbox.

Types of diagram objects

Diagram objects provide the interface to ION registers in your network. Each diagram object performs a single function. For example, a single numeric object placed in a user diagram displays numeric data from a single source. There are seven types of diagram objects available on the Diagram Objects toolbox:

**Grouping Object:**

- Group a number of related objects within a separate grouping window. Click on a grouping object to open the grouping window and display its contents.

**Text Box:**

- Display independent headings, titles, and comments in a user diagram.

**Numeric Object:**

- Display real-time numeric values such as Volts, Amps or kW.

**Status Object:**
Display Boolean data (On/Off, Yes/No, 1/0, etc.) or device-dependent conditions to indicate the status of a digital output (relay), digital input (status input) or setpoint. The image can be customized and it can be configured to use animation.

Data Log Viewer:
Display data logs stored in the ION_Data database (including archives from previous versions of the product), show waveform data (waveform capture, waveform recorder) and trends (data recorders) using tables, and provide data for plotting.

Event Log Viewer:
Display event logs stored in the ION_Data database (including archives from previous versions of the product), show event records from devices and other components, and display alarms.

Control Object:
Send commands to a device on your network (for example, clear an energy accumulator, toggle a relay, reset a counter, or adjust the value of an analog output device).

To add a function to a user diagram, choose the type of diagram object you want, drag it into the user diagram then link it to the appropriate register in a node. The following sections explain how to add and link a diagram object.

See "Monitoring your system in Vista" on page 107 for more information on the function and basic use of each type of diagram object.

Adding a diagram object to a user diagram
1. Select Options > Show Toolbox if the toolbox is not displayed. The toolbox appears in the workspace.
2. Click on the diagram object you want and drag it from the toolbox to the diagram.
   In most cases, the object appears in the window as the icon from the toolbox. However, there are two exceptions:
   - A **text box** appears in the window as a rectangular box that displays the default message: “Your text goes here.”
   - A **numeric object** appears in the window as a rectangular box with a colon (:). This indicates that the object is not yet linked to a node.

   The object is now ready to be linked to a real-time or logged data source. See "Linking a diagram object to a data source" on page 150 for details on linking an object to a source.

**NOTE:** When a diagram object is placed in a window, it automatically uses the same node as the window. If you want to change this source, either relink each diagram object or change the default window link before placing the objects.
Cutting, copying, and pasting a diagram object

Use the Cut, Copy and Paste commands on the Edit menu to make a copy of a diagram object and paste it into another window or user diagram.

You can paste the copy as many times as you like to create multiple versions of an object. Each copy retains all of the attributes and linkage information of the original.

**Cutting or copying a diagram object**

1. Select the object(s).
2. Do one of the following:
   - To remove the original, select Edit > Cut then click Yes to confirm the deletion or No to cancel.
   - To retain the original, select Edit > Copy. The selection is copied to the Power Monitoring Expert clipboard.

**NOTE:** The Power Monitoring Expert clipboard is a temporary storage area that holds any information cut or copied from Vista. It should not be confused with the Microsoft Windows Clipboard.

After the object is copied to the clipboard, you can paste it into the active window.

**Pasting a diagram object**

1. Select the window you want to paste to.
2. Select Edit > Paste. The object appears in the active window.

**Copying a group of diagram objects to a framework**

A Vista framework is a template that you can use to record the layout of a group of diagram objects.

When you select Edit > Copy to framework, Vista saves the selection (including the type and location of each diagram object) as a file. You can then use the Paste from framework command to copy the group layout to another diagram or grouping window. This is useful for replicating a single configuration on multiple workstations. You can store a saved framework with its own filename and retrieve it anytime.

**Copying a group of diagram objects to a framework**

1. Select the group of objects you want to copy.
2. Select Edit > Copy to framework to open the Copy to framework dialog.
3. Type a name for the framework in the File name box then click Save. The framework file extension (.fwu) is added automatically.

   The selection is saved as a framework.

After you save a group of objects as a framework, you can paste it to another window.
Pasting a group of diagram objects from a framework
1. Select the window you want to paste to.
2. Select Edit > Paste from framework to open the Paste from framework dialog.
3. Navigate to the framework you want to paste and click Open. The framework selection appears in the active window.

Adjusting diagram object layout and size
This section describes how to move, align and resize diagram objects.

Moving diagram objects
You can move a single diagram object or a group of diagram objects within a single window or from one window to another.
1. Select the object(s) you want to move.
2. Drag the selected object(s) to the new location.

You can also use the arrow keys on the keyboard to move the selected diagram object(s) one space at a time.

When diagram objects overlap, use the Send to Back command to place one object beneath the others. Select the object then select Edit > Send to Back (or press CTRL+K).

Resizing a single diagram object
You can adjust the size of a diagram object to make it larger or smaller or you can stretch it horizontally or vertically to change its shape.
1. Click on the diagram object to select it.
2. Do one of the following:
   - To make the object larger or smaller, drag a corner handle.
   - To stretch the object horizontally or vertically, drag a middle handle.

Resizing a diagram objects to a standard size
The Size tab in the Layout dialog lets you automatically resize a diagram object or group of diagram objects to a set of standard dimensions.
1. Select the diagram objects you want to resize.
2. Select Edit > Layout or click to open the Layout dialog.
3. Select the Size tab.
4. Edit the horizontal and vertical dimensions of the object(s) as required.
   - Select No change to make no changes to that dimension.
   - Select Shrink to smallest or Grow to largest to adjust the width and/or height to
match that of the smallest or largest object in the selected group.

- Select **Pixels** to enter the exact width or height in pixels.

You can also combine horizontal and vertical options on a single selection. For example, if you select Shrink to Smallest in the Horizontal section and 30 pixels in the Vertical section, the entire selection is resized to the width of the shortest object and the specified height of 30 pixels.

5. Click **OK** to save your changes.

### Aligning diagram objects relative to each other

The **Align** tab of the Layout dialog lets you specify the horizontal and vertical arrangement of the selected objects.

1. Select the diagram objects that you want to align.

2. Select **Edit > Layout** or click **to open the Layout dialog.**

3. Select the **Align** tab to specify the horizontal and vertical alignment of the object(s).

   The options in the Horizontal and Vertical areas determine the criteria by which you can align diagram objects. For example, if you select **Left sides** under Horizontal and **Space evenly** under Vertical, Vista aligns all objects in the selection by their left sides (using the leftmost object for reference) and distributes them evenly along a vertical axis.

4. Select the options you want then click **OK**.

### Aligning diagram objects on a grid

The **Grid** tab of the Layout dialog lets you activate and configure an invisible grid. Objects placed onto the grid snap to the nearest gridline to help align and space them evenly.

To activate or deactivate the grid:

1. Select **Edit > Layout** or click **to open the Layout dialog.**

2. Select the **Grid** tab.

3. Select one of the following options:
   - **No grid** turns the grid off.
   - **Grid size in pixels** activates the grid. Type a number in the “Grid size in pixels” box to specify the size of the grid (distance between grid lines).

4. Click **OK** to save your changes.

### Customizing a diagram object

After you have placed and linked a diagram object, you can customize it. Right-click a diagram object in edit mode to display the configuration options available for that object type.
Customizing a diagram object

1. Right-click the diagram object to open the `<Object>` Configuration dialog (where `<Object>` is the type of diagram object selected).

2. Select the appropriate tab and make your changes. Repeat this step for the other tabs until you have made all your desired changes.

3. Click OK to save your changes to the diagram object.

The options available vary depending on the tab and the object selected. See the sections below for details on the options available for different tabs and objects.

The Preview pane

Use the Preview pane to view how your proposed changes will appear in the diagram.

For some tabs, you access dialog boxes by right-clicking on the image in the Preview pane (for example, the Display tab of a numeric object). More information is given in the relevant sections that follow.

Available configuration options

The following table lists the various configuration options available for each type of diagram object.

<table>
<thead>
<tr>
<th>Available Option Tabs</th>
<th>Diagram Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Grouping Object</td>
</tr>
<tr>
<td>Caption</td>
<td>x</td>
</tr>
<tr>
<td>Text</td>
<td>x</td>
</tr>
<tr>
<td>Edit Text</td>
<td>x</td>
</tr>
<tr>
<td>Link (or Node)¹</td>
<td>x</td>
</tr>
<tr>
<td>Query Server²</td>
<td>x</td>
</tr>
<tr>
<td>Display</td>
<td>x</td>
</tr>
<tr>
<td>Action</td>
<td>x</td>
</tr>
<tr>
<td>Box</td>
<td>x</td>
</tr>
<tr>
<td>Annunciation</td>
<td>x</td>
</tr>
<tr>
<td>Query³</td>
<td>x</td>
</tr>
<tr>
<td>Alarming</td>
<td>x</td>
</tr>
</tbody>
</table>

¹ Node is the tab available with Grouping Objects.

² Query Server is only available on Grouping, Numeric, Status, and Control objects when the Action is set to something other than none.

³ See "Querying the database" on page 152 for information on configuring this option.
**Caption options**

To view caption options, right-click the object then select the **Caption** tab.

Use the **Caption** tab to add custom, user-defined text to a diagram object. The Caption tab is available for the following diagram objects: Grouping, Numeric, Status, Data Log Viewer, Event Log Viewer, and Control.

The Caption tab contains three sections: **Caption**, **Font**, and **Position**.

The **Caption** section determines whether a diagram object displays a textual comment along with the diagram object’s icon. This section has three options:

- Select **None** to display no caption.
- Select **Use default** to display the default Vista caption (i.e., the device name or data source).
- Select **Use custom** to display the text that you type into the field provided.

The **Font** section allows you to change the font used in a caption. This section has two options:

- Select **Inherit from parent window** to use the default font.
- Select **Custom** to specify a custom font. Click **Font** to open the **Font** dialog and change the font, size, style or color.

The **Position** section has two options:

- Select **Top** to place the caption above the diagram object.
- Select **Bottom** to place the caption below the diagram object.

**Text options**

Some diagram objects have a text label integrated into the display. To edit the appearance of this label, use the options offered on the Text tab. The Text tab is available for the following diagram objects: Numeric, Status, Control, and Text.

**NOTE:** You can edit the text displayed in a text label. For a numeric, status or control object, use the **Label** section of the **Link** tab. For a text box object, use the **Edit Text** tab.

To view the Text options, right-click the object then select the **Text** tab. The **Text** tab has two sections: Font and Position.

The **Font** section has two options:

- Select **Inherit from parent window** to use the default font
- Select **Custom** to specify a custom font. Click **Font** to display the **Font** dialog and change the font, size, style or color.
The **Position** section has three options — **Left**, **Center** and **Right** — to define the alignment of the text in relation to the diagram object. Use the Preview area located beside the Text tab to view your proposed changes.

**Edit Text options**

To view the Edit Text options, right-click the object then select the **Edit Text** tab.

Use the **Edit Text** tab to specify a text message for the text box. The Edit Text tab is available on the text box object only.

The **Edit Text** tab has two options:

- **Use default** displays the window link information (i.e., the node).
- **Use custom** displays your custom text message.

If you select custom, use the text box to enter your text. The text box supports multiple lines of text. If your message appears incomplete or truncated after you enter text and click **OK**, you can adjust the dimensions of the text box object. To resize a text box, select it then drag its handles.

The font used in the text box is based on the default setting specified for the active window. Use the Text tab to specify a different font or position for the text box. Use the Box tab to specify a border style or change the background color.

**Link options**

To view the link options, right-click the object then select the **Link** tab.

Use the **Link** tab to link a diagram object to a real-time source, and to specify a new text label. The Link tab is available for the following diagram objects: Numeric, Status, and Control.

**NOTE:** To set a real-time source for a grouping object, use the Node tab.

The Link tab contains two sections: Link and Label.

Use the **Link** section to specify a real-time source for the diagram object. See "Linking a numeric, status or control object" on page 150 for more information.

Use the **Label** section to change the object’s text label. The Label section has three options:

- Select **None** to display no label.
- Select **Use node label** to display the node’s register label. This is the default.
- Select **Custom** to display the label that you type into the text field provided. The custom labels you create are stored in the user diagram and are only available to users of your diagram.
**TIP:** If you have specified custom labels in your diagram, or custom labels have been applied to an ION meter at the device level, you can display the default labels at any time by selecting **Show Default Labels** from the **Options** menu. This displays the default label of the data source instead of the label assigned in the device or in the user diagram.

**Query Server options**

Use the **Query Server** tab to connect a diagram object to a Query Server. The Query Server tab is available on the Data Log Viewer and Event Log Viewer objects. See "Linking a Data Log Viewer or Event Log Viewer" on page 151 for more information.

The Query Server tab is also available on grouping objects and any object configured to open a grouping window or user diagram. In this case, use the Query Server tab to specify a default Query Server for the associated grouping window or user diagram. See "Query Server: setting a default Query Server for a window" on page 161 for more information.

**Display options**

Use the **Display** tab to customize the appearance of a diagram object. The Display tab is available for the following diagram objects: Numeric, Status, Control, and Grouping.

The Display tab offers a unique set of options for each type of diagram object. To view the display options, right-click the diagram object then select the Display tab.

**Customizing the display of a numeric object**

Numeric objects display real-time data in your user diagram. The default numeric object appears as a rectangular alphanumeric display with a single decimal place of resolution and no unit symbol. You can customize the display to change any of these default elements.

**NOTE:** Vista supports a maximum of 59 non-alphanumeric numeric objects within a single window. To change the way numbers are displayed (thousands separator and decimal point), use the Regional Settings option of the Windows Control Panel. You can also use this option to customize the time and date styles. (The year/month/day format can be modified, and the clock can be changed from am/pm to 24 hour.)

**Setting Display style**

The **Display style** box lets you select a new style from the list of available choices. The following styles are available:

- **Alphanumeric:** Default style. General-use text display.
- **Partial Dial:** General use voltage, current, harmonic distortion, etc.
- **Full Dial:** power factor, bi-directional power flow, etc.
- **Horizontal Bar:** General use.
- **Vertical Bar:** General use.
- **Scrolling Graph display:** General use. Displays recent readings on a scrolling graph.
- Arc Meter Display: General use voltage, current, harmonic distortion, etc.
- Timestamped display: Displays the value, and the date and time the value was measured by the device. Useful for min./max. values.
- Timestamp Only: Same as time-stamped, but does not display a value. Can be used as a clock.
- PC Timestamped Display: Displays the value, and the date and time the value was received by Vista.

Setting Units and Resolution

Use the Units box to type the unit name for the measured value (for example, “Volts” or “Amps”). This name is displayed on the numeric object.

In certain cases, the value is scaled. For example, if the unit name begins with K, M, or G (for example, kV or MVolts), the displayed value is adjusted accordingly. However, if the unit contains certain letters (i.e., kW or kVA), the scaling factor is reduced by 1,000 (for example, if the unit begins with K, the value is not scaled and M is scaled by 1,000). The reason for this is that most devices provide these values already scaled.

Use the Resolution box to specify the number of decimal places to be displayed for a numeric object. The default value is 1, but this can be increased to take advantage of any extra resolution available from the data source.

NOTE: Specifying higher resolution does not result in higher accuracy than the specified accuracy of the device.

Setting the Font options

Use the Ticks Labels Font section to define font options (such as style, size, and color) for the numeric object. This section has two options:

- Select Inherit from parent window to use the default style.
- Select Custom to specify a custom style, then click Font to open the Font dialog and make your changes.

Setting Flags

Use the Flags button to display the Normal Operating Range dialog. Use this dialog to set a Low Low Limit, Low Limit, High Limit, and High High Limit, and define a normal operating range to be displayed on the numeric object. After flags have been set, you can use them to quickly determine whether a reading is within the normal range you defined.

The effect of setting these limits depends on the display style you have specified. For example, on the Partial Dial, Full Dial, and Arc Meter displays, flags appear as colored ranges on the dial. On other types of numeric objects, the flag function changes the object’s background color whenever a limit is exceeded.
To view or change the default colors, select **Options > Flag Colors**.

**NOTE:** The flags used in Vista are not linked to setpoints in ION meters. Setpoint activity is automatically logged by the Log Inserter. Setpoint status can be monitored using a status object and/or data log viewer.

**Other display options for Vertical or Horizontal Bar graphs**

In the Preview section of a vertical or horizontal bar graph Display tab:

- Right-click the axis labels to display the Axis Labels dialog. Select the Format (Decimal, Scientific, or Engineering) and determine the Axis Title (none or custom text).
- Right-click the axis tick marks to display the Vertical or Horizontal Axis dialog. Configure the Range, Ticks and Grid style. Select Logarithmic scale to enable the logarithmic scale option.

**Other display options for Partial Dial, Full Dial and Arc Meter displays**

To configure meter parameters on partial dial, full dial or arc meter displays, right-click anywhere in the Preview section of the Display tab.

Set the Range, Arc Position, Ticks, and dial Position. For full and partial dial displays, set the label position to inside or outside. Click Line Attributes to set the style and width of the dial.

**Other display options for Scrolling graphs**

In the Preview section of the Display tab:

- Right-click the vertical or horizontal axis tick marks to open the Vertical and Time Axis dialogs. Set the Range and Ticks, and (for the vertical axis) Grids Style.
- Right-click the vertical axis labels to display the Axis Labels dialog. Select the Format (Decimal, Scientific, or Engineering) and determine the Axis Title (none or custom text).
- Right-click the graph background to display the Scrolling Graph dialog where you can set the Sample Interval and Relative Reset.

The sample interval determines the resolution of the X-axis in seconds. It should be set between one tenth and one hundredth of the X-axis range; for example, when extending the range to one hour (3600 seconds), the sample interval should be set to approximately 60 seconds.

The relative reset is a percentage that determines the amount the scrolling graph shifts back upon filling the plotting area. (For example, a relative reset of 0.5 shifts back 50%; a relative reset of 0.99 scrolls the most smoothly.)

**Customizing the display of a status object**

Status objects display the status of Boolean “on/off” conditions in one of three ways: an indicator light, an alphanumeric field, or a custom image.

To view the display options of a status object, right-click the object then select the **Display** tab.
The Display tab has three options:

- Select **Default image** to display the default indicator light image, which changes color to indicate various conditions: by default, green indicates an OFF condition, red indicates an ON condition and gray indicates a status object that is not connected or is not receiving information. Device dependent multi conditions (HighHigh, High, Normal, Low, and LowLow) also use colors to indicate the various conditions.

- Select **Custom images** to use custom images for each condition. Custom images can show animation, customized buttons, and so on.

  For each item selected under **Condition** (ON, OFF, and Unconnected), click **Browse** to locate and select the image you want to associate with the condition. To hide the status object in a given state, leave the image field blank.

  Currently, the custom image option supports the following graphic file formats: BMP, animated GIF, transparent GIF and PNG, WMF (Windows Metafile), JPG, EMF, AVI (without audio and uncompressed or compressed using RLE8 compression).

  **NOTE:** GIF, JPG, and PNG images need to be in \config\diagrams under the product’s installation location or they will not be shown in the Web-based Diagrams application.

You can use three different files to represent the three display states (ON, OFF, and Unconnected) of a status object. Each of these files can also be of a different type (for example, BMP, GIF, and JPG), however you cannot mix AVI and animated GIF images within a status object.

- Select **Alphanumeric** to display the Boolean state or multi-condition state labels stored in the device and choose custom colors to visually indicate the corresponding states.

  For example, suppose “Running” has been stored in a meter as the label for the Boolean register that stores the ON condition of a motor relay and “Stopped” for the OFF condition. You can show this register label together with the status label using the alphanumeric display style. You can override the meter labels on the Link tab.

  Click **ON Color** and **OFF Color** to specify the colors associated with each condition.

  You can also have multi conditions if you link the status object to an enumerated register instead of a boolean. You can do this for BCPM devices.

**Customizing the display of a grouping object**

The grouping object can be displayed as the default image, a custom image, or no image. You can customize the display to change any of these default elements.
To view the display options of a grouping object, right-click the object then select the Display tab.

The Display tab has three options:

- Select Default image to use the default image for a grouping object that appears in the toolbox.
- Select Custom image to display a custom image. Enter the filename of the image you want to use or click Browse to locate and select an image. The filename should include the file's extension (.bmp, .jpg, .png, .gif, .wmf, .emf, or .avi).
- Select None to hide the grouping object. With no image specified, the grouping object is transparent unless you select it (displaying the handles). If you move the mouse over a transparent object, the status line displays the size and object type (for example, “30x30:Grouping Object” in the status line means the hidden object is a grouping object and its size is 30 pixels by 30 pixels).

Hiding a grouping object is especially effective when using a custom background image; you can integrate your transparent grouping objects into the image by placing them at the appropriate points on the drawing. Users can display site-specific information by double-clicking on the appropriate spot in the background. See "Image: Displaying a background image" on page 160 for information on using a custom background.

Customizing the display of a control object

A control object appears differently depending on the type of register to which it is linked. This same criteria also determines the display options available.

To view the display options of a control object, right-click the object then select the Display tab.

The options available depend on the type of control object.

**External Numeric**

A control object that is linked to an External Numeric module appears as an alphanumeric display box. The Display tab has the following sections: Border and Background Color.

In the **Border** section, select Hide to show no border or select Show to display a border. If you select Show, you can specify the width in pixels and click Color to choose a color for the border.

In the **Background Color** section, select Transparent for no background or select Custom then click Color to define a color for the background.

**External Pulse**
A control object that is linked to an External Pulse module appears as a button icon, by default. The Display tab has three options: Default image, Custom image and None.

Select Default image to display the button icon. Select Custom image and click Browse to select a different image. Select None to show no image (the control object is hidden but still functions).

**External Boolean**

A control object that is linked to an External Boolean module appears as a switch icon, by default. The Display tab has two options: Default image or Custom images.

Select Default image to display the switch icon. Select Custom images then click Browse to define custom images for ON, OFF and Unconnected. To hide the control object for a given state, leave the appropriate box blank. Currently, the custom image option supports the following graphic file formats: BMP, JPG, PNG, GIF, WMF (Windows Metafile), EMF, and AVI (without audio and uncompressed or compressed using RLE8 compression).

Note that you cannot mix AVI and animated GIF images within a control object.

**Action options**

To view the action options, right-click the diagram object then select the **Action** tab.

Use the Action tab to specify the response of a diagram object when it is clicked (in Display mode) or double-clicked (in Edit mode).

The Action tab is available for the following diagram objects: Numeric, Status, Grouping, and Control objects. Depending on the type of diagram object, the Action tab displays one of two sets of options:

- Specify an action for a numeric, status, or grouping object
- Customize the action for a control object

**Specifying an action for numeric, status, or grouping objects**

**NOTE:** If you change the action for a grouping object that is already associated with a grouping window, the existing window (and any objects within it) is deleted. Vista displays a message before performing this action.

When you right-click a numeric, status, or grouping object, the **Action** tab displays the available options:

- Select **None** if you do not want the object to support an action. This is the default for numeric, status, and grouping objects.
- Select **Open Grouping Window** to open a grouping window when the object is clicked. You can use this grouping window to display additional information. For example, if a
numeric object displays a total value (such as total kW), you can display specific information (such as kW readings for each phase) in an associated grouping window.

- The **Open Diagram for Meter Template** option is used by default each time a network diagram is generated. Each meter icon in the network diagram is set to open the default diagrams that match that meter's configuration.

- Select **Open User Diagram** to open a user diagram when the object is clicked. Type the full path and filename into the field provided or click **Browse** to locate the diagram you want. Using this action, you can choose a diagram object that displays a representative reading from an independent diagram and use it to open the other diagram when clicked.

- Select **Open File** to open a file when the object is clicked. Type the full path and filename into the field provided or click **Browse** to locate the file you want. The file can be a third-party program or some other document; if a document is specified, then the program associated with the file extension is launched and the specified document is loaded into the application.

- Select **Open Web Page** to open a specified webpage in your default web browser when the object is clicked. Type the entire address into the field provided.

**NOTE:** When you select any action other than None, the Query Server tab is added to the top of the object configuration box. You can use this tab to specify a source of logged data for the new user diagram or grouping window. If you enter only the filename into the field provided (and do not specify a directory), Vista defaults to \Power Monitoring Expert\config\diagrams\ud.

### Customizing the action for a control object

To view the action options of a control object, right-click the control object and select the **Action** tab.

---

⚠️ **WARNING**

**UNINTENDED EQUIPMENT OPERATION**

- Do not use control objects for time-critical functions because delays can occur between the time a control action is initiated and when that action is applied.

- Do not create a custom control object in a Vista diagram for remote equipment operation without configuring it with the appropriate access level, and without configuring a status object to indicate the status of the control operation.

Failure to follow these instructions can result in death, serious injury, or equipment damage.
The Action tab offers three options that you can use to define how the control object responds when clicked:

- Select **No confirmation** to have no confirmation message displayed.
- Select **Message box confirmation** to display a message box when the object is clicked. The message box requires the user to click either **OK** or **Cancel**.
- Select **Password confirmation** to request the user’s logon password when an object is clicked.

The **Level to operate** list allows you to specify the access level required to perform the action. See “User Manager” on page 53 for more information on access levels and their permissions.

**Box options**

To view the Box options, right-click the object then select the **Box** tab.

Use the Box tab to add a border or background color to a diagram object. The Box tab is available for the following diagram objects: Numeric, Text Box, and any status object that has been configured as an alphanumeric display.

The Box tab has two sections:

- **Border** lets you adjust a border’s width and color as well as whether or not it is displayed. Select **Hide** to remove the border or **Show** to display it. If you select **Show**, click **Color** to define a border color and type a number in the **Width in pixels** field to change the line thickness.

- **Background Color** lets you set the background color of an object. Select **Transparent** to use the background color of the parent window or select **Custom** and click **Color** to select another color.

**Annunciation options**

To view the annunciation options, right-click the Status Object to open the **Status Object Configuration** dialog, then select the **Annunciation** tab.

Use the Annunciation tab to specify how users are notified of a change of status. The Annunciation tab is available only on the Status Object.

**NOTE:** The Annunciation feature requires that the Status Object’s diagram is displayed; if the display is closed or minimized, then the annunciation feature does not work.

The Annunciation tab has three options that set the action that Vista performs when a status object becomes active:

- Select **Command line** to automatically launch another application in the event of a change in status. Type the program’s executable (.exe) command into the field provided or click **Browse** to locate the appropriate file.
Select **Message box** to specify an annunciation message. Type your message into the field provided. The first line of text appears as the title of the message box.

Select **Invert active state** to change the way the status object reacts to an active state. When this option is selected, the status object treats an active state as inactive and vice-versa. This is useful, for example, in cases when you want to be notified if a function (such as a cooling fan) switches off.

**NOTE:** If you select the Invert active state check box, this also inverts the default colors of the status object.

### Alarming options

Every type of event that occurs in an Power Monitoring Expert network has a prioritized value that identifies its relative significance on a scale of zero to 255. By default, Vista identifies any event with a priority of 128 or greater as an alarm.

To view the Alarming options, right-click the Event or Global Event Log Viewer then select the **Alarming** tab.

Use the **Alarming** tab to create or delete a priority range, specify the security level required to acknowledge an alarm, or customize the way Vista annunciates an alarm.

The Alarming tab has three main sections:

- **Priority ranges** lists the currently configured alarm ranges. When you select a range in the Priority ranges section (for example “Range 192-255”), the other sections (Level to Acknowledge and Annunciation) display the current settings for that range. You can proceed to modify any of these settings for the specified range. (Your changes affect only the currently selected priority range.)

  Click **New** to add a new priority range. In the **Priority** dialog box, type a number representing the lower limit of the new range then click **OK**. The upper limit of the new range is automatically defined by the lower limit of the existing range. For example, if you have an existing range of 128-191, you can type 100 then click **OK** and the range 100-127 appears. To delete an existing range, select it and click **Delete**.

- **The Level to acknowledge** list specifies the access level required to acknowledge alarms in the selected range.

- **Annunciation** lets you customize the way Vista annunciates an alarm:
  - Select Beep to play a beeping sound.
  - Select Flash to have a flashing display.
  - Select Command line to have Vista to automatically launch another application in the event of an alarm. Type the program’s executable (.exe) command into the field provided or click **Browse** to locate the appropriate file. This option can be used to automatically alert other users of specific events through paging systems, fax.
transmissions, or any other command line capable application.

- Select Message box to display an annunciation message. When you select this option, type your message into the field provided. The first line of text appears as the title of the message box and the remaining text appears as the content of the message box.

By default, Vista uses a beeping sound to annunciate an event with a priority between 128-191 and a beeping sound combined with a flashing display to annunciate an event with a priority between 192-255.

**NOTE:** If your computer is equipped with a sound card, you can replace the default alarm sound with a custom sound. Save the sound file you want to use as “alarm.wav” and store it in the ...\Power Monitoring Expert\system\etc directory.

### Linking a diagram object to a data source

After placing an object in your user diagram, you need to link the object to a data source. Some types of diagram objects require a real-time data source and others require a logged data source:

- Numeric, status, and control objects require a real-time data source. You can link these diagram objects to a device.

- Event Log Viewers and Data Log Viewers require a logged data source. You can link these diagram objects to any log in your system.

### Linking a numeric, status or control object

This section describes how to link a numeric, status, or control object to a node. Numeric, status, and control objects display real-time data. After you have placed one of these objects into a user diagram, you should link it to a real-time data source. An object cannot receive or display information until it is linked.

#### Specifying a real-time link to a node

1. Right-click the diagram object you want to link to open the **Configuration** dialog.

2. Select the **Link** tab.

   The Link tab contains two sections: **Link** and **Label**. Use the **Label** section to define a label for the diagram object (see "Link options" on page 140 for information on the Label section) and use the **Link** section to choose a real-time source.

3. Select one of the following:

   - **Inherit from parent window:** The selected diagram object defaults to the same node used by the parent window (the window in which the object resides). You must specify a real-time register within the node, but the node itself is pre-selected.
Custom: Allows you to select a new node. Select ION to choose a different device than that used by the parent window.

4. Click Edit Link to open the Create Link dialog.

5. Specify a node, manager, module and output register:
   a. Double-click the node in the Nodes box that contains the data source you want. If you chose Inherit from parent window in step 3, the node is preselected.
   b. Double-click the manager you want (for example, Power Meter modules) from the Managers box.
   c. Double-click the module you want from the Modules box (for example, Power Meter).
   d. Double-click the output register you want from the Output Registers box (for example, V1I avg).

6. Click OK in the Create Link dialog to save your changes.

   The Create Link dialog closes and the new link information is displayed along the lower edge of the Configuration dialog.

7. Click OK on the Configuration dialog to save your new configuration.

Linking a Data Log Viewer or Event Log Viewer

The Event Log Viewer and Data Log Viewer display logged data. After you have placed an Event Log Viewer or Data Log Viewer object into a user diagram, you need to link it to the ION Query Service.

Linking a diagram object to the ION Query Service

1. Right-click the Event or Data Log Viewer object you want to link.

2. Select the Query Server tab in the Configuration dialog.

   The Query Server tab has two options:
   - Select Inherit from parent window to have the selected diagram object default to the same Query Server used by the parent window (the window in which the object resides). If you select this option, click OK to exit, skip the following steps, and continue with "Querying the database" on page 152.
   - Select Custom Query Server and click Edit Link to open a dialog where you can select a new Query Server link.

3. Select Custom Query Server and click Edit Link to open the Create Link dialog.

   Use this dialog to specify the Query Server, Query Manager, Query module, and Query register.

   - Double-click the Query Server that you want from the Nodes box.
   - Double-click Query Modules from the Managers box.
Double-click the Query module that you want from the Modules box.

Double-click the Query Register that you want from the Output Registers box.

4. Click OK the Create Link dialog to save your changes.

The name of the selected ION Query Service is displayed as the Group Name on the Query Server tab of the Configuration dialog.

5. Click OK on the Configuration dialog to accept your new configuration.

After you have linked a diagram object to a log server, you need to define a query to specify the type(s) of logged data that you want the object to display. See "Querying the database" on page 152 for more information.

NOTE: If the Query Server has multiple Query modules that are accessing multiple databases, you need to select the Query module that is connected to the database that contains the data of interest.

### Querying the database

The Data Log Viewer, the Event Log Viewer and the Global Event Log Viewer query the database, extract logged data, and display that data in Vista.

A query is a set of instructions that the log viewer uses to request particular data from the database. Each log viewer has its own individual query. Editing this query information changes what data the query retrieves and the way a log viewer displays that data.

Right-click the data or event log viewer object and select the Query tab to view the query options or access the Query Wizard. Use the query options to define the way a viewer displays data and the Query Wizard to edit the actual query.

NOTE: Anytime you place and link a new Data Log Viewer or Event Log Viewer, you need to specify a query for it. You can specify a query using the Query Wizard.

### Using the Query options

To define the way a log viewer displays information, configure its query options.

To view the query options for an Event Log Viewer, Data Log Viewer, or Global Event Log Viewer, right-click the viewer object to open the Configuration dialog. Select the Query tab.

The upper section of the Query tab offers two buttons:

- **Edit Query** starts the Query Wizard, a user-friendly interface that helps you edit the query.

- **Edit SQL** accesses the SQL statement via Windows Notepad so you can edit the query directly using SQL, if preferred.
NOTE: If you edit a query directly (i.e., by editing the SQL statement), your changes may not be accessible to the Query Wizard. This is not a problem unless you intend to use the Query Wizard as well.

The Options section of the Query tab offers the following options:

- **Records uploaded at a time:** This option specifies the number of records Vista uploads into active memory (RAM) when you first open a Data or Event Log Viewer. The maximum value is 9999. As you scroll down the list of records, Vista uploads additional records as needed. You may want to change this default value if, for example, you want to select a large number of records for plotting, without scrolling down repeatedly.

- **Update automatically:** This option is disabled (cleared) by default. The Data or Event Log Viewer does not display any new records; rather, the Log Viewer initially uploads the specified number of records (for example 100) and does not update again unless it is closed (and its query results deleted) then reopened.

With this option selected, the Log Viewer continually receives and displays new records up to a maximum of 1000 records; the Log Viewer checks for new records every 20 seconds. However, the updates can consume a noticeable amount of CPU power, especially if several Log Viewers remain open simultaneously or if Log Viewers are uploading waveform data.

- **Delete query on close:** This option is enabled (selected) by default. The Log Viewer clears its temporary records from active memory (RAM) upon closing so that every time a Log Viewer is opened, the database is queried again and all available records are displayed. (This option does not affect any original records stored in the database.)

If this option is disabled, Vista caches the record set returned to the Log Viewer, meaning that if the Log Viewer is closed then reopened, the table is populated from memory and not from the database. Any new records inserted into the database during the time the Log Viewer was initially open do not appear.

NOTE: Since it is recommended that Update automatically remain disabled in all but the most compelling circumstances, it is important that the Delete query on close option remains enabled.

- **Use parent node:** With this option selected, the log viewer uses the same node linkage as the parent window. The node is also pre-selected in the Query Wizard - you should not select this option if you intend to query more than one node or query the global event log.
**X-Parameter for Log View Plotter**

For a Data Log Viewer, the X-Parameter for Log View Plotter section is offered at the bottom of the Query tab. Use this section to specify a column to be used on the X-axis of the Log View Plotter. This section offers two options:

- **Timestamp** is selected as the X-parameter by default. In some cases, you may need to specify a different X-parameter. For example, when you are plotting disturbances, you need to plot your data against the Duration column.

- **Use column #** lets you specify a new x-parameter. In the field provided, type the column number that you want to use as the X-parameter (for example, 3). When you click **OK** on the Data Log Viewer Configuration box, the specified column changes to blue.

**NOTE:** In the Data Log Viewer, the column specified for the X-parameter is colored blue for easy identification.

**Using the Query Wizard**

The Query Wizard helps you edit an existing query or create a new query for a Data Log Viewer, Event Log Viewer, or Global Event Log Viewer.

1. Right-click the log viewer that you want to configure.
2. Select the **Query** tab in the Configuration box.
3. Click **Edit Query** to open the Query Wizard.

   The Query Wizard consists of four steps designed to guide you through the process of editing a query. These steps are described in more detail in the following sections.
   - Selecting the node(s) to query.
   - Specifying logs within the specified node(s).
   - Specifying columns and specifying filters.
   - Choosing a sort order.

Depending on the type of query (new or existing), you may not need to perform all four steps. When you start the Query Wizard, it automatically opens on the appropriate step in the process.

4. Use the four buttons at the bottom of the Query Wizard to move through or exit the Query Wizard:
   - Use the **Back** and **Next** buttons to navigate through the wizard.
   - Click **Cancel** to quit the Query Wizard and discard your changes.
   - Click **Finish** to quit the Query Wizard and save your changes.

5. When finished, click **OK** to save your changes and close the viewer configuration box.
The following example describes each step in the process of creating a typical query: configuring a Data Log Viewer to display waveforms for three phases (V1, V2, V3).

**Step 1: Selecting the nodes**

The Available list displays the available nodes (device or software) and the Selected list displays the currently selected nodes.

Select a node (or nodes) for your query. If a node has already been specified or you select Use Parent Node on the Query tab, the Query Wizard proceeds directly to Step 2: Specifying logs.

1. Click **Edit Query** on the **Query** tab of the Log Viewer Configuration dialog to start the Query Wizard.

2. Highlight the name of the node that you want from the Available list and click **Add**. The node appears in the Selected list. Repeat this procedure to add additional nodes for this query, if required.

   If you want to remove a node from the Selected list, highlight the node and click **Remove**. The node disappears from the Selected list.

3. Click **Next** to continue.

   **NOTE**: If you want to view or edit a node's SQL statement directly, highlight the node in the Selected list and click the **SQL** button. The Windows Notepad displays the SQL statement for the specified node.

**Step 2: Specifying logs**

Specify one or more data logs to query. If a valid query has already been specified, the Query Wizard proceeds directly to Step 3: Specifying columns.

1. The Available list displays the logs available on the specified node. The Selected list displays the currently selected logs.

2. Highlight the name of the log(s) that you want from the Available list and click **Add**. The log(s) appears in the Selected list.

   **NOTE**: Check for additional tabs. If you selected more than one node in step 1, this box requires you to specify logs for each node. Each tab is labeled “Node 1,” “Node 2,” etc. and is identified at the top of each tab. Select “Advanced log view” to access any logs whose configuration has changed over time. This check box enables access to old configurations of snapshot logs.

3. Click **Next** to continue.
Step 3: Specifying columns and filters

Use the Select the columns to appear in the Log Viewer section to add or remove a column from your log viewer and the Filter section to establish a range for your query and to screen out unwanted data.

If you selected multiple logs in step 2, this box contains a tab for each log. Specify the column and filter information for each tab.

Specifying columns to appear in the Log Viewer

The Available list displays the available columns and the Selected list displays the currently selected columns. The Selected list displays the columns in the same order (left to right) that they will appear in the log viewer (top to bottom).

To specify the columns to appear in the Log Viewer:

1. Highlight the name of the column(s) you want then click Add. The column(s) appears in the Selected list.

   Select the asterisk (*) at the top of the Available list to select all available columns.

   For example, if you want to select some basic columns for the first waveform log you chose in the last step, you could highlight timestamp, node, and V1 in the Available list.

   NOTE: The * column option shows all inputs connected to a recorder for Data Log Viewers. For example, use the * option if you are using a framework and the configuration of the data log is different for several meters. The * option is not available if more than one table is selected, as in the example.

2. Repeat this procedure for each column that you want (and for each tab).

3. Adjust the order of the items in the Selected column—highlight the column name you want to move in the Selected (in order) list then click the up or down arrows to move it. The columns are listed from top to bottom in the order they will appear from left to right.

   For example, if you want the Timestamp column to be the first (leftmost) column in your log viewer, highlight "timestamp" in the Selected (in order) section then click the up arrow to move it to the top of the list.

   After you have selected the columns you want, proceed to specify filter settings.

Specifying a filter

Use the Filter section to construct one or more filter statements for your log viewer. Filters are useful for restricting the scope of your query or specifying a priority range for alarms.

To edit an existing filter statement, double-click on it.
For example, if you want to instruct the log viewer to display data for the past month (excluding today), you could use the following procedure:

1. In the first dropdown list on the left, select “timestamp”.
2. In the second dropdown list to the right, select “BETWEEN”.
3. In the third dropdown list to the right, select “last_month_to_date()”.
4. In the fourth dropdown list (on the right), select “today_12AM()”.
5. Click Insert.

The following filter definition appears in the area below the filter controls:

“timestamp” BETWEEN last_month_to_date() and today_12AM()

**NOTE:** When setting priorities for a Global Event Log Viewer, specify high priorities to prevent the viewer from filling up with low-priority events.

If you wanted to instruct an Event Log Viewer to display only unacknowledged alarms, create a filter that only displays alarms that have no acknowledgement time (ack-time).

1. In the first box, select “ack-time”
2. In the second box, select “IS NULL”
3. Click Insert.

The following filter appears in the box below the filter controls:

“ack_time” IS NULL

As you construct a filter statement, each field offers options based on your selection in the previous field(s). For example, if you select “priority” in the first field, the third field becomes a text field where you can type a numeric value; if you select “timestamp” in the first field, the third field displays time-based options (i.e., now, today 12AM, yesterday, etc.).

<table>
<thead>
<tr>
<th>Time-related functions</th>
</tr>
</thead>
<tbody>
<tr>
<td>now_()</td>
</tr>
<tr>
<td>today_12AM()</td>
</tr>
<tr>
<td>yesterday()</td>
</tr>
<tr>
<td>last_week()</td>
</tr>
<tr>
<td>this_month()</td>
</tr>
<tr>
<td>last_month_to_date()</td>
</tr>
<tr>
<td>last_month()</td>
</tr>
<tr>
<td>last_quarter_to_date()</td>
</tr>
</tbody>
</table>
Note that time-related functions only return one record. To return all of the records for the time period, you also need to specify < \text{today\_12AM}(). For example, specifying a filter of \text{=yesterday()} returns only one record, but a filter specifying \text{>=yesterday()} AND \text{<today\_12AM()} returns all of yesterday’s records.

The second field offers a standard set of operators.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>less than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>greater than or equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>less than or equal to</td>
</tr>
<tr>
<td>!</td>
<td>not equal to</td>
</tr>
<tr>
<td>LIKE</td>
<td>like</td>
</tr>
<tr>
<td>BETWEEN</td>
<td>between</td>
</tr>
<tr>
<td>IS NULL</td>
<td>is null</td>
</tr>
<tr>
<td>IS NOT NULL</td>
<td>is not null</td>
</tr>
<tr>
<td>IN</td>
<td>in</td>
</tr>
</tbody>
</table>

**Operator-specific data**

If you select an operator that requires additional information, Vista displays a dialog where you can specify the required data.

For example, if you select the “node” column in the first field then select the “IN” operator from the second field, a dialog opens requesting that you specify the node you want to use.

If you specify any column other than “node” then select “IN”, a box appears requesting numeric values.

After you have specified a filter, click **Next** to continue.

**Step 4: Choosing a sort order**

Specify a sort order. The sort order is the order in which records appear in the viewer.

1. Highlight the name of the column to sort by in the Available Columns list then click **Add**. The column appears in the Sort Order list.

   Available Columns displays the columns you chose in step 3.

2. Double-click on the column in the Sort Order list to select either an ascending or descending sort order.

   The Sort Order list displays the column(s) that dictate the order in which the records are sorted.

3. Click **Finish** to save your changes and quit the Query Wizard.

4. Click **OK** in the Configuration box to save your changes.

**Customizing a diagram window**

You can customize the appearance and configuration of any window within a user diagram. You can customize a window’s font or background color, or configure window properties such as background image, real-time and logged data links, double-click action, and stale data settings.
In many cases, Vista uses the properties specified for the parent window as the default settings for any diagram objects or grouping windows contained within. By modifying a setting in the parent window, you automatically modify the same property on all objects inside the window that share this setting. (For example, any object with an option set to Inherit from parent window shares this information.) This can be useful when adding multiple diagram objects that are all linked to the same source.

To access any of these options, right-click anywhere in the background of the user diagram or window that you want to customize.

**NOTE:** Right-clicking in the background of a window displays a menu of available options; however, right-clicking on any object in the window while in Edit mode (including transparent objects such as text boxes or grouping windows) displays the configuration options for that object.

### Default font

The font you select becomes the default setting for all captions and text labels within the window.

**Changing the default font**

1. Right-click the background of a user diagram and select Default Font to open the Font dialog.
2. Set the default font, style, size, effects, color, and format that you want.
3. Click OK to save your changes.

### Background color

The default background color is gray. However, you can display any solid color as a background for any window in your user diagram.

**Changing the background color**

1. Right-click the background of a user diagram and select Background Color to open the Color dialog.
2. Select the color that you want or click Define Custom Colors for more options.
3. Click OK to save your changes.

### Configuring window properties

To view the Window Properties Configuration options, right-click the background of any window in your user diagram and select Properties.

The Window Properties Configuration dialog opens with five option tabs: Image, Query Server, Node, Action and Updates.
Image: Displaying a background image

To view the image options, select the Image tab on the Window Properties Configuration dialog. Use the Image tab to specify a background image for the active diagram or grouping window.

The Image tab has two options:

- Select None if you do not want to display a background image, or if you prefer to display a single color.
- Select Custom image to display a background image. Enter the path and filename of the image you want to display. Vista supports images saved in the following formats: Windows bitmap (.bmp), Windows metafile (.wmf), or Windows Enhanced metafile (.emf).

You can create your own background image using a scanned photograph or a drawing created within a standard graphics program. Some ideas include:

- An engineering drawing of your installation depicting the power distribution system and the location of critical elements.
- A single line diagram illustrating the power distribution network or the individual components of your facility.
- An aerial photograph of your facility depicting the approximate location of your monitoring equipment.
- A satellite image or geographical map depicting your transmission and distribution network.

The following illustration depicts a sample Vista background with hidden diagram objects (here the object is visible by the handles because it is selected in Edit mode):
You can integrate your diagram objects into the image by placing them at the appropriate points on the drawing. Users then display site-specific information by clicking on the appropriate spot in the background.

**Specifying a custom background image**

1. Right-click the background of the window you want to customize and select **Properties** to open the **Window Properties Configuration** dialog.
2. Select the **Image** tab.
3. Select Custom image and click **Browse**.
4. Select the image file you want to use and click **Open**.
5. Click **OK** to set this image as the background.

**Query Server: setting a default Query Server for a window**

Use the Query Server tab to specify a logged data source for any window in a user diagram. The Query Server that you select provides the default source of logged data for all Event Log Viewers, Data Log Viewers and Grouping Objects within the window.

**Setting a default Query Server for a window**

1. Right-click the background of the window and select **Properties**.
2. Click the **Query Server** tab in the Window Properties Configuration box.
3. Select either **Inherit from parent icon** or **Custom Query Server**.
   - Select **Inherit from parent icon** for the active window to default to the same Query Server used by the parent icon. (The parent icon is the diagram object that you clicked to open this window.)
   - Select **Custom Query Server** then click **Edit Link** to open a dialog where you can select a new Query Server link.

When you click the **Edit Link** button, the **Create Link** dialog opens.

Use the **Create Link** dialog to specify a query:

1. Double-click the Query Server that you want from the Nodes box.
2. Double-click Query Modules from the Managers box.
3. Double-click the Query that you want from the Modules box.
4. Double-click the query register that you want from the Output Registers box.
5. Click **OK** to save your changes.

The name of the selected Query Server and register are displayed as the Group Name on the Query Server tab of the Window Properties Configuration dialog.
Node: Setting the default node for a window

Use the Node tab to specify a real-time source for any window (or grouping object) in a user diagram. The node that you select provides the default source of real-time data for all numeric, status, and control objects within the window. It also is the parent node for any Data Log Viewer or Event Log Viewer objects placed in the window.

Setting a default node for a window

1. Right-click anywhere in the background of the window and select Properties from the pop-up menu to open the Window Properties Configuration dialog.
2. Select the Node tab.
3. Do one of the following:
   - Select Inherit from parent icon to use the same node as the parent icon (the diagram object you double-clicked to open the window).
   - Select Custom to select a different node. Select ION and click Select to display the Select Node dialog. Select a default real-time source for the window from the nodes available.
4. Click OK to save your changes.

Action: Specifying an action for a window

You can specify an action for Vista to perform upon opening or closing a particular window. For example, if you want Vista to automatically engage a modem tool (such as the Connection Manager) every time you open a certain grouping window, you can specify the tool as an action.

Specifying an Open or Close action

1. Right-click the background of the user diagram or grouping window and select Properties to open the Window Properties Configuration dialog.
2. On the Action tab, select Command line on open or Command line on close.
3. Click Browse to open the Browse dialog, locate the program you want, select the .exe file, and click Open.
   The specified file and path name appears in the box below the selected option.
4. Click OK to save your changes.

NOTE: To remove an action, clear the check box beside the option.

Updates: Setting the time interval

Data that is not updated is considered stale data. Vista detects stale data as it occurs and identifies it with a colored border around the diagram object (the default color is yellow).
On the **Updates** tab, you can specify the interval of time Vista uses to detect stale data. The **Updates** tab has two sections:

- **Update Period** allows you to specify how often data in that window is refreshed.
- **Stale Data** allows you to specify whether data is highlighted and how old data must be to be considered "stale".

**NOTE:** The Update Period and Stale Data settings also apply to Diagrams.

### Changing the Update and Stale Data settings

1. Right-click the background of the window and select **Properties** to open the **Window Properties Configuration** dialog.
2. Select the **Update** tab.
3. Enter a numeric value in seconds in the **Update data period** or **Stale data timeout** fields to set the intervals.
4. Select or clear the **Highlight stale data** check box to enable or disable checking for stale data.
5. Click **OK** to save your changes.

To change the color of the stale data border, close the Window Properties Configuration dialog, then select **Options > Flag Colors** to open the Flag Colors dialog. Click **Edit** beside "Stale Flag Color" to open a dialog where you can select a different color.
Chapter 5: Designer

Use Designer to configure nodes on your network that are based on ION Architecture. The node can be a software component or a hardware device.

**NOTE:** Only nodes based on ION Architecture can be configured using Designer.

Designer’s graphical user interface helps visualize a node’s configuration. You can link ION modules together to customize a node for your particular application. You can also cut, copy and paste functionality within a single node or between different nodes.

⚠️ **WARNING**

**UNINTENDED EQUIPMENT OPERATION**

- ION modules and registers must only be configured by personnel with a thorough understanding of ION architecture and the system in which meters and software are installed.
- Do not use a controlled output for any safety critical application due to possible unexpected change of state during power cycles, power outages, configuration changes, or firmware upgrades.

Failure to follow these instructions can result in death, serious injury, or equipment damage.

For more information on ION Architecture, ION modules or ION registers, see the *ION Reference*.

**In this section**

- Getting started with Designer ................................................................. 166
- Node diagrams and the Designer interface .............................................. 166
- ION module overview ............................................................................. 176
- Using ION modules .................................................................................. 178
- Linking ION modules ............................................................................... 186
- Configuring ION modules ....................................................................... 192
- Copying and pasting ION modules ............................................................ 197
- Viewing output registers, setup registers, and inputs ................................. 205
- Virtual Processor service .......................................................................... 207
Getting started with Designer

Designer is a programming tool intended for advanced users only. Familiarity with ION architecture is essential, as Designer is based on ION architecture.

The functions used in traditional power monitoring are treated as discrete modular objects that can be interconnected and customized. These objects, known as ION modules, are the basic building blocks that comprise a node.

Designer is used to make any changes to the operation of an ION-compliant node. ION devices, the Virtual Processor and Log Inserter are all configured using Designer.

For those already familiar with Designer, see "Designer shortcuts" on page 170 for a list of the most commonly used commands.

Starting, logging into and exiting Designer

To start Designer, use one of the methods outlined in "Starting a component of Power Monitoring Expert" on page 21 or open Management Console and select Tools > System > Designer.

For instructions on logging in to or exiting Designer, see "Logging into a component" on page 21 and "Ending a session" on page 21, respectively.

Node diagrams and the Designer interface

This section describes the components of the Designer interface and of node diagrams.
The Designer interface

The Designer interface consists of a main screen with a title bar, a menu bar, a toolbar, a workspace, and a status bar. When in Edit mode, the ION Modules toolbox is also displayed.

**Title bar**

The title bar displays the name of the program, the user name, and the name of the active node diagram.

**Menu bar**

Below the title bar is the menu bar. Click on a menu name to display a list of available commands.

**Toolbar**

The Toolbar offers quick access to the commands used most frequently. Each command offered on the toolbar is also available from the menu bar.

<table>
<thead>
<tr>
<th>A</th>
<th>Menu bar</th>
<th>B</th>
<th>Toolbar</th>
<th>C</th>
<th>Workspace with open node diagram</th>
<th>D</th>
<th>Core module (indicated by double border)</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>Toolbox</td>
<td>F</td>
<td>Status line</td>
<td>G</td>
<td>Grouping object</td>
<td>H</td>
<td>Shortcut icon</td>
</tr>
<tr>
<td>I</td>
<td>Module link</td>
<td>J</td>
<td>Module icon</td>
<td>K</td>
<td>Time display</td>
<td>L</td>
<td>Progress indicator</td>
</tr>
<tr>
<td>M</td>
<td>Communication status lights</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

When you point at a toolbar button, a description of it appears in the status bar at the bottom of the screen and on a small ToolTip beside the button.

**Workspace**

The main area in the center of the screen is the workspace, where you view and edit node diagrams.

**Status bar**

The status bar displays status information. The components, from left to right, are:

- **Status line**: Describes any active processes and provides brief descriptions of the currently selected command or toolbar button. For example, when you move the pointer over a toolbar button or click on a menu name, a brief description of the item appears in the status line.

- **Time display**: Displays the current time on the workstation.

- **Progress indicator**: Depicts the progress on an action being performed.
• **Communication status lights**: Indicate if Designer is currently receiving and transmitting data on the Power Monitoring Expert network.

**The node diagram**

A node diagram is a graphical representation of an ION-compliant node. The node diagram displays the actual configuration of the node. Module icons represent the ION modules in the node, while lines drawn between these module icons show links between the ION modules.

In some cases, groups of modules are organized inside grouping windows. When closed, a grouping window appears as a grouping object (an icon that looks like a folder). Click a group object to open the grouping window that contains the module icons.

**Using a node diagram**

The node is graphically displayed as a node diagram in Designer. The node diagram contains a number of ION modules, which represent the node's current configuration. You can change the configuration of the node simply by editing its node diagram. For example, when you delete a module from a node diagram, the module is removed from both the diagram and the node. You can add, configure, link and delete modules on the node by making the corresponding changes to the module icons in the node diagram. A module’s setup registers can be accessed and changed through the module icon.

Use Designer to configure hardware nodes (for example, ION meters) or software nodes (for example, Virtual Processor or Log Inserter).

---

**NOTICE**

**LOSS OF DATA**

Do not leave hardware or software nodes open in Designer, as this stops log downloads from the device.

Failure to follow these instructions can result in a loss of data.

**Default node diagrams in Designer**

When a meter is opened in Designer, the default diagrams for the appropriate meter and default template are loaded automatically.

**Opening a node diagram**

1. Select **File > Open** to open the **Select Node** dialog.
2. Select the node you want to open then click **OK**.

When you select a node from the list, Designer communicates with the specified node and opens the applicable node diagram.
NOTICE

UNINTENDED DEVICE OPERATION
Do not open a node diagram if the node is currently being configured from its front panel.

Failure to follow these instructions can result in unplanned configuration changes.

When Designer loads a node diagram, it compares the diagram with the configuration of the node. If there are any discrepancies between the diagram and the node, Designer updates the diagram to match the node:

- If a diagram depicts a module that does not exist on the node, Designer deletes the module icon from the diagram.
- If a node contains a module that is not depicted in the diagram, Designer adds the module icon to the diagram.
- If the links between modules differ from node to diagram, Designer adjusts the diagram to match the node.

A node diagram typically does not differ from the node's true configuration unless the node's configuration was changed through other means (for example, with a remote display unit.)

Saving a node diagram
Saving a node diagram serves two purposes: it saves your changes to the diagram, and applies your changes to the node.

- To save the active node diagram, select File > Send & Save.
- To save all open node diagrams, select File > Send & Save All.

Closing a node diagram
To close the node diagram(s):

- Select File > Close to close the active diagram, or
- Select File > Close All to close all open diagrams and windows.

If you attempt to close a diagram without saving your changes, Designer displays a message with a list of the modules affected.

You can then do one of the following:

- Click OK to return to the diagram and save your work before closing the diagram.
- Click Close Anyway to discard any unsaved changes and close the diagram.

NOTE: If you reopen a diagram containing unsaved changes, Designer may list the unsaved changes as offline modules.
Display mode versus Edit mode

There are two display modes in Designer, which affect how you navigate a node diagram. Whether or not the toolbox is shown indicates the mode you are in: if the toolbox is open, you are in edit mode; if it is closed, you are in display mode.

Display mode allows you to view the node diagram without making changes. To prevent accidentally moving or deleting modules or links, use Display mode when navigating node diagrams. In Display mode, single-click grouping objects to open associated grouping windows.

Edit mode allows you to configure the node and the appearance of the node diagram. In Edit mode, double-click grouping objects to open associated grouping windows. Right-click objects or icons to view configuration options.

For more information on the Toolbox, see “Using the ION modules toolbox” on page 178.

Designer shortcuts

Designer provides several shortcuts to assist in programming the nodes.

The following table lists the different mouse and keyboard combinations you can perform on a module’s input or output symbols, and their corresponding functions:

<table>
<thead>
<tr>
<th>Action</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left-click input</td>
<td>The list of inputs appears - you can select an input and link it to another module's output register</td>
</tr>
<tr>
<td>SHIFT + left-click input</td>
<td>The list of inputs appears with the current input values displayed in square brackets</td>
</tr>
<tr>
<td>Right-click input</td>
<td>The Delete Links dialog appears - you can break links from this dialog.</td>
</tr>
<tr>
<td>SHIFT + right-click input</td>
<td>The Delete Links dialog appears, showing inputs and current input values in square brackets</td>
</tr>
<tr>
<td>Left-click output</td>
<td>The list of output registers appears</td>
</tr>
<tr>
<td>SHIFT + left-click output</td>
<td>The list of output registers appears with the current register value displayed in square brackets</td>
</tr>
<tr>
<td>CTRL + left-click output</td>
<td>The list of setup registers appears - these setup registers can be linked to inputs on other modules</td>
</tr>
<tr>
<td>SHIFT + CTRL + left-click output</td>
<td>The list of setup registers appears with the current register settings displayed in square brackets</td>
</tr>
<tr>
<td>Right-click output</td>
<td>The list of output register owners appears - you can break links from this dialog</td>
</tr>
<tr>
<td>CTRL + right-click output</td>
<td>The list of setup register owners appears - you can break links from this dialog</td>
</tr>
</tbody>
</table>
NOTE: To create a shortcut to an ION module, see "Creating a shortcut to an ION module" on page 184.

**Designer icons**

In each node diagram, Designer uses icons to represent the configuration of the node. There are two basic types of icons: module icons and grouping icons.

Module icons represent ION modules located on the node. Grouping icons represent a group of module icons.

NOTE: A module icon with a symbol in the lower corner is a shortcut.

**Module icons**

All module icons share four common elements: a label, a graphic, an input symbol and an output symbol.

- The **label** displays the name of the module.
- The **graphic** shows a picture to distinguish one type of module from another.
- The **input** and **output** symbols provide access to the module’s input and output registers. Click the left symbol to display a list of inputs; click the right symbol to display a list of output registers. See "Linking ION modules" on page 186 for more information.

Module icons with a double border represent core modules; module icons with a single border represent standard modules. For more information on core and standard modules, see "Core modules and standard modules" on page 177.

**Grouping icons and grouping windows**

Grouping icons represent grouping windows. Click a grouping icon (left) to open its associated grouping window (right).
A grouping window acts as a folder or sub-window where you can store icons that you want to keep together. For example, you can use grouping windows to group module icons by application—a single grouping window may contain all module icons required for demand or advanced setup routines.

You can use a grouping window much like a standard window. You can create, rename or delete a grouping window; you can move a grouping window within a diagram, and you can move a module into or out of a grouping window.

When you finish editing the grouping window, close it to minimize the window to its corresponding grouping icon in the node diagram.

**Opening a grouping window**

Click on the grouping icon.

**Closing a grouping window**

Click the Close button ✗

**Moving icons into a grouping window**

To move an icon (or group of icons) to or from an open grouping window, select it and drag it to the new location.

1. Click on a grouping icon to open the grouping window.

   Drag the grouping window by the title bar and position it so that you can see the icon(s) that you want to move.

2. Select the icon(s) you want to move and drag the selection into the grouping window.

When you move a linked module icon into a grouping window, the module remains linked but any lines that represent links to modules outside the window disappear.

**Creating a new grouping window**

To create a new grouping window, drag the grouping object from the toolbox onto the node diagram.

The ION modules toolbox is a collection of ION modules and generic tools that you can add to a node diagram. If the ION modules toolbox is not displayed, select **Options > Show Toolbox**. See "Using the ION modules toolbox" on page 178 for more information.
When you point to an object in the toolbox, the name of the object is displayed on a ToolTip. You can use ToolTips to identify the grouping object in the toolbox.

**Renaming a grouping window**
When you create a new grouping window, the default name is that of the node diagram. To change the name of a grouping window, rename the grouping icon:

1. Right-click the grouping icon to open the **Grouping Object Configuration** dialog.
2. Select **Use Custom** from the Caption section and type the new name into the text box.
3. Click **OK**.

**Changing the font of a grouping window**
To change the font, font style and size of a caption:

1. Right-click the grouping icon to open the **Grouping Object Configuration** dialog.
2. In the Font section, do one of the following:
   - To use the font of the parent window, select **Inherit from parent window**.
   - To use a different font, select **Custom**, then click **Font** to open the **Font** dialog. Select the font options you want then click **OK** to continue.
3. Click **OK**.

**Changing the position of the caption**
To change the location of the caption:

1. Right-click the grouping icon to open the **Grouping Object Configuration** dialog.
2. Select either **Top** or **Bottom** in the Position section to specify a caption position above or below the grouping icon.
3. Click **OK**.

**Deleting a grouping window**

**NOTE:** When you delete a grouping window, any modules inside are deleted as well. Designer displays a message before deleting modules. See “Deleting or cutting an ION module” on page 180 for more information on deleting modules.

1. Select the grouping icon of the window you want to delete.
2. Press the **Delete** key. If the grouping window contains modules, Designer displays a list of modules that will be deleted.

**Displaying default or custom icon labels**
Module icons can display two types of labels: Default (left) and Custom (right).
**Default labels:** All modules have a default label. The default label identifies the module by type and, if applicable, by number. It appears in node diagrams, user diagrams and event logs unless a custom label is available.

**Custom labels:** Custom labels are available only if they have been preconfigured by a user. A custom label usually identifies a module by its function or purpose. Custom labels are useful for describing modules, setup registers, output registers, and Boolean ON/OFF conditions. For information on adding custom labels, see "Customizing a module label" on page 195.

### Displaying default labels or custom labels

Select **Options > Show Default Labels** to toggle the option on or off.

- When Show Default Labels is selected, default labels are displayed.
- When Show Default Labels is not selected, custom labels are displayed.

This is a global setting that applies to all node diagrams.

### Moving icons in a node diagram

You can move module and grouping icons anywhere in a node diagram. This is useful for organizing your diagram (for example, by function or type) so that you can easily find a particular module or visualize the workings of your node's configuration. You can move a single icon or group of icons within a single node diagram, or into an open grouping window.

**NOTE:** Moving the icons in a node diagram does not affect the function of the modules or the node in any way.

### Moving icons

1. Select the icon(s) you want to move.
   - When a grouping icon is selected, all icons within its grouping window are automatically selected as well.

2. Drag the selected icon(s) to the new location.

**NOTE:** When selecting a group of icons, you can only choose icons from within the active window.

### Arranging icons in a node diagram

You can use the Align and Grid options in the Layout dialog to adjust the spacing and layout of the module and grouping icons in your node diagram. Use the Align option to specify the horizontal and vertical arrangement of the selected icons and the Grid option to activate and configure invisible guidelines.

**NOTE:** Arranging the icons in a node diagram does not affect the function of the modules or the node in any way.
Changing the order of layered or stacked icons

If an icon appears on top of another icon that you want to bring to the front, select the icon that is sitting on top, then click CTRL+K (or click Edit > Send to Back).

Aligning icons

The Align tab in the Layout dialog allows you to specify the horizontal and vertical alignment of selected objects.

To align objects:

1. Select the icons that you want to align.
2. Select Edit > Layout to open the Layout dialog.
3. Select the Align tab and set the horizontal and vertical alignment of the icons.

   The options in each area determine the criteria by which you can align icons. For example, if you select Left sides under Horizontal and Space evenly under Vertical, Designer aligns all objects in the selection by their left sides (using the leftmost object for reference) and distributes them evenly along a vertical axis.

4. Click OK.

Using the grid

The Grid tab in the Layout dialog activates and configures an invisible grid. Icons placed onto the grid snap to the nearest gridline to help align and space them evenly.

To activate or deactivate the grid:

1. Select Edit > Layout to open the Layout dialog.
2. Select the Grid tab.
3. Select one of the following options:
   - No Grid turns the grid off.
   - Grid size in pixels activates the grid. Type a number in the Grid size in pixels box to specify the size of the grid (distance between grid lines).

4. Click OK to save your changes.

Designer windows

To create links between several node diagrams or grouping windows, you need to position the open windows so you can see all the modules involved. Use the Window menu to organize open windows in the workspace.

Arranging windows in your workspace

To arrange windows, do one of the following:

- To locate an open window and move it to the foreground, select the Window menu and select the window name from the list of open windows.
- To arrange all open windows in the workspace, select Window > Arrange All.
Changing a window’s background color
By default, the background color of all windows in a node diagram is light gray. To select a new background color for a window:

1. Right-click the background of the window and select **Background Color** to open the **Color** dialog.
2. Select the color you want or click **Define Custom Colors** for more options.
3. Click **OK**.

When choosing a background color, consider how the color affects the visibility of icons and links. Links, highlights and shadow effects used to depict the various states of an ION module may not appear against certain background colors. For this reason, you should avoid using certain colors for your background, particularly white, dark gray and black.

Changing a window’s default font
You can specify a default font to be used for all module icons, grouping icons and text boxes in a window.

1. Right-click the background of the window and select **Default Font** to open the **Font** dialog.
2. Specify a new default font, size and style.
3. Click **OK**.

Fonts can also be specified individually for grouping windows and text boxes. See “Changing the font of a grouping window” on page 173 and “Changing the font of a Text Box” on page 185 for more information.

ION module overview
After you have opened a node diagram, you can view the node’s configuration or edit it by working with its ION modules. As described earlier, each module performs a specific function. Using Designer, you can add, remove or link modules together to customize the function of the node.

This section explains how to add and remove ION modules from your node diagram. It describes the basic types of modules, and explains how you can organize your node diagram by grouping modules together, arranging them, and labeling them.

For more information on ION modules and architecture, refer to the ION Reference.

**Working with ION modules**
The following sections outline some considerations to remember when working with ION modules.

**Output and setup registers**
A register is a type of memory bank that stores a module’s linking and configuration information. Each module uses two types of registers: output registers and setup registers.
Module status: online and offline

The terms “online” and “offline” describe whether a module is currently active or not. A module is described as online when it is functioning normally (monitoring its input and updating its output registers). An offline module is inactive.

Anytime you send and save changes to a node, Designer temporarily takes the affected modules offline and programs them with your changes. After they have been programmed, the modules are then placed back online.

Normally, this is a routine procedure. However, certain circumstances may cause a module to remain offline. For example, if the node lacks sufficient processing power to operate the module, the module remains offline.

You can easily identify any offline modules: all offline modules are highlighted with a red outline. In addition, whenever you open a node diagram, Designer displays a list of all offline modules in the node.

**NOTE:** If you have offline modules in your node, you may be able to put them back online by selecting File > Send & Save.

Module status: programmed vs. pending

The terms “programmed” and “pending” refer to whether or not a module's representation in the node diagram matches the node itself.

**Programmed:** A programmed module is one that is the same both in the node diagram and in the node. The links, labels and setup register values in the node diagram exactly match those on the node. When you first open a node diagram, all the modules appear programmed since they are read directly from the node itself and then displayed in the node diagram.

**Pending:** A pending module is one where changes have been made to the module in the node diagram and not yet sent to the node, so the node diagram does not match the node. The borders of pending module icons appear as a dashed line.

If you change a module in the node diagram (for example, re-link it or edit its setup registers), it does not match the node until you select File > Send & Save. Until it is saved, the edited module is depicted as pending to indicate that it does not match the configuration on the node. When you send and save your changes to the node, the module becomes programmed.

Core modules and standard modules

There are two basic types of ION modules: core (left) and standard (right).
Core modules are required ION modules that are fundamental to the operation of the node. You cannot add or delete core modules and, in some cases, you cannot configure them. Core module icons are identified by a double border around the edge. The Power Meter module is an example of a core module.

Standard modules are reusable ION modules. Generally, most modules in a node are standard modules. You can add or delete standard modules as required. Standard modules icons are identified by a single border. The Setpoint module is an example of a standard module.

**Persistent modules**

Similar to core modules in that they cannot be added or deleted, persistent modules are standard modules that have been converted to core modules. These modules are created at the factory, and can never be removed from the meter frameworks. Persistent modules are represented by icons with single borders.

An example of a persistent module is External Pulse module #1 on the ION8600 meter. This module pulses when the Demand Reset switch is pressed on the meter.

**Using ION modules**

You can change the function of a node by editing the appropriate module(s) in the node diagram and linking modules together.

This section describes how to locate an existing module, how to add a new module, and how to delete a module. It also explains how to create a shortcut to a module and how to view the contents of a module in text format.

After you have located or added the module you want, you can configure it using the procedure described in "Linking ION modules" on page 186.

**Using the ION modules toolbox**

The ION Modules toolbox is a collection of ION modules and generic tools that you can add to a node diagram. To display the ION Modules toolbox, select **Options > Show Toolbox**.
The type and quantity of modules offered on the toolbox varies depending on the type of node you are configuring; however, the generic tools (the grouping and text objects) are available for all nodes.

**NOTE:** To identify a module in the toolbox, point to it with the mouse—the module type is displayed as a ToolTip and on the status line at the bottom of the screen.

To add a module to your node diagram (and to the node itself), drag its icon from the toolbox into the diagram window.

**Opening the ION modules toolbox**
To open the toolbox, select **Options > Show Toolbox**.

**Closing the ION Modules Toolbox**
Click the **Close button** or clear **Options > Show Toolbox**.

**Locating an existing ION module**
Before you can edit a module, you must first locate it in the node diagram. To find a module in a node diagram, you can use the module tray feature of the toolbox.

**Locating an existing module from the Module Tray**
1. To display the module tray, right-click the toolbox icon for the type of module you want to locate. The module tray appears beside the toolbox.
The module tray displays links to all modules of that type that are currently in use on the node—for example, in the image above, there are eight Display modules in use by the node. To identify a link in the tray, point to it—the module’s label is displayed on the status line at the bottom of the screen.

2. To locate a particular module, click its link in the module tray. Designer locates the module and displays it in the center of the workspace. If the module is located inside a grouping window, Designer opens the window to display the module.

**TIP:** To close the module tray, click on any module icon in the toolbox.

### Adding a new ION module

Most nodes are pre-programmed at the factory to provide the most commonly required functions. However, if the factory default configuration is not appropriate for your application, you can add a new module.

**Adding a module on a node**

Drag the icon of the module you want to add from the toolbox onto the node diagram.

As you drag the icon, the cursor changes shape to indicate you are placing an object.

Designer adds the module and places a pending module icon into the diagram. You can then link and configure the module.

See "Linking ION modules" on page 186 for more information on programming modules.

### Deleting or cutting an ION module

To remove a standard module from a node, delete its icon from the node diagram. By removing unnecessary modules from the node, you can free up resources for use elsewhere.
NOTICE

UNINTENDED DEVICE OPERATION
Do not delete any ION modules without knowing which modules are dependent on it.

Failure to follow these instructions can result in the unintended operation of the remaining modules.

NOTE: Each time a module is deleted, all of its output registers, setup registers and input links are deleted as well. Removing this information from the node affects the operation of any modules that depend on it. For this reason, you should be aware of all dependent modules (also known as owners) before you delete anything.

Checking for dependent modules
When two linked modules are located in the same window, Designer depicts the link as a line that runs from the output register of one module to the input of another. You can easily identify the dependent module (or owner) by the line running to its input. However, if one of the linked modules is located in a different window, the connection is not visible. A more effective way to locate a module’s owners is to view the owners of its registers.

Viewing the owners of a module’s setup and output registers
You can view a register’s owners to quickly identify all dependent modules on the node. You can determine what purpose the modules serve, and then decide whether to delete them or not.

1. Do one of the following to open the Owners dialog:
   - To view the owners of a module’s output registers, right-click the output symbol.
   - To view the owners of a module’s setup registers, hold the CTRL key and then right-click the output symbol.

   The dialog lists all of the module’s registers and any dependent modules on the node (dependent modules on other nodes are not displayed).

2. Click a register in the Registers list to display the owners of that register in the Owners list on the right. Owner information includes the module name or label and its relevant input.

3. If necessary, delete the link between a register and one of its owners. Select the owner from the Owners list and click Unlink. (See "Deleting links" on page 190 for more information on deleting module links.)

4. When you have finished viewing the register owners, click OK.
Viewing owners on other nodes

Displaying a module’s register owners is an effective way to locate dependent modules on the selected node but it does not show any dependent modules located on another node.

If you remove a module with a dependent module on another node, the dependent module’s inputs are not reset. It continues to look for the deleted output register.

If you are not sure whether a module has dependents on other nodes, check with the person who programmed them to ensure you do not disrupt the operation of any modules on that node. If you still want to remove the module, you may want to directly delete the link on the other node first. In this way the module is not inadvertently linked to the next module to occupy the location of the deleted module.

Deleting or cutting an ION module

After you have determined that you can remove an ION module without disrupting other functions, there are two ways to remove it: delete and discard the module or cut the module to paste it in another location.

In either case, Designer immediately removes the icon from the node diagram and deletes the module from the node. The difference is, when you delete a module, it is discarded; when you cut a module, it can be restored (by selecting Edit > Paste).

**NOTE:** You do not have to select Send & Save Changes to delete a module. Designer immediately removes the module from both the diagram and the node.

Removing an ION module from the node

1. Select the icon(s) of the module(s) you want to remove.

2. Do one of the following:
   - To cut the module(s) to paste it in another location, select Edit > Cut.
   - To discard the module(s), press the Delete key.

**NOTICE**

**UNINTENDED DEVICE OPERATION**

Do not delete any ION modules without knowing which modules are dependent on it.

**Failure to follow these instructions can result in the unintended operation of the remaining modules.**

**NOTE:** If a module has a dependent module on another node, Designer does NOT alert you of the dependency when you delete it. Before you delete a module, ensure that you are aware of all links to modules on other nodes.

Designer displays a summary of the proposed changes.
The summary lists all selected modules, and identifies those in the selection that will be deleted (including those with dependents on that node) and those that will not. Select a module in this list to display any additional information available in the field at the bottom of the dialog.

3. Click **OK** to remove the selected modules (or **Cancel** to abort the procedure).

   Designer removes the module icon from the node diagram and deletes the module from the node itself.

   **NOTE:** If you delete a shortcut icon, the original module is not affected. However, when you delete the original module, all shortcuts to that module are also deleted.

### Viewing a node or module as text

You can use the View Diagram Text command to display as text the complete contents of one or more modules or of an entire node. Use this option to view the specified information on your screen so you can sort it, perform analysis, create a detailed record of your node's configuration, or print a copy for your records.

1. Select the module(s) that you want to display.

   **TIP:** To select all modules in the node, left-click on the background of the main node window, being careful not to click on a module icon, then select **Edit > Select All**.

2. Select **Options > View Diagram Text** to open the **Text View** screen. The text of any modules that are offline appears in red.

   - The Text View screen offers several ways to view, sort and find information:
   - In the View dropdown list, select one of two view modes:
     - Use **Archive** to display information useful for archiving the node's configuration.
     - Use **Diagnostic** to display diagnostic information on the selected module(s).
In the **Sort by** dropdown list, select the criteria by which you want to sort the data:

<table>
<thead>
<tr>
<th>Archive View</th>
<th>Diagnostic View</th>
<th>Sorts by</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default</td>
<td>Default</td>
<td>Module label</td>
</tr>
<tr>
<td>Module Class</td>
<td>Module Class</td>
<td>Type of module</td>
</tr>
<tr>
<td>Module Name</td>
<td>Module Name</td>
<td>Default label</td>
</tr>
<tr>
<td><strong>Module State</strong></td>
<td></td>
<td>Displays offline modules first followed by online modules. Sorts alphabetically within each group.</td>
</tr>
<tr>
<td><strong>Module Update Period</strong></td>
<td></td>
<td>Displays event driven modules first, then inactive (not updating) modules, followed by high-speed (one cycle updates) modules, and finally high-accuracy (one second updates) modules. Sorts alphabetically within each group.</td>
</tr>
</tbody>
</table>

In the **Find** text field, type a text string and click **Find** to find that text string in the data.

To reset the text view after you have made a configuration change, click **Refresh**. If you want to print a copy of the text view information, click **Print**. When you are finished viewing the text view information, click **Close**.

### Creating a shortcut to an ION module

To save time switching between modules in different windows, create a shortcut icon in one window that represents the original module in the other window.

A shortcut icon is identified by a symbol in the lower left corner of a module icon.

### Creating a Shortcut Icon

Hold down **SHIFT+CTRL** then drag the module icon(s) to the window where you want to place the shortcut(s).

After you have created a shortcut icon, you can use it in the same way you use the original module icon. Both icons support the same features. However, if you delete the shortcut icon, the original module icon is not deleted; whereas if you delete the module icon, it deletes all shortcuts to that module.

**NOTE:** You cannot create more than one shortcut icon per window for a single module.

### Adding a text box to a node diagram

You can place a text box anywhere in a node diagram, and move it or resize it as necessary. You can use a text box to describe any process or function in your system; for example, you can label individual components of your system or display a block of descriptive text or instructions.
Adding a Text Box

1. Drag a **Text Box** object (▃▃) from the toolbox onto the node diagram.
   
   A text box opens in the diagram with the default message: “Your text goes here.”

2. Right-click the text box to replace the default text with your own text. The **Text Box Configuration** dialog opens.
   
   - Select the **Edit Text** tab, then do one of the following:
   
     - To display the name of the node in the text box, select **Use Default**.
   
   3. To display your own message, select **Use Custom** and type your text into the field provided.

4. Click **OK**. The text box displays your specified text.

Resizing a Text Box

To resize a text box:

1. Select the text box.

2. Do one of the following:
   
   - To make the object larger or smaller, drag a corner handle.
   
   - To stretch the object horizontally or vertically, drag a middle handle.

Changing the font of a Text Box

The font, size and style of the text used in the text box is based on the default setting specified for the active window. If you want to use a different font, you can specify a new font for the text box:

1. Right-click the text box to open the **Text Box Configuration** dialog.

2. Select the **Text** tab.

3. In the Font section, do one of the following.
   
   - To use the font specified for the parent window, select **Inherit from parent window**.
   
   - To use a different font, select **Custom**, then click **Font** to open the **Font** dialog. Specify a font, style, and size. Click **OK** to continue.

4. Click **OK**.

Changing the position of the Text

To change the position of the text in the text box:

1. Right-click the text box to open the **Text Box Configuration** dialog.

2. Select the **Text** tab.
3. In the Position section, select **Left**, **Center**, or **Right**.

4. Click **OK**.

**Adding a border or background color to a Text Box**

To add a border to a text box or change its background color:

1. Right-click the text box to open the **Text Box Configuration** dialog.

2. Select the **Box** tab.

3. Do one or more of the following:
   - To add a border, select **Show** in the Border section and click **Color** to select a border color.
   - To set the width of the border, type a border width in the “Width in pixels” field in the Border section.
   - To add a background color, select **Custom** in the Background Color section and click **Color** to select a background color.

4. Click **OK**.

**Linking ION modules**

Linking ION modules together is the foundation of programming ION-compliant nodes in Power Monitoring Expert. Although an ION module can perform a function in isolation, the strength and flexibility of the ION architecture comes from the ability to interconnect modules to build more sophisticated functions.

**Choosing which ION modules to link**

The first step in linking modules is to decide which modules you want to use. When choosing a module to link, you have two choices: you can add and link a new module or you can re-link an existing module.

In some cases, you may not want to add a new module. For example, if all the modules of a particular type are already used, you need to re-link one of them to perform the new function. Most devices are preconfigured at the factory to provide common measurements and calculations. If any of these factory defaults are unnecessary in your application, you can unlink the modules involved and reuse them.

Plan ahead before you add new modules. Unlinked modules are wasted resources.

You may find a linked module that you can use to add a new link, in order to augment the function it is performing. For example, if you have a Setpoint module that triggers a waveform recording, then later decide to use this trigger to reset a counter, you can link that Counter module to the same Setpoint that controls the Waveform Recorder module.
Linking ION modules graphically

Linking modules graphically means pointing and clicking a module’s input, then clicking another module’s output register to link it (note that both input and output register classes must be compatible). You can use this method to link to modules on the same node or to create links across nodes.

You can use the autolinking feature to speed up the process of linking ION modules. Typically, linking ION modules involves connecting the output register of one module to the input of another. In many cases, only one of the module’s inputs have the same register class as the selected output register.

If autolinking is enabled, Designer automatically selects the appropriate input and establishes the link. If necessary, it overwrites an existing link. This relieves you from having to manually select the input; however, you cannot see what input you are linking to.

By default, autolinking is disabled. You should only use autolinking if you are thoroughly familiar with all the inputs and output registers of the modules you are working with so that you do not inadvertently create undesirable links.

Enabling autolinking
To enable autolinking, select Options > Enable Autolinking. A check mark beside the option indicates it is selected.

Disabling autolinking
To disable autolinking, clear Options > Enable Autolinking.

Linking ION modules on the same node
If the selected node is a meter such as the ION7650, the process of configuring the node primarily involves creating links between modules on that node.

**NOTE:** To cancel a link-in-progress, click anywhere in the background of the window or press the ESC key.

Linking modules using the point and click method
1. To list a module’s output registers, click the output symbol on the right side of the module icon. To list the module’s setup registers, hold the CTRL key while clicking the output symbol.

   Either a menu opens or, if the module has many registers, a dialog opens listing the available registers.

2. Select the register you want to link:

   - In the menu, click the register you want to select.
   - In the dialog, double-click the register (or click it then click Select).

3. Move the cursor towards the module you want to link to. The cursor changes and a
dotted line follows it across the node diagram. This indicates you are in the process of creating a link and it shows where the connecting line will appear in the node diagram.

If you link to a module that is in a different window than the original module (either in a different node diagram or grouping window) the dotted line disappears but the cursor still indicates that a link is in progress.

If the module you want is obscured by another window, click on the title bar of the window containing the module. This brings the window to the foreground without canceling the link. (If you click on the background of the window, the link is cancelled.)

4. Click the input symbol of the module that you want to link to display the module’s inputs. Either a menu opens or, if the module has many registers, a dialog opens listing the module’s inputs.

If the input is already linked, the label of the register it is linked to is displayed beside the input. If you select the input, the existing link is overwritten.

The inputs that are of a different class than the selected output register are grayed out to indicate you cannot select them.

5. Select the input you want to link to:
   - In the menu, click the register you want to select.
   - In the dialog, double-click the register (or click it then click Select).

6. Select File > Send & Save to save your changes to the node.

The procedure described above can also be performed in reverse order. You can select a module's input first and then link it to another module's output register.

**Linking modules with variable number of inputs**

Some modules, such as AND/OR modules, Data Recorder modules, and Log Acquisition modules have a variable number of inputs. In these cases, when you click on the input symbol, the menu offers one instance of the variable input as well as any fixed inputs the module may have. When linking to one of these modules, you can select the **NEW Source** item to add a new link or you can select an existing link and overwrite it.

If the two modules are in the same window, the line remains on the screen to show the link between the modules—when you save this change to the node, the line changes from a dotted line to a thin black line to indicate that the link is now programmed on the node.

**Linking ION modules across different nodes**

If the selected node is a software node, such as the Virtual Processor or Log Inserter, many of the links you create are to modules on other nodes. When you create links across different nodes, it is important to keep track of these links and note what modules are dependent on others. This helps you determine what will happen if you ever want to delete a module that is linked to a module on another node.
NOTE: You cannot link modules on one device to another. For example, you cannot create a link between a module on an ION7330 to a module on a different ION7330 or to a module on another meter.

1. Open the node diagrams that contain the modules you want to link.
2. Position the diagrams within the workspace so you can see the two modules you want to link.
3. In the first node diagram, click on the output symbol of the module icon. A menu or dialog opens listing the module's output registers.
4. In the list of output registers, click the register you want. (In the case of the dialog, click a register and then click Select.)
5. Drag the cursor from the first node diagram to the module you want to link to in the second node diagram. The dotted line ceases to follow the cursor if it crosses the window boundary but the cursor changes to indicate a link is in progress.
6. Click on the input symbol of the module icon in the second node diagram. A menu or dialog opens listing the module's inputs. Those that are of a different class than the selected output register are grayed out to indicate you cannot select them.
7. Click the input you want, or in the case of the dialog, click the input then click Select. Designer does not graphically represent links between modules on different nodes so you will not see a line connecting the modules.
8. Select File > Send & Save to save your changes to the node.

This procedure can also be performed in reverse order. You can select a module's input first and then link it to another module's output register.

NOTE: If the input is already linked, the label of the register it is linked to is displayed beside the input. If you select this input, the existing link is overwritten.

A note about performance

While creating links, you may notice that the circle at the end of the arrow cursor is sometimes black (●). This indicates that Designer is in the process of retrieving information about a module. You can still click on the inputs or outputs of other modules, but Designer aborts the original request. To minimize the amount of communications between Designer and the connected nodes, avoid unnecessary clicking on the input and output symbols.

If you click on several items in a row, you only see the menu for the last item you click; however, Designer initiates many requests for information, which may impact its performance.
Linking ION modules using the ION tree

In some cases, you may want to use the ION tree to select the register for linking. The ION tree is a hierarchical listing of every node, manager, module, and register in the Power Monitoring Expert network. It allows you to select a register on a node without opening the node diagram. Generally, you use the ION tree to create links across nodes.

The ION tree is also the only way to select registers from devices that are not ION-compliant (and use translators to make data available) such as 3000 series meters. For example, if you are programming a Virtual Processor node and you want to sum data from several 3720 ACMs, you must access the 3720 ACM register via the ION tree.

Using the ION tree is faster than opening a node diagram. It is useful if you want to link to a register on a node whose diagram has not yet been opened. It is also useful if you want to link to a register, but you are not acquainted with the configuration of the node in which it resides. You can go straight to the register without having to navigate through an unfamiliar node diagram. Also, since a diagram can only be accessed by one user at a time, you can use the ION tree to link to a register on another node where the diagram is already open.

Linking modules using the ION tree

1. Click the input symbol of the module icon. A list of the module's inputs is displayed.
2. In the list of inputs, select the input you want to link.
3. Click the ION button in the toolbar. (To link a module's setup register, hold the CTRL key while clicking this button.)
   The Create Link dialog opens, providing access to the ION tree.
4. Specify a node, manager, module and output register: Double-click the node you want in the Nodes box. All managers within the selected node appear in the Managers box. You can then double-click the manager you want, and repeat this procedure for the modules and registers.
5. Click OK. The module whose inputs changed appears grayed-out to indicate it is now pending. If both modules are in the same window of the same node diagram, a line appears to represent the link.
6. Select File > Send & Save. The new link is established and the module appears programmed.

The procedure described above can also be performed in the reverse order. You can click the ION button first, select an output register, and then click the input symbol of a module icon to select one of its inputs.

Deleting links

If you want to disassemble a group of linked modules and use them for another function, you can delete the links between the modules rather than deleting the modules. Designer provides several ways to delete links.
Fixed links
Most links between standard modules can be deleted. However, some links between core modules are fixed and cannot be deleted. These fixed links include:

- Data Acquisition module and all Power Meter modules.
- Data Acquisition module and all FFT modules.
- FFT module and all Harmonics Analyzer modules.
- FFT module and all Symmetrical Components modules.

If you attempt to delete a fixed link, Designer informs you that the link cannot be deleted.

Deleting visible links
If the linked modules are in the same window, simply click on the link line and press the **Delete** key. This works well as long as you know which output register and input are involved. For example, in the image below, to delete the link click on the line joining the Power Meter and the Sliding Window Demand module (its color reverses to indicate it is selected) and press **Delete**.

![Power Meter and kW swd](image)

If there are multiple lines between the same modules and you only want to delete one of the links, you may want to use the method described in "Deleting links that are not visible" below.

Deleting links that are not visible
If you cannot see a line that links the modules (for example, if they are in different windows), or you need to know which output registers and which inputs are involved, you must use a dialog to delete the link between modules. You can look either at the output register owners of the first module or you can look at the inputs of the second module to see what they are linked to, and then delete the link from there.

Deleting a module's input links
Deleting links at a module's inputs is generally faster than deleting them at the module's output registers because Designer does not need to check the entire node. On the other hand, there is less information available if you view input links. All you see is the label of the output register that is linked to the input. If this is sufficient information, proceed with this method; if not, go to the output registers to delete the link.

Viewing a module's input links
1. Right-click the input symbol of the module icon to open the **Delete Links** dialog.
2. Each input and the label of the output register it is linked to are displayed in the dialog. To delete one or more of these links, select the input and click **Unlink**. The output register label is replaced with dashed lines.
3. When you have unlinked all the registers you need to, click OK.

4. Select Send & Save to unlink the modules on the node.

Deleting a module's output links

You can also delete links from the Register Owners dialog. This method gives you the most information about the link you are deleting (the output register label and the input and label of the module it is linked to).

Viewing a module's output links

1. Right-click the output symbol side of the module icon to open the Register Owners dialog. (To list the module's setup registers, hold the CTRL key while right-clicking on the symbol.)

2. Select the output register you want from the Registers section. The Owners section lists all the module inputs to which the selected register is linked.

3. To delete one or more of these links, select the module input in the Owners list box and click Unlink. The input name is replaced with a dashed line.

4. When you have unlinked all of the module inputs you want, click OK.

5. Select Send & Save to unlink the module inputs on the node.

NOTE: Owners that reside on a different node are NOT displayed in this dialog. If you need to delete a link between modules on different nodes, use the procedure described in "Deleting a module's input links" on page 191.

Configuring ION modules

After you have placed a module in a node diagram, you can configure the various setup parameters of the module. It is not necessary to do this before you link the modules but you should ensure the module is set up correctly before sending the configuration to the node.

⚠️ WARNING

UNINTENDED EQUIPMENT OPERATION

- ION modules and registers must only be configured by personnel with a thorough understanding of ION architecture and the system in which meters and software are installed.

- Do not use a controlled output for any safety critical application due to possible unexpected changes of state during power cycles, power outages, configuration changes, or firmware upgrades.

Failure to follow these instructions can result in death, serious injury, or equipment damage.
Module setup parameters include the module's label; its setup registers, labels and values; and its output register labels. To access these, right-click the symbol in the center of the module icon.

A Right-click the graphic to access the module's setup parameters

The ION Module Setup dialog opens.

The Setup Registers box lists all the setup registers of the module along with their current values or settings. To change any of the settings or assign a custom label to a setup register, select the register, then click **Modify** (or double-click on the register) to open the **Modify Register** dialog where you can make modifications.

In most cases, configuring a setup register is a simple matter of entering a number, entering text, or choosing an option from a list. (To determine the options or ranges available for a setup register, refer to the module's description in the ION Reference.)

When you have completed all your modifications to the module, click **OK** to return to the node diagram. The module icon appears pending until you send and save your changes.

**Modifying enumerated, numeric bounded, and string setup registers**

If the register you have selected is an enumerated, numeric bounded or string register, one of the following dialogs appear when you click **Modify**:

**Enumerated registers**

To modify an enumerated register, select an option from the Options list.

**Numeric bounded registers**

To modify a numeric bounded register, type a number in the Value box. The allowable range is shown under the Value box; you are alerted if you type a number outside this range.

To enter a formatted numeric value, click **Format**. In the **Time Interval Value** dialog, you can enter the numeric value as a date (offset from Jan 1, 1970) or a time interval.

**String registers**

To modify a string register, type your text in the String box.

Note that when you click **Modify** for a string register that is the connection string for a Log Acquisition module or Query module, the **Modify Database Connection Properties** dialog opens.

**Modifying calendar setup registers**

The ION Scheduler module has a special class of setup register called a calendar register. Configuring a calendar register is only necessary for nodes that have a Scheduler module. For detailed information on how to configure a calendar register, see the description of the Scheduler module in the ION Reference.
Modifying address setup registers

All Distributed Numeric, Distributed Boolean, and Distributed Pulse modules contain an address setup register that references another register. You can specify a new value or clear an existing value as required. (Currently, the Virtual Processor is the only node offering these types of modules.)

**NOTE:** Currently, you can only link the address setup register to External Numeric, External Boolean, and External Pulse registers.

Modifying an address setup register

1. Right-click a Distributed Numeric, Distributed Boolean or Distributed Pulse to open the ION Module Setup dialog.

2. In the Setup Registers section, select a register then click **Modify** to open the **Modify Address Register** dialog.

3. In the **Modify Address Register** dialog, double-click on the node, manager, module and output register you want to use. Click **OK** to continue.

4. Click **OK** in the ION Module Setup dialog.

**NOTE:** You can clear the value of an address setup register. On the **Modify Address Register** dialog, select **Reset Register Value** and then click **OK**.

Parent module and shared setup registers

Setup registers that are surrounded by asterisks (for example, ***PM1 PT Sec***) indicate that the module shares its setup registers with another ("parent") module. An example of this is the High-Speed Power Meter or Meter Units Power Meter module ("HS Power Meter", "MU Power Meter"). They share their setup registers with the parent Power Meter module.

If you try to modify a shared setup register, a prompt identifies the register as shared and gives the name of the parent module.

Navigate to the parent module and change the setup register there.

Using custom labels

You can assign custom labels to modules, setup registers, output registers, and Boolean ON/OFF conditions. All modules and registers have a default label and this label is what you see in node diagrams, user diagrams and event logs unless you specify a custom label.

Creating custom labels allows you to clearly describe what the module and its registers have been set up to do.

However, carefully consider which modules and registers should be assigned custom labels. There is a fixed number of labels available, but there are thousands of registers you can
assign them to. Many of these registers do not benefit from custom labels. For example, most setup registers can be left at their default names since the only place their names might appear is in the event log.

**NOTE:** Some devices, such as the ION7300 and ION7700, have a 15-character limit for labels.

### Customizing a module label

The ION Module Setup dialog allows you to edit the module label. The module label is the text that appears across the top of the module icon in the node diagram. It is also the label that is used in event logs and in the dialog for the ION tree.

1. In the **ION Module Setup** dialog, do one of the following:
   - To create a custom label, select **Use Custom Label** and then type a name for the label in the box.
   - To use the default label, select **Use Default Label**.
2. Click **OK** to return to the node diagram.

### Customizing an output register label

By providing a custom label for an output register, you can clearly indicate the information that register contains. For example, if you have linked the Vlna output register of a Power Meter module to a Thermal Demand module, and in turn linked the ThrmDemand output register to a Maximum module, you may want to label the Maximum module’s output register as “Va TD Maximum” (instead of using the default name of “Maximum 1”).

1. In the **ION Module Setup** dialog, select the output register in the Output Registers area and then click **Modify** to open the **Modify Label** dialog.
2. Do one of the following:
   - To create a custom label, select **Use Custom Label** and then type a name for the label in the box.
   - To use the default label, select **Use Default Label**.
3. Click **OK** to return to the **ION Module Setup** dialog.

### Customizing Boolean ON/OFF labels

If the output registers of the module are Boolean, you can create custom labels to associate with the ON and OFF conditions of these registers. These labels can clarify exactly what the ON or OFF conditions represent. For example, if a Boolean output register is used to switch a fan on and off, you could create a Boolean ON label called “Fan Running” and an OFF label called “Fan Not Running.”

1. In the **ION Module Setup** dialog, select the Boolean output register and then click **Modify** to open the **Modify Boolean Register** dialog.
2. Do one of the following:
   - To create custom labels, select **Use Custom Labels** and then type names for the Register Label, ON Label and OFF Label in the appropriate fields.
   - To use the default labels, select **Use Default Labels**.

3. Click **OK** to return to the **ION Module Setup** dialog.

**Customizing a setup register label**

1. In the **ION Module Setup** dialog, select the setup register and click **Modify**.

2. Do one of the following:
   - To create a custom label, select **Use Custom Label** and then type a name for the label in the field.
   - To use the default label, select **Use Default Label**.

3. Click **OK** to return to the **ION Module Setup** dialog.

**Resetting ION modules in a node diagram**

Designer allows you to undo certain changes you have made in a node diagram since the last time you saved and sent your changes to the node. It refreshes the selected module icons so they reflect what is actually on the node. Reversible changes include:

- Changing the value of a setup register.
- Changing module or register labels.
- Changing the links between modules.

**NOTE**: Since adding and deleting modules happens immediately on a node, you cannot undo the deletion or the creation of a module.

To reset ION Modules:

1. Select the module(s) you want to reset.

2. Select **Edit > Reset**.

All the changes made to the selected modules since the last time you sent and saved the node diagram are discarded. Modules not included in the selection are unaffected (that is, if they had pending changes, the changes are still pending.)

**Fast-linking ION modules in the Log Inserter**

When linking modules in the Log Inserter, you can save time by using the Fast Linker utility. The Fast Linker automates much of the linking process, enabling you to quickly link any combination of event, data or waveform recorders. To access the Fast Linker options, press the CTRL key and click on the Log Inserter inputs.

For more information on using the Fast Linker utility, refer to the description for the Log Acquisition module in the **ION Reference**.
Copying and pasting ION modules

You can easily create a new function in a node diagram by copying and pasting modules. You can copy and paste a single module, a group of modules, grouping icons, text objects, or the entire node.

You can copy modules from one node and paste them into another, as long as the node you are pasting to supports the selected modules and has sufficient resources. When pasting modules, you can replace existing modules or add new ones.

You can also copy modules and save them as a framework. You and other users can then reuse this framework in other nodes. Saving a node’s configuration as a framework provides a fast and easy way to program a large number of nodes at once.

**NOTE:** Persistent modules cannot be deleted, but they can be overwritten during a framework paste. Overwriting a persistent module effectively relinks its outputs and rewrites its label, but its core functionality remains intact (for example, the Master Reset module may be relabeled, but pulsing this module still initiates a master reset). When pasting a default framework onto a meter, use lock-paste to ensure that all persistent modules in the "old" default framework are overwritten by the corresponding persistent module in the "new" default framework. Persistent modules are listed in the "ION Device Template Reference".

**Copying modules**

Designer offers two ways to create copies of modules: copy and paste using the product's clipboard or copy or paste using a framework.

**NOTE:** The Power Monitoring Expert Clipboard is a temporary storage area that holds any information cut or copied from Designer. This clipboard should not be confused with the Windows Clipboard.

When you copy a selection of ION modules, you can use **Copy, Cut, or Copy to Framework**:

- **Copy** saves the selection to the clipboard and leaves the original module(s) intact.
- **Cut** saves the selection to the clipboard and removes the original module(s).
- **Copy to framework** saves the selection as a file and leaves the original modules intact.

Additional considerations include pasting with shortcuts, modules that cannot be pasted, and cloning a node (copying and pasting an entire node configuration from one node diagram to another).

**Cutting or copying ION modules to the clipboard**

Use the Cut or Copy command to save a temporary copy of the selected modules to the clipboard. You can then use the Paste command to transfer the selection from the clipboard into any node diagram. Each copy retains the setup register values, custom labels, link
information and layout of the original selection.

**NOTE:** When selecting modules to be cut or copied, you can also include grouping icons and text objects. If you select a grouping icon, all modules within the group are copied, as well as any nested grouping icons.

1. Select the module(s) you want to cut or copy.
2. Do one of the following:
   - To cut the selection to the clipboard and remove the original, select **Edit > Cut**. Designer copies the requested information to the clipboard.
   - To copy the selection to the clipboard and retain the original, select **Edit > Copy**.
   After the selection has been copied to the clipboard, you can select **Edit > Paste** to paste it into any user diagram.

**Copying ION modules to a framework**

You can use the **Copy to framework** command to create a framework from the selected modules. A framework is a template that you can use to reproduce a group of modules. Unlike regular copying and pasting, a framework is stored as a file so you can paste it later.

When you select **Edit > Copy to framework**, Designer copies the layout, linking and configuration information of each module in the selected group. It saves the framework as an .fwn file. You can then use the **Paste from framework** command to paste the group in another node diagram.

You can use frameworks to simplify the process of programming multiple devices with similar configurations. For example, if you wanted to program a single function into several nodes, you could program the first node and then copy the configuration to a framework. You could then quickly program the other nodes by simply opening their node diagrams and pasting the framework you created. You can also use frameworks to program an entire node at once, considerably reducing the amount of time required to set up a large installation.

Before you save a group of modules as a framework, consider carefully which modules you want to include. If you include core modules in your framework, you will not be able to paste them unless you overwrite the existing core modules that correspond to those in your framework. Another approach is to select the modules “downstream” of the core module and save them as a framework. Then when you paste the framework into another node diagram, you can use the Maintain External Inputs option to preserve your links to the original core modules. (See "Using the Paste Summary dialog" on page 200 for more information.)

**NOTE:** After you have saved a framework, it can be used in another node diagram, as long as the node supports the modules included in the framework. Although it is possible to create a framework from one node type and use it with another node type, it is advisable to restrict your use of frameworks to nodes of the same type.
Copying a group of ION Modules to a framework

1. Select the group of module icons you want to copy.
2. Select Edit > Copy to Framework to open the Copy to Framework dialog.
3. In the File Name field, type a name for the framework, then click Save. The framework filename extension (.fwn) is added automatically and the selection is saved as a framework file.

After you have copied a group to a framework, you can select Edit > Paste from framework to paste it into a node diagram.

Pasting ION modules

You can paste a saved copy of one or more modules into any node diagram. Designer offers two ways to paste modules:

- **Paste** inserts a selection that has been placed on the clipboard using the Cut or Copy command
- **Paste from framework** inserts a selection that has been saved as a file

Pasting modules is a little more complicated than copying them, because the action of adding modules to the node may require you to replace existing modules. Whether you choose Paste or Paste from framework, Designer displays a Paste Summary dialog that explains each aspect of the proposed changes.

You can use the Paste Summary box to define how to integrate the source modules into the destination modules. For example, if a source module is being pasted to a destination that is already occupied, you can either lock paste the new module over the existing one or free paste the new module into the next available destination.

If you paste a selection that contains a shortcut, Designer may paste the shortcut as a module. (See "Pasting shortcuts" on page 203 for more information.)

In some cases, Designer may not paste every module in your selection. (See "Modules that cannot be pasted" on page 204 for more information.)

Pasting ION modules from the clipboard or a framework

When pasting modules, the first thing to do is select the node diagram and window where you want the modules to go. If you have more than one window open, you can click on the title bar of the window you want to make it the active window.

**NOTE:** You can paste modules into the same node diagram they were copied from or into a different one.

You can paste modules from two sources: the clipboard or a framework. When you paste a selection from either source, Designer describes the proposed changes in the Paste Summary dialog. You can use the Paste Summary area to review your changes and make modifications as necessary.
**NOTICE**

**UNINTENDED DEVICE OPERATION**
- Do not use the lock paste option to overwrite existing destination modules.
- Only use the lock paste option if you are an advanced user familiar with ION architecture.

Failure to follow these instructions can result in operational differences in required modules.

**NOTE**: The lock paste option overwrites an existing module but the outputs from that module are retained as inputs of other modules. Consequently, the module may not operate as expected. (See "Using the Paste Summary dialog" on page 200 for more information.)

**Pasting ION modules into a node diagram**

1. Open the window where you want the modules to go. Click in the background of the window to clear any selected modules.

2. Do one of the following:
   - To paste a selection from the clipboard, select **Edit > Paste**.
   - To paste a selection from a framework, select **Edit > Paste from Framework**. In the Paste from Framework box, select the file you want and then click **Open**.

3. The **Paste Summary** dialog opens. Use the Paste Summary area to review the proposed changes (see "Using the Paste Summary dialog", below, for more information). When you are satisfied with the summary, click **OK** to complete the procedure.

The selection is pasted into the active window. The entire selection is automatically selected so you can easily move it to a clear area in the window. All module icons in the selection appear as pending until you click **Send & Save** to save the changes to the node.

**Using the Paste Summary dialog**

Before Designer pastes a selection, it displays the **Paste Summary** dialog. Use the **Paste Summary** dialog to review and modify the proposed changes to the node diagram.

The **Paste Summary** dialog lists each module to be pasted and indicates its destination in the node. For each module, a short summary of the proposed modification as well as a more detailed description of how the module is pasted or why it cannot be pasted as requested displays in the dialog.
The following sections describe the various areas of the Paste Summary dialog.

Source
The Source column lists each module that was copied to the clipboard or framework. Each source module is listed by its default label unless a custom label has been specified (in which case the default name appears in brackets after the label). Select a module in this column to view additional information in the Details area at the bottom of the dialog.

Destination
The Destination column indicates where the copy of each source module will be placed in the node diagram. The module label listed in the Destination column may or may not match the module label listed in the Source column. (If the destination module is to be overwritten, it is reused; otherwise, the next available module is used.)

Summary
The Summary column indicates whether the source module is copied into the destination as a new module or if it replaces (overwrite) an existing module. This column also indicates if a module will not be pasted.

NOTE: You can sort the paste summary information alphabetically by source or destination, or by importance of summary. Click on the Source, Destination, or Summary column headers to sort the list by the chosen criteria.

Details
The Details area located at the bottom of the dialog provides more detail than the description in the Summary column. When you click on a module in the Source column, you can view a description of the proposed transaction in the Details box. This description explains how a module is pasted or offers reasons why it will not be pasted.
TIP: You can create a copy of the information displayed in the Details section of the Paste Summary box. To copy it, use the mouse to highlight the text you want, right-click the selection, then select Copy. You can then paste this selection into a word-processing program.

Maintain external inputs

The Maintain External Inputs check box allows you to paste the module selection with all external links intact. If this check box is cleared, all external links (links to modules outside the selection) are discarded.

The following example depicts an external link to a Power Meter module.

If you copied the two modules on the right but omitted the Power Meter module from the selection, the link to the Power Meter module would be external. Upon pasting the selection, the external link to this module would be lost unless you selected “Maintain external inputs” on the Paste Summary box.

Check Boxes (Free Paste/Lock Paste/No Paste)

The check boxes to the left of each module indicate the proposed action (that is, how the module will be pasted):

- A green check mark ✓ indicates a free paste.
- A check mark with a lock symbol ✖ indicates a lock paste.
- A red “X” symbol ✗ indicates the module will not be pasted.
- An “X” symbol without a check box ✗ identifies a module that has no possible destination and cannot be pasted.

You can click on a check box to change the proposed action. For example, if you click on a “free paste” ✓ or a “will not be pasted” ✗ symbol, it changes to a “lock paste” ✖ symbol. When you change the type of paste, the descriptions in the Summary column and the Details box also change to describe the new action. (See “Copying and pasting ION modules” on page 197, below, for more information.)
Free paste or lock paste?

You can use the free paste and lock paste options to instruct Designer how to respond to potential conflicts. For example, if you want to paste the module “Setpoint 1” into a diagram that already has a “Setpoint 1” module, you have two options. You can either add the new module under a new name (for example, “Setpoint 2”) or you can overwrite the existing module with the new one and reuse the old name.

The first option in the above example is a free paste. It can be used to paste new modules into a diagram without deleting any existing modules. This is useful for integrating new functions into a node without disrupting the node’s existing functionality. Although this may seem desirable, another option is available. By leaving existing modules intact, a free paste can result in needless duplication of functions. In addition, some groups of modules are interdependent and may require a lock paste to operate correctly.

The second option in the above example is a lock paste. It instructs Designer to recreate the source modules exactly, even if this requires Designer to overwrite existing modules in the diagram. When used to quickly replace old modules with new ones, lock pasting is an efficient alternative to the time-consuming process of deleting a module, adding a new one and then configuring it.

You can use a combination of both free paste and lock paste within a single paste operation.

**NOTE:** You can pre-select modules for Designer to reuse when free pasting. In the actual diagram where you paste the selection, press the SHIFT key and then click on any module icons that you don't want. When you paste the new selection, Designer has the option of replacing any of the selected modules with the new ones.

**NOTE:** Overwriting a module is not the same as deleting the module and then pasting a replacement module. If a module is overwritten, links from the outputs of that module are retained as the inputs of other modules. If a module is deleted, these links are also deleted and do not exist after the replacement module is pasted.

Pasting shortcuts

Identified by the symbol [shortcut], a shortcut icon is a representation of a module icon that is located in another window.

You can copy a shortcut in the same way you copy the original module, but when you paste a shortcut, one of two things happens: It is either pasted as a shortcut to an existing module (if one is available) or as a new module. In either case, it continues to perform its function as before.

There is a basic reason for replacing a shortcut with a module: a shortcut cannot exist in a node without the module it represents. When you paste a selection containing a shortcut, Designer searches both the selection to be pasted and the destination to locate the module the shortcut represents. If it finds the module, it pastes the shortcut as a shortcut. If it doesn’t
find the module, it replaces the shortcut with a copy of the module. In this way, Designer functions so that the pasted selection is complete and not dependent on a module that is unavailable in the destination node.

Designer performs this process automatically; it requires no input from you.

**Modules that cannot be pasted**

Some modules cannot be pasted because their settings are non-transferable between nodes. All Factory, Communications, and Diagnostics modules must be individually configured for each node.

When pasting a selection that contains a Factory, Communications or Diagnostics module, Designer pastes the location of the icons only.

**Cloning a node**

You can quickly configure multiple nodes by cloning a node. Essentially, cloning a node involves copying a node’s entire configuration into a framework then pasting it onto another node. This effectively reprograms the node receiving the framework as an exact copy of the original.

**NOTE:** When you paste an entire node’s configuration, the Factory, Communications, and Diagnostics modules are not pasted because they could disrupt the operation of the device’s communications. If you need to change the settings of these modules, you can do so manually.

**Copying a node’s entire configuration**

1. Open the node diagram of the node you want to copy. Ensure that you are in the main or root window of the diagram.
2. Select **Edit > Select All**. All core modules, standard modules, grouping windows and text icons are selected.
3. Select **Edit > Copy to framework** to open the **Copy to framework** dialog.
4. In the File name box, type a name for the framework and then click **Save**. The framework filename extension (.fwn) is added automatically and the entire node configuration is saved in this framework file.

After you have saved the source node’s configuration as a framework, you can paste it to other nodes of the same type. This file can also serve as a backup in case you want to restore the configuration of the source node.

**Pasting a node’s entire configuration into another node**

1. Open the node diagram of the node to which you want to paste the configuration. Ensure that you are in the main or root window of the diagram.
2. Select **Edit > Select All**. Press the **Delete** key to remove the node’s existing
configuration. A dialog opens listing the standard modules that will be deleted and the core modules that cannot be deleted. Click OK to continue.

The standard modules and text icons are deleted, and the core modules (and any grouping windows containing core modules) remain.

3. Select Edit > Select All to select the remaining module (and grouping) icons.

4. Select Edit > Paste from framework to open the Paste from framework dialog, select the framework file that contains the node configuration you want to paste, and then click Open.

   The Paste Summary dialog opens. (See "Using the Paste Summary dialog" on page 200 for information on using the Paste Summary box.)

5. Select all modules in the list (click last item, hold the SHIFT key, and then click first list item - the entire list appears highlighted).

6. Change the paste type to lock paste (hold the SHIFT key and then click the paste type check box until all modules are set to lock paste.

7. Click OK to complete the procedure.

The selected framework is pasted into the node diagram. All module icons in the selection appear as pending until you select Send & Save to save the changes to the node.

**Viewing output registers, setup registers, and inputs**

Each module icon has an input symbol and an output symbol. The input symbol (on the left) provides access to the module’s inputs and the output symbol (on the right) provides access to the module’s output and setup registers.

A register is a type of memory bank that stores a module's linking and configuration information. Each module uses two types of registers:

- Output registers store data that has been processed by the module (such as numeric values, event log entries, and waveform data).
- Setup registers store the module's configuration information.

Both types of registers serve as storage locations for the module.
Viewing output register information

Output register information includes the module's available output registers, the real-time values of the output registers and the owners of the output registers. Each of these can be accessed from the output symbol located on the right side of the module icon.

| A | Click the output symbol to access the module's output register information |

Viewing available output registers

Click the output symbol.

Viewing the real-time values of output registers

Press the SHIFT key and click the output symbol.

Viewing the owners of output registers

Right-click the output symbol. This displays an output register's owners so you can identify all dependent modules on the node and determine the purpose of each dependent module. This is useful when determining the effects and consequences of deleting a module.

Viewing setup register information

A module's setup registers contain its configuration information. When a module processes data, it manipulates the data according to the guidelines stored in its setup registers. Setup register information includes the module's available setup registers, the setup register settings, and the setup register owners. Each of these can be accessed from the output symbol located on the right side of the module icon.

| A | Right-click the graphic to access the ION Module Setup dialog. |
| B | Press CTRL and click the output symbol to access the ION Module Setup dialog. Press CTRL+SHIFT and click the output symbol to display the ION Module Setup dialog to view Setup Register settings. Press CTRL and right-click the output symbol to view SetupRegister owners. |

Viewing setup registers

Press the CTRL key and click the output symbol or right-click the graphic in the center of the module to display the ION Module Setup dialog.
Viewing setup register settings
Press CTRL+SHIFT and click the output symbol or right-click the graphic in the center of the module to display the ION Module Setup dialog.

Viewing setup register owners
Press the CTRL key and right-click the output symbol.

Viewing input information
Input information includes the module’s inputs and a sample of its real-time input values. Each of these can be accessed from the module’s input symbol.

Viewing inputs
Click the input symbol.

Viewing real-time input values
Press the SHIFT key and click the input symbol.

Virtual Processor service
The Virtual Processor is a service that operates on the Power Monitoring Expert server, providing coordinated data collection, data processing, and control functions for groups of meters. This makes distributed operations possible, providing customized solutions to a variety of industrial, commercial, and power utility needs.

⚠️ WARNING

UNINTENDED EQUIPMENT OPERATION
• Do not use control objects for time-critical functions because delays can occur between the time a control action is initiated and when that action is applied.
• Do not create a custom control object in Virtual Processor for remote equipment operation without configuring it with the appropriate access level, and without configuring a status object to indicate the status of the control operation.

Failure to follow these instructions can result in death, serious injury, or equipment damage.

The Virtual Processor lets you gather the information available from your network of power monitoring devices, and enables you to categorize, manipulate, and/or customize the data before distributing the information to the different departments in your company. You could
think of the Virtual Processor as a virtual device, capable of collecting and processing data from several power monitoring devices, analyzing the information and performing control functions as required. The Virtual Processor's name implies its characteristics:

- **Virtual** - The Virtual Processor runs in the memory of your PC, not as a remote device.
- **Processor** - The Virtual Processor contains a wide selection of ION modules, which it uses to process information.

**Using the Virtual Processor**

The Virtual Processor is not configured at the factory. To perform data collection, data analysis, Modbus communications, or distributed control, you must first create ION module frameworks, using Designer. Refer to the ION Reference for information on ION modules.

**Configuring the Virtual Processor with Designer**

Use Designer to perform all Virtual Processor configuration, including adding new modules, configuring module setup registers, and linking module inputs and output registers to other modules.

**Creating a second Virtual Processor**

Create a second ION Virtual Processor Service and start it using the following steps:

1. Open a command prompt window.
2. Register the Virtual Processor as a service from the ...\Power Monitoring Expert\system\bin folder by typing: `vip.exe -Service -N<custom Virtual Processor name>`
3. Open Control Panel > Administrative Tools > Services and start the new registered Virtual Processor.

**Viewing Virtual Processor data with Vista**

After you have used Designer to add and link modules in the Virtual Processor, you can create a user diagram in Vista and link it to the modules in the Virtual Processor. You can then use your user diagram to display system data, monitor alarms, and control basic functions in your Virtual Processor framework.

**Configuring the Virtual Processor to interact with the desktop**

2. Right-click the ION Virtual Processor Service and select Properties.
3. Select the Log On tab.
4. Select the “Allow service to interact with desktop” check box and click OK.
5. Stop and restart the ION Virtual Processor Service.
Distributed control

Virtual Processor Distributed Control modules are a means of transferring information between the different devices in your network. These modules can be used to build frameworks for control processes such as alarm annunciation, plant-wide demand control, power factor control, load shedding, paging, and generator switching.

Before you decide to use a Virtual Processor to implement a control system, it is important to understand the various factors that influence the speed with which the Virtual Processor is able to generate a control action. Some of these factors include network traffic, the number of polled devices in your network, the reliability of your communications network, and the Virtual Processor workstation's CPU usage.

⚠️ WARNING

UNINTENDED EQUIPMENT OPERATION

- Do not use control objects for time-critical functions because delays can occur between the time a control action is initiated and when that action is applied.
- Do not create a custom control object in Virtual Processor for remote equipment operation without configuring it with the appropriate access level, and without configuring a status object to indicate the status of the control operation.

Failure to follow these instructions can result in death, serious injury, or equipment damage.

The information presented in this section assumes that you are familiar with the various ION modules and their functions. Refer to the ION Reference for details on Distributed Control and other modules.

Distributed control modules

The Virtual Processor uses four modules to implement Distributed Control frameworks. Three types of Distributed Control modules (Distributed Boolean, Numeric, and Pulse modules) receive data from devices or other Virtual Processors within your network and transfer this data to the node address specified in the module's setup registers. The Data Monitoring module is used as a means of disabling a control module, if the data at the source input (which is used to make the control decision) becomes “stale”.

Distributed control module setup registers

All Distributed Control modules (Distributed Boolean, Distributed Numeric, and Distributed Pulse modules) have a Source input and an Activate input. The Activate input must be linked to another module, and it must be on for a Distributed Control module to function. These modules also contain a Destination setup register that specifies the node receiving the data.

Distributed Boolean module

All Distributed Boolean modules have one input that must linked to an External Boolean output register. Whenever this register's Boolean value changes state, the new value is sent to the node defined in the Destination setup register.
Distributed numeric module

A Distributed Numeric module's input must be linked to an External Numeric module. This input's value is sent to the node specified in the Destination setup register. This module has two additional setup registers that are used to determine when and how often new data is sent to the Destination node.

Distributed pulse module

All Distributed Pulse modules have one input that must link to an External Pulse module. This module's pulse is sent to the node defined in the Destination setup register.

Data monitoring module

The Data Monitor module provides a means of alerting you to communication problems that may occur between the Virtual Processor and any ION node referenced by the Data Monitor's Source inputs.

NOTE: ION meters with Advanced Security enabled do not accept control operations from the Virtual Processor. In order to enable these control operations, you need to provide a device password in Management Console for these applications to use. See "Accessing meters with advanced security" on page 39 for information on configuring Advanced Security.

Distributed control network performance

It is important to maximize the speed at which the Virtual Processor receives the data used to make control decisions. The performance of a Virtual Processor using Distributed Control is sensitive to factors such as network traffic, the Virtual Processor's global parameters, and the workstation's CPU usage.

The following sections provide some guidelines for improving a distributed control network's performance.

System configuration

- Minimize the number of devices per site for sites including devices used for distributed control.
- Minimize the number of applications (such as Vista diagrams) that are requesting data from the control site.
- Decrease the Virtual Processor's Client Polling Period.
- Maximize the site's baud rate.

CPU performance

- Dedicate a single Virtual Processor for control purposes; an additional Virtual Processor can be run for less critical functions.
- Do not run CPU intensive functions on the same workstation as your distributed control Virtual Processor.
Distributed control applications

The Virtual Processor's Distributed Control frameworks can perform various control processes; two examples are presented below. Ensure that you are familiar with the sections above before using any of these module frameworks in a control system.

Example: Passing a value between devices

The following example shows how the numeric output of the Integrator modules in meter "A" is sent to an External Numeric module in meter "B".

![Diagram of passing a value between devices]

Note that the Distributed Numeric module is disabled if the Data Monitor module detects a communication problem between the meter "A" and the Virtual Processor (for example, timeouts or slow network connections). As a result, control actions are only performed based on up-to-date data.

Example: Device control

This example framework monitors total harmonic distortion (THD), which could cause a piece of equipment (like a power transformer) to overheat. When a setpoint is reached, the system sends a network message to a workstation and turns on a fan.
Common Virtual Processor applications

The Virtual Processor can be used to create numerous analysis, recording, and control functions. This section describes three common Virtual Processor applications:

- Data Aggregation.
- Logging Data from Meters.

The examples shown on the following pages assume that you understand the functions and options of the various modules used. Refer to the ION Reference for module details. See the previous sections for common Modbus and Distributed Control applications.

Example: Event driven report generation using Reporter

The Virtual Processor can be used in conjunction with a device and the Log Inserter to generate reports in response to system events. In the following example, a Power Quality report is automatically generated in the event of a system disturbance.

As transients often occur in groups, the five minute delay setup with the One-Shot timer module allows multiple transients to appear in one Power Quality report.
NOTE: The Virtual Processor Launching module only supports non-interactive processes. This is an operating system limitation. Using the Virtual Processor’s Launching module may require that the Virtual Processor be run as an application instead of a service. Running the Virtual Processor as an application may not work in all cases. Contact Technical Support if you require more information.

Example: Data aggregation

In the following example, meters monitor average current values (I_avg). Every day at a specified time (determined by the Periodic Timer module), the Data Recorder Module stores the maximum average current value for each meter.

Example: Logging data from meters

The Virtual Processor can be used to log data from meters that do not have Data Recorders. In the following example, the total kWh from a meter’s Integrator module is recorded every 15 minutes by a Virtual Processor’s Data Recorder module.

Note that the Virtual Processor holds only 100 records at a time, that is, it holds about one day of 15 minute data. If the Virtual Processor stops operating, data logging also stops.

Setting global parameters

The Virtual Processor global operating parameters and Modbus network setup are configured using Virtual Processor Setup.
The global parameters do not need to be changed for normal operation. The Virtual Processor operates properly in most applications with the default settings. See "Modifying the Global Parameters" on page 90 for details.

To set up the Virtual Processor's Modbus network, see "Virtual Processor setup" on page 90.

**NOTE:** The ION Virtual Processor Service must be restarted for any changes to take effect, as the Virtual Processor only reads the vipsys.dat file once on startup. The ION Virtual Processor Service can be restarted, like any other service, using the Services window found via the Control Panel service applet.
# Chapter 6: Database Manager and Windows Task Scheduler

Use Database Manager to manually perform operations on the Power Monitoring Expert databases. Use Windows Task Scheduler to configure scheduled jobs to perform operations such as backup, maintenance, and trim.

**NOTE:** Database Manager does not include manual database operations on the Application Modules database (ApplicationModules). In a disaster recovery situation or when directed by Technical Support, the Application Modules database can be restored by using the *Restore database* function in the SQL Server Management Studio. See "Restoring a database" on page 221 for further information about this operation. ION databases can be restored using the same process.

In this section

<table>
<thead>
<tr>
<th>Prerequisites</th>
<th>216</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database Manager</td>
<td>216</td>
</tr>
<tr>
<td>Manual actions</td>
<td>218</td>
</tr>
<tr>
<td>Restoring a database</td>
<td>221</td>
</tr>
<tr>
<td>Alarm notification in a SQL Server Express installation</td>
<td>223</td>
</tr>
<tr>
<td>Scheduled jobs in Windows Task Scheduler</td>
<td>224</td>
</tr>
<tr>
<td>Limiting SQL Server memory usage</td>
<td>229</td>
</tr>
<tr>
<td>Log Inserter</td>
<td>229</td>
</tr>
<tr>
<td>Accessing the ION Database with 3rd-party applications</td>
<td>230</td>
</tr>
</tbody>
</table>
Prerequisites

The following user prerequisites need to be met to work with Database Manager, Windows Task Scheduler, and database functions through SQL Server Management Studio:

- For Database Manager: Database Manager uses Windows authentication to access the SQL Server databases. The user needs to be a member of the sysadmin SQL Server role, which is set in SQL Server Management Studio.

- For scheduled jobs in Windows Task Scheduler: The password for the IONMaintenance account needs to be updated before you perform any Task Scheduler actions. See "Changing the IONMaintenance password" on page 225 for further information.

- For most database functions available in SQL Server Management Studio: The user needs to be a member of the sysadmin SQL Server role.

**NOTE:** If the Windows user that you used to log into the system is not a member of the sysadmin role, and you want to run Database Manager, you can do so without logging out by completing the following steps:

1. Navigate to the system\bin folder in the product's install location.
2. Locate DatabaseManager.exe.
3. Click the EXE file name to highlight it, then press Shift+Right-click to open the menu.
4. Click Run as different user to open the Windows Security dialog.
5. In the User name field, type a user name that has the sysadmin role, then type the password for that user.
6. Click OK to open Database Manager.

Database Manager

To access Database Manager, start Management Console then click **Tools > Database Manager**.

Note that the Windows user running Database Manager needs to be a member of the sysadmin SQL Server role.

To start Database Manager in a distributed product installation, log on to your Database Server, go to...

...\Schneider Electric\Power Monitoring Expert\system\bin

and double-click DatabaseManager.exe.

Expand the items in the navigation tree to display the Databases for each instance.

Note that scheduled jobs are available only in Windows Task Scheduler. For further information, see "Scheduled jobs in Windows Task Scheduler" on page 224.
SQL Server instance

The default SQL Server instance that the product uses for its databases is
COMPUTERNAME\INSTANCE, where COMPUTERNAME is the name of the server, and
INSTANCE is the SQL Server instance used with the product.

Databases

The Databases section lets you view information about the databases or perform manual actions on the databases.

For information on the manual actions you can perform, see "Manual actions" on page 218.

Viewing Database Properties

To view the properties of a particular database, right-click that database and select
Properties. The properties are:

- **Size**: The current size of the database.
- **Primary File Location**: The file path for the primary database (.mdf) file.
- **Transaction Log Location**: The file path for the transaction log (.ldf) file.
- **Creation Date**: The date and time when the database was created.
- **Last Backup Date**: The date when the last backup was performed.
Chapter 6: Database Manager and Windows Task Scheduler

- **Disk Space Available**: The amount of free space available on the disk where the database resides.
- **Server Version**: The type and version of the SQL Server instance that is hosting the database.

**Show archives**

Select this check box (lower left-hand corner) if you want the list under **Databases** to include all archived databases along with the live databases. After **Show Archives** is selected, you can upgrade archived databases or view the properties of the archived databases.

Clear the **Show Archives** check box to hide the archived databases from view. This also prevents the database actions from being performed on database archives.

**Manual actions**

The following sections provide information on the manual actions that you can use to manage your databases.

To perform an action manually, do one of the following:

- Right-click **Databases** and select the action from the menu, or
- Right-click the specific database and select the action you want to perform from the pop-up menu.

When you right-click **Databases** and select an action, a dialog specific to that action opens. The databases listed in the dialog are those to which the action applies.

When you right-click a specific database, only the actions that apply to that database appear in the menu and the database is selected by default in the dialog for the action.

**Archive**

The Archive action creates an archive of the selected database.

Before proceeding, ensure that you have write access the archive directory location.

1. Right-click **Databases** or **ION_Data** and select **Archive** to open the **Database Archive** dialog. If necessary, select the database that you want to archive.

2. Click the browse button \( \text{...} \) to select the location for the saved archive.

    The directory \( \text{...}ackslash\text{Power Monitoring Expert}\backslash\text{config}\backslash\text{cfg}\backslash\text{Archives}\backslash\text{Data} \) is the default location for the saved archive, but you can specify another local directory (you can only save an archive to a directory on the local machine, not to a location on the network).

3. Type a name for the archive.

    After you select the location, the archive is given a default filename, but you can rename the archive to follow your naming conventions.

**NOTE**: Database names are restricted to characters A-Z, a-z, 0-9, and \_ (underscore).
4. Select the data types that you want to archive.

5. Specify the date range of the data that you want to archive. For **Start**, select **The beginning of the database** or select **Date** and enter a date and time. Enter a date and time for **End Date**.

6. Under **Trim after archive** select whether or not you want to remove archived data from the database.

   When you select a start date for the archive procedure instead of using the beginning of the database, the option to trim the live database is disabled, even if you selected the trim option before you set the date range.

7. Click **OK**.

   The **Progress** field displays the current progress of the archive process. If a manual archive does not succeed, a message appears and the **Database Archive** dialog remains open with the **OK** button grayed out — examine the **Progress** field to discover where the process did not succeed. If the archive is successful, the dialog closes automatically.

**Export Registry Setting**

The Export Registry Setting action exports settings to a registry (.reg) file. This is useful if you need to set up client computers in a system where the primary server's database settings (server instance name, database name, or password) are customized. After you export the settings to the registry (.reg) file, you can run that registry file on the client computer.

1. Right-click **Databases** and select **Export Registry Setting** to open the **Database Registry Key Export** dialog.

2. Type the path and filename for the file or click the browse button ▶ to specify the location for the saved database registry key.

   The directory `...\Power Monitoring Expert\config\cfg\` is the default save location for the exported database registry key.

3. Click **OK**.

**Modify Login**

The Modify Login action changes the SQL Server password for the default login name **ION**.

1. Stop all Power Monitoring Expert services.

2. Right-click **Databases** then select **Modify Login** to open the **Modify Login** dialog.

3. From the **Login Name** dropdown list select **ION** if it is not already selected. Type the new password in the **New Password** and **Confirm New Password** fields. Click **OK**.

4. Restart the services.
New ION Databases

The New ION Databases action creates a new, blank version of the ION_Data database.

1. Right-click Databases and select New ION Databases to open the New Historical Database dialog.
2. Type a name for your new database.
   
   **NOTE:** Do not name it “ION_Data” as this is the default name for the existing ION database. Database names are restricted to characters A-Z, a-z, 0-9, and _ (underscore).
3. Click the browse button to specify a location for the database.
4. Click OK.

Trim

The Trim action removes data from a database.

<table>
<thead>
<tr>
<th>NOTICE</th>
</tr>
</thead>
<tbody>
<tr>
<td>LOSS OF DATA</td>
</tr>
</tbody>
</table>
Backup or archive data before trimming a database.

**Failure to follow these instructions can result in permanent loss of data.**

1. Right-click Databases, ION_Data or ION_SystemLog and select Trim to open the Trim Database dialog.
2. Select the database you want to trim from the Database to trim list.
3. Under Trim Range, specify the date range of data you want to trim (for the ION_Data database) or set the maximum data age in days (for the ION_SystemLog database).
4. For the ION_Data database, select the data types you want to trim (Data Records, Waveforms, Events) in the Data Types section. You can select any combination of data types to trim.
5. Click OK. A message appears to notify you that the selected data will be removed. Click Yes to continue or No to cancel.

Upgrade Databases

The Upgrade Databases action upgrades the selected database to the latest database schema.

1. Right-click Databases and select Upgrade Databases to open the ION Database Upgrade dialog.
The Power Monitoring Expert installer automatically upgrades your databases with the new database schemas when you install Power Monitoring Expert on an existing server. If you install the latest version of the product on a different server so that you can manually copy older database files to the new computer, you can run this action on the older databases (that is, on the ION_Data, ION_SystemLog, and ION_Network databases, and archives) to upgrade them with the new schema.

2. Select the database in the list that you want to upgrade and click OK.

**Restoring a database**

You can restore a database from a backup by logging in to SQL Server Management Studio as a user with syadmin access authority for the **Restore Database** function. (Database backups are specified as a scheduled job in Windows Task Scheduler. See "Scheduled jobs in Windows Task Scheduler" on page 224 for further information.)

**Restoring the latest database**

Complete the following to restore a database from the latest backup:

1. Stop all ION services.

2. Open **SQL Server Management Studio**, enter your password if required and click **Connect** to access your SQL Server.

3. In the **Object Explorer** pane on the left, expand **Databases**, right-click the database you want to restore and click **Tasks > Restore > Database** to open the **Restore Database** dialog.

4. Under **Source**, select **Database** and click the database you want to restore in the drop-down list if it is not already selected.

5. Under **Backup sets to restore**, select the checkbox in the **Restore** column for the database you want to restore.

6. Click **Options** in the **Select a page** pane on the left.

7. On the **Options** page:
   - Under **Restore options**, select **Overwrite the existing database (WITH REPLACE)**.
   - For **Recovery state**, select **RESTORE WITH RECOVERY** from the dropdown list.

   **RESTORE WITH RECOVERY** is described as **Leave the database ready to use by rolling back uncommitted transactions. Additional Transaction logs cannot be restored.**

8. Click **OK** to begin the restore operation.

A message indicates that the database has been restored successfully. If the restore operation is not successful, the database reverts to its original state.
NOTE: After you restore the database, you need to assign its ownership to the ION user as follows:

a. In SQL Server Management Studio, right-click the restored database and click Properties in the menu to open the Database Properties dialog.

b. Click Files under Select a page.

c. Click the button on the right of the Owner field to open the Select Database Owner dialog.

d. Type ION in the field labeled Enter the object names to select and click Check Names to adjust the format of your entry to [ION].

e. Click OK to update the owner of the database.

f. Click OK to close the Database Properties dialog.

9. Restart all ION services.

Restoring a specific database

Complete the following to restore a specific database:

1. Repeat steps 1 through 3 from "Restoring the latest database" above.

2. Under Source, select Device and click Browse to open the Select backup devices dialog.

3. Select File in Backup media type list if it is not already specified and then click Add to open the Locate Backup File dialog.

4. Navigate to and select the backup file you want to restore and click OK.

5. Verify that the file referenced in the Specify Backup dialog is the one you selected and click OK to return to the Restore Database dialog.

6. Under Select the backup sets to restore, select the checkbox in the Restore column for the database you are restoring.

7. Click Options in the Select a page pane on the left.

8. On the Options page:

   - Under Restore options, select Overwrite the existing database (WITH REPLACE).

   - Under Recovery state, select RESTORE WITH RECOVERY from the dropdown list.

   RESTORE WITH RECOVERY is described as Leave the database ready to use by rolling back uncommitted transactions. Additional Transaction logs cannot be restored.

9. Click OK to begin the restore operation.
A message indicates that the database has been restored successfully. If the restore operation is not successful, the database reverts to its original state.

**NOTE:** After you restore the database, you need to assign its ownership to the ION user as follows:

a. In SQL Server Management Studio, right-click the restored database and click **Properties** in the menu to open the Database Properties dialog.

b. Click **Files** under **Select a page**.

c. Click the button on the right of the **Owner** field to open the Select Database Owner dialog.

d. Type **ION** in the field labeled **Enter the object names to select** and click **Check Names**.

   The format of your entry changes to [ION].

e. Click **OK** to update the owner of the database.

f. Click **OK** to close the Database Properties dialog.

10. Restart all ION services.

**Alarm notification in a SQL Server Express installation**

For product installations using a supported edition of SQL Server Express, alarm notification for database size has been configured by default as follows:

- For alarming purposes, the maximum size for a database on a system is set at 9 GB. This provides a buffer for taking action prior to reaching the 10 GB maximum, at which point the database stops logging data.

<table>
<thead>
<tr>
<th>NOTICE</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>LOSS OF DATA</strong></td>
</tr>
<tr>
<td>Do not allow a SQL Server Express database to reach the 10GB maximum before performing a database Trim action.</td>
</tr>
<tr>
<td><strong>Failure to follow these instructions can result in an inoperable database and loss of data.</strong></td>
</tr>
</tbody>
</table>

- A notification message is automatically issued at 85% of the 9 GB maximum database size.

When the alarm threshold is reached, a message is logged in the System Log and also as a Critical event in the Alarms viewer. (You can access the Alarms viewer in the Web...
Applications component of the product.) Depending on the volume of database logging that occurs, one of the following event notifications is generated (where database_name is the affected database and x is the percent threshold for event notifications):

- Your database_name database is x% full. Data will stop being logged if your database is full. Please see the information about "Trim" in Database Manager's online help.
- Your database_name database is x% full. You must take immediate action to prevent data loss. Data will stop being logged if your database is full. Please see the information about "Trim" in Database Manager's online help.

See "Trim" on page 220 for information about removing data from a database.

If you find that the threshold percentage needs to be changed for your installation, you can change it by editing the Configuration.ps1 file as follows:

1. Use Windows Explorer and navigate to the following location under the program's root directory:
   
   ...\config\cfg\DbScheduledTasks\Support

2. Edit Configuration.ps1 with a text editor and change the threshold percentage setting of 85 in:

   $databaseSizeNotificationThresholdPercentage = 85

3. Save your change and close the text editor.

Scheduled jobs in Windows Task Scheduler

Power Monitoring Expert schedules the following preconfigured jobs using Windows Task Scheduler.

<table>
<thead>
<tr>
<th>Database</th>
<th>Scheduled Job</th>
<th>Enabled by Default</th>
<th>Default Time</th>
<th>Configurable</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application Modules database</td>
<td>Backup</td>
<td>Yes</td>
<td>Daily at 1:30 AM</td>
<td>Yes</td>
</tr>
<tr>
<td>(Application_ Modules)</td>
<td>Maintenance</td>
<td>Yes</td>
<td>Daily at 3:30 AM</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Trim</td>
<td>Yes</td>
<td>Daily at 2:30 AM</td>
<td>Yes</td>
</tr>
</tbody>
</table>
### Database Manager

<table>
<thead>
<tr>
<th>Database</th>
<th>Scheduled Job</th>
<th>Enabled by Default</th>
<th>Default Time</th>
<th>Configurable</th>
</tr>
</thead>
<tbody>
<tr>
<td>ION database (ION_Data)</td>
<td>Archive</td>
<td>No</td>
<td>Annually at 1:00 AM on January 3rd</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Backup</td>
<td>Yes</td>
<td>Weekly at 12:00 AM every Friday</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Maintenance</td>
<td>Yes</td>
<td>Daily at 2:00 AM</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Size Notification (for SQL Express installations)</td>
<td>Yes</td>
<td>Daily at 3:00 AM</td>
<td>Yes</td>
</tr>
<tr>
<td>Network Configuration database (ION_Network)</td>
<td>Backup</td>
<td>Yes</td>
<td>Daily at 1:00 AM</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Maintenance</td>
<td>Yes</td>
<td>Daily at 7:30 AM</td>
<td>Yes</td>
</tr>
<tr>
<td>System Events database (ION_SystemLog)</td>
<td>Maintenance</td>
<td>Yes</td>
<td>Daily at 7:05 AM</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Trim</td>
<td>Yes</td>
<td>Daily at 4:00 AM</td>
<td>Yes</td>
</tr>
</tbody>
</table>

### Changing the IONMaintenance password

Before you perform any editing on the database scheduled jobs, you need to reset the password for the IONMaintenance account that is used to access the job properties.

1. Log on to your server as a user with Administrator privileges.
2. Click **Start**, then right-click **Computer** and click **Manage** to open the **Computer Management** dialog.
3. Expand **Local Users and Groups** under **Configuration** and click **Users** to display the list of users.
4. Right-click **IONMaintenance**, select **Set Password**, and click **Proceed** on the confirmation window to open the **Set Password for IONMaintenance** dialog.
5. Enter your new password in the **New password** and **Confirm password** fields, and click **OK** to reset the password.
   A confirmation window indicates that the password has been set.
6. Click **OK** on the confirmation window and close the **Computer Management** dialog.
Opening Task Scheduler to view scheduled jobs

1. To open Task Scheduler:
   - In Windows 2012 and 2012 R2, open the Start screen, click the Administrative Tools icon, then locate and double-click Task Scheduler in the list.
   - In Windows 2008, click Start > Administrative Tools > Task Scheduler.
   - In Windows 7, click Start > All Programs > Accessories > System Tools > Task Scheduler.
   - In Windows 10, type Task Scheduler in the search field on the task bar and press Enter.

2. Click Task Scheduler Library in the left pane of the Task Scheduler dialog to view the scheduled jobs for the Application_Modules, ION_Data, ION_Network, and ION_SystemLog databases.

   ![Task Scheduler Library](image)

   The schedule for each database job is shown under Triggers for each database name. You can see the properties for each database job by clicking the tabs in the bottom portion of the dialog.

**NOTE:** In an installation using a supported edition of SQL Server Express, you can enable the history of all database jobs by clicking Enable All Tasks History in the Actions pane on the right of the Task Scheduler dialog.

Editing scheduled jobs in Task Scheduler

To edit a scheduled job:

1. Right-click a database job and select Properties to open the Job Properties dialog.
2. Click the Triggers tab to display the current schedule.
3. Click the schedule entry then click Edit to open the Edit Triggers dialog.
4. Make your changes to the options for the job schedule and click OK to close the Edit Triggers dialog.
5. Click OK to close the Job Properties dialog.
A password window for the IONMaintenance account opens.

6. Enter the password that you created for IONMaintenance and click **OK** to apply the schedule changes for the job.

   The **Job Properties** window closes.

7. Close **Task Scheduler**.

**Changing the default location for the backup files**

By default, database backups are saved to the `Database\Backup` location (under ...\Program Files\Schneider Electric\Power Monitoring Expert). This default location is specified in the `Configuration.ps1` file as:

$locationForBackupFiles = "..\Database\Backup\"

To change the default location for the backup files:

1. Use Windows Explorer to create a new folder for your backup files.
   
   The folder name and location are used in the following steps.

2. Navigate to the following location under the program’s root directory:

   ...\config\cfg\DbScheduledTasks\Support

3. Edit **Configuration.ps1** with a text editor and change the path information to specify either a fully-qualified path or a relative path for the folder to be used for the backup files.

   For example:

   - If you created a folder named `backupdirectory` under the `Database` folder in the default product install location, change the path entry in the file to
     
     $locationForBackupFiles = "..\Database\backupdirectory\"
     
     to specify the relative path for the backup location.

   - You need to use a fully-qualified path if you want to use a secondary disk drive or an external drive for the backup files.

4. Save your changes and close the text editor.

**Setting permissions for the backup folder**

Complete the following to give the IONMaintenance account read and write permissions to the new backup folder:

1. In Windows Explorer, navigate to the new backup folder you created,

2. Right-click the folder and select **Properties**

3. Click the **Security** tab and then click **Edit** to open the permissions dialog for the folder.

4. Click **Add** to open the **Select Users or Groups** dialog.

5. Enter **IONMaintenance** as the object name in the field.
The From this location field should contain the name of your server. If not, click Locations and select the server name.

6. Click Check Names to validate the object name, and then click OK to add IOMaintenance to the list of user names in the permissions dialog.

7. Click IOMaintenance under Group or user names, select Read and Write under Allow in the permissions area, and then click OK to apply the settings and to close the permissions dialog.

8. Click OK to close the Properties dialog.

Considerations when running the Archive task in Task Scheduler

- The Windows user running the Archive task needs to be added to Security > Logins in SQL Server Management Studio with the sysadmin Server role.

- If the default location for the archived database is being used, the user running the Archive task needs to run the task as an Administrator.

This is necessary to satisfy file copy restrictions for the C:\Program Files (x86) folder and its subfolders. (On 32-bit systems, the folder is C:\Program Files.)

a. Right click [ION Data] - ARCHIVE - Job and click Properties to open the job properties dialog.

b. Click Change User or Group to open the Select User or Group dialog.

c. Type the Windows user name in the Enter the object name to select field and click Check Names to populate the field with the correct format for the user ID.

d. Click OK to close the Select User or Group dialog.

e. Click OK to close the properties dialog.

f. Enter the password for the user at the prompt and click OK.

The user ID now has administrative privileges to run the Archive task.

- If the location for the archived database is not in the C:\Program Files (x86) folder and its subfolders, then the regular user account needs to have permissions set for Log on as a batch job and Log on as a service. To set these permissions:

a. Open the Run dialog, type secpol.msc /s and click OK to open the Local Security Policy dialog.

b. Expand Local Policies and click User Rights Assignment to list the policies in the area on the right.

c. For each of Log on as a batch job and Log on as a service, right-click the policy and click Properties.

d. Click Add User or Group, add the local user account and click OK.

e. Click OK in the properties dialog to apply the change and close the dialog.
To change the default location for archived database files:

a. Navigate to the following location under the program's root directory:

   \config\cfg\DbScheduledTasks\Support

b. Edit Configuration.ps1 with a text editor and change the path information to specify either a fully-qualified path or a relative path for the folder to be used for the archived database files.

   For example:
   If you created a folder named dbarchives under the Database folder in the default product install location, change the path entry in the file to

   $locationForArchiveDBFiles = "\..\Database\dbarchives"

   to specify the relative path for the archive location.

   You need to use a fully-qualified path if you want to use a secondary disk drive or an external drive for the archived database files.

c. Save your changes and close the text editor.

Limiting SQL Server memory usage

By default, SQL Server 2012 and 2014 Standard and Enterprise Editions are configured to dynamically adjust the amount of memory used based on demand.

Under some circumstances, it is possible for SQL Server to use up memory to a point where the overall system performance is affected. You can adjust the amount of memory reserved by using a configuration tool such as Microsoft SQL Server Management Studio.

Using SQL Server Management Studio to limit memory usage

1. In the Object Explorer pane, right-click the SQL Server instance that corresponds to the Power Monitoring Expert database (that is, the database icon at the root level of the tree-view) and select Properties to open the Server Properties dialog.

2. In the Select a page pane, select Memory.

3. Use the controls on the Memory page to adjust the memory allocation.

4. Click OK.

Log Inserter

The Log Inserter component automatically configures itself to collect data from every available recorder in every device or Power Monitoring Expert software component and inputs this data into the database. Log Inserter is typically run only on the Primary workstation.

Most systems use only a single Log Inserter which is automatically configured to perform all required logging functions. The default configuration works for most systems. Situations where changes may be required include systems with large numbers of devices with logs, systems with primary and secondary servers or cases where only specific devices and/or
logs need to be monitored for new records. If any of these situations apply to your system, contact Technical Support for more information on the operation of Log Inserter, its different modes of operation, and the functions of its internal components.

**Accessing the ION Database with 3rd-party applications**

The following example uses Microsoft Excel 2007 to retrieve data from the ION_Data database.

**NOTE:** The database uses Universal Coordinated Time (UTC) time. When you import data into Excel, the Clock module’s Time Zone Offset register for the meter is applied.

1. To create a database query in Excel, click **Data > From Other Sources > From Microsoft Query.**
2. To create a new data source, select **<New Data Source>** from the list and click **OK.**
3. Type the name you want to give the data source. Once you type a name, the list of drivers for the database type becomes available. Select **<SQL Server>** from the list. Click **Connect.**
4. Choose your server from the list. Provide your LoginID and Password and click **OK.** Select a default table for your data source (optional). Click **OK** to continue.
5. Select the source name you created and click **OK.**
6. After you have selected the data you want to view, the **Query Wizard** opens. Use this to filter and sort the data.
7. Follow the steps in the **Query Wizard** to add data to the spreadsheet.
Chapter 7: Modbus Device Importer

The Modbus Device Importer utility enables Power Monitoring Expert software to recognize and integrate third-party Modbus devices into the Power Monitoring Expert network.

In this section

- Introduction .......................................................... 232
- ION object descriptions ........................................ 234
- Main console screen ................................................ 235
- Main toolbar ........................................................... 236
- Editing a register ...................................................... 242
- Shortcut keys .......................................................... 246
- Additional information ............................................. 249
- Configuring Logging and Calculation ......................... 251
Introduction

The Modbus Device Importer is a tool for advanced users that creates the files and software support necessary to display data from any Modbus device using the Vista component of the product. The Modbus Device Importer user interface sets up useful common Modbus parameters by default, but also allows you to configure all Modbus-specific and device-related parameters. The Modbus Device Importer also has built-in error checking to validate the files you created, or those from other sources.

⚠️ CAUTION

**UNINTENDED EQUIPMENT OPERATION**

- Do not use control objects for time-critical functions because delays can occur between the time a control action is initiated and when that action is applied.
- Do not create a custom control object in Modbus Device Importer for remote equipment operation without configuring it with the appropriate access level, and without configuring a status object to indicate the status of the control operation.

Failure to follow these instructions can result in injury or equipment damage.

Process overview

Creating a new Modbus device type involves the following steps:

1. Identify the new device type (device name, file name, etc.)
2. Create a Modbus map file for the device type:
   - Identify a Modbus register to be added.
   - Find an appropriate register to map to in the ION tree.
   - Select appropriate data format, scaling factors, and so on.
3. Configure additional Modbus device functionality (if required).
4. Validate and check the device type.
5. Add the new Modbus device type to the ION_Network database.

After it is defined in the ION_Network database, the new Modbus device is available in Power Monitoring Expert just like any other device. Simply select the Modbus device type from the dropdown list.

Default modbus device types

Power Monitoring Expert is shipped with numerous pre-configured Modbus device types. For a list of these device types, navigate to **Tools > View current Device Types** from the Modbus Device Importer main console. These pre-configured device types can also be modified as required, using the Modbus Device Importer.
The ION tree file

The Modbus Device Importer creates and edits ION tree files (.ion) for the device, which are then saved and entered into the ION Network, allowing the software to recognize and use the device. The tree file defines the organization of the ION managers, modules and registers.

The modbus map file

The Modbus Device Importer creates and edits mapping files for the device, linking Modbus registers with ION registers. A Modbus map file is an XML file that must refer to the XML schema defined in /.../config/translators/modbus-schema.xml.

It also defines how to convert the module register value into the value shown in the ION register.

Map file format

Each distinct Modbus device type has its own special address ranges and requires its own Modbus map file. Vln avg, on an ION6200, for example, is located at 40103. It could be in a different location on any other device. In either case, it would be most logically mapped to the Power Meter Module's Vln avg output register (0x5803) in the default tree.

The example map file shown below illustrates the map file format:

```xml
<?xml version="1.0" encoding="UTF-8"?>
<!--Created by Modbus Device Importer v 3.21.0 at: 3/22/2007 10:41:56 AM-->
<ModbusMap xmlns="x-schema:modbus-schema.xml">
  <DeviceInfo Type="Example Device" MultiplePresetSupported="0"
    GlobalNotAvailable="NotSpecified" MaxRequestRegisters="125"
    LowSpeedUpdateRate="30" HighSpeedUpdateRate="5"/>
  <ModbusInfo IONHandle="134217729" Name="Baud Rate" ModbusAddress="40001"
    RequestType="RW" Format="UINT16" Scale="1" Offset="0" Multiplier="1"
    DefaultEnumValue="Invalid Data">
    <Enumeration Value="300 Baud"/>
    <Enumeration Value="2400 Baud"/>
    <Enumeration Value="9600 Baud"/>
    <Enumeration Value="115200 Baud"/>
  </ModbusInfo>
  <ModbusInfo IONHandle="134217985" Name="VoltsA@!!DeviceName!!Meter01" ModbusAddress="40002" RequestType="R" Format="UINT16" Scale="1" Offset="0" Multiplier="1"/>
</ModbusMap>
```
<ModbusInfo IONHandle="134217986" Name="VoltsB@Meter01"
ModbusAddress="40003" RequestType="R" Format="UINT16" Scale="1" Offset="0"
Multiplier="1"/>

<ModbusInfo IONHandle="134217987" Name="VoltsC@Meter01"
ModbusAddress="40004" RequestType="R" Format="UINT16" Scale="1" Offset="0"
Multiplier="1"/>

<CalcInfo IONHandle="135266304" Name="Averaging 1" Function="Averaging_Module"/>

<CalcInfo IONHandle="136314880" Name="Minimum 1" Function="Minimum_Module"/>

<CalcInfo IONHandle="137363456" Name="Maximum 1" Function="Maximum_Module"/>

<CalcInfo IONHandle="138412032" Name="Data Rec 1" Function="DataRecorder_Module"/>

<CalcInfo IONHandle="139460608" Name="Feedback 1" Function="Feedback_Module"/>

<CalcInfo IONHandle="140509184" Name="Periodic Tmr 1" Function="PeriodicTimer_Module"/>

<CalcInfo IONHandle="131072000" Name="Diagnostics 1" Function="Diagnostics_Module"/>

</ModbusMap>

**ION object descriptions**

ION objects are software items that are recognized by Power Monitoring Expert software. ION objects consist of device managers, modules, and registers. Managers separate different module types and groups together modules of the same type. Modules group registers into convenient or logical groups. Registers are the objects that actually hold the Modbus register information.

For more information on ION architecture, refer to the *ION Reference*.

**Managers**

Managers organize the Modbus map file into a formatted structure. There are three different types of managers supported in the Modbus Device Importer:

- **External Boolean Manager**: holds Boolean type registers.
- **External Numeric Manager**: holds Numeric type registers.
- **External Pulse Manager**: holds Pulse type registers.

You can create up to 127 managers. After you create a manager, you cannot change its manager type.
## Modules

Similar to managers, modules also help organize the map file structure. You can create up to 4095 modules inside a given manager. Use modules to arrange registers into logical groupings or similar register types. When naming a module, choose a name that is relevant to the type of registers it contains. Modules inherit the class type of their parent manager, so you cannot change a module type after it has been created.

## Registers

A register is an object that can be linked to a physical register on a Modbus device, where data is read from or written to. You can map registers to a Modbus address, then use Vista to read and write data to this Modbus device.

When you create a register, it inherits the type of its parent module. You can create up to 255 registers per module.

There are three different register types:

**Boolean Registers**

Boolean registers hold Boolean data, i.e., a logical True or False (1 or 0). You can attach a label to the register to indicate an ON or OFF state. If a numeric register is mapped to a Boolean register, a value of "0" (zero) puts the Boolean register in an OFF state, while any other value turns the Boolean register ON (unless a mask is applied).

If any of the bits exposed by the mask are set, the value is interpreted as a 'True'. Otherwise it is interpreted as 'False'. MaskedBool can be used to sift out individual Booleans that are stored as arrays of bits in Modbus. If no mask is specified, all bits are relevant. Boolean registers can be 16 or 32 bits long.

**Numeric registers**

Numeric registers hold numeric data.

**Pulse registers**

Pulse registers are used in Vista to send a pulse to the specified address. They are used specifically to write values to a device. The user can specify the exact value to send out as a pulse for each register. Pulse registers can only write 16 bits worth of data.

**Factory registers**

You cannot add or remove Factory objects but you can edit them. All Factory registers are initially set to a default constant value. You can change these constant values, or map the registers to a valid Modbus address (see "Editing a register" on page 242). There are four user defined factory registers that you can change if the required registers are not already present in the default list.

## Main console screen

To open Modbus Device Importer, start Management Console then select **Tools > System > Modbus Device Importer**.
The main console is where most actions are performed and ION objects are managed. The device managers, modules, and registers are displayed in the ION Map Information Pane on the left hand side of the screen. Information specific to registers is displayed on the right hand side of the screen in the Modbus Register Information Pane. If you select an object in the tree, all registers below it have their information displayed.

Navigate through the tree-view by clicking on the specific objects or by using the arrow keys on the keyboard.

When the application is started or the File > New menu is selected, a default configuration is loaded. The only object included in the default configuration is the factory manager and associated registers. By default, you cannot specifically see the factory objects so a blank template is displayed.

Main toolbar

File menu

Select File on the main toolbar to access the following menu items:

- **New**: Creates a new, blank map file.
- **Open**: Opens an existing map file.
- **Save**: Saves the current map file template and the corresponding ION tree file template.
- **Save As**: Lets you save the current map template to a different location.
- **Exit**: Closes the program.

The File menu also lists the most recently opened device templates.

Edit menu

You can add new objects by either right-clicking in the ION Map Information pane or selecting the appropriate option from the Edit menu.
Objects are placed either as children or siblings. For example, you may add a new manager to the device (sibling of an existing manager) or a new module to an existing manager (child of a manager). The same relationship applies to modules and registers.

- **New Manager**: Adds a new manager.

**Adding a New Manager**

1. Click **Edit > New Manager** to open the **Add New Manager** dialog.
2. Type a name for the manager.
3. Select a manager type from the drop-down: External Boolean Manager, External Numeric Manager, or External Pulse Manager.

**NOTE**: The manager type you choose determines parameters in the modules and registers under it.

4. Click **OK**.

- **New Module**: Adds a new module.

**Adding a New Module**

Click **Edit > New Module** to open the **Add New Module** dialog.

1. Type a name for the module.
2. The default is the next available number of that module type within the current manager (for example, Ext Num 3). The name of the module determines the default names of the registers under it. Note that the module name can be changed later, if required.
3. Click **OK**.

**NOTE**: Duplicate names are permitted but not recommended.

- **New Register**: Adds a new register. See "Editing a register" on page 242 for more information on using this dialog.

- **New Register (Quick)**: Adds a new register, using all default settings. No dialog is associated with this command unless no registers currently exist in the target module (in that case, it is treated as creating a new register with a dialog).

The Modbus address is automatically incremented as appropriate based on the register type and size.

**Copying and pasting objects**

You can copy and paste modules and registers. After you copy an object, you can paste it into a different location in the tree. You cannot paste registers or modules from one class type to another (i.e., you cannot copy a Boolean register and paste it into a numeric module).

- **Copy**:Copies your selection(s) to the clipboard.
There are three different paste options: Paste, Paste Clone and Paste Multiple.

- **Paste**: Pasting registers will normally automatically increments the Modbus address based on the register data type. In the case of MaskedBool, it increments the bit mask by one until it reaches 0x8000, when the Modbus address increments by one and the mask resets to 0x0001.

  The new register label is reset to a default label such as "Power Meter Module.0004".

- **Paste Clone**: Pasting a Clone is the same as pasting normally with the exception that the Modbus address of the register is not increased. This is a useful feature for pasting multiple registers with the same Modbus address but applying different masks.

  The new register label is reset to a default label such as "Power Meter Module.0004".

- **Paste Multiple**: Pasting multiple copies simply performs a normal paste a determined number of times, each copy incrementing the address the appropriate number of addresses.

**Moving objects**

You can move both modules and registers. This is done by selecting the desired object(s) in either the ION Map Information pane or Modbus Register Information pane and then holding down the ALT key. You can move the module or register to any other holding object, but it must be moved to the same data type.

**Editing objects**

To edit objects in the Modbus Device Importer, right-click them and select Advanced Properties. See "Editing a register" on page 242 for more information.

**Deleting selected <type of object>**

To delete objects in the Modbus Device Importer, right-click them and select Delete selected <type of object>. If you delete an object, all children (objects beneath it) are also deleted. To delete multiple registers at once, select them in the Modbus Register Information pane and then click "Delete selected Registers".

**Advanced properties**

Select this menu item to open the Device Properties dialog. You can also open this dialog using View > Device Properties. For more information regarding device properties, see "View menu". below.

**View menu**

The following menu items are accessed by clicking View on the main toolbar.

- **Refresh**: Refreshes the main console screen.

- **Collapse All**: Collapses the tree view.

- **Device Properties**: Click View > Device Properties (or right-click the tree-view root and select Properties) to open the Device Properties dialog:
Device Properties tab

- **Device Type**: Type the name of the Device Type.

- **Default Diagram Template Label field**: This is used if the device has a default Vista diagram. The string entered in this field is an internal identifier and is only used if the "Add Generate Network Diagram Support" feature is used; see "Main toolbar" on page 236 for more information.

Changes made here are not be reflected in the product until you add or update the device type.

These fields are used to identify the device type. By default, all values are constant values, but you can map them to Modbus registers if required.

**Advanced tab**

- **Maximum number of registers for a single request setting**: The maximum number of registers requested for the device can be set anywhere from 1 to 125. It is recommended that you do not change this setting unless the specific device has special requirements.

- **Multiple Preset Write check box**: Be sure that you match this check box with the device type. Select the check box if the device type supports Multiple Preset Write for registers and coils; clear the check box if the device type only supports Single Preset Write.

- **Disable “-1” check box**: This is a special feature for ION meters. ION meters return a “-1” if a specified register is not available and the system interprets that value as a control signal. Most devices use the value of -1 as a valid data value, so it is recommended that this feature is turned off for all non ION meters.

- **Requested update period for any calculated registers setting**: Enter a number (in seconds) to specify how often the physical Modbus device is polled to update the registers used for calculations.

**Tools menu**

Select the **Tools** menu on the main toolbar to access the following menu items:

- **Add Device Type**: After you correctly configure and save a device, you can add it to the ION_Network database.

  By adding a device to the ION_Network database, you can now create new devices of the device type in Management Console. Before you can add the device type, you must go to the Device Properties and configure the device (See "View menu" on page 238).

  To add the device type, click **Tools > Add Device Type**. After the device type is added, a new screen appears that shows the device types currently in the ION_Network database (See “View Current Device Types”). Ensure that the device type you added is present and the configuration is correct.
- **Update Device Type:** If you add a device type to the ION_Network database but changes were made to the template, then you can update the ION_Network database to reflect these changes.

  You are notified if the update is successful or not. If it is not successful, you must remove any devices of the specified device type from Management Console and then update to the ION_Network database again.

  **NOTE:** The ION_Network database update may not be successful if the device type you are updating is currently being used in Management Console. If this occurs, you must remove all devices of the specified type before the update will be successful, or contact Technical Support for possible workarounds.

- **Add “Generate Network Diagram” Support:** If a Vista diagram has been created for a device type, then you can set it up as the default network diagram in Vista.

  This enables all devices which are of the new device type to have default diagrams in Vista when the “Generate Network Diagram” feature is utilized. It is recommended that the default Vista diagram is created before running this feature.

  You must configure the following factory registers in order for this feature to work correctly:

  - **FAC1 Device Type register**
    
    This register must have a constant value. This is set in the Device Properties window as the Device Type. Use a descriptive name that easily identifies the device.

  - **FAC1 Template register**
    
    This register must have a constant value. Use something specific to the current register. For example, a device called “Test_Device” could be “Test_Device_Rev1.0.3". The template should reflect the device type, as well as the current version, to avoid future confusion if similar devices are added.

    **NOTE:** Both of these registers must have constant values. Modbus Device Importer does not support the “Add Generate Network Diagram support” feature for devices that get either of these register values dynamically (i.e., mapped to a Modbus register).

  After you enter the correct register values, you can find the “Add Generate Network Diagram support” feature under the **Tools** menu. This feature is very useful if you have multiple versions of a specific device type.

  This feature creates the necessary registry keys and sets up the required directory structure for generating a network diagram.

    **NOTE:** By default, the diagram is a blank diagram. You must modify this diagram to actually correspond to the specified device.

  - **Save ION Handle List:** This command saves a list of the registers along with their
corresponding ION handles. You can use this list to create a Vista diagram without an active device connected.

The list is saved as a text file in the current Modbus Device Importer installation folder. The name of the text file is in the format <currentDeviceName>.csv.

- **Validate Template**: This command lets you validate the current configuration.

  Doing this performs various validation and integrity tests on the current configuration of the ION and Modbus objects. It lists potential errors such as registers that share the same Modbus register address or registers that have conflicting masks. The error checks that are performed can be toggled on or off, using the check boxes in the dialog: general issues, address conflicts, handle conflicts, label conflicts, and name conflicts.

  You must manually fix any errors identified during validation before you can add or update the device type.

- **View Current Device Types**: This command allows you to view the device types currently in the ION_Network database.

  From here you can delete old device types that are not being used.

  Note that you may see multiple entries for the same physical device in the device type listings (for example, 6200 RTU and 6200 ModTCP). The Modbus Device Importer classifies each different protocol as a separate device type.

  **NOTE**: You cannot delete a device type that is currently being used by Management Console.

- **Calculator**: This loads the default Windows calculator.

  **Settings menu**

  Select **Settings** on the main toolbar to access the following menu items:

  - **Change Default Template Path**: The default template path is used for loading a new template. Use this command to change the path if required.

  - **Enable Auto-Validation**: This is selected by default.

  - **Start Application Maximized**: This sets the Modbus Device Importer window to open in a maximized state.

  - **Show Properties Window on Double-Click**: Allows an object’s property window to open if the object is double-clicked in the ION Map Information pane.

  - **Auto Select Text on Edit in Register Information**: Allows a field that is clicked on in the Modbus Register Information pane be fully selected when the edit screen opens. This is useful if you need to change the entire field.
Chapter 7: Modbus Device Importer

- **Advanced**: You can access two features from this sub-menu:
  - **Show Factory Objects**: Makes the factory objects visible in the ION Map Information pane. With this feature enabled, you can edit the properties of the Factory objects.
  - **Show Modbus Addresses Offset in Hex**: With this feature enabled, all Modbus addresses in the Modbus Register Information pane are displayed in hexadecimal format.

If this setting is enabled, registers cannot be edited in the Modbus Register Information pane.

### Help menu

Select **Help** on the main toolbar to access the following menu items:

- **About**: Provides version information for the program.
- **Modbus Device Importer Help**: Opens the Help file for the program.

### Configure Logging and Calculation button

Click this button to enter the Configure Logging and Calculation utility. This screen allows you to configure advanced functions for Modbus devices, such as enabling logging, and should only be used by advanced users. See the "Configuring Logging and Calculation" on page 251 for more information.

### Editing a register

To edit a register, right-click the register in the ION Map Information pane and select **Advanced Properties** to open a dialog displaying the register information. Depending on the type of register being edited, different data fields may appear.

You can also double-click the register in the Modbus Register Information pane to edit it. This is a faster way to edit basic register properties. When the Edit Mode is initiated in the Modbus Register Information pane, the selected register opens up into an edit mode:

To scroll through the list in Edit mode, use the PAGE UP and PAGE DOWN keys. After editing the values, press ENTER to save the changes.

**NOTE**: If you use the PAGE UP and PAGE DOWN keys, the changes made are saved as if ENTER was pressed.

To cancel any changes, press the ESC key.

### Register properties defined

The following register properties can be configured:

#### Register Label

The label is a description attached to the register. You can change this value at any time; it is only an identifier for the register.
NOTE: The register label string has a maximum character limit of 50, including spaces. Keep this in mind especially when creating labels for downstream devices since they may require additional space in the label name.

Make this Register a Constant Value
If this check box is cleared, then the ION register is mapped to a Modbus register and, when viewing it in Vista, you see the real values from the meter. If this check box is selected, then it is set to a constant value. You can use a constant value to hold dynamic constant values, device identification or other values.

ION Setup Register
You can configure any register to be an ION setup register. Setup registers do not appear in the Vista register list unless you select to view the setup registers.

NOTE: This does not affect the read/write capabilities of a valid Modbus register; it is a feature specific to Vista.

Data Type
This data type is used for decoding the values returned from the meter. The selected data type format must match the format delivered by the device. Each supported data type is explained in "Additional information" on page 249.

Register Type
This is a convenient way to change the Modbus register type. It only changes the most significant number in the Modbus address to correspond to the specified register type. This register type must match the register type specified by the device documentation. The register type also determines the Modbus function code used when talking to the device.

Modbus Address
This is the physical address of the specified register. You can find this number in the device documentation, and you can enter the number in either decimal or hexadecimal format. Address ranges correspond to register types as follows:

- COIL STATUS = 0xxxx
- INPUT STATUS = 1xxxx
- INPUT REGISTER = 3xxxx
- HOLDING REGISTER = 4xxxx

NOTE: When entered in hexadecimal format, the value is only the register offset and does not include the Register Type identification.

Request Type
This tells the system whether or not it can read (R) the specified register.
Register Mask
This mask is applied to the raw data received from the register. The mask is applied in an AND fashion.
For example, if the mask “0x4” is applied, then the register value displayed is only nonzero if the 3rd least significant bit in the register is a 1.
You can apply masks to both numeric and Boolean data types. To apply custom masks, scroll down the list and select Custom. When prompted, enter the value in Decimal, Binary, or Hexadecimal format.

**NOTE:** For integer values, the bit order of the mask corresponds to the bit order of the actual data and NOT the order in which the bytes representing the data are returned over Modbus. The high-order nibble of a 32-bit value is selected as ‘0xf0000000’ regardless of whether the format is U32_4321 or U32_2143. It should also be noted that the resulting value of a masked integer is NOT bit shifted. A mask of ‘0xf000’ applied to a 16-bit value of ‘0x1234’ results in ‘0x1000’ (4096 decimal) and NOT 1.

Register Scale and Register Multiplier
This specifies what the scale factor of the data being requested should be. The scale can be set to any constant decimal value within the range of -3.402823466 E + 38 to 3.402823466 E + 38. If you can obtain the scale for a specific register from the device, then you can map the scale value to another register. You can only map the scale factor to registers already created in the Modbus Device Importer.
The mapped register used can be a valid Modbus mapped register or a register with a constant value. Mapping the scale to a constant register is a convenient feature; you can change the scale for many registers by changing the constant value in one location.

**Mapping the scale factor to another register**
1. Select the Reference another register for the scale check box to open the Select Register for Reference dialog.
2. Use the dropdown list to navigate to the required register. Click OK.
The scale to be used now appears in the Register Scale field.

Register Offset
The register offset is used if the register value returned must be offset by a value.
The scale can be set to any constant decimal value within the range of -3.402823466 E + 38 to 3.402823466 E + 38

**NOTE:** If “10” is entered, then 10 is subtracted from the received value. To add 10, enter “-10”.

Scale / Multiplier and Offset applied:
Modbus value = scale * ION value + offset / multiplier
OR

ION value = (Modbus value - offset) * multiplier / scale

If the offset for a specific register can be obtained from the device, then you can map the offset value to another register. You can only map the offset factor to registers already created in the Modbus Device Importer.

The mapped register used can be a valid Modbus mapped register or a register with a constant value.

Mapping the offset to a constant register is a convenient feature; you can change the offset for many registers by changing the constant value in one location.

**Mapping the offset factor to another register**

1. Select the **Reference another register for Offset** check box.
2. Use the drop-down menus to navigate to the required register. Click **OK**.

   The offset to be used now appears in the Register Offset field.

**Register Not Available Value**

If the register has a control signal value to indicate that the register is currently not available, then you can set the value here. The value must match the data that is received from the register on the device. If a value is received that matches this property value, the string “Not Available” is displayed when viewing the register in Vista.

**Boolean Labels**

This option is only available for Boolean registers. It allows you to set default labels for Status Objects in Vista.

**Value to Send Out as a Pulse**

This option is only available for pulse registers. It allows you to specify the exact Modbus value sent to the device when a pulse register is activated in Vista.

**Constant String Value**

A constant for manipulating data retrieved from the device.

**Number of Registers to Request**

This option is only available if the data type is set to ASCII, ASCII-Reverse or Packed BCD. It allows you to specify the number of registers to retrieve from the device on a request.

**Enumeration**

Enumeration is useful for converting numeric value representation into human readable string values.

For example, you can use enumeration on a Baud rate register. The value is represented as a number from 0 to 3, where 0 = 300 Baud and 3 = 115200 Baud. With enumeration you can map the return values to corresponding string values. In Vista, when you view the register, it displays the corresponding string value instead of the actual return value.
You can also use enumeration to generate non-contiguous scaling values for other registers. For example, a Modbus scale register returns -2, -1, 0, +1 and +2, which indicate scaling of 10-2, 10-1, 1, 101 and 102 respectively. In this case, use an enumerated ordinal of -2 through +2 with enumerated labels “0.01” through “100”.

You can access enumeration for a register from the register properties window, the Edit Mode window and also from the toolbar.

When selected, the **Edit Enumeration Labels** dialog opens.

To add or remove enumeration values, select them and click **Add New** or **Remove**. When new enumerations are added, they are appended to the bottom of the list and are given the next sequential ordinal value. You can relocate values up and down with the up and down arrow and buttons.

To change the ordinal value for the enumerations, double-click in the Ordinal Values list. The change propagates down to the bottom of the list, ensuring that the list goes from smallest number to largest number.

**Shortcut keys**

**General Key shortcuts**

<table>
<thead>
<tr>
<th>Keystrokes</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL-N</td>
<td>Opens a new template (after a save prompt).</td>
</tr>
<tr>
<td>CTRL-O</td>
<td>Opens an existing template (after a save prompt).</td>
</tr>
<tr>
<td>CTRL-S</td>
<td>Quick saves the current template.</td>
</tr>
<tr>
<td>CTRL-A</td>
<td>Saves the current template in a new location.</td>
</tr>
<tr>
<td>CTRL-D</td>
<td>Adds the device to the ION_Network database.</td>
</tr>
<tr>
<td>CTRL-U</td>
<td>Updates the device in the ION_Network database.</td>
</tr>
<tr>
<td>CTRL-G</td>
<td>Adds Network diagram support for the device to the system.</td>
</tr>
<tr>
<td>CTRL-P</td>
<td>Opens the device properties window.</td>
</tr>
<tr>
<td>F5</td>
<td>Refreshes the ION Map Information pane, collapsing all nodes except the currently selected node.</td>
</tr>
<tr>
<td>F6</td>
<td>Collapses all nodes in the tree-view.</td>
</tr>
<tr>
<td>F11</td>
<td>Saves the current ION Handle list.</td>
</tr>
<tr>
<td>F12</td>
<td>Views the current device types in the ION_Network database.</td>
</tr>
</tbody>
</table>

**Register Quick Edit mode**

<table>
<thead>
<tr>
<th>Keystrokes</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>TAB</td>
<td>Cycles through the data fields.</td>
</tr>
<tr>
<td>Enter</td>
<td>Saves the changes to the current register and exits edit mode.</td>
</tr>
<tr>
<td>Page Up</td>
<td>Saves the changes to the current register and displays the edit mode for the register above the current register.</td>
</tr>
<tr>
<td>Keystrokes</td>
<td>Action</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Page Down</td>
<td>Saves the changes to the current register and displays the edit mode for the register below the current register.</td>
</tr>
<tr>
<td>Escape or Mouse-Wheel Click</td>
<td>Cancels the changes to the current register and exits edit mode.</td>
</tr>
</tbody>
</table>

### ION Map Information pane

<table>
<thead>
<tr>
<th>Keystrokes</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Right Arrow</td>
<td>Expands a node or selects a child if children are already expanded.</td>
</tr>
<tr>
<td>Left Arrow</td>
<td>Collapses a node or selects a parent node if no children are expanded.</td>
</tr>
<tr>
<td>Up Arrow</td>
<td>Scrolls up through the list of nodes.</td>
</tr>
<tr>
<td>Down Arrow</td>
<td>Scrolls down through the list of nodes.</td>
</tr>
<tr>
<td>Mouse Right-Click</td>
<td>Opens the edit menu.</td>
</tr>
<tr>
<td>Enter, Space Bar or CTRL-X</td>
<td>Opens the properties window for the selected object.</td>
</tr>
<tr>
<td>F1</td>
<td>If the root device type is selected, a new manager is created and the manager properties window is displayed.</td>
</tr>
<tr>
<td>F2</td>
<td>If a manager is selected, a new module is created and the module properties window is displayed.</td>
</tr>
<tr>
<td>F3</td>
<td>If a module is selected, a new register is created and the register properties window is displayed.</td>
</tr>
<tr>
<td>F4</td>
<td>If a module is selected, a new register is created but the register properties window is not displayed.</td>
</tr>
<tr>
<td>Insert</td>
<td>- It is equivalent to F1, F2 or F3 depending on which object is currently selected.</td>
</tr>
<tr>
<td></td>
<td>- If a register is selected, then the enumeration window is displayed.</td>
</tr>
<tr>
<td>Delete</td>
<td>- If a manager is selected, a prompt to delete the manager is displayed.</td>
</tr>
<tr>
<td></td>
<td>- If a module is selected, a prompt to delete the module is displayed.</td>
</tr>
<tr>
<td></td>
<td>- If a register is selected, a prompt to delete the register is displayed.</td>
</tr>
</tbody>
</table>
Keystrokes | Action
--- | ---
ALT + dragging an object | - If the object is a module it can be dragged and dropped into another manager of a similar class.
- If the object is a register it can be dragged and dropped into another module of a similar class.
CTRL-C | - If a module is selected, then the module is copied.
- If a register is selected, then the register is copied.
CTRL-V | - If a manager is selected and a module has been copied, then the module is pasted.
- If a module is selected and one or more registers have been copied, then the registers are pasted.
CTRL-B | If a module is selected and one or more registers have been copied, then the registers are clone pasted.
CTRL-Z | If a module is selected and one or more registers have been copied, then a prompt comes up asking how many copies to paste.

**Modbus Register Information pane**

Keystrokes | Action
--- | ---
Up Arrow | Scrolls up through the list of registers.
Down Arrow | Scrolls down through the list of registers.
Mouse Right-Click | Opens the edit menu.
Enter, Space Bar or CTRL-X | Opens the quick edit window for the selected register.
Insert or F3 | A new register is created in the module of the currently selected register and the register properties window is displayed.
F4 | A new register is created in the module of the currently selected register but the register properties window is not displayed.
Delete | A prompt is displayed asking to confirm the delete of the selected registers.
ALT + dragging one or more objects | The selected registers can be dragged and dropped over to a new module of similar class in the tree-view.
Insert | It is equivalent to F1, F2 or F3 depending on which object is currently selected. If a register is selected then the Enumeration window is displayed.
<table>
<thead>
<tr>
<th>Keystrokes</th>
<th>Action</th>
</tr>
</thead>
</table>
| **Delete** | - If a manager is selected a prompt to delete the manager is displayed.  
- If a module is selected a prompt to delete the module is displayed.  
- If a register is selected a prompt to delete the register is displayed. |
| **Holding ALT while dragging an object** | - If the object is a module it can be dragged and dropped into another manager of a similar class.  
- If the object is a register it can be dragged and dropped into another module of a similar class. |
| **CTRL-C** | The selected registers are copied. |
| **CTRL-V** | The registers that have been copied are pasted into the current module. |
| **CTRL-B** | The registers that have been copied are clone pasted into the current module. |
| **CTRL-Z** | The registers that have been copied are pasted multiple times into the current module. A prompt comes up asking how many copies to paste. |

**Additional information**

**Data formats**

Typically, Modbus data is transmitted in big ENDIAN (big end in) format but alternates in which the individual 16-bit words are swapped are not uncommon. The formats supported by Power Monitoring Expert are:

<table>
<thead>
<tr>
<th>Format Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SINT16</td>
<td>A 16-bit signed value in 2-1 (or big ENDIAN) format. The high order byte is first, the low-order byte second.</td>
</tr>
<tr>
<td>UINT16</td>
<td>A 16-bit unsigned value in 2-1 (or big ENDIAN) format. The high order byte is first, the low-order byte second.</td>
</tr>
<tr>
<td>SINT32 or S32-4321</td>
<td>A 32-bit signed value returned in two consecutive 16-bit registers. The high-order word is returned in the first register, the low order word in the second. In effect, the 4 bytes are returned in 4-3-2-1 (or big ENDIAN) format.</td>
</tr>
<tr>
<td>UINT32 or U32-4321</td>
<td>A 32-bit unsigned value returned in two consecutive 16-bit registers. The high-order word is returned in the first register, the low-order word in the second. In effect, the 4 bytes are returned in 4-3-2-1 (or big ENDIAN) format.</td>
</tr>
<tr>
<td>Format Type</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------</td>
</tr>
<tr>
<td>S32-2143</td>
<td>A 32-bit signed value returned in two consecutive 16-bit registers. Contrary to S32_4321, the high-order word is returned in the second register, the high-order word in the first. In effect, the 4 bytes are returned in 2-1-4-3 format.</td>
</tr>
<tr>
<td>U32-2143</td>
<td>A 32-bit unsigned value returned in two consecutive 16-bit registers. Contrary to U32_4321, the high-order word is returned in the second register, the low-order word in the first. In effect, the 4 bytes are returned in 2-1-4-3 format.</td>
</tr>
<tr>
<td>S32-MFP or S32-M10k-4321</td>
<td>A 32-bit signed value returned in two consecutive 16-bit registers. The word stored in the first 16-bit register is multiplied by 10000 and added to the word stored in the second 16-bit register. Also known as ‘signed Modulo 10000’.</td>
</tr>
<tr>
<td>U32-MFP or U32-M10k-4321</td>
<td>A 32-bit unsigned value returned in two consecutive 16-bit registers. The word stored in the first 16-bit register is multiplied by 10000 and added to the word stored in the second 16-bit register. Also known as ‘unsigned Modulo 10000’ or mod-10K.</td>
</tr>
<tr>
<td>S32-M10k-2143</td>
<td>A 32-bit signed value returned in two consecutive 16-bit registers. Contrary to S32_M10k_4321, the word stored in the second 16-bit register is multiplied by 10000 and added to the word stored in the first 16-bit register.</td>
</tr>
<tr>
<td>U32-M10k-2143</td>
<td>A 32-bit unsigned value returned in two consecutive 16-bit registers. Contrary to U32_M10k_4321, the word stored in the second 16-bit register is multiplied by 10000 and added to the word stored in the first 16-bit register.</td>
</tr>
<tr>
<td>S48-M10k-21-65</td>
<td>A 48-bit signed value returned in three consecutive 16-bit registers. R3<em>10,000^2 + R2</em>10,000 + R1, where R3 is the last register and R1 is the first register. Each registers range is -9,999 to +9,999</td>
</tr>
<tr>
<td>U48-M10k-21-65</td>
<td>A 48-bit unsigned value returned in three consecutive 16-bit registers. R3<em>10,000^2 + R2</em>10,000 + R1, where R3 is the last register and R1 is the first register. Each registers range is 0 to +9,999</td>
</tr>
<tr>
<td>S64-M10k-21-87</td>
<td>A 64-bit signed value returned in four consecutive 16-bit registers. R4<em>10,000^3 + R3</em>10,000^2 + R2*10,000 + R1, where R4 is the last register and R1 is the first register. Each registers range is -9,999 to +9,999</td>
</tr>
<tr>
<td>U64-M10k-21-87</td>
<td>A 64-bit unsigned value returned in four consecutive 16-bit registers. R4<em>10,000^3 + R3</em>10,000^2 + R2*10,000 + R1, where R4 is the last register and R1 is the first register. Each registers range is 0 to +9,999</td>
</tr>
<tr>
<td>S64-87-21</td>
<td>A 64-bit signed value returned in four consecutive 16-bit registers. The highest order word is returned in the first register, the lowest order word in the fourth. In effect, the 8 bytes are returned in 8-7-6-5-4-3-2-1 (or big ENDIAN) format.</td>
</tr>
<tr>
<td>U64-87-21</td>
<td>A 64-bit unsigned value returned in four consecutive 16-bit registers. The highest order word is returned in the first register, the lowest order word in the fourth. In effect, the 8 bytes are returned in 8-7-6-5-4-3-2-1 (or big ENDIAN) format.</td>
</tr>
<tr>
<td>S64-21-87</td>
<td>A 64-bit signed value returned in four consecutive 16-bit registers. The highest order word is returned in the fourth register, the lowest order word in the first. In effect, the 8 bytes are returned in 2-1-4-3-5-8-7 (or little ENDIAN) format.</td>
</tr>
<tr>
<td>Format Type</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>U64-21-87</td>
<td>A 64-bit unsigned value returned in four consecutive 16-bit registers. The highest order word is returned in the fourth register, the lowest order word in the first. In effect, the 8 bytes are returned in 2-1-4-3-6-5-8-7 (or little ENDIAN) format.</td>
</tr>
<tr>
<td>S16-1-15</td>
<td>A 16-bit signed value. Bits 1 to 15 are unsigned data. If bit 16 is 0, the value is positive, if bit 16 is 1, the value is negative.</td>
</tr>
<tr>
<td>IEEEFloat or F32-4321</td>
<td>A 32-bit IEEE floating point value returned in two consecutive 16-bit registers. The high-order word is returned in the first register and the low order word in the second. In effect, the 4 bytes are returned in 4-3-2-1 format.</td>
</tr>
<tr>
<td>SwappedFloat or F32-2143</td>
<td>A 32-bit IEEE floating point value returned in two consecutive 16-bit registers. Contrary to F32_4321, the high-order word is returned in the second register and the low order word in the first. In effect, the 4 bytes are returned in 2-1-4-3 format.</td>
</tr>
<tr>
<td>MaskedBool or PackedBool</td>
<td>A 16-bit value that is interpreted according to the bit pattern described by the Mask attribute. Bits exposed by the mask can be read or written without affecting the value of other bits. Unmasked bits are interpreted as 0 on a read and are unaffected on a write. Undeclared bits of a mask are interpreted as unmasked (i.e., mask=&quot;0x7F&quot; is interpreted as 0x007F). The value that is read or written is determined by using enumeration ordinals, described below. If used for read-only Boolean data, enumerations are not required. If no mask is specified, all bits are relevant.</td>
</tr>
<tr>
<td>PF-Nexus</td>
<td>A 16-bit unsigned value, range 0 to 3999, representing 3 decimal places of accuracy.</td>
</tr>
<tr>
<td>BCD (Binary Coded Decimal)</td>
<td>A number is expressed as a sequence of decimal digits and then each decimal digit is encoded as an 8-bit binary number. For example, decimal 92 is encoded as 00001001 00000010.</td>
</tr>
</tbody>
</table>

The following data types can have their length specified by the “Number of Registers to Request” setting.

| Packed BCD | A number is expressed as a sequence of decimal digits and then each decimal digit is encoded as a 4-bit binary number (nibble) For example, decimal 92 is encoded as 1001 0010. |
| ASCII      | A sequence of bytes representing the ASCII character set. Each word stores two ASCII characters. Trailing spaces are removed. |
| ASCII-Reverse | Same as ASCII except every second character is in the reverse order. |

**Configuring Logging and Calculation**

Use the **Configure Logging and Calculation** utility to perform additional Modbus device configuration, including:

- Enabling register logging, including setting log frequency.
- Enabling low (minimum), high (maximum) and mean (average) calculations and logging.
- Configuring stale data settings.
- Appending downstream device information to labels.
NOTE: Only numeric output registers can be calculated and logged. All other types of registers (for example, enumerated) do not appear on the Configure Logging and Calculation screen.

Screen overview

Click the Configure Logging and Calculation button from the main Modbus Device Importer screen to open the application.

The following screen appears:

A  Select this check box to make the downstream device columns appear
B  Pre-register edit area
C  Stale data link
D  Low area
E  High area
F  Mean area
G  Help link
H  Global register edit area. Use this area to globally edit all rows selected in the upper pane.

All the register information from the main MDI screen is pre-populated in this table when you open the application.

Show downstream device columns: Select this to show all the columns for selecting and setting the downstream device properties for registers.

Per-register area: Use this area to individually configure registers.

Low area: Use this area to enable calculation and set logging of low values.

High area: Use this area to enable calculation and set logging of high values.

Mean area: Use this area to enable calculation and set logging of mean values.
**Global register edit area:** Use the bottom half of the screen to edit individual registers or multiple registers, after selecting them in the list.

**Help link:** Click this link to open the Modbus Device Importer online help.

**Stale data link (All):** Click this link to open the Configure Stale Data Settings dialog.

**Filtering and sorting columns**

See "Sorting data in a column" on page 24 and "Filtering data in a column" on page 24 for instructions on filtering and sorting.

**Configuring register logging**

To edit registers on an **individual** basis, select the row of the register and edit the cells in the row or use the editing tools in the Global area.

To edit **more than one** register, select the rows you want to configure similarly and use the editing tools in the Global area.

**Log:** Select to enable logging of the register.

**Interval:** This value determines the logging frequency for the register. Note that this value also controls the reset interval for the min, max and averaging modules, even if these calculations are not being logged. The valid range is 1 to 4,000,000 seconds.

**Configuring Low, High and Mean Calculation and Logging**

To edit the suffix used for Low, High and Mean, click on the applicable link. For example, if you change the suffix to Maximum, VoltsA **High** becomes VoltsA **Maximum**.

**Low**

Select **Calculate** to enable calculation of low (minimum) values for this register. Select **Log** to enable logging of this value. Note how the label is appended to reflect that this is the low value.

**High**

Select **Calculate** to enable calculation of high (maximum) values for this register. Select **Log** to enable logging of this value. Note how the label is appended to reflect that this is the high value.

**Mean**

Select **Calculate** to enable calculation of mean (average) values for this register. Select **Log** to enable logging of this value. Note how the label is appended to reflect that this is the mean value.

**Configuring Stale Data settings**

The “staleness” of data is measured from time data was last read from a physical device until the current time.

Click the **All** (Stale Data) link to open the **Configure Stale Data Settings** dialog.
Mark data stale after: Enter the time you want to elapse before data from this register is marked stale in the data recorder. The valid range is 0 to 7200 seconds.

When data is stale: Select how you want stale data values logged. The setting “log an empty row” logs an empty row in the data recorder, while “use last known value” logs the last non-stale value in the data recorder until the end of the current interval.

NOTE: Stale data settings are global (they apply to all registers).

Configuring downstream device functionality

You must select the Show downstream device columns check box in the Configure Logging and Calculation window before you can edit downstream device functionality.

Show downstream device columns: Select this check box to make the downstream device columns appear.

Is Downstream Device: Select this checkbox to indicate the register belongs to a downstream device.

Downstream Device Name: Enter the name of the downstream device in this field. The register label is appended with this name. For example, if the device name is Meter01, the register label becomes VoltsA@Meter01.

NOTE: Using this option without also using the Include Name of Device Instance option causes multiple devices to appear as a single device in your energy management system. Do not use this option on its own unless only a single instance of this device is present in your system.

Include Name of Device Instance: Select this check box to append the actual device instance name to the register label. The placeholder !!DeviceName!! is then added to the label — the name of the actual device instance gets inserted when it is created in Management Console.

For example, if the device instance is named Device01:

VoltsA{!!DeviceName!!Meter01

is replaced with

VoltsA@Device01Meter01

This allows for the creation of unique names within Power Monitoring Expert, as well as enabling each device instance to appear in the product as multiple virtual devices.

For more information on downstream devices and naming conventions, see "Downstream Device Assistant" on page 263.
Saving and exiting

To exit the Configure Logging and Calculation screen:

- Click **OK** to save your settings.
- Click **Cancel** to exit without saving.

You are returned to the main Modbus Device Importer console screen.

1. Click **File > Save** to save the template files.
2. Click **Tools > Update Device Type** to send the template file changes to the ION_Network database.
Chapter 8: ION Alert Monitor

The ION Alert Monitor receives and processes alarm notifications coming from modem-connected meters on remote power monitoring locations.

In this section

ION Alert Monitor ........................................................................................................ 258
Setting up the ION Alert Monitor ........................................................................ 259
Starting the ION Alert Monitor ............................................................................. 262
ION Alert Monitor

ION Alert Monitor is a Windows service (“ION Alert Monitor”) that replaced the “Alarm Server” program that was available in ION Enterprise 5.5 and earlier (the legacy alarmsrv.exe program is still functional and available in the ...\system\bin folder).

Alert Monitor resides on a workstation, where it receives and processes incoming alarms from a remote ION meter’s Alert module.

With the implementation of the ION Alert Monitor, alarm notification is improved and simplified:

- Since Alert Monitor runs as a Windows service, a user is no longer required to log in to the product in order to start monitoring the system for alarm conditions.
- Alert Monitor can handle incoming calls from multiple communications ports.
- When alarms are received, Alert Monitor uses the ION Connection Management Service to establish a modem connection, rather than using the legacy command line executable “conman.exe”.
- ION Connection Management Service allows you to set up specific modem connection request properties, such as Minimum/Maximum Connection Time, Disconnect on Caught-up, etc. These properties are set up in the Alert Monitor’s configuration file — see “Setting up the ION Alert Monitor” on page 259.

**NOTE:** Alert Monitor does not support TAPI modem drivers for Windows (WinModems).

How it works

The ION Alert Monitor responds to alarm messages originating from the Alert module in an ION meter. For example, an alarm message is initiated as a result of a power quality event:

1. An alarm condition prompts the ION module (for example, Setpoint module) to send a pulse signal to the Trigger input of the ION meter’s Alert module. Refer to the description of the Alert Module in the ION Reference for more information.

2. The Alert module initiates modem communication, and calls the phone number specified in the Alert module’s Destination setup register.

3. The Power Monitoring Expert workstation answers the modem call from the ION meter and completes the communication connection. The meter then sends the following information to Power Monitoring Expert: a timestamp indicating when the alarm condition occurred, the node name, and the message (i.e., contents of the Alert module’s Message setup register).

4. Alert Monitor receives the alarm data and places it in the queue for processing. When the alarm is processed, the commands specified in the COM port configuration settings are executed. At the same time, a connection request is sent to the node specified in the alarm data.
5. The new connection request is received and placed in the queue. If other connection requests to the same site already exist, the new request is merged with the others.

6. ION Connection Management Service establishes a connection to the meter that originated the alarm, then Log Inserter downloads all outstanding event and data logs.

   **NOTE:** ION Connection Management Service uses a modem (from the modem pool) to establish connection to the remote site.

7. ION Connection Management Service disconnects after the ION Log Inserter Service has finished downloading all outstanding logs. When this has been completed, the status of the site is considered "Caught-up".

### Setting up the ION Alert Monitor

**NOTE:** This section is intended for advanced users. Contact Technical Support if you need assistance.

The configuration settings for Alert Monitor are stored in a config file that follows the file naming convention "{MachineName}.AlertMonitor.config". An example config file with this name is provided in the ...\Power Monitoring Expert\config\AlertMonitor folder. An XML schema file named “AlertMonitor-Schema.xml” is also provided in the same folder, for your reference. You can use this schema to validate the config file using available XML validation tools.

Use a text editor or XML authoring tool to create and edit the configuration file. Remember to rename the config file to match the machine name (for example, if the primary server is named “ComputerOne”, rename the config file to “ComputerOne.AlertMonitor.config”).

#### Configuration file components

**Channels** define the communication port and modem that the Alert Monitor uses, while **Actions** define the commands to be carried out in response to an alarm.

A Channel contains the modem definition and configuration settings for the port.

The following table lists the attributes you can assign for a Channel:

<table>
<thead>
<tr>
<th>Channel attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the communications port the modem is connected to. The default value is COM1.</td>
</tr>
<tr>
<td>ModemType</td>
<td>The type of modem. The value entered here must exactly match the displayed value under &quot;Modem Type&quot; property in the “Dial Out Modem Options” dialog.</td>
</tr>
<tr>
<td>BaudRate</td>
<td>The modem’s baud rate. The default value is 9600.</td>
</tr>
</tbody>
</table>
### Channel attribute | Description
--- | ---
AlertMonitorNodeName | The node name, as it appears in the system log messages. The text specified here defines the value for the %a command parameter (described below). The default value is AlertMonitor.[ComputerName]
NoLog | This controls whether all alarms are logged to the product’s system log. The default value is “YES” (log all alarms). A value of “NO” disables all alarm logging.
NumTries | This specifies how many times a connection attempt should be retried if there are communication errors.

**TIP:** Open the example file “{MachineName}.AlertMonitor.config” in a text editor program and refer to it when reading this section to see the proper usage of the elements and attributes in the ION Alert Monitor configuration file.

**Actions** are grouped inside ActionSet elements, which contain connection requests and/or commands to execute when alarms are received. Specify “ConnectionRequest” to set up an ActionSet to send a connection request; specify “Command” to set up an ActionSet to execute an operating system command when the alert is received. You can specify attributes for ActionSets:

- If the Channel attribute is used in the ActionSet (for example, `<ActionSet Channel="COM1">`), then the actions (commands) listed in the ActionSet are executed for all alarms coming through the communications port and modem specified for that Channel (that is, “COM1”).
- If the Location attribute is used in the ActionSet, then the actions (commands) listed in the ActionSet are executed for all alarms originating from the specified Location (regardless of Channel).
- If no attribute is specified, then the actions (commands) listed in the ActionSet are executed for all alarms originating from any communication port or location.

If there are two ActionSets (one specifying a Channel attribute, the other specifying Location attribute), then the one that specifies the Location attribute takes priority.

**NOTE:** The value of the “Location” attribute is specified in the Location setup register of the Alert module for the meter that is sending the alert. For details, refer to the Alert Module description in the ION Reference.
Commands (i.e., command lines that run separate applications such as “net send”) contained in the ActionSet can include parameters that return data values, as described in the following table:

<table>
<thead>
<tr>
<th>Command Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>%U</td>
<td>Universal time: seconds since January 1, 1970</td>
</tr>
<tr>
<td>%u</td>
<td>Universal time: YYYY-MM-DD HH:MM:SS.FFF</td>
</tr>
<tr>
<td>%T</td>
<td>Local time: seconds since January 1, 1970</td>
</tr>
<tr>
<td>%t</td>
<td>Local time: YYYY-MM-DD HH:MM:SS.FFF</td>
</tr>
<tr>
<td>%n</td>
<td>Node name (for example, device name)</td>
</tr>
<tr>
<td>%g</td>
<td>Gate name (for example, site name)</td>
</tr>
<tr>
<td>%p</td>
<td>Priority name</td>
</tr>
<tr>
<td>%P</td>
<td>Priority number</td>
</tr>
<tr>
<td>%m</td>
<td>Alarm message without delimiters</td>
</tr>
<tr>
<td>%M</td>
<td>Alarm message with &quot; &quot; delimiters</td>
</tr>
<tr>
<td>%a</td>
<td>The value of the AlertMonitorNodeName attribute. If this attribute is not used, the default value is “AlertMonitor.[ComputerName]”</td>
</tr>
</tbody>
</table>

The “ConnectionRequest” element contained in the ActionSet has attributes that you can define, as described in the following table:

<table>
<thead>
<tr>
<th>ConnectionRequest Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MaxConnectTimeSeconds</td>
<td>Maximum time (in seconds) a connection to the site is maintained. The default value is 300 seconds.</td>
</tr>
<tr>
<td>MinConnectTimeSeconds</td>
<td>Minimum time (in seconds) a connection to the site is maintained. The default value is 60 seconds.</td>
</tr>
<tr>
<td>RequestLifetimeHours</td>
<td>Defines how many hours a connection request remains valid before it is discarded (even if attempts to connect to the site are unsuccessful). The default value is 0.</td>
</tr>
<tr>
<td>RequestPriority</td>
<td>Priority of the connection request, which ranges from 0 to 2000. The highest priority is 2000. The default value is 1999.</td>
</tr>
<tr>
<td>DisconnectOnCaughtUp</td>
<td>This specifies to automatically disconnect from the site after Log Inserter has finished downloading all outstanding logs, including event and data logs. The default value is “No”</td>
</tr>
</tbody>
</table>
### Multi-station setup

It is possible to run the ION Alert Monitor on more than one machine in the Power Monitoring Expert system. However, the configuration files must be stored in the primary server, following the convention “ComputerName.AlertMonitor.config”.

For example, the Alert Monitor running on a secondary server named “ComputerTwo” uses the configuration file named “ComputerTwo.AlertMonitor.config” located in the primary server.

### Diagnostics

Diagnostic and error messages are logged in the Power Monitoring Expert system log, with the source “Alert Monitor”.

### Starting the ION Alert Monitor

By default, the ION Alert Monitor is stopped, and set to “Manual” startup type. To automatically start Alert Monitor on Windows startup, change the startup properties of this Windows service to “Automatic”, then start the service. Refer to your Windows documentation for details.

<table>
<thead>
<tr>
<th>ConnectionRequest Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device</td>
<td>This explicitly defines which specific device to connect to in the site. This attribute overrides data contained in the alarm message.</td>
</tr>
<tr>
<td>Site</td>
<td>This explicitly defines which site to connect to. This attribute overrides data contained in the alarm message.</td>
</tr>
</tbody>
</table>
Chapter 9: Downstream Device Assistant

Downstream Device Assistant lets you manage downstream devices. With this tool, you can rename downstream sources, change which measurement is associated with specific data from a source, and apply these changes to previously recorded data in ION_Data (historical database). You can also display and manage all the physical sources (devices) in your network.

Downstream Device Assistant is an advanced application and should only be used by users with advanced technical skills and a clear understanding of how data is interpreted and stored in the Power Monitoring Expert databases.

In this section

- Detecting downstream devices ................................................................. 264
- Downstream Device Assistant basics .................................................... 265
- Downstream Device Assistant functions ............................................... 270
- Downstream Device Assistant commands .............................................. 273
Detecting downstream devices

A downstream device is one whose data is logged by a remote data recorder, for example:

- A Modbus slave device whose output registers are logged by a device with Modbus Mastering capability (see illustration below).
- A Modbus device whose outputs are logged by the Virtual Processor.
- Any of various multiple sources in which the same measurement is being logged on a single device, for example, an RTU that is collecting kWh pulses from multiple sources or a single branch circuit monitor that is collecting current readings on multiple circuits.

| A | Power Monitoring Expert server |
| B | Ethernet |
| C | kW |
| D | Data Recorder |
| E | Physical source (Modbus Master) |
| F | RS-485 |
| G | Downstream Devices (Modbus Slaves) |

Power Monitoring Expert automatically detects downstream devices. The Log Inserter component does this by looking for devices (called “physical sources”) that record or host data coming from various downstream devices (for example, an ION meter that utilizes a Modbus Import module to pass through data originating from a “downstream” Modbus device).

Log Inserter resolves the data from each of these downstream devices to the appropriate measurement (for example, the label “VII ab” resolves to the measurement “Voltage Phases AB”). For data that cannot be resolved, Log Inserter creates measurements whose names are based on the ION register labels.

Log Inserter uses a logical naming scheme to assign names to the downstream devices. For example, “Modbus.34” is the name assigned to the downstream Modbus device with a slave address “34”.
Downstream Device Assistant basics

Use Downstream Device Assistant to edit the names assigned to downstream devices or to assign the correct measurement label for a register that has an incorrect measurement mapping.

**IMPORTANT:** Before using the Downstream Device Assistant, make sure you save a copy of the ION_Network and ION_Data databases, in case you need to revert to the original configuration of these databases.

Starting the Downstream Device Assistant

1. Run the program named “DownstreamDevices.DownstreamAssistant.exe” in the \Power Monitoring Expert\system\bin folder.
   A message displays to remind you to back up your ION_Network and ION_Data databases. Click OK to continue.
3. Downstream Device Assistant opens in Basic view or Advanced view, depending on the last view it was in before it was closed. The first time Downstream Device Assistant is started, it opens in Basic view.

Basic view versus Advanced view

The view determines what columns are available as well as whether an action is global (applied to all rows containing a parameter) or specific to a row.
## Columns descriptions

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>IsDownstream</strong>&lt;sup&gt;1&lt;/sup&gt;</td>
<td>The <strong>IsDownstream</strong> column identifies which devices in the <strong>Assigned Source</strong> column are downstream devices. If <strong>IsDownstream</strong> is selected, it means that the device identified in the <strong>Assigned Source</strong> column is downstream to a physical device, whose name is indicated in the <strong>Physical Source</strong> column. If <strong>IsDownstream</strong> is cleared, this indicates that the device is a physical source. Note also that a physical source has the same <strong>Assigned Source</strong> name and <strong>Physical Source</strong> name, by default.</td>
</tr>
<tr>
<td><strong>Assigned Source</strong></td>
<td>This is the default name that Log Inserter assigned to a downstream or physical device. For example, “Modbus.109:MainFeed.PM7650” is the default name assigned for the downstream Modbus device with unit ID “109”, whose measurements are being logged to a data recorder on a Modbus Master device named “PM7650” that is part of the “MainFeed” site (group).</td>
</tr>
<tr>
<td><strong>Updated Assigned Source</strong></td>
<td>This text field allows you change the current name under <strong>Assigned Source</strong>. In Basic view, all rows that contain the same <strong>Assigned Source</strong> name are automatically updated to the new name when you enter it in the <strong>Updated Assigned Source</strong> column. In Advanced view, you can select one or more rows and rename the source using the <strong>Updated Assigned Source</strong> column, while leaving the other rows unchanged. See &quot;Renaming the assigned source&quot; on page 270 for more details.</td>
</tr>
<tr>
<td><strong>Physical Source</strong>&lt;sup&gt;2&lt;/sup&gt;</td>
<td>This identifies the name of the physical device (for example, a Modbus Master device or the Virtual Processor) that is performing the data logging for a downstream device.</td>
</tr>
<tr>
<td><strong>Measurement</strong></td>
<td>This column displays either the ION label (for example, “Vln avg”) or the descriptive name of the measurement (for example, ”Average Voltage Line-to-Neutral”), depending on the setting in the Options dialog; see &quot;Downstream Device Assistant options&quot; on page 268.</td>
</tr>
</tbody>
</table>

### Additional Columns in Advanced View

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Updated Measurement</strong></td>
<td>This lets you redefine what is currently assigned in the Measurement column. Click the cell to display the list of measurements to choose from. Depending on the setting in the Options dialog, you can select from a list containing only the most common measurement definitions or from a list of all available measurements; see &quot;Downstream Device Assistant options&quot; on page 268.</td>
</tr>
<tr>
<td><strong>Handle</strong></td>
<td>This column displays a measurement’s register handle either in hexadecimal format or decimal format, depending on the setting in the Options dialog; see &quot;Downstream Device Assistant options&quot; on page 268.</td>
</tr>
<tr>
<td><strong>Entered By</strong></td>
<td>This identifies which user made a change to the source-measurement definition.</td>
</tr>
</tbody>
</table>
### Columns in Both Basic and Advanced View

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Update Historical Database</strong></td>
<td>The Update Historical Database check box is automatically selected after entering changes in the Updated Assigned Source or Updated Measurement cell. This means that all historical database entries that contain the old Assigned Source name or Measurement will be updated with the new name or measurement. If you want to leave the existing data in the database unchanged, clear the Update Historical Database check box before saving the changes.</td>
</tr>
<tr>
<td><strong>Manual (see the Note below)</strong></td>
<td>By default, Log Inserter automatically associates the proper measurement to the appropriate piece of data in the data log. Normally, the Manual check box should remain cleared. However, if you want to specifically change the measurement or register handle associated with a particular address definition, select the Manual check box for that measurement. This manually overrides Log Inserter so that it uses this new address mapping from now on (i.e., Log Inserter does not attempt to resolve that address ever again).</td>
</tr>
</tbody>
</table>

---

1 Do not change the value of “IsDownstream” when making changes to source/measurement definitions, as it is automatically set by the Downstream Device Assistant
2 Do not use the Physical Source column to modify the existing name of a valid physical device, as Log Inserter uses this name to perform proper data logging.

---

**NOTE:** It is not recommended that you select the Manual check box. This reserves the ION register for which Manual is checked for the selected measurement. This mapping remains in place even if the device is reconfigured such that this register is used in an entirely different context. This may cause unexpected problems in the ION_Data database. It should be used only if you are certain that the configuration you have chosen will not change.

### Basic view

To switch to Basic view, click View > Options. In the Advanced section of the Options dialog, clear the enable advanced features check box. Click OK.

In Basic view, when you enter a new name in the Updated Assigned Source column, all rows that contain the same Assigned Source name are automatically filled in with the new name. Existing data in the historical database (ION_Data) is also automatically updated to reflect the change.

### Advanced view

To switch to Advanced view, click View > Options. In the Advanced section of the Options dialog, select the enable advanced features check box. Click OK.
In addition to the columns displayed in Basic view, Advanced view displays all the other columns for editing individual source-measurement definitions (i.e., Updated Measurement, Handle, Entered By, Update Historical Database, and Manual). In Advanced view, you can:

- Select and make changes to a specific row without affecting the other rows. For example, you may want to change the source name for one particular measurement while leaving the original source name unchanged for all the other measurements.
- Select a different measurement for one that is incorrectly mapped to a particular register handle.
- Select whether or not to update historical data for a changed source name or measurement definition, by selecting or clearing the Update Historical Data check box, respectively. Changing a name or definition automatically selects this check box.
- Select whether or not to allow Log Inserter to resolve the register handle to a particular source measurement, by clearing or selecting the Manual check box, respectively. The default setting is cleared (i.e., Log Inserter automatically resolves the register handle to the source measurement definition). If you want to force the change so Log Inserter does not resolve the handle to the new measurement, select the Manual check box.

**Displaying physical sources**

The default view for Downstream Device Assistant displays only the downstream devices. To display the physical sources as well:

1. Click View > Select Physical Sources.
2. Select the check box beside the physical sources you want to display. Select the Select/Clear All check box to select all physical sources or clear it to select none. Click OK.

**NOTE:** The Physical Sources are not displayed if you restart Downstream Device Assistant. By default, only downstream devices are displayed when Downstream Device Assistant is started.

**Sorting data**

Click a column heading to sort the row entries in ascending or descending alphanumeric order, according to that column.

**Downstream Device Assistant options**

Click View > Options to open the Options dialog. The dialog contains Measurements, Historical Data, and Advanced options.

Certain options such as “show all measurements” and the “Handles” display options are disabled in Basic View. To enable them, switch to Advanced View first (see "Advanced" on page 269).
**Measurements**

This section allows you to select whether to display the default ION label (for example, “VIn avg”) in the Measurement column or to display the full descriptive name of the measurement (for example, “Average Voltage Line-to-Neutral”).

In Advanced view only, you can also select whether to display all available measurements or only the most common measurements in the list when picking a measurement in the Updated Measurement column.

**Displaying ION labels versus measurement names**

To change the setting:

1. Click **View > Options**.
2. In the Measurements section, select **display ION labels** to display the ION label or **display measurement names** to display the full name of the measurement.

**NOTE:** In some situations, if “display ION labels” is selected, the displayed label may not match the label on your meter (for example, if a custom label was used). Instead, it displays the known default label for that particular measurement.

**Updated Measurement column display**

To change the setting:

1. Click **View > Options** and ensure Advanced is selected.
2. In the Measurements section, select **show all measurements** to display all available measurements in the **Updated Measurement** column. To display only the most common measurements, clear **show all measurements**.

**Historical data**

If the **show connection dialog** check box is cleared, the ION_Data database is automatically set as the “Default Connection” (for historical data).

If you want to select a different database, select the **show connection** dialog. With this setting enabled, the database connection dialog is displayed every time you save your changes. When the dialog opens, select **Custom Connection** and specify your database connection details.

**Advanced**

The **enable advanced features** check box sets the view to Basic View if it is cleared or Advanced View if it is selected.

**Handle**

Available in Advanced View only, this option specifies whether register handles are displayed as the hexadecimal value (with the “0x” prefix) or as the decimal value.
To change the setting:

1. Click View > Options and ensure the Advanced is selected.
2. In the Handles section, select display hex to display the register handle in hexadecimal format or display decimal to display it in decimal format.

If you want to manually resolve a register handle to a specific measurement, edit the value in the Handle cell, then select the Manual check box before saving the changes.

**Downstream Device Assistant functions**

This section describes different functions you can perform using the Downstream Device Assistant.

**Renaming the assigned source**

One of the primary reasons for using the Downstream Device Assistant is to change the default name assigned to a downstream device by the Log Inserter. For instance, instead of “Modbus.34”, you may want to rename that device to something more meaningful such as “SM_Bldg2_Boiler7”.

Renaming an **Assigned Source** typically only applies to downstream devices.

**Renaming the assigned source for all its measurements**

1. Switch to Basic view.
2. Find the source you want to rename. Enter the new name in the Updated Assigned Source column. All rows with measurements associated with the renamed source are automatically updated.
   
   If you do not want to assign the existing data in the database to the new source name, switch to Advanced View first, then clear the Update Historical Database check box for all appropriate rows.
3. Click File > Save.
4. A dialog opens showing a summary of the changes. Click Yes to continue. or No to cancel.
5. When the operation completes, click OK, then Close.

**Renaming the assigned source for one or more measurements**

1. Switch to Advanced View.
2. Select the row(s) you want to rename. To select a row, click the area just to the left of the first column. The row is highlighted to indicate that it is selected.
3. Click Edit > Rename Source.
4. In the Source Rename box, type the new name for the downstream source. Click OK.
NOTE: By default, the Update Historical Database check box is selected for all affected rows — this applies the change to existing data in the database. To make the change only to data going into the database from this point forward, clear the Update Historical Database check box for the affected rows.

5. Click File > Save. A dialog open showing a summary of the changes.

6. Click Yes to continue or No to cancel.

7. When the operation has completed, click OK, then click Close.

Cancelling changes
1. To undo all unsaved changes:
   - Click Edit > Reset, or
   - Click View > Refresh.
2. Click Yes to confirm.

Changing the measurement mapping
Log Inserter automatically associates logged data with a measurement by searching for a mapping between the label and the measurement. However, in cases where no mapping exists, Log Inserter creates a "measurement" that is based on the register label. To manually change this measurement mapping:
1. Switch to Advanced View.
2. Click the Updated Measurement cell that you want to change, then select the new measurement you want to map from the list.
4. By default, the Update Historical Database check box is selected — this applies the change to existing data in the database (if, for example, the source and measurement mapping you are adding already exists). To make the change only to data going into the database from this point forward, clear the Update Historical Database check box.
5. Click File > Save. A dialog opens showing a summary of the changes. Click Yes.
6. If prompted, select which database to update. Click OK.

Adding a new downstream device mapping
To add a new address mapping that associates the source and measurement to a specific logged quantity in the database:
1. Scroll down to the end of the table and click the last row (the one with the asterisk beside it).
2. Fill in the **Updated Assigned Source** and **Physical Source** columns. If the source is a physical device (i.e., not downstream), the same name must be entered exactly in both columns.

3. Click the **Updated Measurement** cell, then select the measurement from the list.

4. In the **Handle** cell, type the register handle for this measurement.

5. By default, the **Update Historical Database** check box is selected — this applies the change to existing data in the database (if, for example the source and measurement mapping you are adding already exists). To make the change only to data going into the database from this point forward, clear the **Update Historical Database** check box.

6. Click **File > Save**. A dialog opens showing a summary of the changes. Click **Yes**.

7. If prompted, select which database to update. Click **OK**.

**Updating the historical data at a later time**

When you save your changes using the Downstream Device Assistant, a record of changes to the source-measurement definitions is saved in the folder:

```plaintext
...\Power Monitoring Expert\config\Diagnostic\Downstream Device Assistant\
```

with the following filename:

“Downstream Device DefinitionsYYYY-MM-DD_hh.mm.ss.csv”

where “YYYY-MM-DD_hh.mm.ss” means current YEAR-MONTH-DAY_hour.minute.second.

If you cleared the **Update Historical Database** check box when you saved your changes the first time, you can update the existing data in the database at a later time, through the use of this csv file.

**How to use the Downstream Device Assistant .csv file**

To update the existing data in the database with the source-measurement changes contained in the csv file:

1. Click **Edit > Historical Data**. The Update Historical Data window appears.

2. Click **File > Import CSV**.

3. Downstream Device Assistant opens the folder that contains the csv files. Select the Downstream Device Definitions file you want to use, then click **Open**.

4. Click **File > Update Historical Data**.

5. The Historical Data Update prompt displays how many source-measurement pairs will be updated. Click **Yes**.

6. Click **Yes** at the Historical Data Update prompt.

7. After the operation has completed, click **OK**, then **Close**.
You can update only one ION database at a time. To select a different database, first make sure the **show connection dialog** check box is selected under **View > Options**. You can then use the database connection dialog to specify which database you want to update.

**NOTE:** If you update address definitions that affect multiple historical databases, only the first historical database you select is automatically updated. To update the remaining historical databases, you must import the address definitions to each one, using **Edit > Update Historical Data**.

### Activity log

The saved changes in the Downstream Device Assistant are stored in a log file named “Downstream Device Historical UpdatesYYYY-MM-DD_hh.mm.ss.txt”, that contains a description of the activities carried out when Downstream Device Assistant was updating the source-measurement definitions.

### Downstream Device Assistant commands

The following summarizes the commands available in the Downstream Device Assistant:

- **File > Save**: Saves your changes. A copy of the changes are saved for future reference, in a comma-separated value (.csv) data file in the ...\config\Diagnostic\Downstream Device Assistant\ folder.

- **File > Exit**: Closes the Downstream Device Assistant.

- **Edit > Reset**: Clears the modifications made since the last save.

- **Edit > Delete**: Deletes the selected rows.

- **Edit > Rename Source**: Lets you change the name of an **Assigned Source**. See "Renaming the assigned source" on page 270.

- **Edit > Update Historical Data**: Opens the “Update Historical Data” window that allows you to open a previously-saved source-measurement definition data file (with a .csv file extension), for the purpose of updating existing data in the database. You can also manually add, edit or delete data entries. See "Updating the historical data at a later time" on page 272.

- **View > Refresh**: Loads the current downstream definitions from the database. Functionally the same as **Edit > Reset**, as this command clears the modifications made since the last save.

- **View > Options**: Displays the **Options** dialog where you can change the settings that control what level of detail is displayed for the source-measurement definitions.

- **View > Select Physical Sources**: Displays the **Select Physical Sources** dialog where you can select which physical devices you want displayed in the Downstream Device Assistant.
Chapter 10: Reporter

The Reporter application allows you to define, generate, and manage comprehensive reports based on information contained in your database. Reporter processes selected data and generates a finished report in Microsoft Excel format.

Microsoft Excel and Outlook versions 2007 or 2010 are required by Reporter to format and generate reports, and to email generated reports, respectively.

The Reports application (formerly Web Reporter) in the Web Applications component of the product, can also be used to generate reports. See the Reports online help in the Web Applications component for further information.

In this section

Introduction .......................................................... 276
Creating a report ....................................................... 276
Generating a report ..................................................... 280
Modifying the finished report ........................................ 281
Types of default reports ............................................. 281
Automatic report generation ........................................ 285
Using Reporter on a client ........................................... 286
Troubleshooting ....................................................... 286
Introduction

Reporter features a wizard that guides you through the report creation process. This involves selecting a report template and database, which then allows the wizard to display those sources from your network that contain the type of data required to create the report.

When the report is generated, Reporter retrieves data from the ION_Data database, uses the report template to process the data, then creates a finished report in Microsoft Excel format.

Report templates are preconfigured for the most common reporting needs. The following report templates are supplied. See “Types of default reports” on page 281 for further information about these reports:

- Energy and Demand
- Load Profile
- Power Quality
- CM_EN50160_General
- CM_EN50160_Summary
- EN50160_General
- EN50160_Summary
- EN50160_Mains_Signal
- IEC61000-4-30_10Min
- IEC61000-4-30_2Hr
- IEC61000-4-30_3Sec

Starting Reporter

To start Reporter, double-click the Power Monitoring Expert folder on your desktop, then double-click the Reporter icon in the folder.

Reporter opens with either Manage Reports or Generate Reports pre-selected. The option pre-selected is dependent on whether or not any reports have already been created. You cannot generate reports until you have created at least one.

Creating a report

Creating a report involves the following steps:

1. Selecting a template.
2. Selecting databases and sources.
3. Setting up report options.
4. Previewing the report.

Each of these steps is described in more detail in the following topics.
To begin creating a report:
1. Start Reporter.
2. Select Manage Reports and click New to start the new report wizard.

Selecting a template
1. Type the name of the report in the Report Name field.
2. Select the template you want to use from the Report Template list.
3. Click Next.

Selecting database and sources
1. Specify your database (ION_Data is selected by default). To connect to a different database (for example, an archived database), select it from the Database dropdown list, or click More.
2. Select each source name (“device”) that you want to include in your report. Select Show Details if you want to see additional information for the devices.

   NOTE: Show Details is only available when you select Show only sources applicable to the template.

3. If the report template you are using requires a Time of Use (TOU) schedule (such as “Energy and Demand”), the TOU Schedule section appears in the dialog. Select a TOU schedule from the list or click Manage to create a new one. (See "Creating a new TOU schedule" on page 279 for further information.)

   A typical TOU schedule has On Peak, Off Peak and Shoulder Peak periods. The Energy and Demand report template requires a TOU schedule. If you do not want to use a TOU schedule, simply create a TOU schedule with a single Tariff period.

Setting up the report options
The report options are organized in the window by the tabs Date Range, Distribution, Validation, Display, and Notes.

Date Range
Select the date range you want to use for your report:

- **Ask for Date Range when report is generated** prompts you to supply a date range when the report is run (interactive mode).

- **Pre-specified Date Range** lets you select a specific period. For example, select Last Month to set Reporter to run the report using data from the previous month. Select Fixed Range to specify a start and end time/date. Select Custom Relative Range to specify a date range relative to the current time and date.
In applications where a report is generated based on a power quality system event or similar setpoint condition, specifying Custom Relative Range can include data that shows how the system was behaving before the event occurred.

Distribution
Select any or the entire set of the Distribution options (you must select at least one):

- **Show report on screen** is selected by default; this displays the report on screen each time the report is generated. Clear this box to disable displaying of the report.
- **Save Excel report to folder** stores the report in the folder you specify using the Browse button.
- **Save HTML report to folder** saves an HTML version of the report in the folder you specify using the Browse button.
  Note that there are certain elements and behaviors in the HTML report that may appear differently from the original Excel report. This is due to the HTML conversion process in Excel. Search the Microsoft support knowledgebase for more information.
- **Send report to printer** prints the report each time it is generated. Select the printer you want to use from the list.
- **Email report to recipients** sends the report (in Excel format) to an email address, using Microsoft Outlook 2003. Click New to add a new email address or Delete to remove an existing one from the list.

Validation
Select **Include duplicates and missing entries in source data** to enable error checking.

- Use the **Hours, Minutes** and **Seconds** boxes to specify an expected time interval between each record.
- Select **Only show duplicates in the status information** to display duplicate records in the report. Select **Do not show duplicates in the report** to delete redundant records from the report.

Duplicate data collection is disabled in Power Monitoring Expert by default. To enable duplicate data collection, the parameter **SaveDuplicates** must be set to 1 in the dbo.Registry table in the ION_Data database. Contact your SQL Server administrator if you require this change. Also note that enabling duplicate data collection results in more rapid growth in the size of the ION_Data database.
**NOTICE**

**LOSS OF DATA**
- Do not make unauthorized changes in the software product's databases.
- Only personnel with advanced knowledge of the software product's databases should make database parameter changes.

Failure to follow these instructions can result in irreversible database changes.

- If you want Reporter to insert records automatically for ones that are missing, select **Replace missing records with** then select **Values from the previous row, An empty row, or A zero value**.

**Display**
Select one of the options to control how Reporter handles raw data sheets in the report (Show, Hide, or Delete).

**NOTE:** **Delete** (raw data sheets) is useful when you want to reduce the report’s file size (this particularly applies to those reports that contain a significantly large amount of data).

The **Display Options** grid lists other options you can turn on or off. Double-click the appropriate row to turn the option on or off.

**Notes**
Use the Notes tab to enter details about your report template, such as revision history. To insert a line break, hold down CTRL and press ENTER.

**Previewing the report**
To see a preview of the report without saving or distributing it, click **Preview**. Click **Back To Report Generator** button to return to the main Reporter window. Modify the settings, if necessary. Otherwise, click **Finish** to save your report and return to the main Reporter screen.

**Creating a new TOU schedule**
To create a new TOU schedule:

1. Click **Manage** in the TOU Schedule section in the dialog to open the **TOU Schedules** dialog.

2. Click **New** to open the **TOU Schedule Properties** dialog with a blank TOU schedule with a single tariff.

   Use the left pane to select the item you want to edit, then use the right pane to enter, modify, or set the values.
If an existing (configured) TOU Schedule appears in the list, you can use it as a template to create a new one with similar On Peak/Off Peak periods. See “Copying an existing TOU schedule” on page 280.

3. Select New TOU Schedule then use the TOU Schedule Name field to rename it (for example, “2007 TOU Schedule”).

4. Select Tariff 1 to display the Tariff Details in the right pane, then use the Name field to type a name for it (for example, “Off Peak”).

Use the rate boxes ($/kWh, $/kW, etc.) to enter the tariff rates.

5. In the left pane, click the + beside the tariff to expand it. Select the text underneath it (All Day, Every Day...) to display the Tariff Period fields. Use the From and To boxes to set a time range and a date range for the tariff period.

To create another tariff period, select the tariff period you just configured, then click New to add a new tariff. Set the time range and date range for this new tariff period.

6. To create a new tariff (for example, Off Peak), select the tariff name, then click New. Repeat the above steps to rename the tariff, set the rates, and set the tariff periods.

**Holidays**

1. Select one of the Off Peak periods, then click New.

2. Rename the tariff (for example, Holidays) and click on the day and times underneath to configure the tariff period.

3. Select the appropriate country holidays from the list.

4. Add or remove individual holidays as required.

**NOTE:** Make sure there are no gaps or overlapping date or time ranges in the TOU Schedule.

**Copying an existing TOU schedule**

To create a TOU Schedule using an existing one as a template, select it then click Copy. Rename the copy and modify its properties as needed.

**Generating a report**

1. On the main Reporter screen, select Generate Reports.

2. Select the name of the report you want to run. If you want to view its option settings, click Summary. Click OK to close the summary window.

3. Click Generate. A window displays the progress of the report generation.

4. Click Close to view the report.
Modifying the finished report

To edit the Microsoft Excel presentation sheet for your report:

1. On the main Reporter window, select the report you want to modify, then click Preview.

2. Use the Presentation Sheet to create references to elements in the data sheets that you want to include in the final report. Use Microsoft Excel’s data analysis and charting tools to process the information in the data sheets, then add the appropriate references to the presentation sheet.

   The company name that appears in the report is the “Company” name entered when Microsoft Excel was installed on the computer.

3. Lay out and format the elements as you want them to appear in the report.

4. Save your changes.

Types of default reports

This section shows basic characteristics of the Microsoft Excel reports generated from the Reporter templates. The first tab in the workbook is created from the “Presentation sheet” of the report template. You can modify the look and functionality of a report by editing its presentation sheet. See "Creating a report" on page 276 for details.

NOTE: The presentation sheet contains references that automatically update the data each time the report is generated. Be careful not to overwrite these references.

Energy and Demand

Use the Energy and Demand template to create a tabular report on energy consumption and peak demand levels over a period of time, categorized by time of use. TOU (Time Of Use) schedules are typically set up to match an energy provider’s tariff schedule.

The Energy and Demand template uses quantities from the Energy and Demand log (kWh, kVARh, kVAh, kW Demand, kVAR Demand, kVA Demand) that is available on most ION devices.

TOU Schedule

Reporter requires a TOU schedule when creating a report using the Energy and Demand template. A sample TOU schedule is included — this allows you to define time periods that coincide with time periods in your energy provider’s tariff schedule, such as On Peak and Off Peak times. If you do not need to use a TOU schedule, simply create a new TOU schedule with only one time period defined.

The Aggregate Energy & Demand tab contains a summary of the combined energy and demand values. Energy and demand information from different sources are stored in separate tabs in the workbook.
Load Profile

Use the Load Profile template to create a graphical representation of demand or load levels over a period of time. The profile shows peak loads — points on the graph where peak electricity demand is high. A load profile report can be used to analyze the electrical loads at the time of maximum demand. This information creates opportunities for developing strategies to improve energy management.

Similar to the Energy and Demand template, the Load Profile template uses data from the Energy and Demand log (kW Demand, kVAR Demand, kVA Demand), except it does not use a TOU schedule.

The Load tab contains a graphical representation of the power usage of your system over time (total load profile). Load profiles from different sources are stored in separate tabs in the workbook.

Power Quality

Use the Power Quality template to create a report that summarizes the number and severity of voltage sags, swells and transients over a period of time. The finished report also includes a graphical representation of the disturbances, and an interactive selection of group events.

The Power Quality template uses data from all three Power Quality log files that are found on devices with sag/swell and transient detection capabilities:

- Sag/Swell Log
- Transient Log
- Waveform Log

The Power Quality Summary tab displays a chart that identifies the worst line disturbances and a list of incidents linked to their details. An incident is made up of several disturbances.

The Power Quality report shows a system’s line fluctuations for the specified date range. Use the Interactive Power Quality toolbar to change the time interval between incidents:

Click the timestamp of the incident in the Waveforms tab to view a graphical representation of the disturbance.

EN50160

EN50160 is a set of power quality standards used by energy suppliers and energy consumers in European countries. The following EN50160 templates are available in Reporter:

CM_EN50160_General

Use the CM_EN50160_General template to create a report containing detailed analysis of the entire EN50160 compliance data logged by a single Circuit Monitor device. Data is recorded for each observation period. The worksheets contain percentages of non-compliant EN50160 measurements such as Power Frequency, Supply Voltage Magnitude, and Flicker.
CM_EN50160_Summary

Use the CM_EN50160_Summary template to create a report containing comprehensive analysis of the entire EN50160 compliance data logged by multiple Circuit Monitor devices. The compliance summary is based on the EN50160 limits for each observation period: each default EN50160 measurement indicates a pass with a Y (yes), or a did not pass with an N (no), on the compliance test.

The CM_EN50160_Summary template uses data from the same log files as the CM_EN50160_General template.

An observation sheet is generated for every observation period; however, it is hidden by default. You can access specific observation sheets by unhiding the specific sheet for the generated report in Microsoft Excel (Format > Sheet > Unhide > “observation sheet”).

EN50160_General

Use the EN50160_General template to create a report containing detailed analysis of the entire EN50160 compliance data logged by a single meter. Data is recorded for each observation period. The worksheets contain percentages of non-compliant EN50160 measurements such as Power Frequency, Supply Voltage Magnitude, and Flicker.

The EN50160_General template uses data from these fourteen EN50160 log files:

EN50160 Vlt Dp1 to EN50160 Vlt Dp5 (supply voltage dips)
EN50160 OvrVlt1 to EN50160 OvrVlt3 (temporary overvoltages)
EN50160 Vunbal (supply voltage unbalance)
EN50160 Hrm Vlt (harmonic voltage)
EN50160 Ihm Vlt (interharmonic voltage)
EN50160 Frq/Mg (frequency and magnitude)
EN50160 Flicker (flicker)
EN50160 Intrp (short- and long-term interruptions)

EN50160_Summary

Use the EN50160_Summary template to create a report containing comprehensive analysis of the entire EN50160 compliance data logged by multiple meters. The compliance summary is based on the EN50160 limits for each observation period: each default EN50160 measurement indicates a pass with a Y (yes), or a did not pass with an N (no), on the compliance test.

The EN50160_Summary template uses data from the same log files as the EN50160_General template.

An observation sheet is generated for every observation period; however, it is hidden by default. You can access specific observation sheets by unhiding the specific sheet for the generated report in Microsoft Excel (Format > Sheet > Unhide > “observation sheet”).
**EN50160_Mains_Signal**

Use the EN50160_Mains_Signal template to create a report for signal line frequency statistics for a single meter, for each observation period.

The EN50160_Mains_Signal template uses data from the EN50160 MSignal log.

**IEC 61000-4-30**

IEC 61000-4-30 are power quality standards that define measurement methods for 50 Hz and 60 Hz power quality instruments. Three IEC 61000-4-30 templates are available in Reporter:

- **IEC61000-4-30_10Min**
  
  Use this template to create the IEC 61000-4-30 report based on a 10-minute interval sampling period.

- **IEC61000-4-30_2Hr**
  
  Use this template to create the IEC 61000-4-30 report based on a 2-hour interval sampling period.

- **IEC61000-4-30_3Sec**
  
  Use this template to create the IEC 61000-4-30 report based on a 3-second interval sampling period (i.e., 150 cycles for 50 Hz; 180 cycles for 60 Hz).

**Waveforms**

To generate a report from logs that contain voltage and current waveform data, select <no template> and set the Log to Waveforms. See "Creating a report without a template" on page 284 for details.

After the report is generated, click the tab named for the waveform query to view.

The left pane contains timestamps that link to the waveform chart on the right pane. Click a timestamp to view the waveform.

To view the waveforms for each current and voltage phase, click **Show Complete** on the **Waveforms** toolbar. Use the magnifying glass icons to zoom in or zoom out.

**Custom templates**

Contact Technical Support if you require other specialized report templates.

**Creating a report without a template**

You can use Reporter to copy raw data from a database and paste it into Microsoft Excel:

1. In the main Reporter window, select **Manage Reports**, then click **New**.
2. Fill in the **Report Name** box, select **<No Template>**, then click **Next**.
3. Click **New** to create a source/log query for the report. Set the **Query Properties**:
   - **Name**: New queries are automatically named in a sequential manner, but you can also rename them as required.
   - **Source**: Select the source of the query (for example, power meter).
Chapter 10: Reporter

- **Log**: Choose the data log that you want to copy raw data from.
- **Database**: ION_Data<SQL> is the default setting. To change the database source, select one from the list, or click **More**.

If a TOU schedule is required, select **Apply TOU Schedule to database queries**, then select one from the list, or click **Manage** to create one.

4. To add another query, click **New**, then set the query properties as described above.
5. When you have added and configured each of your queries, click **Next**.
6. Configure the report options as described in the section, "Setting up the report options" on page 277.

**Automatic report generation**

You can use the Windows Task Scheduler to generate reports on a set schedule:

1. To open Task Scheduler:
   - In Windows Server 2008, click **Start > Administrative Tools > Task Scheduler**.
   - In Windows 7, click **Start > All Programs > Accessories > System Tools > Task Scheduler**.

2. Click **Task Scheduler** in the left pane of the dialog, then click **Create Basic Task** in the **Actions** pane on the right to open the **Create Basic Task Wizard**.

3. Enter a name for this new task on the **Create a Basic Task** page. Use the **Description** field to describe the task. Click **Next**.

4. On the **Task Trigger** page specify how often this task should be performed and click **Next**.

5. Set the start time and other relevant data for your schedule. Click **Next**.

6. Select **Start a program** on the **Action** page and click **Next**.

7. On the **Start a Program** page, click **Browse** and navigate to ...\Program Files\Schneider Electric\Power Monitoring Expert\system\bin and select repgen.exe and click **Open**. (On a 64-bit Windows Operating System the path is ...\Program Files (x86)\...)

   Then click **Next** on the **Create Basic Task Wizard**.

8. Select **Open the Properties dialog for this task when I click Finish** on the **Summary** page, then click **Finish**.

   The **Properties** dialog for your task opens.

9. Select **Run only when user is logged on** under **Security options** on the **General** tab.

10. Click the **Actions** tab. Click the start a program entry for the scheduled task under the **Action** column and then click **Edit** to open the **Edit Action** dialog. Enter – `ReportName` in the **Add arguments** field (where ReportName is the name of the
report you want to run. Click **OK**.

For example, for a report name of *Rep1* enter `-rRep1` in the field.

Note that spaces are not supported in report names scheduled for automatic generation. Reporter also supports multiple report generation. Separate the report names with a comma. For example, for reports *Rep1* and *Rep2*, the entry in the **Add arguments** field is `-rRep1, Rep2`.

11. Click the **Triggers** tab to verify your task schedule settings. To update the schedules, click a specific entry under the **Trigger** column and select **Edit**. Modify the settings in the **Edit Trigger** dialog and click **OK** to save your changes.

12. Click **OK** to close the **Properties** dialog.

**NOTE**: Check the properties of your report to verify that you have specified a valid Date Range for your report and that the **Show Report on screen** option is cleared.

**Using Reporter on a client**

You can use Reporter on a client computer by installing the Reporter Client. For further information see the Power Monitoring Expert Installation Guide.

Note that the Reporting Client computer needs to have read/write permissions set for the ION-Ent folder (typically the `\Schneider Electric\Power Monitoring Expert` folder) on the primary server to be able to generate reports.

**Troubleshooting**

**Excel file does not open when you double-click its icon**

This might occur when a Microsoft Excel process hangs. To fix this, start Excel and open a file (or create a new one). Click **Tools > Options**, then in the **General** tab, clear **Ignore other applications**. Close and exit Excel.

If this does not work, try rebooting the computer.

**Excel security settings do not allow waveform processing to run**

This occurs when you want to process waveform data included in a Power Quality report. To address this situation you need to modify the security settings in Excel.

1. Open Excel and click the **Office Button** (upper left corner) to open the menu.
2. Click **Excel Options** at the bottom of the menu to open the **Excel Options** dialog.
3. Click the **Trust Center** tab and click **Macro Settings** in the **Trust Center** dialog.
4. Select **Trust access to the VBA project object model** under **Developer Macro Settings**.
5. Click **OK** to save your selection and to close the **Trust Center** dialog.
6. Click **OK** again to close the **Excel Options** dialog.
Appendix A: PQDIF Exporter

PQDIF (Power Quality Data Interchange Format) is a non-proprietary means of exchanging power quality data between different metering devices and software.

Developed under the guidelines of IEEE P1159.3, PQDIF provides a common ground where different vendors can export to or import from, using a data format consistent with the defined PQDIF standard.

Power Monitoring Expert supports PQDIF through the “PQDIF Exporter” add-on. PQDIF Exporter takes data from the Power Monitoring Expert SQL Server database, converts it to PQDIF, and stores this formatted file for viewing with any of the various programs that can display PQDIF data. The PQDIF Exporter allows you to set regularly scheduled exports of ION data to PQDIF, as well as perform these exports manually.

This guide provides basic configuration and operation instructions for the PQDIF Exporter. It is assumed that the user already has knowledge of PQDIF. For details on viewing the PQDIF data, refer to the documentation that came with your PQDIF viewer. For detailed information on the PQDIF specification, visit the IEEE website.

Configuring the PQDIF Exporter

From Management Console, select Tools > System > PQDIF Exporter.

When you run PQDIF Exporter for the first time, the PQDIF Exporter Configuration dialog opens with the options to perform the initial configuration steps. To edit these settings at any time, select Options > Configure PQDIF Exporter. You can also edit the PT/CT Scaling used for the sources by the PQDIF Exporter; select Options > PT/CT Scaling.
Database options

The Database Options dialog allows you to make changes to the database connection settings (SQL Server Instance, User Name, and Password). Type your changes in the appropriate fields.

**NOTE:** Under most conditions, you do not need to change the factory settings.

Click **Test These Settings** to test your database connection. A prompt displays to indicate whether or not connection to the database was successful.

Output folder

Click **Output Folder** to change the folder where PQDIF Exporter stores its output files. Type the folder path or click **Browse** to navigate and select the folder (or to create a new folder).

Message logging options

Click **Message Logging Options** to change the settings for message logging and email notification. The options available to configure are Log File, System Log, and E-mail Notification.

**Log File options**

Click **Log File Options** to specify the location for the log file and the logging level option.

**Location**

To change the folder location for the log file, type the folder path in the Location field or click **Browse** to navigate and select the folder.
Logging Level
Logging Level lists the different options for logging depth. Select the level you want from the dropdown list:

- **Disabled**: No messages are stored in the log file.
- **Normal**: Warning and error messages are stored in the log file.
- **Detailed**: Warnings, errors, and information are stored in the log file.
- **Diagnostic**: Warnings, errors, information, and diagnostic messages are stored in the log file.

**NOTE**: The “Diagnostic” log file option uses a huge amount of system resources. Select this option only if absolutely necessary.

System Log options
Click **System Log Options** to specify whether or not messages are stored in the Power Monitoring Expert system log.

Select from the following options:

- **Disabled**: No messages are stored in the system log.
- **Normal**: Warning and error messages are stored in the system log.

Email options
Click **E-mail Options** to set up email notification from PQDIF Exporter.

**SMTP Server to set for E-mail messages**
Type the name of the SMTP server PQDIF Exporter uses to send the email.
From E-mail Address to use for PQDIF Exporter
Type the address you want to appear in the “From” field in the email message.

E-mail Recipients
Click Add to enter email address recipients for the PQDIF Exporter messages. To delete an email address from the list, select it then click Remove.

Logging Level
The Logging Level box lists the different options for the amount of information sent in the email message. If you change this setting, it affects the setting for all email recipients.

- **Disabled**: No email sent.
- **Normal**: Email warning and error messages.

When you have finished setting up the email options, click Test These Settings to test the email connection.

If email settings are configured properly, a test message is sent to your inbox.

Exporter service options
Click Exporter Service Options to specify how often the PQDIF Exporter service restarts from an idle state to check the database for data to export.

Use the up and down arrows and dropdown list to set the frequency.

**NOTE**: Setting the Exporter Service Frequency Settings to seconds uses a huge amount of system resources. Select this option only if absolutely necessary.

PT/CT scaling
For a network where the PT/CT ratios on the meters are not set to the actual ratio values (for example, if the ratios are set to 1:1 for revenue metering purposes), the PQDIF Exporter service can scale the values to the correct primary measurements when it exports data.

To set the PT/CT scaling for the PQDIF Exporter:

1. Click Options > PT/CT Scaling to open the PT/CT Scaling dialog displaying the current PT/CT scaling for the sources in your network.
2. Select a source(s) and click Edit PT/CT Scaling for Selected Sources to open the Edit PT/CT Ratios dialog.
3. Enter the multiplier required to convert secondary values to primary values (for example, enter 1000 for a 5000:5 CT). Click OK.
4. Click Save to save your changes.

PQDIF Exporter main window
This is the main user interface for setting up schedules for PQDIF Exporter jobs or for setting up and running the jobs manually.
From Management Console, click **Tools > System > PQDIF Exporter**.

![Main menu items and Status of Exporter](image)

### Menu items

All the PQDIF Exporter commands are available from the main menu. Some of these commands are also available when you right-click on the interface background or on a job.

### Starting/stopping the exporter service

To start the PQDIF Exporter service:

- Select **Options > Start Exporter Service**, or
- Right-click the status bar and select Start Service.

To stop the service:

- Select **Options > Stop Exporter Service**, or
- Right-click the status bar and select Stop Service.
PQDIF Exporter jobs

The Jobs menu contains commands which allow you to set up PQDIF Exporter jobs that run automatically, according to the schedule you specify. You can also set up manual jobs to collect data for a specific date range from the SQL Server database for conversion to PQDIF.

PQDIF data templates

PQDIF data templates are the mapping files that convert ION data to PQDIF. PQDIF Exporter extracts recorded data for the following default templates:

- **Flicker**: Short-term and long-term flicker disturbance data on the voltage inputs.
- **Sag/Swell**: Sag/swell disturbance data for the voltage inputs, including minimum, maximum and average values.
- **Sag/Swell Waveforms**: Waveform data for voltage sag/swell.
- **Steady-state**: Steady-state (RMS) data for trending.
- **Steady-state Waveforms**: Waveform data for steady-state data.

**NOTE**: For the Steady-state Waveforms template, you must program the meter to use a Periodic Timer module to perform periodic waveform recording of the voltage and current channel inputs. The time interval you specify must be a multiple of 15 minutes.

- **Transient Waveforms**: Transient disturbance data for voltage inputs.

In addition to the default templates, custom templates can be also be developed — contact Technical Support if you require customized data templates for your application.

Scheduled export jobs

You can set up PQDIF Exporter to run at a specific time every day, or you can specify a different time interval (for example, every 12 hours or every 7 days). You can create and store multiple scheduled jobs for the PQDIF Exporter.
Creating a Scheduled Export Job

1. Click Jobs > New Job > Scheduled Export to open the Scheduled Export dialog.

2. Type a short but descriptive name in the Job Name field. Use the Job Description field to give more details about the job.

3. Select the sources for your scheduled data export. Click the box beside each source to select or deselect it.

   Click All Sources to select all available devices that log the type of data specified by the data templates. When this logged data is detected for a new device, that device is automatically added to all scheduled PQDIF Exporter jobs that have All Sources selected.

4. Select the Data Templates you want to use when the PQDIF Exporter runs. Click the box beside each template to select or deselect it.

   Click All Templates to select all available data templates for the selected devices.

   When a new data template is added, that template is automatically added to all scheduled PQDIF Exporter jobs that have All Templates selected.

5. Use the Export Time section to specify how frequently the PQDIF Exporter should run, as well as its start/cut-off time. When a scheduled PQDIF Exporter job runs for the first time (at the specified start time), it collects historical data to create PQDIF files so that the time period for that export is consistent (“caught up”) with the time periods of all subsequent scheduled PQDIF exports.

   **Example 1**: If you saved the scheduled job (1) at 4:25 PM, with the Exporter scheduled to run daily at midnight, the first PQDIF file is generated at midnight (2) the same day, and includes data spanning from the previous midnight. PQDIF...
Exporter runs again next midnight (3), and includes data spanning the first scheduled export (2).

Example 2: If you set a scheduled job to run PQDIF Exporter every 8 hours, starting at 3:00 AM, then the first PQDIF file is generated at 3:00 AM, and will include data spanning 8 hours previous to that time (that is, 7:00 PM). The next export starts 8 hours later, at 11:00 AM, then at 7:00 PM, then at 3:00 AM and so on.

Example 3: To run PQDIF Exporter once a week at 6:00 AM, change Export Time to “Export every 7 Day(s) at 6:00 AM”. In this example, the PQDIF file contains a full week’s worth of PQDIF data.

6. Click Add Job.

**NOTE:** Exporter Service must be started in order to run scheduled PQDIF Exporter jobs. See “PQDIF Exporter main window” on page 290.

**Manual export jobs**

A manual export job enables you to run the PQDIF Exporter immediately. You can create a different manual job for each source and/or template, or for specific groups of sources and/or templates.
Creating a manual export job


2. Type a short but descriptive name in the Job Name field. Use the Job Description field to give more details about the job.

3. Select the sources for your data export. Click the box beside each source to select or deselect it.
   - To select all available devices, select the All Sources box.

4. Select the Data Templates you want to use. Click the box beside each template to select or deselect it.
   - To select all available templates, select the All Templates box.

5. Use the Export Range From and To boxes to specify the date range of historical data that the PQDIF Exporter will use. The default time format is local time. If you want to use Coordinated Universal Time format, select UTC.

6. Use the File Splitting options to specify how PQDIF Exporter exports the data. The default method is to export the data to a single PQDIF file. You can change this so the data is split into different PQDIF files — for example, if you want to split the data so each PQDIF file contains 12 hours worth of data, set the File Splitting to “Export into separate files for each 12 Hour(s) of data”.

© 2016 Schneider Electric. All rights reserved.
7. Click **Export Now** to run and save this manual PQDIF Exporter job, or click **Add Job** to save without running it.

**Running manual jobs**

After you enter the manual PQDIF Exporter jobs, you can select and run them:

1. On the PQDIF Exporter interface, select the manual job(s) you want to run.

2. Right-click and select **Export Selected Manual Job(s)**. A command window displays to indicate the progress of the export. Press the RETURN (ENTER) key when prompted to return to the PQDIF Exporter interface.

**NOTE:** To run all manual jobs, click **Jobs > Export All Manual Jobs**.

![Processing Manual Jobs](image)

**Editing the PQDIF Exporter jobs**

To make changes to a scheduled or manual job:

1. To edit a job, open the **Export Configuration** dialog in one of the following ways:
   - Double-click the job.
   - Select the job, then click **Jobs > Edit Selected Job**, or
   - Right-click the job and select **Edit Selected Job**.

2. Make your changes and click **Save**.
Duplicating PQDIF Exporter jobs

If you are creating jobs that have very similar attributes (for example, jobs that use the same set of devices, templates and/or time schedules), you can set up the first job, duplicate it, then simply edit the copy.

1. Select the job(s) you want to duplicate, then click Jobs > Duplicate Selected Jobs (or right-click the job and select Duplicate Selected Jobs).
2. Double-click the copy of the job you want to edit, make your changes, then click Save.

Enabling/disabling the PQDIF Exporter jobs

To enable or disable the scheduled or manual jobs:

1. Select the job(s) you want to enable or disable.
2. To enable the jobs, click Jobs > Enable Selected Jobs. To disable them, click Jobs > Disable Selected Jobs. You can also right-click the jobs and select Enable Selected Jobs or Disable Selected Jobs to enable or disable the jobs.

Adjusting the column widths

To change the width of a column, hover the mouse over border of the column headings — the mouse pointer changes into a double-arrow pointer — click and drag to adjust the column width.

Sorting the PQDIF Exporter job list

Click the title of a column to sort the data according to that column heading. An arrow appears in the title of the column. Click the title again to toggle the sorting—ascending or descending order.

Deleting PQDIF Exporter jobs

To permanently remove PQDIF Exporter jobs from the list:

1. Select the jobs you want to delete, then:
   - Click Jobs > Delete,
   - Press the Delete key on your keyboard, or
   - Right-click and select Delete Selected Jobs.
2. Click Yes when prompted.

**NOTE:** You can also disable a job instead of deleting it (that is, Enable = “No”). This way, the job can be enabled at a later date if required.

Closing the PQDIF Exporter window

To close and exit the PQDIF Exporter window, click the “X” at the top right corner, or click File > Exit.
If the Exporter Service is stopped when you try to exit, PQDIF Exporter prompts you to start the service in order to process scheduled jobs. Click Yes to start the Exporter Service.
Appendix B: OPC Server Assistant

OPC is a set of open standards for connectivity and interoperability of industrial automation and the enterprise system. OPC provides a bridge between Windows based applications and process control hardware, thereby eliminating the need for proprietary or custom interfaces and drivers for the various data types and sources residing in your corporate information network. Having information readily available in a universally-recognized format can cut costs, speed up development and increase operations efficiency. This is especially true when many diverse software applications, hardware, and operating systems exist in the corporate and operations networks.

<table>
<thead>
<tr>
<th>WARNING</th>
</tr>
</thead>
<tbody>
<tr>
<td>INACCURATE DATA RESULTS</td>
</tr>
<tr>
<td>• Do not incorrectly configure the OPC Server; as this can lead to inaccurate data results.</td>
</tr>
<tr>
<td>• Do not use data results as substitutes for proper workplace practices or equipment maintenance; they are supplemental only.</td>
</tr>
</tbody>
</table>

Failure to follow these instructions can result in death, serious injury, or equipment damage.

OPC is supported through the implementation of ION Real Time Data Service, a .NET-based system that takes the traditional “register handle-based” ION data and transforms it into structured “measurement-based” data that complies with open standards such as OPC. ION Real Time Data Service facilitates the translation and organization of data in this new measurement classification system.

Power Monitoring Expert supports OPC server and OPC client functionality. The OPC server translates ION data into OPC data, for exporting and viewing in other third-party OPC client systems. The OPC client, on the other hand, takes OPC standardized measurements from third-party systems and translates them into a data format that Power Monitoring Expert can use.

This appendix provides basic configuration and operation instructions for the OPC server component of Power Monitoring Expert.

**NOTE:** The OPC client is available in all Power Monitoring Expert installations. However, due to the number of different third-party OPC-compliant servers in the industry, as well as different methods and syntax for connecting to these servers and accessing their data, it is highly recommended that you contact Technical Support for assistance in configuring the OPC client.
Optional OPC server license

The OPC Server Assistant is available during the 90-day trial period. After the trial period, you need to purchase an OPC DA Server license and activate it through the Floating License Manager to enable OPC server functionality.

OPC server type

The Power Monitoring Expert OPC server complies with the "OPC Data Access Custom Interface Standard Version 2.05A". The class of data that the current release of OPC Data Access server is able to provide is Read-Only data (i.e., control functions are not currently supported).

OPC server support

OPC server support for Power Monitoring Expert allows you to easily translate data from ION devices and compatible Modbus devices into OPC-compliant measurement data formats, then make this measurement data available to OPC clients through the OPC server.

Management Console has a command that lets you export default measurements from compatible devices to the OPC server. In addition, Designer and Modbus Device Importer user interfaces let you view and select which OPC measurement data you want the OPC server to expose to OPC clients.

Creating/updating default OPC mapping

Power Monitoring Expert can create the default ION-to-OPC data mapping based on the devices contained in the ION_Network database. This default mapping translates the most commonly-used ION data to OPC data and exports the data to the OPC server.

1. Launch Management Console.
2. Click Tools > System > Update OPC Server.
3. Click Yes to create/update the OPC server. A summary of the configuration details is displayed.
4. Click OK.

**NOTE:** If you add a new device to the ION_Network database at a later date, you must repeat the above procedure in order to map the new source device’s data to the OPC server.

OPC Server Assistant

The OPC Server Assistant is a mechanism that lets you select which OPC measurements to expose to the OPC server. Custom labels are not mapped to OPC server by default. They need to be manually exported to OPC server.

OPC Server Assistant is accessible through Designer and Modbus Device Importer user interfaces.
Exporting OPC measurements through Designer

If you customized an ION device’s default templates (for example, custom labels), those measurements are not exposed to the OPC server by default. To manually export those measurements to OPC server:

1. Launch Designer and open the ION device node.
2. Navigate to the ION module that contains the register that you want to expose to OPC server. Right-click to display the module setup dialog.
3. Click **OPC** to open the OPC Server Assistant.
4. Select (check) the box beside each item you want to expose to the OPC server. Clear (uncheck) the box beside each item you do not want to expose to the OPC server.

   **NOTE**: Grayed-out items (such as “PF sign a” in the Power Meter module) cannot be selected or changed. Those registers cannot be removed using OPC Server Assistant.

5. Click **File > Export**. Click **Yes** to save your changes.

Exporting OPC measurements through Modbus Device Importer

For Modbus devices, you can use the Modbus Device Importer to expose OPC measurements to the OPC server:

1. Launch the Modbus Device Importer. Click **File > Open**, then navigate to the folder containing the ION map file for your Modbus device. Select it and click **Open**.
2. Navigate to the module containing the register you want to map. Right-click the module and select OPC. The OPC Server Assistant appears.
3. Select (check) the box beside each item you want to expose to the OPC server. Clear (uncheck) the box beside each item you do not want to expose to the OPC server.

4. Click **File > Export**. Click **Yes** to save your changes.

### Description of commands

This section describes the commands available in the OPC Server Assistant.

<table>
<thead>
<tr>
<th>Command</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File &gt; Export</strong></td>
<td>Saves your configuration changes. Items that are selected (checked) in the OPC Server Assistant are exposed to the OPC server, while cleared (unchecked) items are not.</td>
</tr>
<tr>
<td><strong>File &gt; Exit</strong></td>
<td>Closes the OPC Server Assistant.</td>
</tr>
<tr>
<td><strong>Edit &gt; Reset values</strong></td>
<td>Discards your changes and reverts to the last saved configuration (for the items that are exported to the OPC server).</td>
</tr>
<tr>
<td><strong>Edit &gt; Select All</strong></td>
<td>Selects (checks) all registers.</td>
</tr>
<tr>
<td><strong>Edit &gt; Clear All</strong></td>
<td>Clears (unchecks) all registers that are not grayed out.</td>
</tr>
<tr>
<td><strong>View &gt; Setup Registers</strong></td>
<td>Displays the setup registers, in addition to the output registers, for the module.</td>
</tr>
<tr>
<td><strong>View &gt; Measurements</strong></td>
<td>Displays a column containing the measurement names associated with the registers.</td>
</tr>
</tbody>
</table>

### Viewing OPC data

A third-party OPC client can connect to the ION OPC server using a valid connection address, which consists of the network node or host machine name where the OPC server is running and the OPC program ID (ION.OpcDaServer). For example:

```
opcda://WORKSTATION3/ION.OpcDaServer
```

**NOTE:** Syntax use varies across different OPC clients. Refer to your OPC client documentation for details.
Appendix C: Time synchronization for ION meters

You can synchronize the internal clocks of all networked PowerLogic™ ION™ meters and devices through the Management Console component of Power Monitoring Expert. When they are synchronized, all data logs have time stamps that are relative to a uniform time base.

**NOTE:** This information is specific to ION devices. It is not applicable to devices that are not based on ION architecture.

Time synchronization signals are broadcast periodically over the network; each meter continually assesses its ability to remain synchronized with the incoming broadcasts. Over a brief period, each meter learns how its internal timing differs from that of the broadcast source and adjusts its timekeeping to compensate. Very accurate time synchronization is achieved with this method.

Meters at modern sites are synchronized each time they are connected. The longer the duration between connections, the larger the error in time synchronization. In the extreme case, this can result in missing or duplicated logs. If this occurs, you can increase the frequency of connections through the Power Monitoring Expert software connection.

**NOTE:** This information assumes that you are using the time synchronization function in Power Monitoring Expert. Although other methods of time synchronization are available, such as with ION Setup, a Network Time Protocol (NTP) server, a Global Positioning System (GPS) receiver, or 3rd party protocols, it is important that you use only one method of time synchronization on each network. If you use multiple methods, the timestamps will differ for the sites and devices that are using separate time synchronizing methods.

Before you configure time synchronization on your network, you should familiarize yourself with the Clock module settings. Once you have done this, you can decide which synchronization method you want to use.

**Enabling and configuring time synchronization**

Time synchronization in Power Monitoring Expert is initially disabled and needs to be enabled and configured through Management Console. The communications port and protocol used for communications between the software and the networked ION devices is automatically used to send time synchronization signals to all connected ION devices. The software sends a time sync packet and the time is set when the packet is received.

When reviewing time synchronization messages in the system log, remember that the time in the message is not the time to which the meter was time synced, but rather it is the time the message was posted to the system log. The message is posted after the meter is time synced.

Note that ION time synchronization only uses the UTC setting; the LOCAL setting cannot be used.
Time synchronization values are set when sites or Ethernet devices are defined in a Power Monitoring Expert network. Enable time synchronization or set custom intervals for supported devices in any site through Management Console as follows:

1. Start Management Console.
2. Select Sites or Devices on the System Setup pane:
   - Select Sites if you want to customize a particular serial, modem, or Ethernet Gateway site.
   - Select Devices if you want to customize an individual Ethernet device.
3. Right-click the device or site and select Configure Device or Configure Site to open the related configuration dialog.
4. Right-click inside the dialog and select Advanced Properties.
5. Configure the Time Synch ION Enabled or Time Synch Ethernet Enabled, and Time Synch Interval Ethernet fields as required for your system.
6. Click OK to save you changes.

The default time synchronization interval of 3600 seconds (displayed in milliseconds) is acceptable in most software installations.

**NOTE:** You need appropriate permissions to configure meters on your network. Refer to the ION System Security technical note for details on software and meter security.

**Time synchronization blackout**

Time synchronization blackout is defined as a period when time synchronization cannot occur. Utilities often record power usage at regular, predetermined intervals. For example, the utility may schedule a recording every five minutes during an hour period (that is, 5, 10, 15, 20,…, 55, 60). If a time sync moves the meter clock forward, the meter may miss one of the recording intervals. If a time sync moves the meter clock backwards, the meter may get two records with the same timestamp. The time synchronization blackout feature seeks to protect the time before and after these recording intervals by not sending out any time sync signals at those times.

Power Monitoring Expert has time synchronization blackouts enabled automatically even though time syncing is disabled by default in Power Monitoring Expert. The blackout intervals are every five minutes as follows: 0, 5, 10, 15, 20, 25, 30, 35, 40, 45, 50, 55. Each blackout is 2 minutes and 30 seconds in duration. This duration is distributed evenly before and after the interval. The diagram below illustrates the time synchronization blackout feature in Power Monitoring Expert.
If a regularly scheduled time sync is not sent because of a blackout interval, the software continues trying to send the time synchronization signal every 15 seconds until the blackout period expires and the time sync is sent.

**Changing default blackout settings**

To change the default settings for the interval or the blackout duration, you must edit the registry of the computer where Power Monitoring Expert is installed. Changing the default registry settings should be performed only by personnel with a thorough knowledge of their computer's operating system and registry entries.

---

**NOTICE**

**IRREVERSIBLE OPERATING SYSTEM DAMAGE OR DATA CORRUPTION**

- Registry edits must be performed only by qualified and experienced personnel.
- Before making any changes, back up your system registry in a network folder or other remote location.

Failure to follow these instructions can result in irreparable damage to your computer's operating system and all existing data.

---

There are two registry entries that control the time-synchronization blackout behavior.

For 32-bit servers, create the following registry `REG_DWORD` values under the `HKEY_LOCAL_MACHINE\Software\Schneider Electric\Power Monitoring Expert\version_number` key.
For 64-bit servers, create the following registry `REG_DWORD` values under the HKEY_LOCAL_MACHINE\Software\Wow6432Node\Schneider Electric\Power Monitoring Expert\version_number key.

**TimesyncBlackoutInterval_mins**

Default value: 5

This entry is specified in minutes. It must have a value greater than 1 in order for time-synchronization blackouts to occur. A value of 60 or greater configures blackouts to occur once an hour.

**TimesyncBlackoutDuration_secs**

Default value: 150 (2 minutes 30 seconds in seconds)

This entry is specified in seconds. A value of 0 (zero) disables the blackout feature. This entry cannot have a value greater than or equal to 3600 (one hour).

**NOTE**: If you want to disable the blackout feature but keep time synchronization enabled, set the `TimesyncBlackoutDuration_secs` register to 0.

Do not use the following settings. They disable both the blackout feature as well as time synchronization in general.

- `TimesyncBlackoutInterval_mins < 1`
- `TimesyncBlackoutDuration_secs >= 3600` (1 hour)
- `TimesyncBlackoutDuration_secs` (the value converted to minutes) >= `TimesyncBlackoutInterval_mins`

To disable time synchronization for a particular device, use Management Console. Refer to "Time synchronization blackout" on page 304.

**Time-synchronization blackout considerations**

- Remember to specify `TimesyncBlackoutInterval_mins` in minutes and `TimesyncBlackoutDuration_secs` in seconds.

- If your blackout values conflict or are out of range, an error is sent to the system log database. If time synchronization signals are not occurring, check the system log to see if there’s an error message about your blackout values.
Index

A
add
connection schedule 40
Ethernet device 34
modem 35
network component 32
OPC device 34
serial device 33
server 33
advanced security (access meters with) 39
alarm
acknowledge (Vista) 115
deactivate alarms 57
Alarm Configuration 89
alarm options 149
alert monitor 258
configuration file 259
setup 259
annunciation options 148

C
CBEMA 130
configuring multiple devices 47
connection schedule 40
control object
action options 147
display options 145
control object (Vista) 134

D
data
copy data to another application 113
filter data 24
plot 112, 117
real-time 110
sort 24
stale data settings (Vista) 108, 162
view logged data 111
data log viewer 111-112
diagram object 134
link to data source 151
database 19
access via 3rd-party application 230
ION (ION_Data) 20
network configuration (ION_Network) 20
system events (ION_SystemLog) 20
database management
archive 218
create new database 220
export registry setting 219
manual 218
modify login 219
SQL Server memory usage 229
trim 220
upgrade database 220
Designer
clon a node 204
ION modules toolbox 178
node diagram 168
window configuration 175
Designer. See ION modules, see node diagram 176
device
Ethernet 31
logical 31
rename 36
serial 31
diagnostics
communications 69
server 61
diagram object 105
caption options 139
preview pane 138
direct site
add serial device 33
display
adjust column width 23
arrange columns 23
customize interface 22
dock (pin) pane 23
filter data in column 24
grid tables 23
group table data by column 24
hide (unpin) pane 23
resizing panes 23
select columns to display 23
sort data in column 24
downstream device 264
downstream device assistant
add new device mapping 271
basic versus advanced view 265
change measurement mapping 271
columns 266
display physical sources 268
options 268
rename assigned source 270
update historical data after changes 272
duplicating a device 44

E
Ethernet device 31
add 34
Ethernet gateway
add device 34
event log viewer 112-113
diagram object 134
display 113
link to data source 151
event watcher 58
add event watcher 60
create template 59
exit a component 21

G
global event log viewer 112-113
add 114
display 114
group name
change 37
grouping object (Vista) 105, 133
display options 144
grouping window (Vista) 105
groups (of users)
add/edit 55

H
harmonics analysis 122
calculate using more than one cycle 122
Hierarchy Manager 88

I
ION module 176, 235
configure 192
core versus standard module 177
online versus offline module 177
output register 176
parent module 194
persistent module 178
programmed versus pending 177
setup register 176
view as text 183
ION tree 190, 233

L
large system setup 42
log inserter
fast-link option 196
log into a component 21
log off from a component 21
log view plotter 117
add data from another application 126
add data from data log viewer 125
add events 125
calculations window 118
customize 126
de-index parameters 121
display curve data in table 119
display options 118
harmonics analysis tab 122
legend 117
overlay curves 130
phasor diagram tab 123
plot display tab 119
remove parameters 130
specify y-offsets 121
symmetrical components 123
X-parameter 154
Logical device 31
logical devices 76
    creating multiple 85
    editors 77, 82

M
Managed circuits
    creating 38
management applications 16
Management Console
    customize the display 29
    interface 28
manager 234
Modbus
    add device type 232
    configure advanced device functions 251
    configure advanced functions 242
    default device types 232
    edit register 242
    map file 233
Modbus gateway
    add device 34
modem
    add 35
    dial out 32
    remote modem setup 89
    WinModem 35
monitoring applications 15

N
navigating
    tree structures 22
network component 30
    add 32
    delete 36
    edit 36
network diagram
    generate 106
node diagram 168
    add module 180
    add text box 184
    configure module 192
    copy module 197
        to framework 198
create shortcut to module 203
    custom labels 194
default versus custom labels 173
delete links between modules 190
display/edit mode 170
find dependent modules 181
icons 171
link modules 186, 190
link modules across nodes 188
linking modules 186
locate existing ION module 179
paste module 199
    free paste or lock paste 203
    from framework 199
reset module 196
shortcut to module 184
view as text 183
view input information 207
view output register information 206
view setup register information 206
numeric object 110, 133
    display options 141
numeric object (Vista)
    flags 110, 142

O
OPC device 31
OPC Server Assistant 17, 299
OPC site
    add device 34

P
phasor diagram 123
power factor, display in Vista 122
PQDIF Exporter 16, 287
programming applications 17

Q
query database, Vista 152
query server 152
querying database
query wizard 154

R
register 235
Reporter 275
Reports application
subscription configuration 56

S
selecting multiple items 22
serial device 31
add 33-34
server 30
add server 33
services, Windows 17
site
direct site 30
Ethernet gateway site 31
modem site 30
OPC site 31
SQL Server 19
SQL Server instance 217
start a component 21
status object 111, 133
display options 143
subscription
event watcher 58
symmetrical components 123
system log events 41

T
Task Scheduler
scheduled jobs 224
text box object (Vista) 133
time of use (Reports) 91

U
upgrade device 72

user diagram 104
add diagram object 133-134
background color 159
background image 160
communication errors 108
copy/paste diagram objects 135
create new 132
customize 132
customize diagram object 138
default 105
default action for window 162
default node 162
default query server 161
diagram objects, types 133
edit/display mode 104
enable undo option 133
font 159
layout 136
navigate 107
save 132
specify for particular user 106
stale data 108, 162
users
add/edit 54
user groups 55

V
virtual processor (VIP)
common applications 212
modify global parameters 90
set global parameters 213
setup 90
Vista
customizing diagram window 158
framework 135
generate network diagram 106
navigate 107
plot data 112
query wizard 154
view logged data 111
view real-time data 110

Vista diagram object
action options 146
alarming options 149
annunciation options 148
box options 148
display options 141edit text options 140
link options 140
link to data source 150
query server options 141
text options 139

W

waveforms
plot 124
WinModem 35